Centos7安装部署Rabbitmq教程
本文最新更新日期:2020.3.16。测试无误
部署环境
OS:Centos7.7
版本依赖
版本依赖一定要提前看清楚。
RabbitMQ相关版本依赖关系查看
https://www.rabbitmq.com/which-erlang.html
安装包下载地址
三个都要下载,放到/root目录下即可
链接:https://pan.baidu.com/s/1dQjSCQz_HmMKHRFEnmvGvA
提取码:4n3a
安装步骤
先安装wxwidgets再安装erlang最后再安装RabbitMQ
以下脚本内容,建议一步步执行
yum install gcc-c++ ncurses-devel fop unixODBC-devel mesa-libGLU-devel gtk3* bzip2 openssl openssl-devel make perl -y #安装依赖
bzip2 -d wxWidgets-3.1..tar.bz2 #解压
tar -xvf wxWidgets-3.1..tar #解压
cd wxWidgets-3.1.
./configure #编译安装
make & make install
ldconfig #重新加载动态库
cd ..
tar -zxvf otp_src_22..tar.gz
cd otp_src_22.
./configure --prefix=/usr/local/erlang --without-javac
make
make install
echo 'export PATH=$PATH:/usr/local/erlang/bin'>> /etc/profile #加入系统PATH
source /etc/profile
erl #不报错说明安装成功
cd
xz -d rabbitmq-server-generic-unix-3.8..tar.xz
tar -xvf rabbitmq-server-generic-unix-3.8..tar
cd rabbitmq_server-3.8./
cd sbin/ #相关命令都在这里,可以考虑把这个路径计入系统PATH
./rabbitmq-server #不报错,说明rabbitmq安装成功
rabbitmq常用命令
./rabbitmq-server #启动RabbitMQ
rabbitmq-plugins enable rabbitmq_management #启用web端,会启动15672端口
rabbitmqctl add_user admin #添加admin用户,密码为123456
rabbitmqctl set_user_tags admin administrator #设置admin为administrator
rabbitmqctl set_permissions -p "/" admin ".*" ".*" ".*" #允许admin远程登录
./rabbitmqctl list_users #查看admin是否是administrator
Centos7安装部署Rabbitmq教程的更多相关文章
- Centos7安装部署MongoDB教程
安装方式: RPM包安装 安装步骤: 一.下载RPM包 下图是需要注意的事项.其一选择MongoDB的社区版本,默认是企业版本.其二,选中版本后,在下方会出现下载地址,直接复制下载即可 二.安装并查 ...
- CentOS7安装部署zabbix3.4操作记录
CentOS7安装部署zabbix3.4操作记录 1.安装前准备 1.1 查看centos的系统版本 [root@zabbix ~]# cat /etc/redhat-release CentOS L ...
- Docker:安装部署RabbitMQ
前言 今天原本想讲解SpringBoot集成RabbitMQ的,临近开始写时才发现家里的电脑根本没有安装RabbitMQ呀.这下只好利用已有的阿里云服务器,直接Docker安装一下了,顺道记录下,算是 ...
- centos7 安装部署运行 Redis5
原文:centos7 安装部署运行 Redis5 Redis5 下载与解压(官网: https://redis.io/download ) 下载命令:wget http://download.redi ...
- Centos7安装Typecho详细教程
Centos7安装Typecho详细教程 首先搭建LAMPH环境 L linux 服务器(centos或者ubunt) .A Apache .M mysql .P PHP 安装Apache.PHP ...
- 容器centos7安装部署ansible
容器centos7安装部署ansible centos镜像版本及ansible版本 centos:centos7.5.1804 ansible:2.9.11 启动容器并进入容器 docker run ...
- Centos7安装部署搭建gitlab平台、汉化
Centos7安装部署搭建gitlab平台.汉化 安装环境要求:内存不要小于4G,否则后期web界面可能会报错 一.准备工作 1.1 查看系统版本 首先查询系统版本,下载Gitlab的对应版本 [ro ...
- Linux下安装部署RabbitMQ
在写正文之前先啰嗦几句,RabbitMQ(消息队列)的安装让我费了半天劲啊!足足折腾了2天,最后写下这篇文章总结下,其实很简单,但是你找不到错在哪个环节就会费很多无用功,如果你也遇到了安装erl后 怎 ...
- jumpserverv0.5.0 基于 CentOS7安装部署
基于 CentOS 7 一步一步安装 Jumpserver 0.5.0 环境 系统: CentOS 7 IP: 192.168.244.144 关闭 selinux和防火墙 # CentOS 7 $ ...
随机推荐
- C语言入门hello world
1.安装软件 c语言开发工具众多,初学者推荐使用Dev-Cpp 5.6.3 TDM-GCC x64 4.8.1 Setup.exe:安装过程全部默认安装即可. 2.使用Dev-Cpp编写第一个入门实例 ...
- Elasticsearch 日期类型的自动监测,官方文档
资料 网址 Elasticsearch Reference [7.3] » Mapping » Field datatypes » Date datatype https://www.elastic. ...
- 表之间的数据匹配(Oracle)
来源表1: 来源表2: 生成一个交叉表: sql: select t.course_name,max(case when t.month='200706' then 'o' else '*' end) ...
- iis站点设置错误页面返回http状态码为404而不是302或其他
今天一位客户说网站错误页面返回的状态码是302而不是404,问ytkah要如何处理.这个应该是设置没有正确的原因.我们一步步来排查一下.1.首先打开iis管理器,左侧选择具体的站点,在右侧窗口中点击4 ...
- 高性能MySQL(一)——索引
一.mysql索引分类 单值索引:一个索引只包含单个列,一个表可以有多个单列索引 唯一索引:索引列的值必须唯一,但允许有空值 复合索引:一个索引包含多个列 基本语法: 创建:1.CREATE [UNI ...
- Keil的RTX特性
Keil RTX是为ARM和Cortex-M设备设计的免版税,确定性的实时操作系统.它允许您创建同时执行多个功能的程序,并帮助创建更好的结构和更容易维护的应用程序. 特征 具有源代码的免版权,确定性R ...
- iOS App开发那些事:如何选择合适的人、规范和框架?
http://www.cocoachina.com/ios/20141202/10386.html 自从做Team Leader之后,身上权责发生了变化,于是让我烦恼的不再是具体某个功能,某个界面的实 ...
- Maven整合SSH框架的所有依赖和插件(记录下来,省的以后再写)
JDK:1.8 Tomcat:7 Maven:3.6.1 调了一个小时,终于没错误了,总结了一个规律,如果在用Tomcat插件启动项目时报错,显示如:org.apache.tomcat.util.bc ...
- 关于api创建监控项,添加灵活调度的事件间隔
在api文档中没有明确说明,可以查询数据库,得到的是一个字符串,
- mybatis多参数查询问题:org.apache.ibatis.binding.BindingException: Parameter 'name' not found. Available par
错误如下: 这个是由于在执行sql的时候无法匹配sql语句的通配符造成的,有两种方式可以解决 第一种:在sql语句中通配符这样写,用0,1匹配: 第二种:在dao接口的方法中的参数前面加param ...