1、下载(版本为elasticsearch-6.5.4):

https://www.elastic.co/downloads/elasticsearch

2、上传至服务/user/local目录

3、解压

tar -zxf elasticsearch-.tar.gz
mv elasticsearch- elasticsearch
cd elasticsearch

4、创建Elasticsearch用户和所在组

Elasticsearch默认是不允许root用户运行的,不管是Elasticsearch5还是Elasticsearch6,否则的话Elasticsearch运行的时候会报错

.先创建bigdata组,并指定组id为1024(我是搞大数据的,大数据所有用户及应用全部放在bigdata用户组内)
groupadd -g  bigdata
.创建es用户并指定所在组为bigdata
useradd -g bigdata es
.查看是否创建成功
id es

5、更改解压的Elasticsearch应用所属用户及组

# 先切换到Elasticsearch根目录
cd /usr/local/elasticsearch

# 更改目录及文件权限
chown -R es:bigdata .

chown:表示修改文件所有权
-R :循环递归修改所有文件及目录
es:bigdata:第一个是用户名,第二个是组名
别忘了最后面的"."啊,表示当前目录

我们发现有很多.bat文件,这个是Windows下执行的脚本
看着就不爽,果断删除

rm -f bin/*.bat

6、执行脚本添加可执行权限

chmod u+x bin/*

7、修改相关配置

1. 修改limits.conf配置文件(修改用户最大可创建文件数)

vi /etc/security/limits.conf

# 添加如下内容
* soft nofile
* hard nofile
* soft nproc
* hard nproc unlimited
* soft memlock unlimited
* hard memlock unlimited

别人的博客里一般只是添加了前两项,我这边还有大数据的环境,所以多一些

2. 修改90-nproc.conf

vi /etc/security/limits.d/-nproc.conf
# 修改成4096或者更大
*          soft    nproc
root       soft    nproc     unlimited

一开始的时候看别人的博客,说改成2048,结果Elasticsearch还是说小,按Elasticsearch的提示加到4096

3. 修改sysctl.conf

vi /etc/sysctl.conf

# 尾部添加下面的配置
vm.max_map_count=

# 然后执行命令
sysctl -p

4. 修改elasticsearch.yml

vi config/elasticsearch.yml 

# Centos6不支持SecComp,
bootstrap.memory_lock: false
bootstrap.system_call_filter: false 

# 默认的只能本机访问,修改后就可以远程访问了
network.host: 0.0.0.0
# 集群名称
cluster.name: bigdata
#当前节点名称,这里配置为主机名
node.name: cm02.spark.com

bootstrap.memory_lock和bootstrap.system_call_filter默认为true而Centos6不支持SecComp,而Elasticsearch默认bootstrap.system_call_filter为true进行检测会导致失败
上面的配置都要一个一个配置啊,不然后面你还要根据报错一个一个改

8、启动
从root用户切换到es用户,
然后在Elasticsearch根目录下执行

su rsbin/elasticsearch

在浏览器输入地址:http://192.168.153.128:9200/

显示如下安装成功:

{
  "name" : "LLvPQcU",
  "cluster_name" : "bigdata",
  "cluster_uuid" : "Gy7vMGNBSjOnMd2uFfPp_w",
  "version" : {
    "number" : "6.5.4",
    "build_flavor" : "default",
    "build_type" : "tar",
    "build_hash" : "d2ef93d",
    "build_date" : "2018-12-17T21:17:40.758843Z",
    "build_snapshot" : false,
    "lucene_version" : "7.5.0",
    "minimum_wire_compatibility_version" : "5.6.0",
    "minimum_index_compatibility_version" : "5.0.0"
  },
  "tagline" : "You Know, for Search"
}

加入集群需要修改的地方:

#有几个集群就加几个IP
discovery.zen.ping.unicast.hosts: ["192.168.153.129", "192.168.153.128"]
#集群数量配置
discovery.zen.minimum_master_nodes: 

centos安装ES(elasticsearch)的更多相关文章

  1. centos7使用docker安装es(elasticsearch)

    1.安装docker依赖(已安装可以不用安装) yum install -y docker 2.搜索镜像 docker search elasticsearch 如果出现以下报错 Cannot con ...

  2. centos 安装es

    第一步:必须要有jre支持 elasticsearch是用Java实现的,跑elasticsearch必须要有jre支持,所以必须先安装jre 第二步:下载elasticsearch 进入官方下载 h ...

  3. Linux(centos)安装es(elasticsearch)

    前提条件--需要安装jdk环境,不同版本的es所对应的jdk版本要求不同,es6的使用jdk1.8可以 1.下载elasticsearch压缩包 下载地址:https://www.elastic.co ...

  4. ElasticSearch | centos7 上安装ES

    0 参考博客文章(感谢!!!) [1]  https://www.jianshu.com/p/10949f44ce9c 在linux服务器上安装jdk [2]  https://www.elastic ...

  5. centos 7安装es 及异常处理

    首先,我们从官网下载zip包:(官网:https://www.elastic.co/downloads/elasticsearch)   直接使用浏览器下载可能会很慢,我一般会copy下载链接,然后w ...

  6. CENTOS安装ElasticSearch(转)

    From: https://my.oschina.net/topeagle/blog/591451?fromerr=mzOr2qzZ CENTOS安装ElasticSearch ElasticSear ...

  7. CENTOS安装ElasticSearch

    原文链接:https://my.oschina.net/topeagle/blog/591451?fromerr=mzOr2qzZ CENTOS安装ElasticSearch ElasticSearc ...

  8. ElasticSearch | windows 上安装ES

    Elastatic需要java JAVA8 环境,确保安装好环境 在windows上安装ES还是比较简单的, 1.首先在官网上下载zip,地址 https://www.elastic.co/downl ...

  9. Centos安装Git、DotNet、Docker

    1.安装Git yum install git 可通过下面的命令查看Git版本 git --version 2.安装Dotnet sudo yum install libunwind libicu 导 ...

随机推荐

  1. vs问题解决:an operation is not legal in the current state

    debug时弹出提示框:内容有:an operation is not legal in the current state 解决方案: Go to Tools > Options > D ...

  2. eclipse 中运行 Hadoop2.7.3 map reduce程序 出现错误(null) entry in command string: null chmod 0700

    运行map reduce任务报错: (null) entry in command string: null chmod 0700 解决办法: 在https://download.csdn.net/d ...

  3. Linux桌面环境安装matlab并创建快捷方式

    安装matlab sudo mkdir -p /mnt/matlab sudo mount -t auto -o loop /home/chris/Downloads/2016b_linux/R201 ...

  4. k8s中的api server的ca证书,可以和front proxy ca证书一样么?

    答案是: 绝对不可以! 因为请求先验证的是 --requestheader-client-ca-file CA 然后才是--client-ca-file. . 那获取的用户名就会通不过了. 所以会影响 ...

  5. 关于K8S证书生成方面的脚本草稿

    周日在家里计划的. 俺不加班,但在家学习的时间一样没少! 还没弄完,只粗粗弄了etcd证书. #! /usr/bin/env bash set -e set -u set -x THIS_HOST=$ ...

  6. Scala学习教程笔记三之函数式编程、集合操作、模式匹配、类型参数、隐式转换、Actor、

    1:Scala和Java的对比: 1.1:Scala中的函数是Java中完全没有的概念.因为Java是完全面向对象的编程语言,没有任何面向过程编程语言的特性,因此Java中的一等公民是类和对象,而且只 ...

  7. es6 let和const

    一.let 1.let块作用域 if(true){ var a=1; let b=2; } console.log("a:"+a);//a:1 console.log(" ...

  8. 异象石(就是sdio宝藏那题)

    题解: 之前这道题写过两次题解了吧.. 实现的时候可以用set<int,cmp>来实现按照dfn排序 代码: 感觉别人的分类讨论比我的简单.. 但我觉得我这个写起来也不烦就不看别人的了.. ...

  9. Java LinqCollection 仿Linq的list常用函数

    目前支持find,findAll,sort,select,remove等,java不支持lamda函数,因此用接口代替 public interface Fun<T1,T2> { publ ...

  10. 【AtCoder】ARC075

    ARC075 在省选前一天听说正式选手线画到省二,有了别的女选手,慌的一批,然后刷了一个ARC来稍微找回一点代码感觉 最后还是挂分了,不开心 果然水平退化老年加重啊 原题链接 C - Bugged 直 ...