JedisConnectionException: java.net.ConnectException: Connection refused
出现问题
我遇到的一个问题,在连接redis的时候出现了错误!错误如下:
JedisConnectionException: java.net.ConnectException: Connection refused
看错误是 连接被拒绝,网上查了报这个错误的相关解决方案,没有一个可以解决的!
问题就是上面的报错的问题,先说明一下我出现这个问题的背景或者环境吧。
环境说明
redis集群部署在 A(10.102.1.2)服务器上部署,我在B(10.102.1.1)服务器上进行应用的部署,代码中配置好了连接redis集群的配置。
过程描述
启动部署的应用,报上面的错误,各种排查,无法解决!
- 使用了 ping,服务器之间是通的。
- 使用了 telnet ,B服务器能telnet上Aredis 的每个端口。没有任何问题!
因为 A(10.102.1.2)服务器的redis也有其他项目的应用在使用,那说明redis本身是没有问题的。
然后去找看到redis集群配置的node.conf 看到如下
怎么配置的IP都是本地的回环地址(127.0.0.1)!!!
然后去问其他项目在使用这个redis的应用服务是部署在那台机器上的
回答说:和redis是一台机器!
那这就好接受了,我的连接redis代码和另外一个项目的连接方法一模一样,另一个项目和redis部署在一台机器可以连接上,我的和redis部署不在一台机器就连接不上!那说明这个127.0.0.1 这种集群的配置是有坑的!
因为这台机器这个redis集群还在使用,不在重新修改,我于是在A这台机器上有搭建了一套集群,创建集群的时候使用 服务器IP创建!如下图
然后在应用中修改了redis集群的端口,重启服务,发现连接正常!
总结
本次问题就这样解决 了,花费了很多的时间,刚开始以为代码配置有问题,改了几次代码和配置,不行!
最后就在沟通中浪费了很多时间,我说我这边不能连接redis,对方提供redis服务的人说我们这边连接的好好的,为什么你连接有问题!
我还能说什么!!! 最后我自己查看redis配置,发现上面配置的可疑点 127.0.0.1 ,自己重新配置一套,验证自己的猜想,最后发现的确就是这个集群创建的问题!
创建集群的命令:
redis-trib.rb create --replicas 1 10.102.1.1:7080 10.102.1.1:7081 10.102.1.1:7082 10.102.1.1:7083 10.102.1.1:7084 10.102.1.1:7085
注意:如果在服务器上创建redis集群,请记得使用服务器IP,不要使用127.0.0.1,避免我上面的问题,本机器应用可以访问,其他服务器应用访问有问题!
最后一张图,上面的7080这一套是我自己配置的,下面的6380这一套是之前A(10.102.1.2)服务器上原本有的!
如果您觉得这篇博文对你有帮助,请点赞或者喜欢,让更多的人看到,谢谢!
如果帅气(美丽)、睿智(聪颖),和我一样简单善良的你看到本篇博文中存在问题,请指出,我虚心接受你让我成长的批评,谢谢阅读!
祝你今天开心愉快!
欢迎访问我的csdn博客,我们一同成长!
不管做什么,只要坚持下去就会看到不一样!在路上,不卑不亢!
博客首页 : http://blog.csdn.net/u010648555
© 每天都在变得更好的阿飞
JedisConnectionException: java.net.ConnectException: Connection refused的更多相关文章
- Exception in thread "main" redis.clients.jedis.exceptions.JedisConnectionException: java.net.ConnectException: Connection refused (Connection refused)
一.linux中配置redis,使用java连接测试时报错: Exception in thread "main" redis.clients.jedis.exceptions.J ...
- [已解决] java.net.ConnectException: Connection refused: no further information
程序抛出这个异常的原因多数是因为在此[host:port]没有监听,那么该如何解决这个问题呢,如下 第一个要做的是看你的host和port是否写错了,如 [ 127.00.1:8080 ] 第二个要看 ...
- com.microsoft.sqlserver.jdbc.SQLServerException: 到主机 的 TCP/IP 连接失败。 java.net.ConnectException: Connection refused: connect
问题描述:最简单的数据库连接报错,到主机 的 TCP/IP 连接失败.(win 7 操作系统) 错误信息: com.microsoft.sqlserver.jdbc.SQLServerExcep ...
- JMS集群部署问题 java.net.ConnectException: Connection refused; No available router to destination
1:本地spring配置如下 <!-- JndiTemplate --> <bean id="jndiTpl" class="org.springfra ...
- Debian部署RMI异常:java.rmi.ConnectException: Connection refused to host: 127.0.1.1;
现象:在windows上部署RMI很顺利,但移到debian上部署后,客户端报异常: java.rmi.ConnectException: Connection refused to host: 12 ...
- Call From master/192.168.128.135 to master:8485 failed on connection exception: java.net.ConnectException: Connection refused
hadoop集群搭建了ha,初次启动正常,最近几天启动时偶尔发现,namenode1节点启动后一段时间(大约10几秒-半分钟左右),namenode1上namenode进程停掉,查看日志: -- :: ...
- Caused by: java.net.ConnectException: Call From master/192.168.199.130 to master:9000 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.
1:安装好hive,准备启动的时候出现下面的错误(由于hive是基于Hadoop的,所以必须先将你的集群启动起来,我就是没有启动集群,直接启动hive导致的错误): [root@master bin] ...
- java.net.ConnectException: Connection refused 异常
错误信息: java.net.ConnectException: Connection refused at java.net.PlainSocketImpl.socketConnect(Native ...
- 调用远程主机上的 RMI 服务时抛出 java.rmi.ConnectException: Connection refused to host: 127.0.0.1 异常原因及解决方案
最近使用 jmx 遇到一个问题,client/server 同在一台机器上,jmx client能够成功连接 server,如果把 server 移植到另一台机器上192.168.134.128,抛出 ...
随机推荐
- python爬虫 scrapy3_ 安装指南
安装指南 安装Scrapy 注解 请先阅读 平台安装指南. 下列的安装步骤假定您已经安装好下列程序: Python 2.7 Python Package: pip and setuptools. ...
- Java基础-SSM之Spring和Mybatis以及Spring MVC整合案例
Java基础-SSM之Spring和Mybatis以及Spring MVC整合案例 作者:尹正杰 版权声明:原创作品,谢绝转载!否则将追究法律责任. 能看到这篇文章的小伙伴,详细你已经有一定的Java ...
- sql查询结果存入DataTable,然后从DataTable取数据
public static DataTable SqlConnectionInformation() { string connstr = ConfigurationManager.Connectio ...
- json字符串和Json对象,以及json的基本了解
考虑到python等语言中没有更好表示json对象的方法,所以使用JavaScript来介绍json 首先是json字符串: var str1 = '{ "name": " ...
- yearProgress.vue
<template> <div class="progressbar"> <el-progress :text-inside="true&q ...
- CM记录-CDH大数据平台实施经验总结2016(转载)
CDH大数据平台实施经验总结2016(转载) 2016年负责实施了一个生产环境的大数据平台,用的CDH平台+docker容器的方式,过了快半年了,现在把总结发出来. 1. 平台规划注意事项 1.1 业 ...
- 设计模式之Mixin模式
介绍 mixin模式就是一些提供能够被一个或者一组子类简单继承功能的类,意在重用其功能.在面向对象的语言中,我们会通过接口继承的方式来实现功能的复用.但是在javascript中,我们没办法通过接口继 ...
- CF876 D 树状数组
大意就是放n个硬币,每次放一个计算下这种情况下的操作次数,一个操作为从左到右扫描,如果一个硬币右边是空的,就将硬币后移,否则该次操作停止. 显然发现对于一个情况,我们只要考虑最右边的空位的左侧有几个硬 ...
- 一主多从+Binlog Server,主库故障无法访问,如何在从库中选举一个新主库
一.基本环境 VMware10.0+CentOS6.9+MySQL5.7.19 ROLE HOSTNAME BASEDIR DATADIR IP PORT M ZST1 /usr/local/mysq ...
- 分模块开发创建Action子模块——(九)
web层选择war打包方式. 1.右击父工程新建maven模块