配置yum,nc,telnet
一、学习中问题
最近学习在学习Hadoop的一个子项目Zookeeper,在测试其中的“四字命令”---”echo ruok|nc localhost 2181“时发现命令无法被识别,如下图所示:
[root@hadoop ~]# echo ruok|nc localhost
-bash: nc: command not found
从提示信息中我们可以知道,是由于nc命令无法被找到。出现该情况有两种可能:
(1)没有配置nc命令的环境变量;
(2)该系统没有安装nc命令;
我查看了一下在/usr/bin目录中并没有nc命令,所以我可以认为出现该情况的原因是第二种情况
二、解决办法
由于我的Linux(CentOS6.4)没有安装该命令,所以我需要安装一下该命令,安装办法有两种在线安装和下载后安装。我先尝试的是通过使用yum命令进行在线安装,由于我的系统配置问题并有成功,所以使用了第二种方法安装成功后,后来经过上网查阅,解决了在使用一种方法时所遇到的问题。在此,记录和大家分享一下,首先先介绍下载安装的办法。
(1)下载安装
下载地址: http://sourceforge.net/projects/netcat/files/netcat/0.7.1/netcat-0.7.1-1.i386.rpm/download
安装方法:
1) 下载后得到一个rpm包,如:netcat-0.7.1-1.i386.rpm
2) 将该包通过Wincp将其上传到Linux目录中,我上传的目录是/root/Downloads
3) 进入该目录,执行命令:rpm -ihv netcat-0.7.1-1.i386.rpm,进行安装
4) 安装成功后可以执行命令:nc --help,进行测试
(2)在线安装
在线安装需要我们使用yum命令,由于nc命令通过上述方法已经安装好了,就不在以nc命令为例了。我们以另一种远程联机指令telnet为例。首先我们执行命令:echo ruok|telnet localhost 2181,同样提示该命令无法找到如下图所示:
[root@hadoop ~]# echo ruok|telnet localhost
-bash: telnet: command not found
所以我们也学要安装一下,在这我使用第一种办法,步骤如下:
1)配置yum
yum是一种在线安装和更新软件的工具,使用该工具要保证网络连接,还要有一个可用的软件源,可以使用163或sohu的软件源,软件源地址如下:
a:163的网址:http://mirrors.163.com/ ,进入后点击右列的“fedora使用帮助”,有使用说明
b:sohu的网址:http://mirrors.sohu.com/
c: Centos自带的源
在此我使用的是Centos自带的源,如果使用163下载源,则步骤如下:
a:下载fedora-163.repo和fedora-updates-163.repo, 通过winCP放入Linux中/etc/yum.repos.d/目录
b:运行以下命令生成缓存:yum clean all、yum makecache
在执行上述两条命令后结果如下:
2)执行命令:yum list telnet*;查看telnet相关的安装包,结果如下:
[root@hadoop ~]# yum makecache
Loaded plugins: fastestmirror, refresh-packagekit, security
Repository updates is listed more than once in the configuration
Determining fastest mirrors
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=6&arch=i386&repo=os error was
14: PYCURL ERROR 6 - "Couldn't resolve host 'mirrorlist.centos.org'"
Error: Cannot find a valid baseurl for repo: base
注意:
又出现了问题,出现如下错误信息,是因为DNS配置错误,我装的是Cent OS 6.4 ,没有图形界面,这个版本默认安装后,配置文件中没有配置DNS。
解决办法:
使用vi打开DNS的配置文件进行修改,执行命令: vi /etc/resolv.conf,添加及几行内容,下面是一个例子文件:
nameserver 8.8.8.8
nameserver 8.8.4.4
search localdomain合法的参数及其意义如下:
nameserver 表明DNS 服务器的IP 地址。可以有很多行的nameserver,每一个带一个I P 地址。在查询时就按nameserver 在本文件中的顺序进行,且只有当第一个nameserver 没有反应时才查询下面的nameserver.
domain 声明主机的域名。很多程序用到它,如邮件系统;当为没有域名的主机进行DNS 查询时,也要用到。如果没有域名,主机名将被使用,删除所有在第一个点( . )前面的内容。
search 它的多个参数指明域名查询顺序。当要查询没有域名的主机,主机将在由search 声明的域中分别查找。domain 和search 不能共存;如果同时存在,后面出现的将会被使用。
sortlist 允许将得到域名结果进行特定的排序。它的参数为网络/掩码对。允许任意的排列顺序。
再次执行命令:yum list telnet*,结果如下:
Cannot retrieve metalink for repository: Fedora. Please verify its path and try again
注意:
出现该提示信息的原因是,原因是我在以前/etc/yum.repos.d/下建立了一个163的源,那个文件可能不正确,将那个源移除,再运行yum makecache时就可以了。
再次执行命令:yum list telnet*,结果如下:
[root@hadoop network-scripts]# yum list telnet*
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: centos.ustc.edu.cn
* extras: centos.ustc.edu.cn
* updates: centos.ustc.edu.cn
Available Packages
telnet.i686 :0.17-.el6_3. base
telnet-server.i686 :0.17-.el6_3. base
[root@hadoop network-scripts]#
这次运行成功,telnet.i686表示客户端,telnet-server.i686表示服务端。我们需要的是客户端,安装telnet.i686即可。
3)执行命令:yum install telnet.i686,进行安装,结果如下:
[root@hadoop network-scripts]# yum install telnet.i686
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: centos.ustc.edu.cn
* extras: centos.ustc.edu.cn
* updates: centos.ustc.edu.cn
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package telnet.i686 :0.17-.el6_3. will be installed
--> Finished Dependency Resolution Dependencies Resolved ========================================================================================================================================================================
Package Arch Version Repository Size
========================================================================================================================================================================
Installing:
telnet i686 :0.17-.el6_3. base k Transaction Summary
========================================================================================================================================================================
Install Package(s) Total download size: k
Installed size: k
Is this ok [y/N]: y
Downloading Packages:
telnet-0.17-.el6_3..i686.rpm | kB :
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
Importing GPG key 0xC105B9DE:
Userid : CentOS- Key (CentOS Official Signing Key) <centos--key@centos.org>
Package: centos-release--.el6.centos..i686 (@anaconda-CentOS-.i386/6.4)
From : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
Installing : :telnet-0.17-.el6_3..i686 /
Verifying : :telnet-0.17-.el6_3..i686 / Installed:
telnet.i686 :0.17-.el6_3. Complete!
4)验证,执行命令:telnet --help,如下所示,表示安装成功。
[root@hadoop network-scripts]# telnet --help
telnet: invalid option -- '-'
Usage: telnet [-] [-E] [-L] [-S tos] [-a] [-c] [-d] [-e char] [-l user]
[-n tracefile] [-b hostalias ] [-r]
[host-name [port]]
[root@hadoop network-scripts]#
配置yum,nc,telnet的更多相关文章
- Redhat配置yum源(使用阿里云yum Repo)
1. 查看版本号和系统类别: cat /etc/redhat-release archor cat /etc/issue && arch 2.检查yum是否安装,以及安装了哪些依赖源并 ...
- redhat 配置yum源(配置163 yum repo)
一般安装好redhat后,不能注册的话,不能使用系统自带的yum源.但是我们可以自己配置yum源来解决这一问题.下面介绍下redhat配置163yum源. 1) 查看版本号和系统类别: cat /et ...
- RHEL 7.0 本地配置yum源
RHEL 7.0 本地配置yum源 yum简介 yum = Yellow dog Updater, Modified 主要功能是更方便的添加/删除/更新RPM包. 它能自动解决包的倚赖性问题. 它 ...
- RedHat linux配置yum本地资源
今天安装个linux平台的oracle数据库,在oracle检测的时候发现有些系统补丁包没有安装,手动rpm安装报有些关联包也没有安装,想想如果一个一个rpm的话累死人了要,所以想起用yum来进行安装 ...
- CentOS 6.3 配置 yum
ContOS 配置yum:1.cd /etc/yum.repos.d2.创建个任意目录,将所有文件移动到创建的目录中,除了CentOS-Media.repo3.编辑CentOS-Media.repov ...
- CentOS7.1 JDK安装 和 CentOS7.1配置yum源
1.卸载自带OPENJDK #查看自身jdk java -verson #查看自身安装的java rpm -qa | grep java #显示如下 python-javapackages-3.4. ...
- redhat 6 配置 yum 源的两种方法
由于 redhat的yum在线更新是收费的,如果没有注册的话不能使用,如果要使用,需将redhat的yum卸载后,重启安装,再配置其他源. 本文包括配置本地源及第三方源.第三方源包括:网易,epe ...
- linux配置yum源
yum(全称为 Yellow dog Updater, Modified)是一个在Fedora和RedHat以及SUSE中的Shell前端软件包管理器.基於RPM包管理,能够从指定的服务器自动下载RP ...
- [转]CENTOS 6.5 配置YUM安装NGINX+服务器负载均衡
原文连接: CENTOS 6.5 配置YUM安装NGINX http://blog.sina.com.cn/s/blog_69f467b70102uyux.html 参考博文: Centos下安装. ...
随机推荐
- encode()、decode()字符编码问题
python3中,更改了默认的编码方式,更改为了unicode 前提知识: utf-8与Unicode的关系:https://baike.baidu.com/item/UTF-8/481798?fr= ...
- Python+Selenium笔记(五):生成测试报告
#HTMLTestRunner代码修改参考 微微微笑 的说明,下面是链接,这个已经说的很详细了 https://www.cnblogs.com/miniren/p/5301081.html (一) 前 ...
- JavaScript动画:offset和匀速动画详解(含轮播图的实现)
本文最初发表于博客园,并在GitHub上持续更新前端的系列文章.欢迎在GitHub上关注我,一起入门和进阶前端. 以下是正文. offset简介 我们知道,三大家族包括:offset/scroll/c ...
- 3hibernate核心对象关系映射 xxx.hbm.xml
Hibernate的核心就是对象关系映射: 加载映射文件的两种方式: 第一种:<mapping resource="com/bie/lesson02/crud/po/employee. ...
- C#中获取数组中相加和最接近或等于(<=)给定值的算法
, ,,,,,,,,, }; List<List<int>> mylist = new List<List<int>>(); int length = ...
- 关联与下钻:快速定位MySQL性能瓶颈的制胜手段
本文根据DBAplus社群[2018年1月6日北京开源与架构技术沙龙]现场演讲内容整理而成. 讲师介绍 李季鹏 新炬网络数据库专家 专注于MySQL数据库性能管理及相关解决方案,目前主要从事MySQL ...
- SqlServer中sqlmaint 实用工具和xp_sqlmaint扩展过程
sqlmaint 实用工具可以对一个或多个数据库执行一组指定的维护操作.使用 sqlmaint,可以运行 DBCC 检查.备份数据库及其事务日志.更新统计以及重建索引.所有数据库维护活动都会生成报表, ...
- 检索 COM 类工厂中 CLSID 为 {00021A20-0000-0000-C000-000000000046} 的组件时失败,原因是出现以下错误: 80080005
创建Excel对象失败: Excel.Application xApp = new Excel.Application(); 错误提示:{"检索 COM 类工厂中 CLSID 为 {0002 ...
- pip 设置国内源
最近使用 pip 安装包,动辄十几 k 甚至几 k 的下载速度,确实让人安装的时候心情十分不好.所以还是要给 pip 换一个国内的源.可以显著的提升安装速度.有更多的时间来研究算法. 下面,列一下收集 ...
- python基础学习11----函数
一.函数的定义 def 函数名(参数列表): 函数体 return语句 return语句不写或后边不加任何对象即为return None 二.函数的参数 无参数 def func1(): print( ...