先给大家看几个实例的错误分析与解决方案。

1.ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/data/mysql/mysql.sock'

  • 问题分析:可能是数据库没有启动或者是端口被防火墙禁止。
  • 解决方法:启动数据库或者防火墙开放数据库监听端口。

2.ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

  • 问题分析:密码不正确或者没有权限访问。
  • 解决方法:

1)修改 my.cnf 主配置文件,在[mysqld]下添加 skip-grant-tables,重启数据库。最后修改密码命令如下:

mysql> use mysql;
mysql> update user set password=password("123456") where user="root";

再删除刚刚添加的 skip-grant-tables 参数,再重启数据库,使用新密码即可登录。

2)重新授权,命令如下:

mysql> grant all on *.* to 'root'@'mysql-server' identified by '123456';

3.客户端报 Too many connections

  • 问题分析:连接数超出 Mysql 的最大连接限制。
  • 解决方法:
  • 1、在 my.cnf 配置文件里面增加连接数,然后重启 MySQL 服务。max_connections = 10000
  • 2、临时修改最大连接数,重启后不生效。需要在 my.cnf 里面修改配置文件,下次重启生效。
set GLOBAL max_connections=10000;

4.Warning: World-writable config file '/etc/my.cnf' is ignored ERROR! MySQL is running but PID file could not be found

  • 问题分析:MySQL 的配置文件/etc/my.cnf 权限不对。
  • 解决方法:
chmod 644 /et/my.cnf

5.InnoDB: Error: page 14178 log sequence number 29455369832 InnoDB: is in the future! Current system log sequence number 29455369832

  • 问题分析:innodb 数据文件损坏。
  • 解决方法:修改 my.cnf 配置文件,在[mysqld]下添加 innodb_force_recovery=4, 启动数据库后备份数据文件,然后去掉该参数,利用备份文件恢复数据。

6.从库的 Slave_IO_Running 为 NO

  • 问题分析:主库和从库的 server-id 值一样.
  • 解决方法:修改从库的 server-id 的值,修改为和主库不一样,比主库低。修改完后重启,再同步即可!

7.从库的 Slave_IO_Running 为 NO问题

  • 问题分析:造成从库线程为 NO 的原因会有很多,主要原因是主键冲突或者主库删除或更新数据, 从库找不到记录,数据被修改导致。通常状态码报错有 1007、1032、1062、1452 等。
  • 解决方法一:
mysql> stop slave;
mysql> set GLOBAL SQL_SLAVE_SKIP_COUNTER=1;
mysql> start slave;
  • 解决方法二:设置用户权限,设置从库只读权限
set global read_only=true;

8.Error initializing relay log position: I/O error reading the header from the binary log

  • 分析问题:从库的中继日志 relay-bin 损坏.
  • 解决方法:手工修复,重新找到同步的 binlog 和 pos 点,然后重新同步即可。
mysql> CHANGE MASTER TO MASTER_LOG_FILE='mysql-bin.xxx',MASTER_LOG_POS=xxx;

维护过MySQL的运维或DBA都知道,经常会遇到的一些错误信息中有一些类似10xx的代码。

Replicate_Wild_Ignore_Table:
         Last_Errno: 1032
         Last_Error: Could not execute Update_rows event on table xuanzhi.test; Can't find record in 'test', Error_code: 1032; handler error HA_ERR_KEY_NOT_FOUND; the event's master log mysql-bin.000004, end_log_pos 3704

但是,如果不深究或者之前遇到过,还真不太清楚,这些代码具体的含义是什么?这也给我们排错造成了一定的阻碍。

所以,今天民工哥就把主从同步过程中一些常见的错误代码,它的具体说明给大家整理出来了。

MySQL常见错误代码说明:

  • 130 :文件格式不正确。
  • 145 :文件无法打开
  • 1005:创建表失败
  • 1006:创建数据库失败
  • 1007:数据库已存在,创建数据库失败
  • 1008:数据库不存在,删除数据库失败
  • 1009:不能删除数据库文件导致删除数据库失败
  • 1010:不能删除数据目录导致删除数据库失败
  • 1011:删除数据库文件失败
  • 1012:不能读取系统表中的记录
  • 1020:记录已被其他用户修改
  • 1021:硬盘剩余空间不足,请加大硬盘可用空间
  • 1022:关键字重复,更改记录失败
  • 1023:关闭时发生错误
  • 1024:读文件错误
  • 1025:更改名字时发生错误
  • 1026:写文件错误
  • 1032:记录不存在
  • 1036:数据表是只读的,不能对它进行修改
  • 1037:系统内存不足,请重启数据库或重启服务器
  • 1038:用于排序的内存不足,请增大排序缓冲区
  • 1040:已到达数据库的最大连接数,请加大数据库可用连接数
  • 1041:系统内存不足
  • 1042:无效的主机名
  • 1043:无效连接
  • 1044:当前用户没有访问数据库的权限
  • 1045:不能连接数据库,用户名或密码错误
  • 1048:字段不能为空
  • 1049:数据库不存在
  • 1050:数据表已存在
  • 1051:数据表不存在
  • 1054:字段不存在
  • 1065:无效的SQL语句,SQL语句为空
  • 1081:不能建立Socket连接
  • 1114:数据表已满,不能容纳任何记录
  • 1116:打开的数据表太多
  • 1129:数据库出现异常,请重启数据库
  • 1130:连接数据库失败,没有连接数据库的权限
  • 1133:数据库用户不存在
  • 1141:当前用户无权访问数据库
  • 1142:当前用户无权访问数据表
  • 1143:当前用户无权访问数据表中的字段
  • 1146:数据表不存在
  • 1147:未定义用户对数据表的访问权限
  • 1149:SQL语句语法错误
  • 1158:网络错误,出现读错误,请检查网络连接状况
  • 1159:网络错误,读超时,请检查网络连接状况
  • 1160:网络错误,出现写错误,请检查网络连接状况
  • 1161:网络错误,写超时,请检查网络连接状况
  • 1062:字段值重复,入库失败
  • 1169:字段值重复,更新记录失败
  • 1177:打开数据表失败
  • 1180:提交事务失败
  • 1181:回滚事务失败
  • 1203:当前用户和数据库建立的连接已到达数据库的最大连接数,请增大可用的数据库连接数或重启数据库
  • 1205:加锁超时
  • 1211:当前用户没有创建用户的权限
  • 1216:外键约束检查失败,更新子表记录失败
  • 1217:外键约束检查失败,删除或修改主表记录失败
  • 1226:当前用户使用的资源已超过所允许的资源,请重启数据库或重启服务器
  • 1227:权限不足,您无权进行此操作
  • 1235:MySQL版本过低,不具有本功能
  • 1250:客户端不支持服务器要求的认证协议,请考虑升级客户端。
  • 1251:Client 不能支持 authentication protocol 的要求Client does not support authentication protocol requested by server; consider upgrading MySQL clientQuote:
  • 1267:不合法的混合字符集。
  • 2002:服务器端口不对。
  • 2003:MySQL 服务没有启动,请启动该服务。
  • 2008:MySQL client ran out of memory错误指向了MySQL客户mysql。这个错误的原因很简单,客户没有足够的内存存储全部结果。
  • 2013:远程连接数据库是有时会有这个问题,MySQL 服务器在执行一条 SQL 语句的时候失去了连接造成的。
  • 10048:建议在my.ini文件中修改最大连接数, 把 mysql_connect() 方法都改成了 mysql_pconnect() 方法. 要修改mysql_pconnect(),可以在论坛的data目录的sql_config.php中 p c o n n e c t = 0 ; / / 是 否 持 久 连 接 修 改 成 pconnect = 0; //是否持久连接 修改成pconnect=0;//是否持久连接修改成pconnect = 1; 开启防刷新,严禁刷新太快.
  • 10055:没有缓存空间可利用,查看下你的C盘空间是否已经满,清除一些没有用的文件. 可以在后台的"论坛核心设置","核心功能设置"里"进程优化"开启,"GZIP 压缩输出"关闭.查找了一下10055(没有缓存空间可利用)
  • 10061: 启动这台机器上的MySQL服务 如服务启动失败,一定是你的my.ini文件出了差错, MySQL服务不能正常启动 你删除了它后,MySQL就会按其默认配置运行, 那就没有问题了

给大家推荐几篇MySQL的文章,值得学习!!!

一入职,就遇到 MySQL 这么大 Bug!差点背锅走人...

超赞!墙裂推荐一个 MySQL 自动化运维工具!

记住!永远不要在 MySQL 中使用 UTF-8

为什么不建议把数据库部署在Docker容器内?

赞!7000 字学习笔记,MySQL 从入门到放弃

官方工具|MySQL Router 高可用原理与实战

以上就是今天给大家整理的常见错误代码说明,希望对大家的日常工作或学习有所帮助与借鉴,大家可以点个赞与转发分享支持一波,你的支持就是民工哥最大的写作动力。

建议收藏备查!MySQL 常见错误代码说明的更多相关文章

  1. mysql常见错误代码解释

    mysql常见错误代码解释 原创 作者:bayaim 时间:2017-12-26 11:07:14 38  ---------------------------------------------- ...

  2. MySQL常见错误代码说明

    附:MySQL常见错误代码说明 1005:创建表失败 1006:创建数据库失败 1007:数据库已存在,创建数据库失败 1008:数据库不存在,删除数据库失败 1009:不能删除数据库文件导致删除数据 ...

  3. MySql 常见错误代码大全 VV2

    从机一直1593错误,排查了半天发现是从的配置文件中的server-id没改导致,此低级错误记录下警醒自己 B.1. 服务器错误代码和消息 服务器错误信息来自下述源文件: · 错误消息信息列在shar ...

  4. MySql 常见错误代码大全

    B.. 服务器错误代码和消息 服务器错误信息来自下述源文件: · 错误消息信息列在share/errmsg.txt文件中.“%d”和“%s”分别代表编号和字符串,显示时,它们将被消息值取代. · 错误 ...

  5. 【转】MySQL常见错误代码及代码说明参考

    Mariadb文档:https://mariadb.com/kb/zh-cn/mariadb/ MySQL文档:https://dev.mysql.com/doc/refman/8.0/en/ 100 ...

  6. MySQL常见错误代码及代码说明

    1005:创建表失败 1006:创建数据库失败 1007:数据库已存在,创建数据库失败<=================可以忽略 1008:数据库不存在,删除数据库失败<======== ...

  7. MYSQL常见出错mysql_errno()代码解析

    如题,今天遇到怎么一个问题, 在理论上代码是不会有问题的,但是还是报了如上的错误,把sql打印出來放到DB中却可以正常执行.真是郁闷,在百度里面 渡 了很久没有相关的解释,到时找到几个没有人回复的 & ...

  8. MySQL常见备份方案

    MySQL常见备份方案有以下三种: mysqldump + binlog lvm + binlog xtrabackup 本例为方便演示,数据库里面数据为空.下面开始动手 mkdir /opt/bac ...

  9. mysql常见安全加固策略

    原创 2017年01月17日 21:36:50 标签: 数据库 / mysql / 安全加固 5760 常见Mysql配置文件:linux系统下是my.conf,windows环境下是my.ini: ...

  10. mysql常见知识点总结

    mysql常见知识点总结 参考: http://www.cnblogs.com/hongfei/archive/2012/10/20/2732516.html https://www.cnblogs. ...

随机推荐

  1. Note -「virtual tree」shorter vrt

    Part. 1 Preface 没什么 preface. Part. 2 实现 具体来说就是把所有关键点按 \(\text{dfn}\) 排序,去重,然后求出相邻结点的 \(\text{LCA}\), ...

  2. VMware Work Station使用ubuntu20.04挂载共享文件夹写入文件时出现输入/输出错误

    原因是默认的max_write为0x00020000即128k,超过此大小会报错,另外big_writes,umask等选项也要加上, sudo /usr/bin/vmhgfs-fuse .host: ...

  3. 用Rust手把手编写一个Proxy(代理), TLS加密通讯

    用Rust手把手编写一个Proxy(代理), TLS加密通讯 项目 ++wmproxy++ gite: https://gitee.com/tickbh/wmproxy github: https:/ ...

  4. snowboy 无法 install

    pip install -i https://pypi.tuna.tsinghua.edu.cn/simple snowboy Looking in indexes: https://pypi.tun ...

  5. jmeter生成随机英文的几种方法

    第一种:用BeanShell后置处理程序 1.写脚本 import java.util.Random; String random(int s_length) {       strings= &qu ...

  6. [GXYCTF 2019]Ping Ping Ping

    题目就是ping,而且这还有一个查询窗口,就随便查询试试 ping了一下本地,发现没有什么很大的作用,给出了提示是php可以执行系统函数这就感到神奇了,就还是上网搜了搜 发现可以在查询IP后面进行拼接 ...

  7. Mybatis_plus笔记

    Mybatis_plus笔记 在使用mybatis_plus的过程中我们可以明显的感受到他的强大之处.它就像是Mybatis和Jpa的结合体一样,它拥有jpa对单表的各种CRUD操作以及强大的条件构造 ...

  8. Python:利用math和random模块实现RSA加密算法

    实验五报告: 利用math和random模块实现RSA加密算法 实验目标 本实验的主要目标是熟悉RSA(Rivest-Shamir-Adleman)密码算法的编写,其中包括求最大公因子.模逆的扩展欧几 ...

  9. 【Vue3响应式入门#01】Reactivity

    专栏分享:vue2源码专栏,vue3源码专栏,vue router源码专栏,玩具项目专栏,硬核推荐 欢迎各位ITer关注点赞收藏 背景 以下是柏成根据Vue3官方课程整理的响应式书面文档 - 第一节, ...

  10. Facade 外观模式简介与 C# 示例【结构型5】【设计模式来了_10】

    〇.简介 1.什么是外观模式? 一句话解释:   将一系列需要一起进行的操作,封装到一个类中,通过对某一个方法的调用,自动完成一系列操作. 外观模式是一种简单而又实用的设计模式,它的目的是提供一个统一 ...