1、安装JDK8(Elastic 需要 Java 8 环境)

  1)下载jdk8文件:http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html\

  2)解压文件:tar -zxvf jdk-8u191-linux-x64.tar.gz

  3)将JDK移动到/usr/local/jdk1.8.0_191目录之中:mv jdk1.8.0_191 /usr/local/jdk1.8.0_191

  4)配置环境变量:

    a)vi /etc/profile

    b)在末尾添加

      export JAVA_HOME=/usr/local/jdk1.8.0_191
      export CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar
      export PATH=$JAVA_HOME/bin:$PATH:$HOME/bin

    c)source /etc/profile

  5)验证是否安装成功:java -version

2、安装Elastic

  1)下载Elastic:wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-6.3.0.tar.gz

  2)解压文件:tar -zxvf elasticsearch-6.5.0.tar.gz

  3)安装:mv elasticsearch-6.5.0 /opt

3、创建Elasticsearch用户

  es 规定 root 用户不能启动 es,所以需要新建一个其他用户来启动 es修改配置文件

  1)添加用户:adduser esuser

  2)设定密码:passwd esuser

  3)添加权限:chown -R esuser /opt/elasticsearch-6.5.0

4、修改配置文件

  1)进入/opt/elasticsearch-6.5.0/config目录,使用vi编辑器:vi elasticsearch.yml(注:冒号前面不能有空格,后面必须有一个空格)
  2)取消如下注释,并修改为当前主机地址:
    cluster.name: my-application
    node.name: node-1
    bootstrap.memory_lock: false
    network.host: 10.100.2.235
    http.port: 9200
    discovery.zen.ping.unicast.hosts: ["10.100.2.235"]
    discovery.zen.minimum_master_nodes: 1 #注意,因为本人目前是单节点,这里必须为1
  3)新增如下配置:
    transport.tcp.port: 9300
    transport.tcp.compress: true
    bootstrap.system_call_filter: false
  4)使用vi编辑器,修改/etc/sysctl.conf文件,添加如下代码(若无将会出现下面常见问题2):
    vm.max_map_count=262144
  5)退出保存后执行如下命令:
    sysctl -p
  6)使用vi编辑器,修改/etc/security/limits.conf文件,在文件末尾添加如下代码(若无将会出现下面常见问题3):
    # esuser为登录服务器的用户名
    esuser soft nofile 65536
    esuser hard nofile 65536
    esuser soft nproc  4096
    esuser hard nproc  4096

5、启动Elasticsearch

  1)切换用户
    su esuser
  2)查看当前用户
    who am i
  3)启动服务
    elasticsearch-6.5.0/bin/elasticsearch
  4)后台启动
    elasticsearch-6.5.0/bin/elasticsearch -d
  5)测试是否启动成功
    curl -XGET 'http://10.100.2.235:9200/'

Linux下安装Elasticsearch6.5的更多相关文章

  1. Linux下安装 Posgresql 并设置基本参数

    在Linux下安装Postgresql有二进制格式安装和源码安装两种安装方式,这里用的是二进制格式安装.各个版本的Linux都内置了Postgresql,所以可直接通过命令行安装便可.本文用的是Cen ...

  2. Linux下安装Tomcat服务器和部署Web应用

    一.上传Tomcat服务器

  3. Linux下安装使用Solr

    Linux下安装使用Solr 1.首先下载Solr.mmseg4j分词包.tomcat并解压,这用google.百度都可以搜索得到下载地址. 2.因为要使用到中文分词,所以要设置编码,进入tomcat ...

  4. Linux下安装tar.gz类型的jdk,并配置环境变量

    近期因要学习一门技术,必须在Linux下运行,故开始学习如何使用Linux. 在安装jdk时出现了困难,环境变量配置不成功,花了一天时间才搞定,特分享出来,供大家参考. Linux下安装jdk,步骤如 ...

  5. Linux下安装和配置JDK与Tomcat(升级版)

    在这个版本 Linux下安装和配置JDK与Tomcat(入门版) 的基础上优化升级 1.下载相关软件 apache-tomcat-6.0.37.tar.gz jdk-6u25-linux-i586-r ...

  6. Linux下安装cmake

    cmake是一个跨平台的编译工具,特点是语句简单,编译高效,相对于原有的automake更为高效,接下来说明在Linux下安装cmake工具的过程 首先去cmake官网下载cmake安装包,下载界面网 ...

  7. linux下安装安装pcre-8.32

    linux下安装安装pcre-8.32 ./configure --prefix=/usr/local/pcre 出现以下错误 configure: error: You need a C++ com ...

  8. CentOS linux下安装和配置Apache+SVN(用浏览器http方式访问SVN目录)

    在CentOS linux下安装SVN,我们可以进行以下步骤: 第一步:安装CentOS Linux操作系统,并在CentOS安装进行的同时,自定义安装这一步,一定要勾选Subversion(在“开发 ...

  9. Linux下安装Apache并以mod_wsgi方式部署django站点

    源码编译方式安装Apache 首先下载Apache源码压缩包,地址为http://mirror.bit.edu.cn/apache/httpd/ 继续下载apr和apr-util压缩包,地址为http ...

随机推荐

  1. 五、WebSocket 链接

    一.前端代码: <!DOCTYPE html> <html lang="en" xmlns="http://www.w3.org/1999/xhtml& ...

  2. Dubble 入门

    Dubbo 01 架构模型 传统架构 All in One 测试麻烦,微小修改 全都得重新测 单体架构也称之为单体系统或者是单体应用.就是一种把系统中所有的功能.模块耦合在一个应用中的架构方式.其优点 ...

  3. P1903 奖学金题解

    众所周知,这是一道通过struct结构体进行排序的题目 思路:平常的输入.. 然后定义一个结构体grade,存放每个学生的学号.三科成绩.(也可以只存语文成绩和总分和学号) 自定义cmp函数,通过三层 ...

  4. linux shell鼠标键盘快捷键

  5. js常用操作

    map操作:var map = {};map["a"] = 1;map["b"] = 2; console.log(Object.keys(map)); //[ ...

  6. jmeter之csv文件参数化

    1.准备好CSV文件,记下路径 2.点击测试计划或者线程组,添加配置元件 ——CSV Data Set Config 3.填写相关参数 4.使用参数

  7. redis集群搭建_超详细

    redis集群中至少应该有三个节点,以保证当集群中的某个节点挂掉,其他节点进行容错投票时,投票数能超过半票. 要保证高可用,则还需要每一个节点有一个备份机. 因此redis集群至少需要6台服务器.这里 ...

  8. 【长郡NOIP2014模拟10.22】搞笑的代码

    题目 在OI界存在着一位传奇选手--QQ,他总是以风格迥异的搞笑代码受世人围观 某次某道题目的输入是一个排列,他使用了以下伪代码来生成数据 while 序列长度<n do { 随机生成一个整数属 ...

  9. 解决 Failed to start LSB: Bring up/down networking 问题

    我用的是虚拟机,一换网络环境虚拟机的ip就没有了,重启网上就报Failed to start LSB: Bring up/down networking错误.网上查了一圈说什么HWADDR有问题,改了 ...

  10. 【织梦手机端仿站】和PC一个后台

    卸载插件,织梦默认带手机站,无需复杂使用插件以后不方便升级.织梦2015年6月8日更新后,就添加了很多针对手机移动端的设计,最大的设计就是添加了生成二维码的织梦标签和织梦手机模板功能,织梦更新后,默认 ...