文档 ID

…
 
 
 
 

11.2 RAC DBconsole Creation Fails With Error: "Invalid username/password or database/scan listener not up" (文档 ID 1276751.1) 转到底部

修改时间:
注释 (0)

 

 

In this Document

  Symptoms
  Cause
  Solution

Applies to:

Enterprise Manager for Oracle Database - Version 11.2.0.0 to 11.2.0.3 [Release 11.2]

Information  in this document applies to any platform.

Checked for relevance on 10-Feb-2013

Symptoms

Creating RAC DBConsole failing with following error:
 
emca -config dbcontrol db -repos create -cluster
=============
STARTED EMCA at Dec 23, 2010 5:08:26 PM
EM Configuration Assistant, Version 11.2.0.0.2 Production
Copyright (c) 2003, 2005, Oracle.  All rights reserved.
 
Enter the following information:
Database unique name: orcl
Service name: orcl
Listener port number: 1561
Listener ORACLE_HOME [ /u01/grid/11.2.0 ]: /u01/oracle/product/db/11.2.0
Password for SYS user:
Password for DBSNMP user:
Password for SYSMAN user:
Cluster name: crs
Email address for notifications (optional):
Outgoing Mail (SMTP) server for notifications (optional):
ASM ORACLE_HOME [ /u01/grid/11.2.0 ]:
ASM port [ 1561 ]: 1521
ASM username [ ASMSNMP ]:
ASM user password:
Invalid username/password or database/scan listener not up or database service is not registered with scan listener.
ASM user password: 
===============
 
Following are the errors logged in emca log:
============
Dec 23, 2010 5:10:36 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngineRemotely
CONFIG: SQLEngine connecting with Service Name: +ASM, oracleHome: /u01/grid/11.2.0, and user: ASMSNMP host: racnode1 port: 1561
Dec 23, 2010 5:10:37 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngineRemotely
CONFIG: ORA-12514: TNS:listener does not currently know of service requested in connect descriptor
 
oracle.sysman.assistants.util.sqlEngine.SQLFatalErrorException: ORA-12514: TNS:listener does not currently know of service requested in connect descriptor
 
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.executeImpl(SQLEngine.java:1655)
...
Dec 23, 2010 5:10:43 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngineRemotely
CONFIG: SQLEngine connecting with Service Name: +ASM, oracleHome: /u01/grid/11.2.0, and user: SYS host: racnode2 port: 1561
Dec 23, 2010 5:10:43 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngineRemotely
CONFIG: ORA-12514: TNS:listener does not currently know of service requested in connect descriptor
===========

Cause

Database is configured with listener port 1561 while ASM instance is configured with port 1521.
In this case, ASM instance is not registered with database listener running on 1561 port.
 
Database listener:
===========
Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=racnode1)(PORT=1561)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=192.168.1.1)(PORT=1561)))
Services Summary...
Service "orcl" has 2 instance(s).
Instance "orcl_1", status READY, has 1 handler(s) for this service...
The command completed successfully
 
ASM Listener:
=========
Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=LISTENER)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=192.168.1,1)(PORT=1521)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=192.168.1.2)(PORT=1521)))
Services Summary...
Service "+ASM" has 1 instance(s).
Instance "+ASM1", status READY, has 1 handler(s) for this service...

The command completed successfully

Solution

Register the ASM instances with the database listener:
 
alter system set local_listener='(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=racnode1)(PORT=1561))))' scope=both sid='+ASM1';
alter system set local_listener='(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=racnode2)(PORT=1561))))' scope=both sid='+ASM2';

NOTE: port numbers here are just for demonstration purposes.

"Invalid username/password or database/scan listener not up"的更多相关文章

  1. ORA-01017 invalid username/password;logon denied" (密码丢失解决方案)

    1.先确认是否输错 用户名和密码 2.如果的确是丢失密码的话: 查看sqlnet.ora 如果是 SQLNET.AUTHENTICATION_SERVICES= (NONE) , 需更改为SQLNET ...

  2. sqlplus登录Oracle时ORA-01017: invalid username/password; logon denied的错误

    今天用scott用户登录Oracle数 据库时,竟然出现了ORA-01017: invalid username/password; logon denied错误,原以为是因为我的scott用户没有解 ...

  3. Oracle 12C 密码文件问题 ORA-01017: invalid username/password; logon denied

    新安装的Oracle 12.1.0.2.0,NBU在测试备份的时候报ORA-01017 --alter user sys identified by "Wwjd!23";sqlpl ...

  4. ORA-01017: invalid username/password; logon denied 解决方案

    在SQLPLUS窗口下进行用户登录,出现ORA-01017:invalid username/password:logon denied .如下图: 在网上找了很久,发现一个实用的解决方案,操作如下: ...

  5. JDBC连接ORACLE无法登陆java.sql.SQLException: ORA-01017: invalid username/password; logon denied

    当用jdbc连接Oracle数据库的时候 private Connection getConnection() throws SQLException { OracleDataSource ods = ...

  6. LR连接oracle时出现:SQLState=28000[Oracle][ODBC][Ora]ORA-01017:invalid username/password;logon denied

    出现的现象:

  7. 被拒--悲剧之ORA-01017: invalid username/password; logon denied 错误

    本地没有安装oracle.安装了oracleclient和PL/SQL Developer.来实现对oracle数据库的可视化操作. 在使用在登录PL/SQL无法登录.提示错误:ORA-01017: ...

  8. .NET 通过entity framework报数据库连接错误:ORA-01017: invalid username/password; logon denied

    如题,答案为:[ORA-01017].NET程序连接数据库失败 转载文章内容如下: 遇到问题 使用 C#/.NET 开发的一个客户端程序,需要连接 ORACLE 数据库,使用 Oracle.Manag ...

  9. oracle 12c ORA-01017:invalid username/password; logon denied

    Oracle 12C 中,想通过操作系统认证登录Oracle 数据库,有一些要注意的地方.不然就会遇到 ORA-01017:invalid username/password; logon denie ...

随机推荐

  1. KVM的虚拟化研究及应用

    引言 虚拟化技术是IBM在20世纪70年代首先应用在IBM/370大型机上,这项技术极大地提高了大型机资源利用率.随着软硬件技术的迅速发展,这项属于大型机及专利的技术开始在普通X86计算机上应用并成为 ...

  2. CodeIgniter 应用开发笔记 - 3

    使用migration建数据表 一.新建migrations文件夹 在application新建一个文件夹migrations,存放建表类. 建表类使用用户手册中的代码作为模板(user_guide/ ...

  3. PHP - 将HTML代码转义

    代码: 页面显示: 页面源码:

  4. Ext.net中常用的三种交互方式

    http://www.ext.net.cn/forum.php?mod=viewthread&tid=10433

  5. Java正则表达式基本应用

    一.概述 正则表达式因为其强大的字符串处理能力,刚开始被被广泛地应用到各种UNIX工具中,如大家熟知的 Perl脚本语言 .后来正则表达式在各种 计算机语言 和各种应用领域得到了广泛的应用和发展,目前 ...

  6. linux下的软件包安装

    linux下安装软件包有两种方法:源文件编译安装(source)和 rpm 安装. 1.源文件包安装的通用方法. 一般安装源代码的程序你得要看它的README,一般在它的目录下都有的. 01.配置: ...

  7. PHP - 类库

    常用的PHP类库,PHP开发者必备[转] PHP开发者常用的PHP类库和组件 PDF 生成器 FPDF - 这量一个可以让你生成PDF的纯PHP类库. Excel 相关 你的站点需要生成Excel?没 ...

  8. IIS - HTTP 错误 500.21 - Internal Server Error 处理程序“WebServiceHandlerFactory-Integrated”在其模块列表中有一个错误模块“ManagedPipelineHandler”

    http://www.cnblogs.com/yc-755909659/p/3445278.html 首先观察,aspnet_regiis.exe文件是不是损坏的,如果是,重新下载,覆盖即可,在百度云 ...

  9. C++如何屏蔽双击运行程序功能?

    问题描述: 我们开发过程中可能会经常遇到,需要屏蔽EXE的双击运行功能,只能通过宿主程序(Service或EXE)来启动.比如腾讯的迷你弹窗,就只能通过主程序来启动,而不能直接通过双击来运行. 实现原 ...

  10. 《WCF技术剖析》博文系列汇总[持续更新中]

    原文:<WCF技术剖析>博文系列汇总[持续更新中] 近半年以来,一直忙于我的第一本WCF专著<WCF技术剖析(卷1)>的写作,一直无暇管理自己的Blog.在<WCF技术剖 ...