该怎么解决no route to host
出现No route to host 的时候,有如下几种可能:
1、对方的域名确实不通
2、本机自己开了防火墙
3、本机的etc/hosts 里面没有配置本机的机器名和ip (可能性最大)
其中第三点是最猫腻的,在不配置的时候是间断性的(可能1个月都正常,然后突然几天不正常)。修改方案如下:
在结尾加上:机器名和机器ip(用空格隔开)
扩展资料:
# telnet虚拟机No route to host的解决方法:
## 问题
知道虚拟机的ip地址,而且可以ping的通:
[minbo@ares ~]$ ping 192.168.62.110
PING 192.168.62.110 (192.168.62.110) 56(84) bytes of data.
64 bytes from 192.168.62.110: icmp_seq=1 ttl=64 time=0.831 ms
64 bytes from 192.168.62.110: icmp_seq=2 ttl=64 time=0.769 ms
64 bytes from 192.168.62.110: icmp_seq=3 ttl=64 time=0.966 ms
64 bytes from 192.168.62.110: icmp_seq=4 ttl=64 time=0.829 ms
64 bytes from 192.168.62.110: icmp_seq=5 ttl=64 time=0.903 ms
64 bytes from 192.168.62.110: icmp_seq=6 ttl=64 time=0.886 ms
^C
--- 192.168.62.110 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5604ms
rtt min/avg/max/mdev = 0.769/0.864/0.966/0.062 ms
但是telnet连不通
telnet 192.168.62.110 7000
Trying 192.168.62.110...
telnet: connect to address 192.168.62.110: No route to host
## 解决方案
把虚拟机中的防火墙清一下
sudo iptables -F
我们信任您已经从系统管理员那里了解了日常注意事项。
总结起来无外乎这三点:
1、尊重别人的隐私。
2、输入前要先考虑(后果和风险)。
3、权力越大,责任越大。
[sudo] minbo 的密码:
再次telnet就好了
该怎么解决no route to host的更多相关文章
- 解决Zabbix网页端Get value error: cannot connect to [[192.168.238.139]:10050]: [113] No route to host问题
在安装配置完zabbix_agentd以后,网页端出现 Get value error: cannot connect to [[192.168.238.139]:10050]: [113] No ...
- centos 7 IP不能访问nginx Failed connect to 185.239.226.111:80; No route to host解决办法
服务器环境 centos 7.4 问题描述 1.可以ping通IP ,用IP访问nginx 不能访问,在服务器上curl localhost curl 185.239.226.111可以获得 [ro ...
- CentOS下配置Hadoop集群:java.net.NoRouteToHostException: No route to host问题的解决
我用的是hadoop 1.2.1 遇到的问题是: hadoop中datanode无法启动,报Caused by: java.net.NoRouteToHostException: No route t ...
- ssh连接MAC服务器显示No route to host解决方法
首先MAC操作系统是10 其它电脑通过ssh访问一台mac服务器时,有时候可以登录进去,有显示显示no route to host 并且通过浏览器访问布署在mac上的jenkins,反应奇慢,后来做了 ...
- 远程连接mongodb出现 no route to host 和 Connection refused
部署好mongodb服务器后,在客户端安装好php的mongodb扩展,用程序连接mongodb服务器出错:no route to host.搜索了差不多一天的时候都没有相关的解决方法.最后在mong ...
- 转载:解决linux ping: unknown host www.baidu.com
解决linux ping: unknown host www.baidu.com 转载网址:http://www.kankanews.com/ICkengine/archives/48417.shtm ...
- 两个docker容器互连时,提示no route to host错误的问题
大家都知道,两个docker container互连的时候可以用link,但是,我们也知道,container可以将自己的端口映射到宿主机上,比如一个container A上的tomcat将端口暴露给 ...
- Hadoop1.2.1异常No route to host
Hadoop1.2.1异常Bad connect ack with firstBadLink (No route to host ) 0.说明 Hadoop集群之前运行正常,增加了新节点之后,需要执行 ...
- nfs报错 - No route to host
nfs报错 - No route to host ______________________________ 因为防火墙阻止的原因. 解决方法:服务器rhel7系统下,打开firewall-conf ...
- dubbo zookeeper报错failed to connect to server , error message is:No route to host
failed to connect to server , error message is:No route to host 转自:http://blog.csdn.net/miaohongyu1/ ...
随机推荐
- 使用 KubeKey 在 AWS 高可用部署 Kubernetes
作者:李耀宗 介绍 对于生产环境,我们需要考虑 Kubernetes 集群的高可用性.本文教您部署如何在多台 AWS EC2 实例快速部署一套高可用的生产环境.要满足 Kubernetes 集群服务需 ...
- KubeSphere 社区双周报 | OpenFunction 发布 v1.1.0 | 2023.5.26-6.8
KubeSphere 社区双周报主要整理展示新增的贡献者名单和证书.新增的讲师证书以及两周内提交过 commit 的贡献者,并对近期重要的 PR 进行解析,同时还包含了线上/线下活动和布道推广等一系列 ...
- 为 KubeSphere 集群启用免费的泛域名 SSL 证书并实现证书自动更新和分发
作者:scwang18,主要负责技术架构,在容器云方向颇有研究. 前言 KubeSphere 集群默认安装的证书是自签发证书,浏览器访问访问会发出安全提醒.本文记录了利用 let's encrytp ...
- 为 .NET Conf 2024 做好准备之本地社区活动 .NET Conf China 2024 启动
.NET Conf 2024 是一个面向.NET生态系统社区的大型活动,将于2024年11月12日至14日举行.该活动将通过YouTube和Twitch进行现场直播,并在dotnetconf.net网 ...
- Linux设置显示中文和设置字体
设置中文 一.查看当前使用的系统语言 1.登陆linux系统打开操作终端之后,输入 echo $LANG可以查看当前使用的系统语言.如 echo $LANG 2.查看安装的语言包 查看是否有中文语言包 ...
- Webshell流量分析之哥斯拉Godzilla&冰蝎Behinder
目录 哥斯拉 冰蝎 哥斯拉和冰蝎相较于菜刀蚁剑,它们的通信流量是加密的,有比较好的抗检测能力. 菜刀和蚁剑流量分析:Webshell流量分析之菜刀Chopper&蚁剑AntSword 哥斯拉 ...
- 解密Facebook产品的开发流程
作者: 王淮 来源: <程序员> 发布时间: 2013-03-25 17:22 阅读: 3750 次 推荐: 6 原文链接 [收藏] [编者注]王淮是Facebook第 ...
- Java Study For Seven Day( 面向对象三)
继承 class Person { String name; int age; } class Student extends Person { void study() { System.out.p ...
- nvm node版本管理
1.说明 NVM是NODE JS的版本管理工具,可以安装nodejs切换nodejs版本. 2.安装NVM https://github.com/coreybutler/nvm-windows/rel ...
- uniapp select组件
1.前言 官方的picker组件不能禁用某个下拉项,所以就有了这个下拉组件 组件只适配了宽屏模式,效果参照element-ui的select组件 demo地址:lianlizhou / ep-sele ...