ElasticSearch在linux上的安装部署全程记录
由于项目需求,需要在linux平台搭建一套ES服务。在搭建过程中,遇到各种各样的问题。后来都一一解决。现在要记录下来这个过程,以及其中遇到的问题,及其解决方法。
一、环境配置
操作系统:Cent OS 7
ElasticSearch版本:1.4.1
JDK版本:1.7
SSH Secure Shell版本:3.2.9
elasticsearch-servicewrapper :ES的服务插件,一般在linux上使用。
二、操作过程
1. elasticsearch 作为一个系统service应用 ,可以安装elasticsearch-servicewrapper插件。
在https://github.com/elasticsearch/elasticsearch-servicewrapper下载该插件后,解压缩。将service目录拷贝到elasticsearch目录的bin目录下。运行这个插件的好处是:elasticsearch需要的jvm参数和其它配置都已经配置好了,非常方便。
2. 通过SSH Secure Shell连接工具,将ES和Sevice文件夹上传到linux系统相应目录。

3. 在linux环境,进入ES目录的bin/service目录,如下图,运行命令sh elasticsearch start

4. 安装es-head插件
进入elasticsearch/bin目录,输入命令./plugin –install mobz/elasticsearch-head 安装head插件。如图

5. 在浏览器中输入http://localhost:9200,http://localhost:9200/_plugin/head/如下图所示则ES启动成功。


6.若是要停止ES服务,则输入sh elasticsearch stop,则输出如下图,则ES成功停止。

三、遇到的问题及其解决方法
1. 在linux上启动ES时与plugin命令安装ES-Head插件时,都出现了如下问题。此处以plugin作为例子,来给出解决方法。
发现这个问题,就用ls -l命令来查看文件的操作权限,如图
附:文件的权限
![]()
r — 文件可以被读取
w — 文件可以被写入
x — 文件可以被执行(如果它是程序的话)
可见,plugin文件,所有者只有读和写的权限,没有执行的权限。所以需要给这个文件加上可被执行的权限。
应用命令chmod +x plugin 来操作
再输入ls –l 来查看,已经具有了X权限
此时再plugin安装插件head,则可以正常安装。
2. 运行es,会提示错误,类似一些version error的错误。JDK版本若不是7,可能会出现ES启动不起来的问题。linux 自带的opensdk7 也最好不要使用。
Elasticsearch依赖Java 7。推荐使用Oracle JDK 1.7.0_55版本。Java的安装,在各个平台上都有差异,所以我们不想在这里深入太多细节。我只想说,在你安装Elasticsearch之前,你可以通过以下命令来检查你的Java版本(如果有需要,安装或者升级): java –version
3.JDK7安装后,系统就会具有两个版本的java,为了确保调用JAVA7版本,需要修改环境变量,保证java7的路径在最前面。
输入命令:vim ~/.bashrc 打开环境变量内容:
ElasticSearch在linux上的安装部署全程记录的更多相关文章
- ElasticSearch elasticsearch-servicewrapper 在linux上的安装部署全程记录
原文地址:http://www.cnblogs.com/tianjixiaoying/p/4316011.html 由于项目需求,需要在linux平台搭建一套ES服务.在搭建过程中,遇到各种各样的问题 ...
- Elastic-search在linux上的安装
今天是我装第四次 ES ,之前装好用了一段时间,后面莫名其妙爆炸了,炸出一堆异常... 安装环境: JDK1.8 centos ElasticSearch-6.2.4 jdk1.8以上,所以 ...
- elasticsearch在linux上的安装,Centos7.X elasticsearch 7.6.2
本文环境:Elasticsearch7.6.2目前最先版本 centos7.X JDK1.8 elasticsearch介绍 官网:https://www.elastic.co/cn/pr ...
- elasticsearch在linux上的安装,Centos7.X elasticsearch 7.6.2安装
本文环境:Elasticsearch7.6.2目前最先版本 centos7.X JDK1.8 elasticsearch介绍 官网:https://www.elastic.co/cn/pr ...
- clickhouse在Linux上的安装部署
$ sudo apt-get install clustershell #输入你的管理员密码 $ cd /etc/clustershell $ sudo gedit groups #在文件中添加如下内 ...
- linux上MongoDB安装部署
①下载安装包 mongodb-linux-x86_64-rhel62-3.6.3.tgz ②解压: tar zxvf mongodb-linux-x86_64-rhel62-3.6.3.tgz ...
- linux上nagios安装完整版
监控server端的安装部署一.apache的安装下载httpd-2.2.15.tar.gz gunzip httpd-2.2.15.tar.gztar xvf httpd-2.2.15.tarcd ...
- ODI11G 在Linux上的安装配置
ODI11G 在Linux上的安装配置 OS环境:Red hat Linux x86_64 一.JDK安装 1. 去oracle官网上下载 http://www.oracle.com/technetw ...
- 【数据库】Mean web开发 04-MongoDB在Linux上的安装及遇到的问题
简介 Mean是JavaScript的全栈开发框架.更多介绍 用MongoDB实现持久数据的存储是Mean Web全栈开发中的一部分. MongoDB是一个介于关系数据库和非关系数据库之间的产品,是非 ...
随机推荐
- “IT学子成长指导”专栏及文章目录 —贺利坚
迂者专栏关键词 就 业 大一 大二 大三 大四 自学 职 场 专业+兴趣 研究生 硕士 规 划 考 研 大学生活 迷 茫 计算机+专业 基本功 学习方法 编程 基 础 实践 读书 前 途 成 长 社团 ...
- 2016年3月3日android实习笔记
1: android自定义控件时,通常需要重写父类构造函数.这三个够找函数具体啥时调用? public View (Context context) 是在java代码创建视图的时候被调用,如果是从xm ...
- Java表达式转型规则
Java表达式转型规则由低到高转换: 1.所有的byte,short,char型的值将被提升为int型: 2.如果有一个操作数是long型,计算结果是long型: 3.如果有一个操作数是float型, ...
- php传值和传引用的区别
php传值和传引用的区别所谓值传递,就是说仅将对象的值传递给目标对象,就相当于copy:系统将为目标对象重新开辟一个完全相同的内存空间.所谓传引用,就是说将对象在内存中的地址传递给目标对象,就相当于使 ...
- springboot中velocity tool中注入bean
在使用springboo的时候,遇到一个问题,想在tool类中注入一个bean,一直失败,翻了下源码,是因为工具类的初始化方法为反射class调用newInstance方法,详见 http://www ...
- Spring中 @Autowired标签与 @Resource标签 的区别(转)
Spring不但支持自己定义的@Autowired注解,还支持由JSR-250规范定义的几个注解,如:@Resource. @PostConstruct及@PreDestroy. 1. @Autowi ...
- Python报错:ImportError: No module named src.data_layer
ImportError: No module named src.data_layer 解决方案: export PYTHONPATH=path/to/modules
- .NET “底层”异步编程模式——异步编程模型(Asynchronous Programming Model,APM)
本文内容 异步编程类型 异步编程模型(APM) 参考资料 首先澄清,异步编程模式(Asynchronous Programming Patterns)与异步编程模型(Asynchronous Prog ...
- UVA 12293 - Box Game(博弈)
UVA 12293 - Box Game 题目链接 题意:两个盒子,一開始一个盒子有n个球.一个仅仅有1个球,每次把球少的盒子中球消掉,把多的拿一些球给这个盒子.最后不能操作的输(球不能少于1个),A ...
- ubuntu 定时执行任务at
安装方法: apt-get install at 使用方法: 添加 at 11:13 warning: commands will be executed using /bin/sh at> & ...




