1. [root@backup read]# touch r01.txt
   touch: cannot touch `r01.txt': Stale file handle
   使用共享目录创建文件出现文件句柄错误
   原因:
   nfs服务端对共享目录进行了调整, 但是调整时客户端还在使用相应的共享目录
   解决方法:
   将和相应共享目录相关的所有挂载点进行卸载,然后重新挂载即可

扩展: 总结nfs服务常见问题:
1. [root@backup read]# touch r01.txt
   touch: cannot touch `r01.txt': Stale file handle
   使用共享目录创建文件出现文件句柄错误
   原因:
   nfs服务端对共享目录进行了调整, 但是调整时客户端还在使用相应的共享目录
   解决方法:
   将和相应共享目录相关的所有挂载点进行卸载,然后重新挂载即可
   
2. [root@nfs-client1 ~]# showmount -e 10.0.0.7        <- 恭喜·各位,这里遇到了故障
   clnt_create: RPC: Port mapper failure - Unable to receive: errno 113 (No route to host)
   原因:
   防火墙iptables服务开启了
   解决:
   关闭防火墙即可
   
3. 第二个错误:
   “RPC: Program not registered”
   原因:
   提示很清楚了,是服务器端RPC服务和NFS服务存在启动顺序问题。

4. 客户端挂载报错“No such file or directory”
   [root@nfs-client ~]# showmount -e 172.16.1.31
   Export list for 172.16.1.31:
   /data    172.16.1.0/24
   [root@nfs-client ~]# mount -t nfs 172.16.1.31:/data /mnt
   mount.nfs: mounting 172.16.1.31:/data failed, reason given by server: No such file or directory
   解答:原因是NFS服务器端没有共享目录/data,创建即可。命令如下:
   [root@nfs-server ~]# mkdir /data

5. 卸载挂载设备时显示device is busy。
   [root@nfs-client mnt]# umount /mnt
   umount.nfs: /mnt: device is busy
   umount.nfs: /mnt: device is busy
   解决方式:
   umount -lf /read/
   -l   Lazy  unmount  -- 懒惰的进行卸载
   -f   Force unmount (in case of an unreachable NFS system)  --- 实现强制卸载
 
6. 共享目录挂载后,创建文件很慢
   mount -t nfs 172.16.1.31:/data /mnt
   cd /mnt
   time touch test.txt
   原因分析:
l NFS服务端重启之后。立刻进行挂载会出现此问题,因为NFS自身重启的时候,拥有无敌的时间,默认是90秒;在无敌时间内,是不能对共享目录进行更改的操作;
l 在系统配置中/etc/sysconfig/nfs中指定了无敌时间的配置参数
   NFSD_V4_GRACE=90
   NFSD_V4_LEASE=90
   NLM_GRACE_PERI0D=90

nfs 问题总结的更多相关文章

  1. nfs 笔记 2

    http://woxihuanpes.blog.163.com/blog/static/12423219820097139145238/ http://blog.csdn.net/willvc123/ ...

  2. linux NFS 配置步骤

    转载 http://woxihuanpes.blog.163.com/blog/static/12423219820097139145238/ NFS server可以看作是一个FILE SERVER ...

  3. ubuntu 14.04LTS 环境下配置NFS服务

    简言之,NFS(Network FileSystem,网络文件系统)用于在不同机器,不同操作系统之间通过网络互相分享各自的文件.NFS设计之初就是为了在不同的系统间使用,所以它的通讯协议设计与主机及操 ...

  4. 【Oracle 集群】11G RAC 知识图文详细教程之RAC在LINUX上使用NFS安装前准备(六)

    RAC在LINUX上使用NFS安装前准备(六) 概述:写下本文档的初衷和动力,来源于上篇的<oracle基本操作手册>.oracle基本操作手册是作者研一假期对oracle基础知识学习的汇 ...

  5. Ubuntu搭建NFS

    NFS全称是Network File System,网络文件系统.它可以通过网络实现文件共享.其结构图大概是这样的: 在机器E上开启NFS服务,机器ABCD都挂载NFS,这样可以实现机器ABCD共享文 ...

  6. nfs挂载配置

    nfs挂载步骤 服务器端 1.安装nfs-utils rpcbind $sudo yum –y install nfs-utils rpcbind 2.文件开放出去配置/etc/exports 例子: ...

  7. NFS服务器搭建——可用于共享文件或负载均衡文件共享服务器使用

    一.软件包安装 yum -y install nfs-utils  rpcbind 二.服务器端配置共享目录 1. 在服务器上创建NFS共享目录:mkdir /usr/local/test 2. 设置 ...

  8. NFS网络共享服务部署

    10.3 NFS服务端部署环境准备 10.3.1 NFS服务部署服务器准备 服务器系统 角色 IP Centos6.7 x86_64 NFS服务器端(NFS-server) 192.168.1.14 ...

  9. Linux NFS服务器的安装与配置

    一.NFS服务简介 NFS 是Network File System的缩写,即网络文件系统.一种使用于分散式文件系统的协定,由Sun公司开发,于1984年向外公布.功能是通过网络让不同的机器.不同的操 ...

  10. NFS指定端口

    nfs服务端: 编辑/etc/nfsmount.conf,在末尾添加: RQUOTAD_PORT=30001LOCKD_TCPPORT=30002LOCKD_UDPPORT=30002MOUNTD_P ...

随机推荐

  1. 在IE11(Win8)中检查up6.2配置

      1.按F12,打开调试模式    2.打开调试程序选项卡 说明:在调试程序选项卡中可看到IE加载的脚本信息是否正确.因为IE有缓存,导致脚本有时不是最新的.    3.打开脚本,up6.js   ...

  2. 命令之 ulimit

    help ulimit help ulimit ulimit: ulimit [-SHacdefilmnpqrstuvx] [limit] Modify shell resource limits. ...

  3. LibreOJ 6001 太空飞行计划(最大流)

    题解:首先源点向每个实验建边,流量为经费的值,实验向器材建边,值为无限大,器材向终点建边,值为价值 然后跑一遍最大流就能跑出所谓的最大闭合图的点值之和. 代码如下: #include<queue ...

  4. 用原生css实现高斯模糊、黑白等滤镜效果

    —引导— 在CSS3中,有一个强大的属性,那就是filter属性,filter顾名思义就是“滤镜”的意思,用filter属性可以让图片无需PS处理就达到一些简单的显示效果. —定义和使用— filte ...

  5. 扩展卢卡斯定理(Exlucas)

    题目链接 戳我 前置知识 中国剩余定理(crt)或扩展中国剩余定理(excrt) 乘法逆元 组合数的基本运用 扩展欧几里得(exgcd) 说实话Lucas真的和这个没有什么太大的关系,但是Lucas还 ...

  6. BST_insert

    #include <stdio.h> /* printf, scanf, NULL */ #include <stdlib.h> /* malloc, free */ stru ...

  7. Android--Apache HttpClient 的一些问题

    1,对于Android4.0之上的环境下,不能在主线程中访问网络    http://www.cnblogs.com/plokmju/p/Android_apacheHttpClient.html   ...

  8. VS2010 由于缺少调试目标"xx.exe"

    有两种可能会造成这种现像.A.配制属性出了问题. 一种方法:右击“解决方案”->“属性”,在弹出的“属性页”框中,选择左边的“配置属性”,在右边,将应用程序的生成那个框框勾上,二可能是这里的属性 ...

  9. libcaffe.so.1.0.0: cannot open shared object file: No such file or directory 运行时报错

    caffe安装好后lib没有配置到/usr/lib或/usr/local/lib中,需手动配置: sudo vim ~/.bashrc export LD_LIBRARY_PATH=your_path ...

  10. .net mvc 框架实现后台管理系统4-layedit使用

    做个简单的文章发布,使用了layui的layedit 效果: 在html页面添加: <textarea id="MyArticleContent" style="d ...