一,准备

1,先查看Linux是32位还是64位

getconf LONG_BIT

如果返回的是32,那么就是32位

如果返回的是64,那么就是64位

2,如果服务器不能联网,就先去官网下载好压缩包,然后上传到服务器

下载地址:https://dev.mysql.com/downloads/mysql/5.7.html#downloads

我这里下载的是64位的5.7.24版本的

二,开始安装

1,检查是否已安装过mariadb,若有便删除(linux系统自带的)

[root@localhost /]# rpm -qa | grep mariadb
[root@localhost /]# rpm -e --nodeps mariadb-libs-5.5.-.el7.centos.x86_64

2,检查是否已安装过mysql,若有便删除(linux系统自带的)

[root@localhost /]# rpm -qa | grep mysql
[root@localhost /]# rpm -e –-nodeps mysql-libs-5.1..x86_64

3,检查mysql组和用户是否存在,如无创建:

[root@localhost ~]# cat /etc/group | grep mysql
[root@localhost ~]# cat /etc/passwd |grep mysql
[root@localhost ~]# groupadd mysql
[root@localhost ~]# useradd -r -g mysql mysql

4,将下载的安装包上传到服务器的/home文件夹下,然后解压

tar -zxvf mysql-5.7.-linux-glibc2.-x86_64.tar.gz

将解压后的文件夹移动到/usr/local下,并将目录名称改为mysql

mv /home/mysql-5.7.-linux-glibc2.-x86_64 /usr/local/mysql

5,在mysql下添加data目录

[root@localhost ~]# mkdir /usr/local/mysql/data

6,更改mysql目录下所有的目录及文件夹所属组合用户

[root@localhost /]# cd /usr/local/
[root@localhost local]# chown -R mysql:mysql mysql/
[root@localhost local]# chmod -R mysql/

7,编译安装并初始化mysql,记住命令行末尾的密码:

[root@localhost local]# /usr/local/mysql/bin/mysqld --initialize --user=mysql --datadir=/usr/local/mysql/data --basedir=/usr/local/mysql
--31T08::.910440Z [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
--31T08::.910635Z [ERROR] Can't find error-message file '/usr/local/mysql/--datadir=/usr/local/mysql/data/share/errmsg.sys'. Check error-message file location and 'lc-messages-dir' con
figuration directive.--31T08::.709286Z [Warning] InnoDB: New log files created, LSN=
--31T08::.767540Z [Warning] InnoDB: Creating foreign key constraint system tables.
--31T08::.892629Z [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 6e083b8f-8e29-11e7-88b1-
005056b427be.--31T08::.895674Z [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
--31T08::.896645Z [Note] A temporary password is generated for root@localhost: gFamcspKm2+u

8,启动mysql服务

[root@localhost local]# /usr/local/mysql/support-files/mysql.server start

9,做个软连接,重启服务

[root@localhost local]# ln -s /usr/local/mysql/support-files/mysql.server /etc/init.d/mysql
[root@localhost local]# service mysql restart
Shutting down MySQL.. SUCCESS!
Starting MySQL. SUCCESS!

10,做个软链接,将安装目录下的mysql 放在/usr/bin 目录下(这一步我好像没有操作)

[root@localhost local]# ln -s /usr/local/mysql/bin/mysql /usr/bin

11,登录msyql,输入密码(密码为步骤7初始化生成的密码)

[root@localhost local]# mysql -u root -p
Enter password:

12,修改密码并开放远程

msql>alter user 'root'@'localhost' identified by '';
mysql>use mysql;
msyql>update user set user.Host='%' where user.User='root';
mysql>flush privileges;
mysql>quit

13,编辑my.cnf,添加配置文件,配置内容为

[root@localhost local]# vi /usr/local/mysql/my.cnf
[mysqld]
port =
sql_mode=
transaction_isolation=READ-COMMITTED log_bin_trust_function_creators=
lower_case_table_names=
binlog_format=mixed

14,重启mysql

service mysqld restart

参考:https://www.cnblogs.com/fangts/p/8994851.html

三,遇到的问题

1,查看mysql是否启动的时候service mysql status报错

信息如下:

ERROR! MySQL is not running, but lock file (/var/lock/subsys/mysql) exists

解决方法如下:

rm /var/lock/subsys/mysql

2,启动mysql的时候service mysql start报错,

错误信息如下:

Starting MySQL...The server quit without updating PID file [失败]lib/mysql/localhost.localdomain.pid)

原因及解决方法:是因为my.cnf配置文件中有一个配置写错了,去掉就可以了

四,创建数据库

CREATE DATABASE `datashare` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci

五,导入.sql文件

1,登录mysql

[root@localhost local]# mysql -u root -p
Enter password:

2,选择数据库

mysql>use datashare;

3,导入数据(注意sql文件的路径)

mysql>source /home/datashare.sql;

4,查看数据库

show databases;

查看表

show tables;

Linux上安装设置mysql 5.7.24的更多相关文章

  1. Linux上安装二进制文件MySQL详解

    前言:昨天晚上搞了很久,终于搞清楚mysql的安装配置了,我真是太low了.当我在云服务器上登进Mysql时,真是高兴哈哈,咱一步一步来,彻底搞懂Mysql的安装配置. 我的安装环境: 阿里云服务器 ...

  2. Ubuntu Linux上安装配置Mysql

    一.安装: 三种安装方式: 1. 从网上安装 sudo apt-get install mysql-server.装完已经自动配置好环境变量,可以直接使用mysql的命令. 注:建议将/etc/apt ...

  3. 在Linux上安装jdk,mysql,tomcat的准备工作

    准备工作: 因为JDK,TOMCAT,MYSQL的安装过程中需要从网上下载部分支持包才可以继续,所以要提前安装下载好下面四个依赖 yum install glibc.i686 yum -y insta ...

  4. Linux+Redis实战教程_Linux上安装jdk,mysql,tomcat_安装jdk

    1. Linux上安装jdk,mysql,tomcat[重点] Windows 控制面板 添加/卸载程序 进行程序的安装.更新.卸载.查看 rpm命令:相当于windows的添加/卸载程序 进行程序的 ...

  5. linux上安装mysql,tomcat,jdk

    Linux 上安装 1 安装jdk 检测是否安装了jdk 运行 java –version 若有 需要将其卸载 a)         查看安装哪些jdk rmp –qa |grep java b)   ...

  6. 怎样在 Ubuntu Linux 上安装 MySQL

    本教程教你如何在基于 Ubuntu 的 Linux 发行版上安装 MySQL.对于首次使用的用户,你将会学习到如何验证你的安装和第一次怎样去连接 MySQL. -- Sergiu MySQL 是一个典 ...

  7. linux上安装 mysql

    一.linux 上安装 mysql 1.查看mysql是否安装 rpm -qa|grep mysql 2.卸载 mysql yum remove mysql mysql-server mysql-li ...

  8. Linux上安装ZooKeeper并设置开机启动(CentOS7+ZooKeeper3.4.10)

    1下载Zookeeper 2安装启动测试 2.1上载压缩文件并解压 2.2新建 zookeeper配置文件 2.3安装JDK 2.4启动zookeeper 2.5查看zookeeper的状态 3将Zo ...

  9. (转载)Linux下安装配置MySQL+Apache+PHP+WordPress的详细笔记

    Linux下安装配置MySQL+Apache+PHP+WordPress的详细笔记 Linux下配LMAP环境,花了我好几天的时间.之前没有配置过,网上的安装资料比较混乱,加上我用的版本问题,安装过程 ...

随机推荐

  1. nginx 配置记录 上传文件大小 size client

    cat nginx.conf worker_processes auto;events { worker_connections 1024;}http { include mime.types; de ...

  2. iPhone将NSString转换编码集为gb2312或者gbk的方法

    很多时候软件读取的中文网页编码集是gb2312,所以显示出来的是乱码.这时需要将NSString文字编码转换.你可以试试以下代码 NSURL *url = [NSURL URLWithString:u ...

  3. javascript---我对闭包的理解

    一.闭包       闭包是一种特殊的对象.它由两部分构成:函数,以及创建该函数的环境.环境由闭包创建时在作用域中的任何局部变量组成. 如何理解这句话:以一个例子说明;(from MDN) funct ...

  4. DQL-分页查询

    关键字 :limit 一.应用场景当要查询的条目数太多,一页显示不全二.语法 select 查询列表from 表limit [offset,]size;注意:offset代表的是起始的条目索引,默认从 ...

  5. Linux-2.6_LCD驱动学习

    内核自带的驱动LCD,drivers/video/Fbmem.c LCD驱动程序 假设app: open("/dev/fb0", ...) 主设备号: 29, 次设备号: 0--- ...

  6. 针对铁定浏览器的css选择符

    /***** Selector Hacks ******/ /* IE6 and below */ * html #uno { color: red } /* IE7 */ *:first-child ...

  7. JavaWeb总结(九)

    过滤器 - 一个中间组件,用于拦截源数据和目的数据之间的消息 - 过滤二者之间传递的数据 Web应用上的过滤器 -驻留在Web服务器上的Web组件 -过滤从客户端传递到服务器端的请求和响应 单个过滤器 ...

  8. Oracle数据库无法向listener注册的解决一例

    当机器的IP地址改变了,或者机器名改变后, 动态注册可能会失败. 运行 lsnrctl status时,无论等待多久,都会发生:no services 这样的信息. 此时,最好的解决方法,就是删除原有 ...

  9. 06 django的用户认证组件

    1.用户认证组件 用户认证组件: 功能:用session记录登录验证状态 前提:用户表:django自带的auth_user 创建超级用户: python3 manage.py createsuper ...

  10. 【HNOI2015】菜肴制作

    题面 题解 这道题目首先可以想到拓扑排序,但是肯定不是字典序最小的排列. 比如说,有\(4\)种菜,限制为\(2 \to 4, 3 \to 1\),那么如果求字典序最小的排列会算出\((2, 3, 1 ...