instance / database / schema / object

login / user / schema (dbo)

sequence

Collation

PSM: Both Instance and DB need case insensitive

Windchill: Both Instance and DB as SQL_Latin1_General_CP1_CS_AS (Since 2012, it is Latin1_General_100_CS_AS_SC)

Cognos: DBs need case insensitive, can share same instance as Windchill

Upgrade:

About Microsoft SQL Server Collation settings in Windchill

  • Instance/Server Collation
  • Database Collation

Instance/database

  • Instance
  1. “Empty” means default Instance Name of MSSQLSERVER
  1. Can get from Service
  1. Or run query below –again NULL means default of MSSQLSERVER

SELECT SERVERPROPERTY('InstanceName')

Login/user/schema

  • Here Instance > Security > login show the Instance Login
  1. Login user can access Instance/Server, but cannot access Database/Tables
  • Database User who map to a Instance Login and define a Default Schema
  • Why SQL select * from wind.wtuser does not work (small case of wtuser)?

wtuser needs to be WTUser

  • Why SQL select * from  WTUser does not work (without wind.)?

The user’s default schema is not wind

  • What is the default schema?
    dbo

Transaction log

  • Windchill down due to database full
  1. Option #1:
  1. Reason #2:

Sequence

  • Sample  create_QueueEntry_Table.sql
  1. Create table for sequence

CREATE TABLE
entryNumber_seq (dummy
CHAR(1), value BIGINT      IDENTITY(1,1))

go

  1. Create the procedure to get/generate the
    sequence

CREATE PROCEDURE
wt_get_next_sequence_entryNumber

AS

INSERT entryNumber_seq (dummy) VALUES ('x')

RETURN SCOPE_IDENTITY()

go

Note: the
procedure changes to as below since 10.1, and then leads to CS128703

CREATE PROCEDURE
wt_get_next_sequence_entryNumber

@returnValue BIGINT OUTPUT

AS

INSERT entryNumber_seq (dummy)
VALUES ('x')

SELECT @returnValue = SCOPE_IDENTITY()

go

  1. Retrieve the sequence

DECLARE  @return_value int

EXEC     @return_value = [wind].[wt_get_next_sequence_entryNumber]

SELECT   'Return Value' = @return_value

GO

  • How to break the IDENTITY temporarily for some
    reason, e.g. configure to a BIG value to avoid ID confliction?
  1. Two methods

SET IDENTITY_INSERT
wind.entryNumber_seq ON

Insert into
wind.entryNumber_seq(dummy, value) values ('x', 99999)

SET IDENTITY_INSERT
wind.entryNumber_seq OFF

GO

OR

DBCC
CHECKIDENT('entryNumber_seq', RESEED, 100014)

GO

  • How to verify sequences, like “select * from
    user_sequences” in Oracle?

SELECT TABLE_NAME,IDENT_INCR(TABLE_NAME) AS IDENT_INCR, IDENT_CURRENT(TABLE_NAME) as IDENT_CURRENT

FROM INFORMATION_SCHEMA.TABLES

where IDENT_CURRENT(TABLE_NAME)is not null

order by TABLE_NAME;

Microsoft SQL Server的更多相关文章

  1. Microsoft SQL Server中的事务与并发详解

    本篇索引: 1.事务 2.锁定和阻塞 3.隔离级别 4.死锁 一.事务 1.1 事务的概念 事务是作为单个工作单元而执行的一系列操作,比如查询和修改数据等. 事务是数据库并发控制的基本单位,一条或者一 ...

  2. Microsoft SQL Server 2008 R2 安装卸载

    问题 问题1 标题: Microsoft SQL Server 2008 R2 安装程序 ------------------------------ 出现以下错误: Could not open k ...

  3. Sql Server系列:Microsoft SQL Server Management Studio模板资源管理器

    模板资源管理器是Microsoft SQL Server Management Studio的一个组件,可以用来SQL代码模板,使用模板提供的代码,省去每次都要输入基本代码的工作. 使用模板资源管理器 ...

  4. 未能加载包“Microsoft SQL Server Data Tools”

    直接在vs2013里的App_Data目录创建数据库,在服务器资源管理器中查看时报错: 未能加载包“Microsoft SQL Server Data Tools” 英文: The 'Microsof ...

  5. SQL SERVER错误:已超过了锁请求超时时段。 (Microsoft SQL Server,错误: 1222)

    在SSMS(Microsoft SQL Server Management Studio)里面,查看数据库对应的表的时候,会遇到"Lock Request time out period e ...

  6. Cannot set a credential for principal 'sa'. (Microsoft SQL Server,错误: 15535)

    在SQL SERVER 2008上上禁用sa登录时,遇到下面错误:"Cannot set a credential for principal 'sa'. (Microsoft SQL Se ...

  7. Microsoft SQL Server 2005 Service fails to start

    今天碰到一雷死人的事情,在Windows Server 2012 R2上安装SQL SERVER 2005标准版过程中一直遇到"The SQL Server service failed t ...

  8. Microsoft SQL Server 2008 R2官方中文版(SQL2008下载).rar

    Microsoft SQL Server 2008 R2官方中文版(SQL2008下载).rar

  9. 无法打开物理文件xxx.mdf操作系统错误 5:“5(拒绝访问。)” (Microsoft SQL Server,错误: 5120)的解决方法

    无法打开物理文件xxx.mdf操作系统错误 5:“5(拒绝访问.)” (Microsoft SQL Server,错误: 5120)的解决方法   问题描述: 在附加数据库到sql server时,附 ...

  10. 无法删除服务器 'old_server_name',因为该服务器用作复制过程中的发布服务器。 (Microsoft SQL Server,错误: 20582)

    无法删除服务器 'old_server_name',因为该服务器用作复制过程中的发布服务器. (Microsoft SQL Server,错误: 20582) 2013-01-05 15:02 478 ...

随机推荐

  1. size函数

    size是求第一维度的大小 size(2)是求第二维度的大小

  2. python学习笔记四 迭代器,生成器,装饰器(基础篇)

    迭代器 __iter__方法返回一个迭代器,它是具有__next__方法的对象.在调用__next__方法时,迭代器会返回它的下一个值,若__next__方法调用迭代器 没有值返回,就会引发一个Sto ...

  3. ord函数-php

    摘录自http://php.net/manual/zh/function.ord.php (PHP 4, PHP 5, PHP 7) ord — 返回字符的 ASCII 码值 说明 int ord ( ...

  4. PowerDesigner导出Excel

    1.打开PowerDesigner,创建物理模型(Physical Data Model) 2.在PowerDesigner菜单栏中,依次点击“Tools ->Excute Commands-& ...

  5. 关于三星A7屏幕锁已由管理员、加密政策,或证书存储禁用

    解决办法:设定-安全-清除证书-再返回锁定屏幕-把密码锁定-改为滑动.....

  6. Spring 框架 详解 (二)

    Spring的入门的程序: 1.1.1 下载Spring的开发包: spring-framework-3.2.0.RELEASE-dist.zip ---Spring开发包 * docs :sprin ...

  7. UVA 10817 十一 Headmaster's Headache

    Headmaster's Headache Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Sub ...

  8. CodeForces 478C Table Decorations

    Table Decorations Time Limit:1000MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u ...

  9. python 列表去重(数组)的几种方法

    一.方法1  代码如下 复制代码 ids = [1,2,3,3,4,2,3,4,5,6,1] news_ids = [] for id in ids:     if id not in news_id ...

  10. QUEEN_BLADE_2D-非常屌-113P

    http://www.cgvoo.com/thread-33670-1-2.html http://blog.sina.com.cn/s/blog_4b92d6070102e7gj.html http ...