If you come across the above error,  you may also come across one or more of the errors below within your Citrix server event logs.

This computer running Citrix Presentation Server will now stop accepting connections. This server is no longer in or could not enter a licensing grace period.

Or

Citrix Presentation Server has entered the grace period. You have x hour(s) remaining before this server stops accepting connections from client devices

Or

The licenses required by this edition of MetaFrame Presentation Server are not present on the license server

Or

Citrix XenApp cannot contact the license server localhost

Or

This computer running Citrix XenApp will now stop accepting connections. This server is no longer in or could not enter a licensing grace period

Or

Error received while obtaining a license for a Citrix Presentation Server client connection. A grace license has been granted.

Or

Citrix presentation server license acquisition err (-xx): Unable to acquire a license from server. Please contact your system administrator or open event viewer for more details.
The alerts are generated when your citrix servers lose connection with the citrix license server. The citrix servers will continue to run until the grace period expires, unless they are able to communicate with the license server again.

Once your citrix servers have successfully communicated with the license server, you should receive the below or something similar within your event log.

This server is successfully communicating with the license server. Citrix Presentation Server has left the grace period

There are a few basic tasks you can carry out:

1) Ensure the citrix licensing services are running. If you need to locate you citrix license server, see link in step 3. If the license server is running go to step 2.

2) Restart the IMA service on your Citrix servers

3) If the above does not resolve issue, restart the license services on your Citrix licensing server. If you don’t know which server holds the citrix licensing role, see http://www.sana-tech.net/blog/?p=1713

4) If any of the above do not resolve your issue, check your citrix licenses have not expired. On your Citrix license server, access Start, Programs, Citrix and Citrix license console. If they have expired you need to renew. Otherwise go to step 5.

5) From your citrix server, open a command prompt window and telnet to your citrix license server on port 27000. Please note, the port may be different, follow the link in step three to find out what port you are using. If you are unable to telnet to the port, you need to open the port on your firewall. The citrix servers need to communicate with the license server. Example telnet servername 27000

6) Can you ping the license server from a citrix server and the citrix server from the license server.

7) An incorrect Presentation Server edition level may have been set. Click a citrix server name within your citrix farm, from the right hand pane click set presentation server edition. Ensure the correct version is selected. Do the same for all your Citrix servers.

8.) Within a command prompt type netstat -a    –  Is the connection from your citrix server to license server established? If not you could have netoworking issues between servers.

9) Restart, the license server

10) If issue still exists, restart Citrix servers.

Just a list of basic tasks which usually get to the bottom of grace period alerts.

Explanation from Citrix:

The problem occurs when there are intermittent problems, or delays (over 10 seconds per message) affecting the communication of messages between the XenApp server and the License Server. Once a timeout of a message sent from the XenApp server to the License Server occurs, subsequent communication to the License Server does not occur correctly because the persistent connection from XenApp to the License Server becomes unstable. As a result of the instability of this connection, subsequent user connections to the XenApp server might fail with the previously noted errors.

Important note: This problem only occurs in cases where the License Server is online and partially accessible over the network from the affected XenApp server. If the License Server is completely offline, this problem does not occur because the XenApp server continues to accept user connections until the standard licensing grace period expires or the License Server becomes accessible, whichever comes first.

A common source of this problem is intermittent network connectivity because of a physical problem such as damaged or defective network hardware (patch cables, patch panels, or switch ports).

FROM:http://www.sana-tech.net/blog/?tag=event-id-9017

Citrix Presentation server can not contact the license server的更多相关文章

  1. InterlliJ IDEA 2017.3.x / 2017.3.4 License Server激活

    InterlliJ IDEA 2017.3.x / 2017.3.4 License Server激活 1.Lincense Server激活 // 激活IDEA的License Server 地址 ...

  2. IDEA 2017破解 license server激活

    确保电脑在联网状态,在激活窗口选择license server 填入下面的license server: http://intellij.mandroid.cn/ http://idea.imsxm. ...

  3. 【转】IDEA 2017破解 license server激活

    确保电脑在联网状态,在激活窗口选择license server 填入下面的license server: http://intellij.mandroid.cn/ http://idea.imsxm. ...

  4. DVT JetBrains License Server(JetBrains授权服务器)2018 v1.1 最新版 含32位/64位

    DVT JetBrains License Server是JetBrains系列软件授权服务器,支持2017版本得jetbrains pycharm,JetBrainswebstorm,JetBrai ...

  5. IntelliJ IDEA 、PyCharm、WebStorm、PhpStorm等JetBrains公司软件 激活的License Server本地搭建教程

    一.背景 IntelliJ IDEA是JetBrains公司的一款IDE,主要用于java开发,可以编写Java.Groovy.Kotlin.Scala等语言,也可以直接做Android开发. 同系列 ...

  6. phpstorm version 2016.2 License Server激活

    phpstorm version 2016.2 License Server激活 安装后,在激活的时候选择 license server; 输入如下地址激活: http://jetbrains.ten ...

  7. PyCharm 2017 免费 破解 注册 激活 教程(附 License Server 地址)(Python 编辑器 IDE 推荐)

    许多朋友都在问如何破解 PyCharm 2017 Professional 专业版,咪博士对此是坚决反对的! 不到万不得已,请不要这样做.破解之前,请拖到文章末尾,思考几个问题,想明白你确实需要这样做 ...

  8. PyCharm激活(License server)

    打开激活窗口 选择 Activate new license with: License server (用license server 激活) 在 License sever address 处填入 ...

  9. webstorm2016.3注册码,License server更新方式,webstorm2017.1版本可用

    以前的webstorm和phpstorm的激活码和地址,今天打开的时候过期了 (your license has expored) 以前是用activation code的更新方式: 后来搜了下,换个 ...

随机推荐

  1. TCP连接的状态分析

    1.先来了解一下TCP连接建立与关闭过程中的各种状态: CLOSED:初始状态,表示没有任何连接.LISTEN:Server端的某个Socket正在监听来自远方的TCP端口的连接请求.SYN_SENT ...

  2. Android获取屏幕的高度和宽度

    方法一: DisplayMetrics metrics=new DisplayMetrics(); getWindowManager().getDefaultDisplay().getMetrics( ...

  3. Linux进程或线程绑定到CPU

    Linux进程或线程绑定到CPU 为了让程序拥有更好的性能,有时候需要将进程或线程绑定到特定的CPU,这样可以减少调度的开销和保护关键进程或线程. 进程绑定到CPU Linux提供一个接口,可以将进程 ...

  4. 自动化构建工具gulp

    1.优点 1.1 易于使用 通过代码优于配置的策略,gulp让简单的任务简单,复杂的任务可管理 1.2 构建快速 利用node.js流的威力,你可以快速构建项目并减少频繁的IO操作 1.3 插件高质 ...

  5. 移动端html5重力感应

    下面是测试案例,只测试过itouch,iphone http://06wjin.sinaapp.com/billd/     http://06wjin.sinaapp.com/billd/test. ...

  6. 关于自定义Adapter实现ListView的使用

    以下为使用BaseAdapter作扩展,自定义Adapter来使用ListView控件: 需要注意以下的几点: 1.自定义Adapter时,需要特别注意Adapter类中getView()方法覆盖,注 ...

  7. CodeForces 474B(标记用法)

    CodeForces 474B Time Limit:1000MS Memory Limit:262144KB   64bit IO Format:%I64d & %I64u Descript ...

  8. codevs 1107 等价表达式

    传送门 题解:第一眼这题好像非常难得样子,简直没有思路.但是这可以用栈带入特殊值来解决.这里用到两个栈,一个是存贮数字,另一个存贮运算符,按优先级进行运算.当读入的运算符比运算符栈的栈顶元素优先级低时 ...

  9. Qt: 网络编程之UDP(理论+实例)

    http://blog.csdn.net/rl529014/article/details/52888525

  10. POJ2248 A Knight's Journey(DFS)

    题目链接. 题目大意: 给定一个矩阵,马的初始位置在(0,0),要求给出一个方案,使马走遍所有的点. 列为数字,行为字母,搜索按字典序. 分析: 用 vis[x][y] 标记是否已经访问.因为要搜索所 ...