====环境==

openstack :kilo

CentOS : 7

====问题===

在没有关vm的情况下,重启了controller。

问题一:

在使用nova service-list 或者openstack-status的时候或者其他认证需求的时候出现以下错误

ERROR: openstack Unable to establish connection to http://controller:35357/v3/auth/tokens

ConnectionRefused: Unable to establish connection to http://controller:35357/v3/auth/tokens

Authorization Failed: Unable to establish connection to http://controller:35357/v3/tokens

 == Keystone users ==
/usr/lib/python2./site-packages/keystoneclient/shell.py:: DeprecationWarning: The keystone CLI is deprecated in favor of python-openstackclient. For a Python library, continue using python-keystoneclient.
'python-keystoneclient.', DeprecationWarning)
Authorization Failed: Unable to establish connection to http://controller:35357/v3/tokens
== Glance images ==
Unable to establish connection to http://controller:35357/v3/auth/tokens
== Nova managed services ==
No handlers could be found for logger "keystoneclient.auth.identity.generic.base"
ERROR (ConnectionRefused): Unable to establish connection to http://controller:35357/v3/auth/tokens
== Nova networks ==
No handlers could be found for logger "keystoneclient.auth.identity.generic.base"
ERROR (ConnectionRefused): Unable to establish connection to http://controller:35357/v3/auth/tokens
== Nova instance flavors ==
No handlers could be found for logger "keystoneclient.auth.identity.generic.base"
ERROR (ConnectionRefused): Unable to establish connection to http://controller:35357/v3/auth/tokens
== Nova instances ==
No handlers could be found for logger "keystoneclient.auth.identity.generic.base"
ERROR (ConnectionRefused): Unable to establish connection to http://controller:35357/v3/auth/tokens

  

问题二:

解决问题一之后发现dashboard无法正常启动了:

ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named main

 [root@controller system]# systemctl status httpd.service
httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
Drop-In: /usr/lib/systemd/system/httpd.service.d
└─openstack-dashboard.conf
Active: failed (Result: exit-code) since Tue -- :: CST; 15min ago
Process: ExecStartPre=/usr/bin/python /usr/share/openstack-dashboard/manage.py collectstatic --noinput --clear (code=e Dec :: controller python[]: File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line , in __getat
Dec :: controller python[]: self._setup(name)
Dec :: controller python[]: File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line , in _setup
Dec :: controller python[]: self._wrapped = Settings(settings_module)
Dec :: controller python[]: File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line , in __init
Dec :: controller python[]: % (self.SETTINGS_MODULE, e)
Dec :: controller python[]: ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.
Dec :: controller systemd[]: httpd.service: control process exited, code=exited status=
Dec :: controller systemd[]: Failed to start The Apache HTTP Server.
Dec :: controller systemd[]: Unit httpd.service entered failed state.

openstack-dashboard也出现了变化

[root@controller httpd.service.d]# openstack-status
== Nova services ==
openstack-nova-api: active
openstack-nova-cert: active
openstack-nova-compute: active
openstack-nova-network: inactive (disabled on boot)
openstack-nova-scheduler: active
openstack-nova-conductor: active
== Glance services ==
openstack-glance-api: active
openstack-glance-registry: active
== Keystone service ==
openstack-keystone: active
== Horizon service ==
openstack-dashboard: uncontactable
== neutron services ==
neutron-server: active

问题三:

使用nova boot 创建vm的时候出现错误:

 ERROR (ClientException): The server has either erred or is incapable of performing the requested operation. (HTTP ) (Request-ID: req-2f5571f4-aa54-4d45-a096-cb8797c5ff7a)

 ConnectionRefused: Unable to establish connection to http://controller:9696/v2.0/ports.json?tenant_id=

  ]# neutron agent-list
  Unable to establish connection to http://controller:9696/v2.0/agents.json

 

  

=======解决方案===

问题一的解决方案:

 ]# netstat -anp|grep         //使用命令查看是否有这个服务端口

 如果没有35357 端口
]# vim /etc/keystone/keystone.conf admin_port = //取消注释 重启keystone服务
在kilo中 keystone 服务名称为openstack-keystone.service
]# systemctl enable openstack-keystone.service && systemctl restart openstack-keystone.service ---------验证---------------
[root@controller ~]# netstat -anp |grep tcp 0.0.0.0: 0.0.0.0:* LISTEN /python [root@controller ~]# nova service-list
+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+
| Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason |
+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+
| | nova-console | controller | internal | enabled | up | --27T08::16.000000 | - |
| | nova-cert | controller | internal | enabled | up | --27T08::16.000000 | - |
| | nova-conductor | controller | internal | enabled | up | --27T08::16.000000 | - |
| | nova-scheduler | controller | internal | enabled | up | --27T08::17.000000 | - |
| | nova-compute | controller | nova | enabled | up | --27T08::12.000000 | - |
| | nova-consoleauth | controller | internal | enabled | up | --27T08::16.000000 | - |
| | nova-compute | compute1 | nova | enabled | up | --27T08::20.000000 | - |
+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+ 问题一解决

  

问题二的解决方案:

I have resolved the "openstack service create" problem following this steps :

HTTP and KEYSTONE service sharing the same port, so stop httpd and start openstack-keystone.service. Edit /etc/keystone/keystone.conf and replace "hostname or ip" to "localhost":

connection = mysql://keystone:openstack@localhost/keystone

Remember to stop service httpd and enable start service keystone: - systemctl stop httpd.service - systemctl enable openstack-keystone.service => systemctl start openstack-keystone.service

And finally, exec "openstack service create --name keystone --description "OpenStack Identity" identity" command.

Most important to remember, the dashboard horizon use apache so that keystone and apache service must be running. Into keystone.conf and wsgi-keystone.conf occur bind a single interface on ports  and  instead of all interface "*" or "0.0.0.0":

edit /etc/keystone/keystone.conf => set admin_bind_host = <ip_mgmt> => set public_bind_host = <ip_mgmt>
edit /etc/httpd/conf.d/wsgi-keystone.conf => set Listen 127.0.0.1: => Listen 127.0.0.1: => same for VirtualHost 127.0.0.1: &
After service openstack-keystone.service and httpd.service restart, both process will be running in the same time. 参考源网址:
https://ask.openstack.org/en/question/66833/kilo-on-centos7-keystone-throws-http-500-except-when-using-os_token/

问题三的解决方案:

 查看9696端口:

 ]# netstat -anp|grep 

 如果没有端口开启,查看下面配置文件

 ]# vim /etc/neutron/neutron.conf
bind_port = 重启neutron服务 ]# systemctl restart neutron-server neutron-dhcp-agent neutron-l3-agent neutron-metadata-agent neutron-openvswitch-agent ]# netstat -anp|grep
tcp 0.0.0.0: 0.0.0.0:* LISTEN /python2 ============验证======= [root@controller etc]# neutron agent-list
+--------------------------------------+--------------------+------------+-------+----------------+---------------------------+
| id | agent_type | host | alive | admin_state_up | binary |
+--------------------------------------+--------------------+------------+-------+----------------+---------------------------+
| 2c0d7171-ae4d-467f-8a24-14d0c683aefb | Open vSwitch agent | controller | :-)| True | neutron-openvswitch-agent |
| 32eb2441-daf9-4f48-8cf6-2a11c3140426 | Metadata agent | controller | :-) | True | neutron-metadata-agent |
| 54c7a92d-2ceb--939f-31a55b34952c | DHCP agent | controller | :-) | True | neutron-dhcp-agent |
| aca60f17-955a-41fc--1387efa6574e | L3 agent | controller | :-) | True | neutron-l3-agent |
| ba6ebc7d-b15f-44d2-a515-17efdd5e3472 | Open vSwitch agent | compute1 | :-) | True | neutron-openvswitch-agent |
+--------------------------------------+--------------------+------------+-------+----------------+---------------------------+

[原]openstack-kilo--issue(十)ERROR: openstack Unable to establish connection to http://controller:35357/v3/auth/tokens的更多相关文章

  1. openstack compute service list Unable to establish connection to http://controller:8774/v2.1/os-services: ('Connection aborted.', BadStatusLine("''",))

    8774是nova的端口号,所以我就逐一查看nova的日志文件. tail -f /var/log/nova/nova-conductor.log 2019-06-13 08:24:53.559 44 ...

  2. Unable to establish connection to tokens

    安装openstack后遇到的第一个问题. 执行命令nova list得到如下结果: [root@localhost ~(keystone_admin)]# nova list No handlers ...

  3. Openstack(Kilo)安装系列之Keystone(五)

    Create OpenStack client environment scripts To create the scripts Create client environment scripts ...

  4. [译] OpenStack Kilo 版本中 Neutron 的新变化

    OpenStack Kilo 版本,OpenStack 这个开源项目的第11个版本,已经于2015年4月正式发布了.现在是个合适的时间来看看这个版本中Neutron到底发生了哪些变化了,以及引入了哪些 ...

  5. OpenStack Kilo版加CEPH部署手册

    OpenStack Kilo版加CEPH部署手册 作者: yz联系方式: QQ: 949587200日期: 2015-7-13版本: Kilo 转载地址: http://mp.weixin.qq.co ...

  6. openstack kilo部署-基础环境

    公司也想搞个私有云玩玩,于是展开了一系列的调研,部署测试,openstack 有几个版本真是坑爹!!,如果喜欢被虐有兄弟,你就试试 openstack 的 juno , icehouse等版本,用不了 ...

  7. (转)OpenStack Kilo 版本中 Neutron 的新变化

    OpenStack Kilo 版本,OpenStack 这个开源项目的第11个版本,已经于2015年4月正式发布了.现在是个合适的时间来看看这个版本中Neutron到底发生了哪些变化了,以及引入了哪些 ...

  8. [转] OpenStack Kilo 更新日志

    OpenStack 2015.1.0 (Kilo)更新日志 原文: https://wiki.openstack.org/wiki/ReleaseNotes/Kilo/zh-hans 目录  [隐藏] ...

  9. OpenStack kilo版(1) 部署环境

    硬件 VMware workstation虚拟机 Ubuntu14.04操作系统 虚拟机网络规划 管理网络: eth0, 桥接模式 10.0.0.0/24 外部网络: eth1, nat模式(需要关闭 ...

随机推荐

  1. iphone程序适配ipad可以用下面的宏进行尺寸改写

    //判断是否为iPad #define ISIPAD [[[UIDevice currentDevice].model substringToIndex:4] isEqualToString:@&qu ...

  2. 更改mac系统语言及其软件

    如图,把所用语音置顶 https://support.apple.com/zh-cn/HT202036 1.firefox需要下载英文版,同时可以保留中文版,两个不能同时启动.如果你只是为了切换浏览器 ...

  3. Android典型界面设计(8) ——ViewPager+PagerSlidingTabStrip实现双导航

    一.问题描述 PagerSlidingTabStrip是android开源项目,指示器控件.官网地址:https://github.com/astuetz/PagerSlidingTabStrip 该 ...

  4. MSSQL存储过程

    存储过程的种类:       1.系统存储过程.        以sp_开头      2.扩展存储过程.        以xp_开头      3.用户定义存储过程. --重新编译存储过程 exec ...

  5. SQL列类型

    列类型的几种基本规则 M:表示最大显示宽度,最大有效显示宽度255 D:适用于浮点和定点类型,表示小数点后面的位数 方括号: [],表示可选部分 如果为一个数值列指定ZEROFILL,MySQL自动为 ...

  6. oracle本地编译问题

    oracle10.2: --将过程重新编译为本地编译方式,提示有编译错误,经查提示未设置plsql_native_library_dir 参数 SQL> alter procedure p_xx ...

  7. Android Studio updating indices 一直刷新和闪烁

    Android Studio 更新到了 3.1.3 版本,在导入了工程以后,一直出现了 updating indices 刷新的情况,造成闪烁,在切换到其他视图以后,Android Studio 会一 ...

  8. JS 日期转换,格式化等常用的函数定义

    //判断字符串是否日期格式 function isDate(val) { return new Date(val) != "Invalid Date"; } //日期格式化 fun ...

  9. Python3自定义http/https请求拦截mitmproxy脚本

    [本文出自天外归云的博客园] 脚本内容 代码如下: from mitmproxy import http, ctx from multiprocessing import Lock class Fil ...

  10. error C3861: “xxxx”: 找不到标识符

    问题出现背景:c++静态类库中主函数里包含子函数 解决办法:先声明子函数再写主函数.