Windows中redis的下载及安装、设置

 

本文是转载自:https://www.cnblogs.com/jylee/p/9844965.html

下载地址: https://github.com/MicrosoftArchive/redis/releases

根据系统下载的版本:以(64位为例)

下载后一般解压到根目录下:如(E:\Redis-x64-3.2.100)

二、安装:

打开cmd命令窗口,使用命令进行安装和注册redis到window服务

安装命令:redis-server.exe --service-install redis.windows.conf --loglevel verbose

启动服务命令:redis-server.exe  --service-start

关闭服务命令:redis-server.exe  --service-stop

最后返回的successfully表示安装成功。

也可以通过任务管理器中查看后台中是否有redis-service来判断是否启动成功。

我们重新打开一个cmd ,作为一个客户端调用redis服务,如下图所示,调用命令是:redis-cli.exe -h 127.0.0.1 -p 6379,如下图显示地址和端口,说明调用成功

然后我们使用set 和get 命令进行测试一下,set uname "abc",然后使用get uname可以获取到对应set的值,说明调用成功

三、客户端使用redis:

我们重新打开一个cmd ,作为一个客户端调用redis服务,如下图所示,调用命令是:redis-cli.exe -h 127.0.0.1 -p 6379,如下图显示地址和端口,说明调用成功

然后我们使用set 和get 命令进行测试一下,set uname "abc",然后使用get uname可以获取到对应set的值,说明调用成功

四、设置密码:

还可以通过将字符串设置为空来清空密码:
CONFIG SET requirepass "" 错误:
1、 Creating Server TCP listening socket 127.0.0.1:6379: bind: No error

解决办法:

E:\Redis-x64-3.2.100>redis-cli.exe
127.0.0.1:6379> shutdown
(error) NOAUTH Authentication required.
127.0.0.1:6379> auth root            ## 登录
OK
127.0.0.1:6379> shutdown
not connected> exit

E:\Redis-x64-3.2.100>redis-server.exe redis.windows.conf

江火似流星

修合无人见,存心有天知

随笔- 23  文章- 0  评论- 1 

Windows中redis的下载及安装、设置

 

本文是转载自:https://www.cnblogs.com/wxjnew/p/9160855.html

除了原文的东西还有自己遇到的一些问题,这里记录一下。

一、下载:

下载地址: https://github.com/MicrosoftArchive/redis/releases

根据系统下载的版本:以(64位为例)

下载后一般解压到根目录下:如(E:\Redis-x64-3.2.100)

二、安装:

打开cmd命令窗口,使用命令进行安装和注册redis到window服务

安装命令:redis-server.exe --service-install redis.windows.conf --loglevel verbose

启动服务命令:redis-server.exe  --service-start

关闭服务命令:redis-server.exe  --service-stop

最后返回的successfully表示安装成功。

也可以通过任务管理器中查看后台中是否有redis-service来判断是否启动成功。

我们重新打开一个cmd ,作为一个客户端调用redis服务,如下图所示,调用命令是:redis-cli.exe -h 127.0.0.1 -p 6379,如下图显示地址和端口,说明调用成功

然后我们使用set 和get 命令进行测试一下,set uname "abc",然后使用get uname可以获取到对应set的值,说明调用成功

三、客户端使用redis:

我们重新打开一个cmd ,作为一个客户端调用redis服务,如下图所示,调用命令是:redis-cli.exe -h 127.0.0.1 -p 6379,如下图显示地址和端口,说明调用成功

然后我们使用set 和get 命令进行测试一下,set uname "abc",然后使用get uname可以获取到对应set的值,说明调用成功

四、设置密码:

还可以通过将字符串设置为空来清空密码:
CONFIG SET requirepass "" 错误:
1、 Creating Server TCP listening socket 127.0.0.1:6379: bind: No error

解决办法:

E:\Redis-x64-3.2.100>redis-cli.exe
127.0.0.1:6379> shutdown
(error) NOAUTH Authentication required.
127.0.0.1:6379> auth root            ## 登录
OK
127.0.0.1:6379> shutdown
not connected> exit

E:\Redis-x64-3.2.100>redis-server.exe redis.windows.conf


学,然后知不足,教然后知困。知不足,然后能自反也;知困,然后能自强也。
 
posted @ 2018-10-24 17:55 江火似流星 阅读(23212) 评论(1) 编辑 收藏
 
评论
 

#1楼 2019-06-20 22:28 | APIJDKIDE

谢谢分享~
 
 
发表评论

昵称:

评论内容:
     

退出 订阅评论

 

[Ctrl+Enter快捷键提交]

 
 
 
 
昵称: 江火似流星
园龄: 1年7个月
粉丝: 3
关注: 11

< 2019年10月 >
日 一 二 三 四 五 六
29 30 1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31 1 2
3 4 5 6 7 8 9

搜索

 
 

我的标签

最新评论

 
 
Copyright © 2019 江火似流星
Powered by .NET Core 3.0.0 on Linux

本地安装配置redis的更多相关文章

  1. 如何在Ubuntu 16.04上安装配置Redis

    如何在Ubuntu 16.04上安装配置Redis Redis是一个内存中的键值存储,以其灵活性,性能和广泛的语言支持而闻名.在本指南中,我们将演示如何在Ubuntu 16.04服务器上安装和配置Re ...

  2. 【安装配置Redis】

    目录 安装 配置 Redis官网:https://redis.io Redis是完全开源免费的,遵守BSD协议. Redis是一个高性能的key-value数据库. @ *** Redis具有以下特点 ...

  3. centos7 yum安装配置redis 并设置密码

    原文:https://www.cnblogs.com/fanlinglong/p/6635828.html centos7 yum安装配置redis 并设置密码 1.设置Redis的仓库地址 yum ...

  4. linux下安装 配置 redis数据库

    通过终端命令安装(推荐): 1 确保更新源服务器能正常使用 如果没有更换更新源服务器,那么可能一直都下不了软件.欢迎参考我之前的博文来更换成国内的镜像服务器http://www.cnblogs.com ...

  5. Linux安装配置Redis,CentOS7下安装Redis教程

    1.下载Redis wget https://download.redis.io/releases/redis-3.0.4.tar.gz 2 . 解压Redis .tar.gz 3 . 编译安装Red ...

  6. Linux 下载安装配置Redis完整步骤

    安装: 1.获取redis资源 wget http://download.redis.io/releases/redis-4.0.8.tar.gz 2.解压 tar xzvf redis-4.0.8. ...

  7. CentOS 7安装配置Redis数据库

    Redis源码获取 1.进入Redis官网获取Redis最新稳定版下载地址 2.通过wget命令下载 Redis 源代码.   Redis编译 1.通过tar -xvf redis-3.0.2.tar ...

  8. linux安装配置redis

    redis是支持linux的,所以linux安装redis非常简单,按照官网的提示操作即可. 下载 $ wget http://download.redis.io/releases/redis-3.2 ...

  9. centos7 yum安装配置redis

    1.设置Redis的仓库地址 yum install epel-release 2.安装redis yum install redis 修改配置文件,监听所有的IP地址 vim /etc/redis. ...

随机推荐

  1. JavaScript--漏写var却还能使用标签

    一个漏写var带来的问题: 这个是不标准的写法!不建议使用 但是效果还是出来了,为什么呢? 原因: https://zhidao.baidu.com/question/1637589020484843 ...

  2. R语言与非参数统计(核密度估计)

    R语言与非参数统计(核密度估计) 核密度估计是在概率论中用来估计未知的密度函数,属于非参数检验方法之一,由Rosenblatt (1955)和Emanuel Parzen(1962)提出,又名Parz ...

  3. IO流理解方式小结

    从业以来一直对IO不甚了解,每次看到都头疼不已,最近有时间小小的总结一下,下面以FileIO流为]; //文件输入流 FileInputStream in = new FileInputStream( ...

  4. python的解释器类型

    Python解释器 当我们编写Python代码时,我们得到的是一个包含Python代码的以.py为扩展名的文本文件.要运行代码,就需要Python解释器去执行.py文件. 由于整个Python语言从规 ...

  5. H5视频播放自动全屏,暂停退出全屏等功能

    html5视频播放自动全屏,暂停退出全屏等功能 在参考了html5 video fullScreen全屏实现方式及司徒正美的书<javascript框架设计>287页相关代码后,在Safa ...

  6. weixin 微信开放平台 微信公众平台

    官网地址入口 微信小程序 https://mp.weixin.qq.com/ appid and openid not match 1.appid :是公众号的ID. 2.openid:关注公众号生成 ...

  7. zabbix概述篇

    zabbix监控系统概述 监控系统 决不允许未经监控的业务和服务的上线 基本功能 采样:获取客户端数据(主动和被动模式) 存储 展示 告警 监控通道 ssh/telnet:无agent snmp:简单 ...

  8. 笔记: CC2540 和 CC2541 的区别

    CC2540 和 CC2541 的区别 CC2540 和 CC2541 是 BLE 低功耗蓝牙芯片,使用的是 51 内核. CC2540 有 USB 接口 CC2541 无. 价格上最早是 CC254 ...

  9. oralce where字句的用法

    ?       如何显示工资高于3000的员工 select * from emp where sal>3000; ?       如何查找1982.1.1后入职的员工 select * fro ...

  10. Quick BI独创千人千面的行级权限管控机制

    摘要 就数据访问权限而言,阿里巴巴以“被动式授权”为主,你需要什么权限就申请什么权限.但是,在客户交流过程中,我们发现绝大多数企业都是集中式授权,尤其是面向个人的行级权限管控,管理复杂度往往呈几何增长 ...