Can't connect to MySQL server on localhost (10061)这个就属于下面要说的情况

启动服务

systemctl start mariadb.service

systemctl enable mariadb.service

systemctl stop mariadb.service

1.首先开启mysql权限

设置ROOT密码

mysqladmin -u root password '888888'

mysql -u root -p

use mysql

GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'mysql' WITH GRANT OPTION;

flush privileges;

第一句中"%"表示任何主机都可以远程登录到该服务器上访问。如果要限制只有某台机器可以访问,将其换成相应的IP即可,如:

GRANT ALL PRIVILEGES ON *.* TO root@"172.168.193.25" IDENTIFIED BY "root";

select * from user where user='root';

查看是否有%这条记录

2.开启3306端口及常用的其它端口

查看是否有这个文件/etc/sysconfig/iptables,如果没有

iptables -P OUTPUT ACCEPT

service iptables save 进行保存,默认就保存到了/etc/sysconfig目录下的iptables文件中

iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 3306 -j ACCEPT   #允许3306数据库端口通过防火墙

service iptables save

cat /etc/sysconfig/iptables有3306这条信息

service iptables restart就ok咯

其它常用端口:

iptables  -A INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT #允许80web端口通过防火墙

iptables  -A INPUT -p tcp --dport 3306 -j ACCEPT

iptables -A INPUT -p tcp --dport 110 -j ACCEPT #email

iptables -A INPUT -p tcp --dport 25-j ACCEPT #email

iptables -A INPUT -p tcp --dport 20-j ACCEPT #ftp

iptables -A INPUT -p tcp --dport 21-j ACCEPT #ftp

iptables -A INPUT -p icmp -j ACCEPT #ping

iptables -A INPUT -p udp --dport 53 -j ACCEPT #DNS

3.查看防火墙是否开启:

service iptables status

active表示开启,inactive表示关闭

firewall-cmd --state

norunning

4.关于防火墙的命令

重启后永久性生效:

开启:chkconfig iptables on

关闭:chkconfig iptables off

即时生效,重启后失效:

开启:service iptables start

关闭:

service iptables stop

重启:service iptables restart

保存配置:service iptables save

或者/etc/rc.d/init.d/iptables save

#设置防火墙开机启动

systemctl enable iptables.service

禁止防火墙在系统启动时启动

/sbin/chkconfig --level 2345 iptables off

5.删除iptables规则

查看当前规则

iptables -L -n

iptables -L -n  --line-number

iptables -D INPUT 3

centos7开启3306端口,liunx查看防火墙是否开启的更多相关文章

  1. Centos7防火墙开启3306端口

    CentOS7的默认防火墙为firewall,且默认是不打开的. systemctl start firewalld # 启动friewall systemctl status firewalld # ...

  2. iptables 开启3306端口

    [root@mysqld ~]# mysql -uroot -h 192.168.1.35 -p Enter password: ERROR 1130 (HY000): Host '192.168.1 ...

  3. Linux下防火墙开启相关端口及查看已开启端口

    最近利用Apache Mina实现了一个http服务,发布到linux下发现无法访问,通过HttpClient来发送http请求时,报如下错误: Exception in thread "m ...

  4. centos7 开放3306端口并可以远程访问

    开启远程访问: GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'root' WITH GRANT OPTION; 允许任何ip以roo ...

  5. windows开启3306端口并用可视化工具访问远程mysql(授权访问)

    开启 MySQL 的远程登陆帐号有两大步: 1.确定服务器上的防火墙没有阻止 3306 端口. MySQL 默认的端口是 3306 ,需要确定防火墙没有阻止 3306 端口,否则远程是无法通过 330 ...

  6. Linux开启相关端口及查看已开启端口

    防火墙层面:   /sbin/iptables -I INPUT -p tcp --dport 8011 -j ACCEPT #开启8011端口  /etc/rc.d/init.d/iptables ...

  7. Linux 开启相关端口及查看已开启端口

    防火墙层面:   /sbin/iptables -I INPUT -p tcp --dport 8011 -j ACCEPT #开启8011端口  /etc/rc.d/init.d/iptables ...

  8. mysql ubuntu 开启3306端口,设置远程访问

    远程登陆数据库的时候出现了下面出错信息 :ERROR 2003 ( HY000 ) : Can 't connect to MySQL server on ' xxx.xxx.xxx.xxx ',经过 ...

  9. linux如何查看防火墙是否开启?删除iptables规则

    iptables是linux下的防火墙组件服务,相对于windows防火墙而言拥有更加强大的功能,此经验咗嚛以centos系统为例.关于iptables的一般常见操作,怎么来判断linux系统是否启用 ...

随机推荐

  1. MySQL报错“1366 - Incorrect integer value: '' XXXXXXX' at row 1 ”

    出现这个错误是因为我在表中插入了一条含有中文字符的语句: 修改方法:(两种) 1:命令行  set names gbk:(此为设置通信编码) 2:my.ini中查找sql-mode 将 sql-mod ...

  2. 为什么要学习和掌握Linux?

    总结:从“为什么要学习和掌握Linux”开始,James阐述原因和理由:规划自己的目标: 为什么要学习和掌握Linux?——在读书时,如果看到别人使用命令行操作计算机实现自己想要的功能,便会冒出一个念 ...

  3. berkeley db replica机制 - election algorithm

    repmgr_method.c, __repmgr_start_int() 初始2个elect线程. repmgr_elect.c, __repmgr_init_election() __repmgr ...

  4. 入门级:怎么使用C#进行套接字编程(一)

    翻译一篇简单的文章学习下基础,此文针对我等对socket只听说未尝试阶段的水平. How to C# Socket programming C#通过他的命名空间像System.Net和System.N ...

  5. 【Win10 UWP】QQ SDK(一):SDK基本使用方法

    每当开发一个应用需要社交分享的应用时,总是心里咯噔一下:到底什么时候分享能加上QQ和微信?除了WP8.0版本的微信SDK,官方似乎从未正面发布过适应时代发展的QQ SDK,就连后台,也没有一个可以创建 ...

  6. Orleans的单线程执行模型

    Orleans在默认情况下只创建一个grain的实例,并以单线程模型执行.如果同一个grain实例,在Orleans存在多个实例,就会产生并发冲突,单线程执行模型就可以完全避免并发冲突了. 但在特殊场 ...

  7. [C++] C/C++结构体的区别

    C/C++结构体的区别 >_<:C中的结构体和C++中结构体的不同之处: 在C中的结构体只能自定义数据类型,结构体中不允许有函数,而C++中的结构体可以加入成员函数. >_<: ...

  8. Hadoop Capacity Scheduler源码实现剖析

    作者: 大圆那些事 | 文章可以转载,请以超链接形式标明文章原始出处和作者信息 网址: http://www.cnblogs.com/panfeng412/archive/2013/09/13/had ...

  9. 微软 PowerShell Script Explorer 满血复活,正式发布

    一年前的今天,微软在其Windows PowerShell官方博客声明中止 ‘Script Explorer’ 应用程序的开发. 一年后的今天,微软为其Script Explorer注入了新的生命.一 ...

  10. Oracle dmp文件导入(还原)到不同的表空间和不同的用户下

    ------------------------------------- 从生产环境拷贝一个dmp备份文件,在另外一台电脑上搭建测试环境,用imp命令导入dmp文件时提示如下错误: 问题描述: IM ...