安装mariadb/mysql 连接失败问题
在linux下安装mariadb会出现一系列问题
问题1->服务器端不需要用户名密码就可登陆数据库
问题2->php使用mysql不能连接数据库 访问受限
问题3->navicate远程连接数据库失败
在捣鼓一段时间之后然后莫名就可以了,虽然知道是权限方面的问题,但是终究不得要领。为了弄清楚特意找了个新服务器,重新搭建一套ubuntu、php7、mariadb的环境重现一下问题。
具体的安装过程这里略过了啊,网上这方面资料很多。
安装完mariadb第一次登陆是没有登录密码限制的,就是随便输什么密码都可以进入,但是用户名是固定的 root
#mysql -u root -p
空格

注意我这里输入的是空格 然后就进来了.
之后我们看看这是为什么
MariaDB [mysql]> use mysql; MariaDB [mysql]> select user,password,host from user;

这个名为mysql的库是记录mysql相关内容的数据
而user就是记录mysql用户名及密码权限的表可以看到root的密码是空的
下面我们先解决这个问题
先运行命令
MariaDB [mysql]> grant all privileges on *.* to root@"localhost" identified by "123456";
然后我们查看用户及密码
MariaDB [mysql]> select user,password,host from user;
然后我们就会发现必须使用123456这个密码来进图数据库了 问题一解决
下一步我们尝试使用远程工具navicate链接mariadb 

然后通过度娘找到了一些方法
mysql和mariadb中关于root权限管理不同 需要调配
执行两条命令 添加两个用户
MariaDB [mysql]> grant all privileges on *.* to root@"%" identified by "123456"; MariaDB [mysql]> grant all privileges on *.* to root@"127.0.0.1" identified by "123456"; MariaDB [mysql]> flush privileges;
退出数据库 exit;或者ctrl+c
修改mysql的配置文件
# vim /etc/mysql/mariadb.conf.d/50-server.cnf
找到
bind-address = 127.0.0.1
将其注释掉
# bind-address = 127.0.0.1
保存退出 重启mysql
# service mysql restart
再次连接之后我惊喜的发现 还是链接不上,一股烦躁之气渐渐升起。平定一下心神,看看数据库去吧。
MariaDB [mysql]> select * from user;
之后找到这一行 为什么是N呢 这个权限不对啊 改下试试

MariaDB [mysql]> GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY '123456' WITH GRANT OPTION; MariaDB [mysql]> GRANT ALL PRIVILEGES ON *.* TO 'root'@'127.0.0.1' IDENTIFIED BY '123456' WITH GRANT OPTION; MariaDB [mysql]> flush privileges;
重新连接发现

苍天啊 大地啊 绝望啊 ,放弃吧? 开玩笑!
继续查资料发现是端口问题使用
# netstat -aptn执行看看,是否监听在0.0.0.0:3306
重启mysql之后发现监听并没有改变
kill掉3306的进程号 991 再次重启之后我得到了下面几张截图效果


本以为弄到这种程度就可以了 然而现实继续教育了我 navicate远程连接继续失败!!!
其实这时候我对于权限这块还是端口这块我是抱有疑问的 所以我试了下 本地php 使用pdo链接数据库 发现是可以连接操作的 经过以前失败的经验我可以认为权限问题已经解决了。
所以问题二 php使用mysql不能连接数据库访问受限 在倒腾的过程中已经解决了
这里画下重点:一般情况下 到这里数据库连接的问题 已经基本解决了
根据查阅的资料,造成不能连接的原因是 mysql 和 mariadb 对于 root 权限管理是不同的,mariadb对于root的权限默认是不开放Gan_priv权限的。另外对于用户表mariadb添加了两个新字段,is_role和password_expired。数据库的表格数也是不同的,老版mysql是24张表左右 而mariadb是30张左右(这里就不去数各个版本的具体数量了,有个概念)
下面继续直面我的问题
想想如果权限没有问题了 是不是端口问题呢?
然后使用telnet工具本地 cmd 命令行测试端口开放情况
1、安装telnet。我的win7下就没有telnet,在cmd下输入telnet提示没有该命令。于是我们进入控制面板---->程序---->打开或关闭windows功能。然后等一段时间,在出来的对话框把telnet客户端和telnet服务器勾选上,其他的不用管,然后点击确定。这样就安装好了telnet组件了。
2、 下面开始测试某个端口是否开启,比如我测的是47.104.195.152的 3306 这个端口。在cmd下输入
telnet 47.104.195.152 3306

而正常的情况是这样的 跳转一个新的页面 如果有疑问可以测试80 或者22 端口我这里是通的

所以现在已经锁定是端口的问题
下面是一些开放的操作 不过在我这里是没什么用的 怎么开端口加防火墙规则也么用
我用是阿里云的服务器
ss -nltp | grep 3306 查看服务端口是否连接
iptables -nL 查看防火墙端口是否开启
iptables -I INPUT -p tcp --dport 3306 -j ACCEPT 开放防火墙3306端口
经过一系列恶心的尝试 发现还是不能接通
既然内部不能改变规则 那就去服务器上 阿里云界面去改试试
这个是案例云安全组里面的内容 经过添加一定的规则 有了下面的内容 这个3306
开始是没有的,添加好了规则之后 重启服务器


ok 链接成功 整理一下回去睡觉了 中间还有很多细节没弄清楚 但是明天还要上班啊
人生什么的还是不要随便怀疑吧 相信自己。
-------------------------------------------------------------------------------分割线--------------------------------------------------------------------------------------------------------
这里给大家普及一个阿里云服务器比较实惠的小技巧 在阿里云创建实例的时候 选择抢占实例的选项
很适合开发人员进行一次性试验的时候使用 做一次试验 部署一台云服务器 成本控制在2元以内
抢占式实例 抢占式实例 抢占式实例
这个官方的解释是随时有可能会释放 提前5分钟通知,其实就是把卖不出去的服务器资源便宜卖了,如果资源不够了再及时收回来。批发改零售嘛!一天两天的 是不会被回收的!


因为是一次性的想怎么捣鼓怎么捣鼓 如果想在正式服务器上面捣鼓 也不拦着,如果你吼得住的话!
安装mariadb/mysql 连接失败问题的更多相关文章
- mysql连接失败或出现“Too many connections”错误
mysql连接失败或出现"Too many connections"错误 # 按自己服务器的配置文件路径修改 vi /etc/my.cnf 查找:max_connections 修 ...
- mysql连接失败HikariPool错误
1. mysql连接失败HikariPool错误 1.1. 异常 com.zaxxer.hikari.pool.HikariPool : HikariPool-1 - Exception during ...
- CentOS通过yum安装MariaDB(MySQL)无法启动服务或者找不到mysql.sock
转载自:http://www.linuxidc.com/Linux/2016-03/129396.htm 今天在Linux主机(CentOS 7)安装(yum install方式)Mariadb(即开 ...
- CentOS 7 Linux 卸载/安装 Mariadb MySQL mysql 5.7
[root@localhost mysql]# ls mysql-community-client--.el7.x86_64.rpm mysql-community-embedded-compat-- ...
- cent os 安装mariaDB / mySQL 之后初始化的命令
#安装mysql mysql-server,默认安装的是开源的mariaDB和它的server,mariadb-server,安装源中可能有找不到的,就换个名字再找找 yum install -y ...
- mysql 连接失败问题汇集
FHost '192.168.5.128' is not allowed to connect to this MySQL serverConnection closed by foreign hos ...
- 解决idea中mysql连接失败Could not create connection to database server. Attempted reconnect 3 times. Giving up.
原因是少一个参数,设置时区的. 解决方法: 加一个参数: serverTimezone=UTC jdbc:mysql://localhost:3306/SshProject?useUnicode=t ...
- 【MySQL】Mac通过brew安装的MySQL重启方法
问题 在 Mac 上通过 brew install mysql 安装的的MySQL使用基本MySQL命令重启会失败: mysql.server stop mysql.server start mysq ...
- mysql安装和配置详解以及Navicat连接失败问题
好久没安装过MySQL了,今天安装了下竟然碰壁了, 就来做个笔记吧.安装步骤如下: 记住:一定要看到最后!!!!!!!!! 一. 安装 1.安装 (https://dev.mysql.com/dow ...
随机推荐
- Java8 日期和时间类
新的日期和时间API 新的日期和时间类解决了Date和Calendar类出现的问题 浅尝 LocalDate 日期类 LocalDate of = LocalDate.of(2018, 7, 13); ...
- python实践项目1
python #南昌理工学院人工智能学院实验室 WORKSHOP 实践项目 import time print('welcome to our WORKSHOP') print('.......... ...
- 详解 Python 的二元算术运算,为什么说减法只是语法糖?
原题 | Unravelling binary arithmetic operations in Python 作者 | Brett Cannon 译者 | 豌豆花下猫("Python猫&q ...
- Visual Studio Code 下载安装
1.官网下载:https://code.visualstudio.com/ 2.下载完成后,点开如果是黑屏的话,右键勾上.
- Springboot中WebMvcConfigurer接口详解
Springboot 使用越来越多,企业的基本框架,到Springcloud分布式,可以说无论面试还是平常技术学习,一说到spring几乎就就代替了Java,可以说spring,springboot的 ...
- Solr专题(三)SSM项目整合Solr
一.环境配置 所需要的jar包: org.apache.solr.solr-solrj maven依赖: <!-- https://mvnrepository.com/artifact/org. ...
- 不光是查找值!"二分搜索"
从有序数组中查找某个值 问题描述:给定长度为n的单调不下降数列a0,…,an-1和一个数k,求满足ai≥k条件的最小的i.不存在则输出n. 限制条件:1≤n≤1060≤a0≤a1≤…≤an-1< ...
- robotframework安装与运行(ride.py1.7.4.2命令报错)(win10+python3.8.1)
首先,robotframework必须在python的环境下运行 所以你的电脑里必须有python3.x的环境先. 上古时期的robotframework只支持python2,不过python2都已经 ...
- 口罩预约管理系统——数据库设计(前端+PHP+MySQL)
目录 一.背景 二.口罩预约管理系统介绍 三.数据库设计 四.MySQL创建数据库以及数据表 五.数据库设计总结 一.背景 2020年的疫情影响了我们的生产生活,政府不断加大力度联防联控,遏制疫情的蔓 ...
- .net MVC4.0项目发布到阿里云虚拟主机中遇到的问题。
正所谓学以致用,今天本来想做个bootstrap的demo发到服务器上看一下效果,结果服务器搞了半天,最终太晚了没能学到什么东西. 首先写好页面之后我做了一个MVC4.0的网站项目,然后把Bootst ...