MHA 报错:There is no alive slave. We can't do failover
dba http://blog.csdn.net/zengxuewen2045/article/details/51524880
关于这个错误:
|
1
2
3
4
|
Mon Feb 13 10:29:41 2017 - [error][/usr/share/perl5/vendor_perl/MHA/ServerManager.pm, ln188] There is no alive server. We can't do failover
Mon Feb 13 10:29:41 2017 - [error][/usr/share/perl5/vendor_perl/MHA/MasterMonitor.pm, ln424] Error happened on checking configurations. at /usr/share/perl5/vendor_perl/MHA/MasterMonitor.pm line 326
Mon Feb 13 10:29:41 2017 - [error][/usr/share/perl5/vendor_perl/MHA/MasterMonitor.pm, ln523] Error happened on monitoring servers.
Mon Feb 13 10:29:41 2017 - [info] Got exit code 1 (Not master dead).
|
在之前的部署文档里:
|
1
|
http://d-prototype.com/archives/6873
|
我说需要把server_id,改成10,可以走过去。
其实这是很片面的。
今天又遇到了这个问题,并解决了。
关于该问题,比较靠谱的解释是:
MHA默认去连接MySQL的端口是:3306
如果你的主机名解析,或者你写的IP都没问题,防火墙也关闭了,那么,剩下的原因是:
你的MySQL,没有运行在默认端口上。
如果不能修改MySQL的端口为:3306。
那么你可以给MHA,添加PORT描述。
以下是添加端口描述的MHA应用配置文件的样例:
|
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
|
[server default]
manager_workdir=/work_dir/mha_manager
manager_log=/work_dir/mha_manager/mha_manager.log
[server1]
hostname=mha2
candidate_master=1
port=3307
[server2]
hostname=mha3
candidate_master=1
port=3307
[server3]
hostname=mha4
#candidate_master=1
no_master=1
port=3307
|
——————————————
=================================================
8.MHA架构中的错误
Tue Apr 28 15:15:36 2015 - [error][/usr/local/share/perl5/MHA/ServerManager.pm, ln193] There is no alive slave. We can't do failover
Tue Apr 28 15:15:36 2015 - [error][/usr/local/share/perl5/MHA/MasterMonitor.pm, ln383] Error happend on checking configurations. at /usr/local/share/perl5/MHA/MasterMonitor.pm line 298
Tue Apr 28 15:15:36 2015 - [error][/usr/local/share/perl5/MHA/MasterMonitor.pm, ln478] Error happened on monitoring servers.
解决方法:
(1).删除健康检查文件 rm -rf /var/log/masterha/app1/app1.master_status.health
(2).在宕机的数据库中重新同步到主服务器 change master to master_host...............
(3).检查复制是否出错 masterha_check_repl --conf=/etc/mysqlmha/conf/app1.cnf
========================================
主从同步已经打好的情况下执行
grant all privileges on *.* to 'root'@'server01' identified by '123qwe!@#';
grant all privileges on *.* to 'root'@'server02' identified by '123qwe!@#';
grant all privileges on *.* to 'root'@'server03' identified by '123qwe!@#';
grant all privileges on *.* to 'root'@'server04' identified by '123qwe!@#';
flush privileges;
[root@server01 lib]# masterha_check_repl --conf=/etc/masterha/app1.cnf
Tue Jul 12 16:08:08 2016 - [warning] Global configuration file /etc/masterha_default.cnf not found. Skipping.
Tue Jul 12 16:08:08 2016 - [info] Reading application default configurations from /etc/masterha/app1.cnf..
Tue Jul 12 16:08:08 2016 - [info] Reading server configurations from /etc/masterha/app1.cnf..
Tue Jul 12 16:08:08 2016 - [info] MHA::MasterMonitor version 0.53.
Tue Jul 12 16:08:08 2016 - [error][/usr/local/share/perl5/MHA/ServerManager.pm, ln193] There is no alive slave. We can't do failover
Tue Jul 12 16:08:08 2016 - [error][/usr/local/share/perl5/MHA/MasterMonitor.pm, ln383] Error happend on checking configurations. at /usr/local/share/perl5/MHA/MasterMonitor.pm line 298
Tue Jul 12 16:08:08 2016 - [error][/usr/local/share/perl5/MHA/MasterMonitor.pm, ln478] Error happened on monitoring servers.
Tue Jul 12 16:08:08 2016 - [info] Got exit code 1 (Not master dead).
配置主主复制架构,并设置其中一台为read_only (set global read_only=1;)
MHA 报错:There is no alive slave. We can't do failover的更多相关文章
- mha 复制检查报错“There is no alive server. We can't do failover”
安装mha所参考的文章: http://linzhijian.blog.51cto.com/1047212/1906434 http://www.cnblogs.com/xiaoboluo768/p/ ...
- 配置MySQL主从复制报错Last_IO_Error: Fatal error: The slave I/O thread stops because master and slave have equal MySQL server ids; these ids must be different for replication to work
配置MySQL主从复制报错 ``` Last_IO_Error: Fatal error: The slave I/O thread stops because master and slave ha ...
- mha报错
用命令检查集群复制状态:masterha_check_repl --conf=/etc/masterha/app1.cnf 报错如下: Tue Jan 12 09:25:51 2016 - [info ...
- jenkins slave启动报错:hudson.util.IOException2: Slave JVM has terminated. Exit code=126
添加mac slave节点报错如下:Expanded the channel window size to 4MB [11/07/14 19:11:54] [SSH] Starting slave p ...
- mysql MHA报错 Can't exec "mysqlbinlog": No such file or directory at /usr/local/share/perl5/MHA/BinlogManager.pm line 99.
如果发现如下错误: Can't exec "mysqlbinlog": No such file or directory at /usr/local/share/perl5/MH ...
- MySQL MHA 报错处理
安装环境:CentOS 6.5 MySQL 5.7.22 MHA 0.56 1.找不到mysql 命令 Sat Mar 23 07:17:50 2019 - [info] Connecting to ...
- MySQL主从复制报错及解决方法
mysql> show slave status \G *************************** 1. row *************************** Slave_ ...
- 【MySQL】MySQL同步报错-> received end packet from server, apparent master shutdown: Slave I/O thread: Failed reading log event, reconnecting to retry报错解决和分析
[root@db-ft-db-48 ~]# tail -f /mysqlLog/beside_index_err.log 140102 20:42:26 [Note] Slave: received ...
- jenkins centos slave起不来报错The SSH key presented by the remote host does not match the key saved in the Known Hosts file against this host. Connections to this host will be denied until the two keys mat
场景:我的centos-204是一台centos的机器,本来用https://www.cnblogs.com/zndxall/p/8297356.html 的centos slave方式搭建ok的,一 ...
随机推荐
- Maven安装Oracle驱动包到本地仓库
驱动下载地址:https://download.csdn.net/download/yang_lover/9455401 mvn install:install-file -DgroupId=com. ...
- 替换Jar包内的文件
要替换Jar包内的文件可以用以下命令实现: jar uvf myjar.jar com/test/myclass.class 这里值得注意的是 myclass.class 必须放在com/test ...
- 3.Appium处理原生与H5的嵌套
环境前置准备 手机与电脑USB连接,开启USB调试模式,通过adb devices可查看到此设备. 电脑端.移动端安装chrome浏览器.(尽量保证移动端chrome版本低于电脑端) App webv ...
- 何时使用SUM()与SUMX()
概述 SUM()是一个聚合函数.在应用将影响公式的所有过滤器后,它会将您指定的单个列中的所有值相加.SUM()不知道行的存在(它不能逐行求值) - 它所能做的就是在应用过滤器之后将所有内容添加到它所呈 ...
- [转]Skynet之斗转星移 - 将控制权交给Lua
Skynet之斗转星移 - 将控制权交给Lua http://www.outsky.org/code/skynet-lua.html Sep 7, 2014 在我看来,Skynet的一个重要优势是 ...
- 会话执行存储过程,等待被阻塞,Kill session场景模拟
本次场景来源: 通知某个会话:执行execute addupp(1,'five');类似的存储过程,会话等待:(会话等待两种情况:一种确实执行,但是未完成:另一种就是执行的操作无法获取资源,等待资源释 ...
- Java简单双向链表实现 @version 1.0
package com.list; /** * 数据结构和算法Java表示 双向链表 * * @version 1.0 * @author 小明 * */ public class MyDoublel ...
- Shell #*/ 和 %/*
#!/bin/bash i="this/is/a/path.config" name=${i#*/} path=${i%/*} echo $name echo $path is/a ...
- matlab学习(1)strsplit与strtok
strsplit函数用法: <1>默认使用空格符分割,返回一个cell数组 <2>也可以指定第二个参数进行分割 <3>第二个参数也可以时包含多个分隔符的元胞数组 & ...
- 完整的AJAX
$.ajax({url:"请求路径",data:{"key":前端传入后台处理的数据},type:"post", //请求方式dataTyp ...