MongoDB启动和关闭问题
1、当我们使用离线安装mongodb完成后,
推荐安装教程:
http://dblab.xmu.edu.cn/blog/868-2/#more-868
在使用 ' mongod -f XXX/mongodb.conf ' 启动mongodb服务后(XXX是conf文件存放目录,根据自己新建的位置确定。因为添加了path变量,所有我直接使用的mongod命令)
关闭mongodb服务一定要:
' mongo ' 命令进入shell界面
使用以下命令停止mongodb服务
use admin
db.shutdownServer()
然后输入exit或Ctrl+C退出shell模式
这里一般就完成了,但是我退出后遇到了一个问题
会输出以下信息报错,服务无法正常关闭:
--01T10::53.961+ I NETWORK [js] trying reconnect to 127.0.0.1: failed
--01T10::53.961+ I NETWORK [js] reconnect 127.0.0.1: failed failed
--01T10::53.962+ I QUERY [js] Failed to end session { id: UUID("ebb3c7bf-a3e9-4d03-bda4-3c0e5ad2e54c") } due to SocketException: socket exception [CONNECT_ERROR] server [couldn't connect to server 127.0.0.1:27017, connection attempt failed: SocketException: Error connecting to 127.0.0.1:27017 :: caused by :: Connection refused]
这里,我们输入以下命令:
mongod --repair
输出有以下即关闭了服务:
--01T10::01.943+ I STORAGE [initandlisten] Finished shutting down checkpoint thread
--01T10::01.962+ I STORAGE [initandlisten] shutdown: removing fs lock...
--01T10::01.963+ I CONTROL [initandlisten] now exiting
--01T10::01.963+ I CONTROL [initandlisten] shutting down with code:
如果没有正常关闭服务,下次启动时就会报以下错误无法启动,哪怕没有mongo进程在运行
ERROR: child process failed, exited with error number
2、centos使用yum源安装mongodb:
可以参考以下网站:
https://blog.csdn.net/weixin_34393428/article/details/93026350
其中设置yum源时,建议gpgcheck=0,因为没有梯子大概率验证失败
然后mongod.conf配置文件不需要修改。特别是bind ip该参数,使用默认127.0.0.1即可,修改为本机ip会启动mongod服务失败
最后使 mongodb 系统启动:
systemctl enable mongod
查看状态:
systemctl status mongodb
3、启动的两个警告:
1.WARNING: Access control is not enabled for the database.
可以参考以下链接:
https://blog.csdn.net/ttxsely/article/details/77726164
2.WARNING: /sys/kernel/mm/transparent_hugepage/enabled is 'always'.
这个警告好像无法解除,可以看看下面的链接:
https://www.cnblogs.com/ywcz060/p/5543228.html
总结:
推荐使用yum源安装,这样安装不会有其他的问题。
MongoDB启动和关闭问题的更多相关文章
- mongodb启动和关闭
mongodb的启动 mongod --dbpath=/data/mongodb/data --logpath=/data/mongodb/log/33988.log --port 33988 --f ...
- MongoDB 启动和关闭
重启命令 service mongodb restart 启动命令 mongod -f /data/tools/mongodb/config/config.conf 必须要带配置文件才能启动 关闭命令 ...
- Mongodb启动&关闭
mac 下mongo的启动和关闭以及启动问题解决 mongo的安装在这:http://www.cnblogs.com/leinov/p/6855784.html Mac os mongodb数据安装路 ...
- mongodb之 非正常关闭启动报错处理
Mongodb如果非正常关闭,直接启动会报错.查看日志文件. 处理: 需要做的是删除mongod.lock和WiredTiger.lock这两个lock文件,然后执行--repair,这里的mongo ...
- mongodb因非法关闭导致无法启动的解决方案
mongodb因非法关闭导致无法启动的解决方案 1.删除数据库目录的.lock文件 2.输入命令 mongod --repair 3.重启
- Mongodb启动命令mongod参数说明
Mongodb启动命令mongod参数说明 mongod的主要参数有: 基本配置 ----------------------------------------------------------- ...
- mongodb启动后台服务
将MongoDB部署在服务器机子上时mongodb的实例应为后台服务进行的方式运行,而非前台进程,否则远程会话一关闭mongodb也跟着关闭了.本文介绍mongodb后台服务进程开启和关闭的操作. 开 ...
- MongoDB启动配置等
目录: 一.mongoDB 启动配置 二.导出,导入,运行时备份 三.Fsync锁,数据修复 四.用户管理,安全认证 一.启动项 mongod --help C:\Windows\system32&g ...
- mongoDB启动参数备忘
本文转载 Mongodb启动命令mongod参数说明 mongod的主要参数有: 基本配置 ----------------------------------------------- ...
随机推荐
- Lowest Common Ancestor of a Binary Search Tree(树中两个结点的最低公共祖先)
题目描述: Given a binary search tree (BST), find the lowest common ancestor (LCA) of two given nodes in ...
- Constant Palindrome Sum(贪心*RMQ)
传送门 怎么说呢,想了几个小时没做出来实在可惜. \(\color{Red}{首先肯定想到暴力嘛!但是x定值有那么多值可以取,怎么办呢?}\) 但是题目中有一个很关键的条件 \[a[i]>=1\ ...
- 前缀和(P2697 宝石串)
前言 每次做出来什么本来做不出的题目,就忍不住记录一下.不过大多时候隔几天来看,就发现,啊,我当时只是做了一道这么弱智的题目呀,哈哈.前缀和确实不算太难.. 传送门 题目大意: 给你一个字符串只含G和 ...
- 【FPGA篇章二】FPGA开发流程:详述每一环节的物理含义和实现目标
欢迎大家关注我的微信公众账号,支持程序媛写出更多优秀的文章 FPGA的开发流程是遵循着ASIC的开发流程发展的,发展到目前为止,FPGA的开发流程总体按照下图进行,有些步骤可能由于其在当前项目中的条件 ...
- jQuery中操作属性的方法attr与prop的区别
attr 与 prop 都可以对某个属性进行获取和设置的操作,二者的用法相同: <script src = 'jQuery.js'></script> <script&g ...
- vue滑动吸顶以及锚点定位
Vue项目中需要实现滑动吸顶以及锚点定位功能.template代码如下: <template> <div class="main"> <div id= ...
- 【漫画】JAVA并发编程 J.U.C Lock包之ReentrantLock互斥锁
在如何解决原子性问题的最后,我们卖了个关子,互斥锁不仅仅只有synchronized关键字,还可以用什么来实现呢? J.U.C包中还提供了一个叫做Locks的包,我好歹英语过了四级,听名字我就能马上大 ...
- java读取文件内容常见几种方式
①随机读取文件内容 ②以行为单位读取文件,常用于读面向行的格式化文件 ③以字符为单位读取文件,常用于读文本,数字等类型的文件 ④以字节为单位读取文件,常用于读二进制文件,如图片.声音.影像等文件 pa ...
- webpack指南(一)HRM+Tree Shaking
参考:https://www.cnblogs.com/PasserByOne/p/12084323.html https://blog.csdn.net/qq593249106/article/det ...
- mysql运维入门1:基础及备份还原
存储引擎 myisam 表强调的是性能 执行速度比innodb类型更快 不提供事务支持 如果执行大量的select操作,是首选 支持表锁,不支持行锁 innodb 提供事务支持.外键等高级数据库功能 ...