提出问题

近日助友 Docker 部署 Kafka 服务,服务日志启动正常,但客户端却无法连接

往日曾踩过此坑,然方法均源于博客,其语焉不详,不知为何不行,亦不知为何行,印象不甚深刻,耗费大量时间

为避此坑,特地学习官方文档相关章节,让我寻到珠丝马迹,请听我娓娓道来~

如嫌篇幅较长,可跳过验证,直奔结论

本文主要记录为何会出现无法连接到 Broker 的原因,想必看完本文你会知道该怎么做的

谨以此文献给那些因为无知而浪费的时光!

大胆猜测

Kafka的服务端称为 Broker,每个 Broker 启动时会将自己的 Broker 配置信息上报给 Zookeeper ,如,监听地址与端口号等,Kafka的客户端(生产者与消费者统称)要连接 Broker 需要经过一层认证,不通过认证就无法连接!

小心求证

测试环境:

  • GNU/Linux Debian 10 4.19.0内核
  • Docker:19.03.6
  • Docker-compose:1.17.1
  • 镜像:zookeeper:3.5.5
  • 镜像:wurstmeister/kafka:2.12-2.2.1

设计实验:

使用 docker 镜像部署一套单节点的 Zookeeper + Kafka

要求Broker监听自定义域名(主机名)与端口,服务启动后展示 Zookeeper 中 Broker 的注册信息

使用客户端连接 Broker ,使用不同的 --bootstrap-server 组合方式,进行验证

开始实验

为了提高部署效率,这里提供一个简单可启动的 docker-compose-test.yml

version: "3.3"
services:
zookeeper:
image: zookeeper:3.5.5
restart: always
container_name: zookeeper
ports:
- "2181:2181"
expose:
- "2181"
environment:
- ZOO_MY_ID=1
kafka:
image: wurstmeister/kafka:2.12-2.2.1
restart: always
container_name: kafka
environment:
- KAFKA_BROKER_ID=1
- KAFKA_LISTENERS=PLAINTEXT://kafka:9090
- KAFKA_ZOOKEEPER_CONNECT=zookeeper:2181
- KAFKA_MESSAGE_MAX_BYTES=2000000
ports:
- "9090:9090"
depends_on:
- zookeeper

将 docker-compose-test.yml 放入你的目录,运行部署脚本

查看两者的日志,检查是否正常启动

docker logs -f zookeeper

docker logs -f kafka

可以看到 Kafka 已经注册成功

让我们查看一下,Zookeeper 中注册的 Broker 信息

docker exec -it zookeeper bash bin/zkCli.sh

输入 quit 退出

想到我们已经将Kafka监听的端口号已经映射到宿主机了,使用宿主机 IP 访问不就得了?

先创建个Topic

docker run -it --rm --network host wurstmeister/kafka:2.12-2.2.1 \
bash /opt/kafka/bin/kafka-topics.sh \
--bootstrap-server 192.168.1.19:9090 \
--create --topic logsTopic --partitions 1 --replication-factor 1

噢!又是这该死的错误!

想到刚才在 zookeeper 中看到的信息,要不我把 IP 换成 kafka 不就结了?

docker run -it --rm --network host wurstmeister/kafka:2.12-2.2.1 \
bash /opt/kafka/bin/kafka-topics.sh \
--bootstrap-server kafka:9090 \
--create --topic logsTopic --partitions 1 --replication-factor 1

不对,宿主机本身没有对 kafka 作映射,问题一定出在这里!

再次执行刚才的命令,没有输出,说明创建 Topic 成功!

生产一条消息测试下

docker run -it --rm --network host wurstmeister/kafka:2.12-2.2.1 \
bash /opt/kafka/bin/kafka-console-producer.sh \
--broker-list kafka:9090 --topic logsTopic

输入回车,发送消息; ctrl + c 断开连接

创建消费者,消费消息测试

docker run -it --rm --network host wurstmeister/kafka:2.12-2.2.1 \
bash /opt/kafka/bin/kafka-console-consumer.sh \
--bootstrap-server kafka:9090 --topic logsTopic --from-beginning

嗯,消费也成功了

归纳总结

这个实验说明了什么呢?

说明 Kafka 客户端在连接 Broker 的时候,Broker 将客户端发来的请求带的信息与 Broker 启动时上报给 Zookeeper 的信息 进行了比对,比对相同则认证通过,反之建立连接失败!

官方文档

通过耐心地查看 Kafka 的官方文档,终于在角落里看到她的影子!(好久不见妹子,看文档都眉清目秀的~)

比如下面这段:

From Kafka version 2.0.0 onwards, host name verification of servers is enabled by default for client connections as well as inter-broker connections to prevent man-in-the-middle attacks.

大意是讲通过这种认证hostname的机制,来避免中间人攻击

还有这段:

advertised.host.name: DEPRECATED: only used when advertised.listeners or listeners are not set. Use advertised.listeners instead. Hostname to publish to ZooKeeper for clients to use. In IaaS environments, this may need to be different from the interface to which the broker binds. If this is not set, it will use the value for host.name if configured. Otherwise it will use the value returned from java.net.InetAddress.getCanonicalHostName().

虽然这个参数已经标记为废弃了,但是她提供了个信息:如果设置主机名可能会被上报

最后看看这段

advertised.listeners: Listeners to publish to ZooKeeper for clients to use, if different than the listeners config property. In IaaS environments, this may need to be different from the interface to which the broker binds. If this is not set, the value for listeners will be used. Unlike listeners it is not valid to advertise the 0.0.0.0 meta-address.

也就是说,默认设置 advertised.listeners与 listeners 的值相同,上报Zookeeper供客户端使用;无需绑定不同接口时,只需要设置 listeners 即可。

结论

Kafka 客户端在连接 Broker 的时候,Broker 将客户端发来的请求附加信息与 Broker 启动时上报给 Zookeeper 的 listeners参数信息、host(来自listeners的中间域名或主机名部分)、port (来自listeners的端口部分) 进行了验证,认证通过建立连接执行请求,反之建立连接失败

如果看完本文还不知如何去做,请参考https://www.cnblogs.com/hellxz/p/how_to_add_hosts_on_docker.html

写这篇文章费了好大的功夫,猜是一回事,弄明白又是一回事,如果本文对你有所帮助,欢迎点推荐与关注

引用:
https://kafka.apache.org/documentation.html

本文采用 CC BY 4.0 协议进行授权,转载请标注作者署名及来源。
https://www.cnblogs.com/hellxz/p/why_cnnect_to_kafka_always_failure.html

【原创】为什么我的 Kafka 总是连接失败呢?的更多相关文章

  1. ssh连接失败,排错经验

    一.场景描述 ssh连接服务器,发现连接失败,但是对应服务器的ip能够ping通. 场景: [root@yl-web ~]# ssh root@10.1.101.35 ssh_exchange_ide ...

  2. com.microsoft.sqlserver.jdbc.SQLServerException: 到主机 的 TCP/IP 连接失败。 java.net.ConnectException: Connection refused: connect

      问题描述:最简单的数据库连接报错,到主机  的 TCP/IP 连接失败.(win 7 操作系统) 错误信息: com.microsoft.sqlserver.jdbc.SQLServerExcep ...

  3. mysql客户端授权后连接失败问题

    在本地(192.168.1.152)部署好mysql环境,授权远程客户机192.168.1.%连接本机的mysql,在iptables防火墙也已开通3306端口.如下:mysql> select ...

  4. ORA-12545: 因目标主机或对象不存在, 连接失败

    ORA-12545: 因目标主机或对象不存在, 连接失败 1. 问题描述 XP系统下同时安装了AX1应用程序和升级版AX2,连接同一个在本机Oracle客户端上配置的连接实例,其中AX2显示链接成功, ...

  5. 【转】Java JDBC连接SQL Server2005错误:通过端口 1433 连接到主机 localhost 的 TCP/IP 连接失败

    错误原因如下: Exception in thread "main" org.hibernate.exception.JDBCConnectionException: Cannot ...

  6. GPRS连接失败问题

    备注:采用的是SIMCOM的SIM900模块 1. GPRS连接失败问题 2013.08.06测试9台C2000两次,两次之间是机器拿开电池,间隔40分钟左右,每次都出现一台(但不是同一台): ⑴9台 ...

  7. kafka+storm连接

    本项目为maven项目,需要添加必要的storm库,以及kafka依赖,使用storm自带的storm-kafka进行连接,根据自己集群环境 <dependency> <groupI ...

  8. Java JDBC连接SQL Server2005错误:通过port 1433 连接到主机 localhost 的 TCP/IP 连接失败

    错误原因例如以下: Exception in thread "main" org.hibernate.exception.JDBCConnectionException: Cann ...

  9. ssh连接失败,排错经验(转)

    一.场景描述 ssh连接服务器,发现连接失败,但是对应服务器的ip能够ping通. 场景: [root@yl-web ~]# ssh root@10.1.101.35 ssh_exchange_ide ...

随机推荐

  1. rsyslog与journal日志架构

    系统日志架构概述 在centos7系统中有两个日志服务,分别是传统的rsyslog和新添加的systemd-journal systemd-journal是一个改进型的日志管理服务,可以收集来自内核. ...

  2. RPM包和YUM仓库管理

    1.RPM包管理 RPMRPM Package Manger,前身Redhat Package Manger,由红帽开发用于软件包的安装升级卸载与查询有一个完整的数据库体系,每个RPM包的所有信息都固 ...

  3. php函数 之 iconv 不是php的默认函数,也是默认安装的模块。需要安装才能用的。

    windows下最近在做一个小偷程序,需要用到iconv函数把抓取来过的utf-8编码的页面转成gb2312, 发现只有用iconv函数把抓取过来的数据一转码数据就会无缘无故的少一些.  让我郁闷了好 ...

  4. python语法基础-基础-变量和数据类型

    ###############   第一个python程序   ############### print("hello python") # 打印hello python # 分 ...

  5. 新iPhone又要提价,苹果靠什么基业长青?

    在股神巴菲特一番煽情言论之后,苹果股价再创新高,达到187.67美元,总市值约为9450亿美元,正大踏步向着1万亿美元市值的目标前进,这是一条科技.经济.财经.社会等领域的头条新闻,遭到全球各界人士的 ...

  6. 数位dp——BZOJ1026 Windy数

    1026: [SCOI2009]windy数 Time Limit: 1 Sec  Memory Limit: 162 MB Description windy定义了一种windy数.不含前导零且相邻 ...

  7. python易错知识集合

    本篇用于记录在写leetcode时遇到的python易错知识. 2019.8.29 1.Python range() 函数用法: range(start, stop[, step]) start: 计 ...

  8. Nuxt.js 踩坑笔记 - 缓存向

    零.前言 最近参与了一个立足 seo 的移动端项目,公司前端工程主栈 vue,所以理所当然的用上了 nuxt,UI 主要选择了 Vant.   一.公共列表页的缓存 公共列表页由于数据量较大,故需要滚 ...

  9. 写个匹配某段html dom代码某属性的正则匹配方法

    private static string GetHtmlDomAttr(string html, string id, string attrname) { string xmatchstring ...

  10. LG_2869_[USACO07DEC]美食的食草动物Gourmet Grazers

    题目描述 Like so many others, the cows have developed very haughty tastes and will no longer graze on ju ...