2016-05-27 09:25:01 31332 [Note] Plugin 'FEDERATED' is disabled.
2016-05-27 09:25:01 31332 [Note] InnoDB: Using atomics to ref count buffer pool pages
2016-05-27 09:25:01 31332 [Note] InnoDB: The InnoDB memory heap is disabled
2016-05-27 09:25:01 31332 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2016-05-27 09:25:01 31332 [Note] InnoDB: Memory barrier is not used
2016-05-27 09:25:01 31332 [Note] InnoDB: Compressed tables use zlib 1.2.3
2016-05-27 09:25:01 31332 [Note] InnoDB: Using Linux native AIO
2016-05-27 09:25:01 31332 [Note] InnoDB: Using CPU crc32 instructions
2016-05-27 09:25:01 31332 [Note] InnoDB: Initializing buffer pool, size = 128.0M
InnoDB: mmap(137363456 bytes) failed; errno 12
2016-05-27 09:25:01 31332 [ERROR] InnoDB: Cannot allocate memory for the buffer pool
2016-05-27 09:25:01 31332 [ERROR] Plugin 'InnoDB' init function returned error.
2016-05-27 09:25:01 31332 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2016-05-27 09:25:01 31332 [ERROR] Unknown/unsupported storage engine: InnoDB
2016-05-27 09:25:01 31332 [ERROR] Aborting 2016-05-27 09:25:01 31332 [Note] Binlog end
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'partition'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'BLACKHOLE'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_SYS_DATAFILES'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_SYS_TABLESPACES'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN_COLS'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_SYS_FIELDS'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_SYS_COLUMNS'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_SYS_INDEXES'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_SYS_TABLESTATS'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_SYS_TABLES'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_FT_INDEX_TABLE'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_FT_INDEX_CACHE'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_FT_CONFIG'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_FT_BEING_DELETED'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_FT_DELETED'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_FT_DEFAULT_STOPWORD'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_METRICS'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_BUFFER_POOL_STATS'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE_LRU'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX_RESET'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_CMPMEM_RESET'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_CMPMEM'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_CMP_RESET'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_CMP'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_LOCK_WAITS'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_LOCKS'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'INNODB_TRX'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'ARCHIVE'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'MyISAM'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'CSV'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'MRG_MYISAM'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'MEMORY'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'sha256_password'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'mysql_old_password'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'mysql_native_password'
2016-05-27 09:25:01 31332 [Note] Shutting down plugin 'binlog'
2016-05-27 09:25:01 31332 [Note] /alidata/server/mysql/bin/mysqld: Shutdown complete 160527 09:25:01 mysqld_safe mysqld from pid file /alidata/server/mysql/data/iZ23d3p8chpZ.pid ended

操作步骤

vi /etc/my.cnf
添加
[mysqld]
federated
重启--失败
Starting MySQL.The server quit without updating PID
日志信息:Cannot allocate memory for the buffer pool(无法给buffer池分配内存)

再配置

vi /etc/my.cnf
去除
federated

添加
innodb_buffer_pool_size=100M
重启成功

MySql启动,提示:Plugin 'FEDERATED' is disabled....Cannot allocate memory for the buffer pool的更多相关文章

  1. mysql启动报错cannot allocate memory for the buffer pool处理

    今天启动mysql服务器时失败了.去/var/log/mysql/查看error.log,报错信息如下: 160123 22:29:26 InnoDB: Initializing buffer poo ...

  2. mysql报错mmap(137428992 bytes) failed; errno 12,Cannot allocate memory for the buffer pool

    mysql以`systemctl start mysqld.service`的方式启动一段时间后发现突然无法启动,尝试重新启动也不能解决问题,排查问题时,先后通过`systemctl status m ...

  3. Mysql错误处理: /usr/bin/mysqld_safe: line xxx: xxxx Killed ... (mysql自动停止 Plugin FEDERATED is disabled 的完美解决方法)

    哈哈哈,问题总算解决,内心抑不住的开心 centos mysql 问题:Plugin 'FEDERATED' is disabled. /usr/sbin/mysqld: Table 'mysql.p ...

  4. MYSQL启动报1067错误,系统日志中是“服务 mysql 意外停止” Mysql日志中则是:“Plugin \'FEDERATED\' is disabled”

    MYSQL启动报1067错误,系统日志中是"服务 mysql 意外停止" Mysql日志中则是:"Plugin \'FEDERATED\' is disabled&quo ...

  5. Plugin 'FEDERATED' is disabled 或 1067错误 启动错误与“服务 mysql 意外停止”解决方法

    MYSQL启动报1067错误,系统日志中是“服务 mysql 意外停止” Mysql日志中则是:“Plugin 'FEDERATED' is disabled” 网我在网上找到解决方案:1.在MY.I ...

  6. mysql 错误解决:Plugin 'FEDERATED' is disabled. /usr/sbin/mysqld: Table 'mysql.plugin' doesn't exist

    今天安装完Mysql后,开启发生了错误: 1.打开相应文件夹,查看错误信息: 2.打开错误信息文件,查看错误原因是:Plugin 'FEDERATED' is disabled. /usr/sbin/ ...

  7. Plugin 'FEDERATED' is disabled. /usr/sbin/mysqld: Table 'mysql.plugin' doesn't exist

    问题:在linux上安装mysql的时候出现Plugin ‘FEDERATED’ is disabled. /usr/sbin/mysqld: Table ‘mysql.plugin’ doesn’t ...

  8. Mysql net start mysql启动,提示发生系统错误 5 拒绝访问,原因所在以及解决办法

    1,Mysql net start mysql启动,提示发生系统错误 5 拒绝访问 在dos下运行net  start MySQL 不能启动mysql!提示发生系统错误 5:拒绝访问!切换到管理员模式 ...

  9. MySQL:cannot allocate the memory for the buffer pool

    InnoDB: The InnoDB memory heap is disabled InnoDB: Mutexes and rw_locks use GCC atomic builtins Inno ...

随机推荐

  1. google你懂得

    地址 https://github.com/racaljk/hosts

  2. xcode 第三方插件遇到问题

    xcode 第三方安装的路径 ~/Library/Application Support/Developer/Shared/Xcode/Plug-ins 

  3. 用Unity代码通过Xml配置生成GameObject之——前两天掉的坑

    1. Resources.Load(path),path不是绝对路径,而是相对"Resources/"的相对路径!如: 要想Instantiate则代码应该如下: string m ...

  4. iOS 源代码管理工具之SVN

    源代码管理工具之SVN 源代码管理工具SVN是一款非常强大的源代码管理工具,现在国内70%-90%的公司都在使用SVN来管理源代码,下面就让小编给大家着重介绍一下SVN的使用,SVN的使用主要分为下面 ...

  5. 分布式blog系统 TFS总结

    解决的问题 文件总量太大  一台服务器无法存放 只能放在网络集群中分节点存放   也就是通过屏蔽网络部分 形成一个“ one big CPU” 和 “one big disk” .Client只需要向 ...

  6. javascript onblur事件阻塞选中input框

    先上问题实例: <!DOCTYPE html> <html> <head> <meta charset="utf-8"> <t ...

  7. 关于MySQL数据导出导入

    工具 mysqlmysqldump 应用举例 导出 导出全库备份到本地的目录 mysqldump -u$USER -p$PASSWD -h127.0.0.1 -P3306 --routines --d ...

  8. Tomcat的ISO-8859-1

    Tomcat的默认编码时ISO8859-1,有些老工程,遗留项目很可能没改这块,这样写代码时如果传输中文,服务器收到的就可能是乱码. 昨天就被郁闷了1小时,左右都不通. 后来发现Android里的字符 ...

  9. java.nio.ByteBuffer中flip,rewind,clear方法的区别

    对缓冲区的读写操作首先要知道缓冲区的下限.上限和当前位置.下面这些变量的值对Buffer类中的某些操作有着至关重要的作用: limit:所有对Buffer读写操作都会以limit变量的值作为上限. p ...

  10. Android深度探索HAL和驱动开发(卷1) 第一章 Android系统移植和驱动开发

    由于Android是基于Linux内核的,因此,Android和其他Linux系统的核心部分差异非常小.然而不同版本的Android使用的Linux内核的版本有细微的差异,所以不同Android驱动可 ...