weblogic安装错误BEA-090870解决方案
00、问题描述
<Sep 3, 2017 3:29:09 PM CST> <Error> <Security> <BEA-090870> <The realm "myrealm" failed to b
e loaded: weblogic.security.service.SecurityServiceException: java.lang.ExceptionInInitializerError.weblogic.security.service.SecurityServiceException: java.lang.ExceptionInInitializerError
at weblogic.security.service.CSSWLSDelegateImpl.initializeServiceEngine(CSSWLSDelegat
eImpl.java:341) at weblogic.security.service.CSSWLSDelegateImpl.initialize(CSSWLSDelegateImpl.java:22
0) at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.InitializeServi
ceEngine(CommonSecurityServiceManagerDelegateImpl.java:1785) at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initializeRealm
(CommonSecurityServiceManagerDelegateImpl.java:442) at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.loadRealm(Commo
nSecurityServiceManagerDelegateImpl.java:840) Truncated. see log file for complete stacktrace
Caused By: java.lang.ExceptionInInitializerError
at com.octetstring.vde.util.guid.GuidGenerator.nextGuidInBytes(GuidGenerator.java:125
) at com.octetstring.vde.util.guid.Guid.<init>(Guid.java:84)
at com.octetstring.vde.backend.standard.BackendStandard.add(BackendStandard.java:378)
at com.octetstring.vde.backend.BackendHandler.add(BackendHandler.java:460)
at com.octetstring.vde.util.LDIF.importLDIF(LDIF.java:279)
Truncated. see log file for complete stacktrace
Caused By: java.lang.NullPointerException
at java.lang.System.arraycopy(Native Method)
at com.octetstring.vde.util.guid.GuidParamGenerator.generateNodeID(GuidParamGenerator
.java:47) at com.octetstring.vde.util.guid.GuidStateManager.initializeGUIDParameters(GuidStateM
anager.java:59) at com.octetstring.vde.util.guid.GuidStateManager.<init>(GuidStateManager.java:30)
at com.octetstring.vde.util.guid.GuidStateManager.<clinit>(GuidStateManager.java:23)
Truncated. see log file for complete stacktrace
>
<Sep 3, 2017 3:29:09 PM CST> <Notice> <Security> <BEA-090082> <Security initializing using se
curity realm myrealm.> <Sep 3, 2017 3:29:09 PM CST> <Critical> <WebLogicServer> <BEA-000362> <Server failed. Reason: There are 1 nested errors: weblogic.security.service.SecurityServiceRuntimeException: [Security:090399]Security Services
Unavailable at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.doBootAuthoriza
tion(CommonSecurityServiceManagerDelegateImpl.java:916) at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(Comm
onSecurityServiceManagerDelegateImpl.java:1050) at weblogic.security.service.SecurityServiceManager.initialize(SecurityServiceManager
.java:873) at weblogic.security.SecurityService.start(SecurityService.java:141)
at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:178) >
<Sep 3, 2017 3:29:10 PM CST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to
FAILED> <Sep 3, 2017 3:29:10 PM CST> <Error> <WebLogicServer> <BEA-000383> <A critical service failed
. The server will shut itself down> <Sep 3, 2017 3:29:10 PM CST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to
FORCE_SHUTTING_DOWN>
01、解决方案
hosts没有配置主机名于ip映射
vim /etc/hosts
172.24.0.24 mvp #例子
weblogic安装错误BEA-090870解决方案的更多相关文章
- weblogic安装错误记录
问题1:/opt/oraInventory路径无效(无法读取/写入/执行) 查看目录权限,发现此目录属于dba,如果用这个目录的话,可能会覆盖掉Oracle数据库相关的东西 再参照weblogic静默 ...
- R 之 rJava 包安装错误的解决方案
前几天在Ubuntu上安装R中的xlsx包时一直卡在了rJava包的安装上,最终各种google都没能解决问题.直到最后,我回到了安装rJava时的错误记录....我用血的教训证明,错误日志是很重要很 ...
- weblogic安装注意事项_linux
➠更多技术干货请戳:听云博客 一.安装过程:参考“weblogic安装截屏(linux)” 注意事项:安装weblogic时,需要注意以下两点: 1.首先在安装目录下创建weblogic12文件夹 如 ...
- weblogic系列漏洞整理 -- 1. weblogic安装
目录 0. 概述 1. 下载安装Java环境 2. 下载安装weblogic 安装 部署domain域 进入weblogic 3. 排错 如果出现如下错误 0. 概述 WebLogic是美国Oracl ...
- weblogic安装使用: Could not Create the Java Virtual Machine
第一次使用weblogic,完全不明白是怎么一回事!找安装包花了大把时间!找到了不知道怎么安装 -- _ --||| 找了一篇安装文档<weblogic 安装部署手册.doc>, 位于:[ ...
- Weblogic安装配置教程
一.WebLogic的介绍 WebLogic是美国bea公司出品的一个application server,确切的说是一个基于Javaee架构的中间件,纯java开发的,最新版本WebLogic ...
- weblogic 安装及配置
修改AdminServer为不需要输入密码的方式开启 : 安装使用的是production模式,不是开发模式,如果要后台启动Weblogic, 需要在如下DOMAIN_HOME/servers/Adm ...
- ElasticSearch 集群环境搭建,安装ElasticSearch-head插件,安装错误解决
ElasticSearch-5.3.1集群环境搭建,安装ElasticSearch-head插件,安装错误解决 说起来甚是惭愧,博主在写这篇文章的时候,还没有系统性的学习一下ES,只知道可以拿来做全文 ...
- Oracle安装错误“程序异常终止
Oracle安装错误"程序异常终止.发生内部错误.请将以下文件提供给oracle技术支持部 "程序异常终止.发生内部错误.请将以下文件提供给oracle技术支持部门:" ...
随机推荐
- Domino(群组工作软件)
ylbtech-Miscellaneos: Domino(群组工作软件) “Domino”是一种群组工作软件.使用了Domino的服务器就叫Domino服务器Domino的功能强大,界面丰富,主要用于 ...
- knockout 多值绑定
knockout 这种东西现在已经很流行了,相信很多人对它的使用都已经很熟悉了,最近项目开发中发现knockout 绑定用的有些不怎么充分,发现整个page的code 有点累赘. 1.在绑定click ...
- AS 注解处理器 APT Processor MD
Markdown版本笔记 我的GitHub首页 我的博客 我的微信 我的邮箱 MyAndroidBlogs baiqiantao baiqiantao bqt20094 baiqiantao@sina ...
- 【Kafka】Kafka-配置参数详解-参数调优
Kafka-配置参数详解-参数调优 kafka 目录_百度搜索 为什么kafka使用磁盘而不是内存 - CSDN博客 Kafka 配置说明 - 風吹云动 - 博客园 kafka生产服务器配置 - Or ...
- mahout0.7 示例运行纪实
http://1992mrwang.blog.51cto.com/3265935/1205282 运行太不容易了 所以要记下来以免后面忘记了 首先是数据 vim testdata.txt 第一列为Us ...
- telnet 163发送邮件
1.telnet smtp.163.com 25 2. 3.测试成功
- 论文阅读:Memory Networks
一.论文所解决的问题 实现长期记忆(大量的记忆),而且实现怎样从长期记忆中读取和写入,此外还增加了推理功能 为什么长期记忆非常重要:由于传统的RNN连复制任务都不行,LSTM预计也够玄乎. 在QA问题 ...
- 从网易云音乐网页版无登陆下载MP3的办法
用chrome浏览器就能办到 现在,你还为下载不到满意的音乐而苦恼吗?
- vi入门到精通
VI是在Linux命令行下常用的文本编辑工具,在服务配置管理过程中经常用到:vi的常见的使用指南,互联网上随处可见,但仅能满足初学者对文档编辑的需求.这里就我自己在使用过程中通常用到的一些技巧操作方法 ...
- jQuery Jcrop 图像裁剪
jQuery Jcrop 图像裁剪 http://code.ciaoca.com/jquery/jcrop/ cropper.js 实现HTML5 裁剪图片并上传(裁剪上传头像.) https://b ...