centos 6.7 (UDEV,、etc/hosts)安装 RAC 11.2.0.4 报错处理
环境说明:
db 11.2.0.4 os: centos 6.7 UDEV管理ASM 没有配置DNS服务器,采用/etc/hosts
报错:
1. CVU(Cluster Verification Utility)检查 CRS 的安装前环境。 (正常没有配置DNS服务器,采用/etc/hosts报错,可以忽略)
node1-> ./runcluvfy.sh stage -pre crsinst -n node1,node2 -fixup -verbose
hecking DNS response time for an unreachable node
Node Name Status
------------------------------------ ------------------------
node2 failed
node1 failed
PRVF-5636 : The DNS response time for an unreachable node exceeded "15000" ms on following nodes: node2,node1
2. shmmax大小设置不合理,调整合适大小。

相关理论:
SHMMAX参数:Linux进程可以分配的单独共享内存段的最大值。一般设置为内存总大小的一半。这个值的设置应该大于SGA_MAX_TARGET或MEMORY_MAX_TARGET的值,因此对于安装Oracle数据库的系统,shmmax的值应该比内存的二分之一大一些。
# grep MemTotal /proc/meminfo
# cat /proc/sys/kernel/shmmax
上面的命令是检查系统内存的大小,以及当前shmmax的设置。
# echo 21474836480 > /proc/sys/kernetbl/shmmax
# sysctl -w kernel.shmmax=21474836480
# echo "kernel.shmmax=21474836480" >> /etc/sysctl.conf
这是设置shmmax参数的几种方法,这三种方式都可以将shmmax设置为20G。这个参数的修改可以不重启数据库。个人推荐使用第二种sysctl命令的方式。采用第三种方式需要执行sysctl –t操作或重启,但是为了确保下次重启后设置值仍然生效,第三种方式是必不可少的。前两种方式类似alter system set scope = memory,而第三种方式则类似alter system set scope = spfile。
解决办法:
[root@node1 ~]# sysctl -w kernel.shmmax=1610612736
kernel.shmmax = 1610612736
[root@node1 ~]# echo ''kernel.shmmax=1610612736'' >> /etc/sysctl.conf
[root@node1 ~]#sysctl -p
3. 采用UDEV管理ASM正常报错,没有配置DNS服务器,采用/etc/hosts报错,可以忽略

4. 非正常报错,原因是包有问题。
当安装oracle 11204的rac的时候,安装集群软件到执行root.sh的时候,执行root.sh报错:
Failed to create keys in the OLR, rc = 127, Message:
/app/grid/product/11.2.0/bin/clscfg.bin: error while loading shared libraries: libcap.so.1: cannot open shared object file: No such file or directory
Failed to create keys in the OLR at /app/grid/product/11.2.0/crs/install/crsconfig_lib.pm line 7660.
/app/grid/product/11.2.0/perl/bin/perl -I/app/grid/product/11.2.0/perl/lib -I/app/grid/product/11.2.0/crs/install /app/grid/product/11.2.0/crs/install/rootcrs.pl execution failed
解决方法:所有节点都执行
[root@node1 yum.repos.d]# cd /lib64
[root@node1 lib64]# ln -s libcap.so.2.16 libcap.so.1
5. 非正常报错,原因不明。 (有待研究)
node1-> ./runcluvfy.sh stage -post crsinst -n node1,node2 -verbose
ERROR:
PRVG-1101 : SCAN name "scan-cluster.localdomain" failed to resolve
SCAN Name IP Address Status Comment
------------ ------------------------ ------------------------ ----------
scan-cluster.localdomain 10.100.25.100 failed NIS Entry
ERROR:
PRVF-4657 : Name resolution setup check for "scan-cluster.localdomain" (IP address: 10.100.25.100) failed
ERROR:
PRVF-4664 : Found inconsistent name resolution entries for SCAN name "scan-cluster.localdomain"
Verification of SCAN VIP and Listener setup failed
搜了一下发现老杨(yangtingkun)的文章中也提到了这个错误:
F:RHEL5.532oracle_patchyangtingkun 安装Oracle11_2 RAC for Solaris10 sparc64(二).mht
老杨在文章的最后提到:
导致这个错误的原因是在/etc/hosts中配置了SCAN的地址,尝试ping这个地址信息,如果可以成功,,则这个错误可以忽略。
我尝试ping scan ip可以ping通,所以暂时也就忽略了这个错误。
6. 没有配置DNS服务器,采用/etc/hosts报错,可以忽略

补充:
GI安装时候报错
1、缺少 pdksh-5.2.14-1.i386.rpm
解决:
在RHEL 6.4上安装Oracle 11g 数据库,在安装过程中检测包的依赖关系,发现缺少pdksh-5.2.14-1.i386.rpm这个包,在安装pdksh-5.2.14-1.i386.rpm包的过程中,发现此包和ksh包冲突,卸载ksh包,再安装完pdksh-5.2.14-1.i386.rpm包后,安装正常进行。或者系统存在 ksh 包,忽略这个报错。
2、缺少 cvuqdisk-1.0.9-1.rpm
解决:
在解压的grid/rpm目录下找到 cvuqdisk-1.0.9-1.rpm 。 用 root 安装即可。
centos 6.7 (UDEV,、etc/hosts)安装 RAC 11.2.0.4 报错处理的更多相关文章
- Oracle 安装 RAC 11.2.0.4 centos7.4 -udev磁盘绑定/执行root脚本报错
在centos 7.4上安装oracle rac 11.2.0.4 报错及相关解决 $ cat /etc/redhat-release CentOS Linux release 7.4.1708 (C ...
- linux7 安装rac 执行root脚本时候报错
运行root.sh脚本的时候报错 报错信息: [root@rac1 ~]# /u01/app/oraInventory/orainstRoot.sh Changing permissions of / ...
- 基于CentOS与VmwareStation10搭建Oracle11G RAC 64集群环境:4.安装Oracle RAC FAQ-4.1.系统界面报错Gnome
1.错误信息:登录系统后,屏幕弹出几个错误对话框,无菜单.无按钮 GConf error: Failed to contact configuration server; some possible ...
- Vmware Workstation实现CentOS6.10_x64 下ORACLE RAC 11.2.0.4的搭建
想必大家在学习ORACLE 11g时,都想搭建一个RAC的实验环境.在搭建RAC实验环境时,会碰到诸如IP怎么规划.虚拟机环境下怎么共享磁盘.ASM磁盘创建,以及安装过程中会遇到这样那样的问题.搭建一 ...
- centos6.5 x86_64安装oracle 11.2.0.3grid
centos6.5 x86_64安装oracle 11.2.0.3grid 1.安装前的准备 工作 1.1.配置node1 1.1.1.配置虚拟机并安装centos 安装node1----- 1 ...
- 安装grid之前检查配置 ,报错如下
centos 5 _x86_64 oracle 11.2 安装grid之前检查配置 ,报错如下 : ./runcluvfy.sh stage -pre crsinst -n rac1,rac2 -fi ...
- 安装php时,make步骤报错make: *** [ext/gd/gd.lo] Error 1
安装PHP时,make步骤报错make: *** [ext/gd/gd.lo] Error 1 /usr/local/src/LAMP+memcahed+catci/php-5.4.0/ext/gd/ ...
- AIX 7.1 RAC 11.2.0.4.0升级至11.2.0.4.6(一个patch跑了3个小时)
1.环境 DB:两节点RAC 11.2.0.4.0升级至11.2.0.4.6 OS:AIX 7.1(205G内存 16C) 2.节点1.节点2(未建库) 2.1.patch 20420937居然用了3 ...
- Asianux 7.3安装Oracle 11.2.0.4单实例体验
环境:Asianux 7.3 需求:安装Oracle 11.2.0.4 单实例 背景:系统使用默认的最小安装部署,Oracle安装额外需要的包统一使用yum安装. 查看当前系统相关信息: [root@ ...
随机推荐
- Nginx结合GeoIP库
1. 编译nginx时带上geoip模块 # wget http://nginx.org/download/nginx-x.x.x.tar.gz # tar zxvf nginx-x.x.x.tar. ...
- Netty 源码(ChannelHandler 死磕)
精进篇:netty源码死磕5 - 揭开 ChannelHandler 的神秘面纱 目录 1. 前言 2. Handler在经典Reactor中的角色 3. Handler在Netty中的坐标位置 4 ...
- HTML/CSS/JS初始化
CSS <link type="text/css" href="http://www.mazey.cn/css/mazey-base.css" rel=& ...
- python+NLTK 自然语言学习处理五:词典资源
前面介绍了很多NLTK中携带的词典资源,这些词典资源对于我们处理文本是有大的作用的,比如实现这样一个功能,寻找由egivronl几个字母组成的单词.且组成的单词每个字母的次数不得超过egivronl中 ...
- Spring 拦截器——HandlerInterceptor
采用Spring拦截器的方式进行业务处理.HandlerInterceptor拦截器常见的用途有: 1.日志记录:记录请求信息的日志,以便进行信息监控.信息统计.计算PV(Page View)等. 2 ...
- date_default_timezone_get():
[Symfony\Component\Debug\Exception\ContextErrorException] Warning: date_default ...
- R语言图形base系统(三)
本篇介绍R语言base系统绘制散点图.条形图.直方图.箱线图.饼图,还将简单介绍点图.核密度图.折线图. 散点图: attach(mtcars) plot(wt, mpg, main="B ...
- vim vimdiff diff 使用及命令
vim: vim 从 vim7 开始加入了多标签切换的功能, 相当于多窗口. 之前的版本虽然也有多文件编辑功能, 但是总之不如这个方便啦.用法::tabnew [++opt选项] [+cmd] 文件 ...
- myBatis中使用Map进行遍历
myBatis中使用Map获取key, value的方式 第一次的配置 <trim prefix=" tags =case" suffix="end"&g ...
- 微信小程序高度设置为100%
在网页中设置body,html{height:100%}; 将body和html设置为100%,这样我们就可以在他们的子元素中使用height:100%来使的我们的容器元素占满屏幕的高度啦. 但是在微 ...