转:解决Arcsde用户锁定的问题
采用arcgis平台做GIS应用的人,可能偶尔碰到sde用户锁定(Arccatalog 或应用程序异常退出的时比较多)的问题,往往咱们解决的办法是重启sde服务。如果一个服务器上有多个连接时,重启服务会影响别人。下面小罗介绍另外二种办法:
方法一:
1, 用sde用户身份登录到Oracle(如:PLSQL developer之类的东东),找到sde用户下面的process_information 表;
2, 然后执行查询select t.sde_id,t.owner from process_information t , sde_id 是sde的进程ID, owner 是连接的oracle用户
3, 从owner中找到你要解除锁定的用户以及所对应的sde_id ;
4, 进入ArcSDE安装的服务器(如:192.9.100.185),进入cmd ,执行sdemon如下:(下面这些就是sdemon常用操作,感兴趣的同事可以自己去摸索,当然也可以直接执行第5步,第4步主要是防止出错)
C:/Documents and Settings/Administrator>sdemon
ESRI ArcSDE System Monitor Utility Thu Mar 05 16:15:26 2009
----------------------------------------------------------------------
sdemon -o status {[-i <service>] [-s <server_name>] | [-H <sde_direc [-q]
sdemon -o start {[-i <service>] [-s <server_name>] | [-H <sde_direc [-p <DB_Admin_password>]
sdemon -o shutdown {[-i <service>] [-s <server_name>] | [-H <sde_direc [-p <DB_Admin_password>] [-N]
sdemon -o pause {[-i <service>] [-s <server_name>] | [-H <sde_direc [-p <DB_Admin_password>]
sdemon -o resume {[-i <service>] [-s <server_name>] | [-H <sde_direc [-p <DB_Admin_password>]
sdemon -o info -I {users | config | stats | locks | vars | insta] {[-i <service>] [-s <server_name>] | [-H <sde_direc
sdemon -o kill -t {all | <pid>} [-p DB_Admin_password>] [-N] {[-i <service>] [-s <server_name>] | [-H <sde_direc
5, 然后执行 sdemon -o kill -t 5459 这里的5459 是上面从process_information表中查询出来的sde_id,然后要你输入sde的密码,完了之后确认ok,如下所示:
Please enter ArcSDE DBA password:
ArcSDE Instance esri_sde Process Management on testserver185 at Thu Ma:42 2009
-------------------------------------------------------Kill Server Task 5459? ARE YOU SURE (Y/N)?: y
6, 搞定收工;
方法二:直接在Arcsde空间服务器上面,运行
sdemon -o info -I users -i esri_sde (sde服务名),如下所示:
C:/>sdemon -o info -I users -i esri_sde
ArcSDE Instance esri_sde Registered Server Tasks on hzgt-dbcenter at Sun Dec 13
17:39:46 2009
-------------------------------------------------------------------------
S-ID User Host:OS Started
----- -------- -------------------------------- ------------------------
635 SJZX hzgt-appsrv:Win32 Sun Dec 13 17:36:24 2009
625 CJ_SGYX hzgt-appsrv:Win32:XDR Sun Dec 13 16:14:13 2009
626 SJZX hzgt-appsrv:Win32 Sun Dec 13 16:14:15 2009
633 SJZX hzgt-appsrv:Win32 Sun Dec 13 17:31:26 2009
636 SJZX hzgt-appsrv:Win32 Sun Dec 13 17:37:06 2009
622 CJ_SGYX hzgt-appsrv:Win32:XDR Sun Dec 13 13:45:50 2009
然后kill掉某个连接进程:
C:/>sdemon -o kill -t 622
Please enter ArcSDE DBA password:
ArcSDE Instance esri_sde Process Management on hzgt-dbcenter at Sun Dec 13 17:41
:55 2009
-------------------------------------------------------------------------
Kill Server Task 622? ARE YOU SURE (Y/N)?:y
原文:http://blog.csdn.net/luowangjun/article/details/4596849
转:解决Arcsde用户锁定的问题的更多相关文章
- 解决oracle用户锁定
故障现象: SQL> connect scott/scottERROR:ORA-01017: invalid username/password; logon deniedSQL> ...
- 解决Oracle用户被锁定的方法
解决Oracle用户被锁定的方法 1,cmd控制台: 使用sqlplus 命令:sqlplus sys/密码@ip/orcl as sysdba; 2,先设置具体时间格式,以便查看具体时间 SQL&g ...
- Oracle数据库用户锁定原因以及处理方式(ORA-28000)
现场在实施过程中,基于安全考虑(用户名和密码之前暴露给其他公司了),需要对用户密码进行修改. 修改过程很简单(alter user [username] identified by [password ...
- Oracle报错>记录被另外一个用户锁定
原因 当一个用户对数据进行修改时,若没有进行提交或者回滚,Oracle不允许其他用户修改该条数据,在这种情况下修改,就会出现:"记录被另外一个用户锁定"错误. 解决 查询用户.数据 ...
- 一旦ORA-28000: the account is locked用户锁定故障排除
今天我的同事们反映的问题,测试库的变化password,并改变相关的应用程序中使用password后,其中一个仍然会出现在帐户被锁定,报告ORA-28000: the account is locke ...
- oracle "记录被另一个用户锁定"
出现的原因是有人对某一条数据进行了修改,oracle会通过这个事务记住这条数据,若修改的人没有进行提交或进行回滚记录,oracle是不允许对这条数据在此进行修改的,在这种情况下你要进行修改数据,则会被 ...
- [加入用户]解决useradd 用户后没有加入用户Home文件夹的情况,Linux改变文件或文件夹的訪问权限命令,linux改动用户password,usermod的ysuum安装包。飞
usermod的yum安装包: shadow-utils 将nobody用户加入到nogroup 组: usermod -g nogroup nobody cat /etc/passwd|grep n ...
- Linux用户锁定、解锁及锁定查看
[root@l01 ~]# passwd -S pispread pispread PS -- - (Password set, SHA512 crypt.)用户锁定 [root@l01 ~]# pa ...
- Oracle 数据库用户锁定与解锁,用户锁定最大密码失败次数设置方法,ORA-28000: the account is locked问题解决方法
转至:https://blog.csdn.net/qq_38161040/article/details/108274161 用户多次密码输入错误达到一定值就会被锁定. -- 用户锁定方法 alter ...
随机推荐
- 使用Tensorflow object detection API——环境搭建与测试
[软件环境搭建] 操作系统:windows 10 64位 内存:8G CPU:I7-6700 Tensorflow: 1.4 Python:3.5 Anaconda3 (64-bit) 以上环境搭建请 ...
- 9.path Sum III(路径和 III)
Level: Easy 题目描述: You are given a binary tree in which each node contains an integer value. Find t ...
- kuangbin专题七 ZOJ1610 Count the Colors (灵活线段树)
Painting some colored segments on a line, some previously painted segments may be covered by some th ...
- 《Qt 学习之路 2》目录
<Qt 学习之路 2>目录 <Qt 学习之路 2>目录 豆子 2012年8月23日 Qt 学习之路 2 177条评论 <Qt 学习之路 2>目录 序 Qt ...
- DRF教程7-token认证
Authentication 认证是将一个传入的请求和一组标识凭据相关联的机制,比如请求过来的用户,或者用户登录时携带的token. 然后权限策略就能使用这些凭据来决定是否允许这个请求. REST框架 ...
- Ant junitreport with Maven
大家可能都知道在Ant里可以使用junit和junitreport两个task来完成对测试结果生成HTML格式的报告. Maven里的Surefire-report的插件只能对Java测试报告支持的比 ...
- Java 实现栈,队列
package base.structure; /** * @program: Algorithm4J * @description: 实现一个Stack * @author: Mr.Dai * @c ...
- 神奇的操作--O(1)快速乘
从同机房大佬那里听来的... 用O(1)时间求出两个相乘超过long long的数的取摸的结果 神奇的操作... inline long long multi(long long x,long lon ...
- SQL Server 清理日志
USE[master] GO ALTER DATABASE 要清理的数据库名称 SET RECOVERY SIMPLE WITH NO_WAIT GO ALTER DATABASE 要清理的数据库名称 ...
- 图像数据转换成db(leveldb/lmdb)文件(转)
参考网站:http://www.cnblogs.com/denny402/p/5082341.html 在深度学习的实际应用中,我们经常用到的原始数据是图片文件,如jpg,jpeg,png,tif等格 ...