1.修改 /etc/httpd/conf/httpd.conf

添加一个Listen,如:

Listen 80
Listen 8001
Listen 8002

2.添加一个VirtualHost

#vim /etc/httpd/conf.d/vhost.conf
NameVirtualHost *:8001
<VirtualHost *:8001>
DocumentRoot /var/www/html/public_html
ServerName localhost
ServerAdmin test@gmail.com
#ErrorLog "| /usr/sbin/rotatelogs /var/www/html/log/public_html_error_%Y_%m_%d.log 86400 480"
#CustomLog "| /usr/sbin/rotatelogs /var/www/html/log/public_html_access_%Y_%m_%d.log 86400 480" common
ErrorLog "/var/www/html/log/error.log"
CustomLog "/var/www/html/log/access.log" common
</VirtualHost> NameVirtualHost *:8002
<VirtualHost *:8002>
DocumentRoot /var/www/html/phpmyadmin
ServerName localhost
ServerAdmin test@gmail.com
#ErrorLog "| /usr/sbin/rotatelogs /var/www/html/log/public_html_error_%Y_%m_%d.log 86400 480"
#CustomLog "| /usr/sbin/rotatelogs /var/www/html/log/public_html_access_%Y_%m_%d.log 86400 480" common
ErrorLog "/var/www/html/log/error.log"
CustomLog "/var/www/html/log/access.log" common
</VirtualHost>

3.为新端口添加防火墙规则

iptables -I INPUT -p tcp --dport 8001 -j ACCEPT
/etc/rc.d/init.d/iptables save

4.禁用selinux(如果不禁用,会无法重新启动apache)

方法1.关闭selinux

vim /etc/selinux/config

首先将SELINUX=enforcing添加注释

#SELINUX=enforcing

然后在文件末尾添加如下代码

SELINUX=disabled

方法2.修改selinux规则
首先查看现在支持http的端口有哪些

semanage port -l | grep http

然后为http服务新的端口号

semanage port -a -t http_port_t -p tcp 8001

查看添加的结果

semanage port -l | grep http

5.重启httpd服务

service httpd restart

apache单ip配置多端口多站点的更多相关文章

  1. Apache Wamp WampServer 配置多端口 多站点 虚拟目录

    第一步:配置Apache 的 httpd.conf #Listen 0.0.0.0:80Listen 80Listen 81 第二步:开启虚拟站点 所属文件:httpd.conf #Virtual h ...

  2. Apache配置多端口多站点

    配置httpd.conf 监听多个端口 复制代码 代码如下:# Listen: Allows you to bind Apache to specific IP addresses and/or # ...

  3. apache单ip多域名多目录配置

    自己的vps上放了别人的网站,那怎么样让自己的网站和别人的网站能同时被访问呢?需要使用apache的虚拟主机配置. 配置httpd.conf文件 比如原来是这种只是指向一个目录的配置 Document ...

  4. linux服务器apache 一个IP,一个端口,建立多个网站的方法。

    找到apache-tomcat-6.0.14\conf\server.xml ,再services 后面添加此段代码: Xml代码 <!-- 此处  新增的项目配置-->  <Ser ...

  5. apache 单个ip配置多个发布目录多个域名

    1.找到apache 配置文件 httpd.conf 搜索   Include conf/extra/httpd-vhosts.conf  去掉前面的注释; 注释不注释都可以 DocumentRoot ...

  6. apache一个ip多个端口虚拟主机

    1.打开httpd.conf,查找Listen:80,在下面一行加入Listen:8080:2.查找#Include conf/extra/httpd-vhosts.conf,将此行前面的#去掉:3. ...

  7. Apache和IIS共享80端口的四个设置方法

    方法一:IIS5,多IP下共存,IIS为192.168.0.1,apache为192.168.0.2c:\Inetpub\Adminscriptscscript adsutil.vbs set w3s ...

  8. Apache 多端口多站点配置实例

    分享下Apache多端口多站点的配置方法,配置apache服务器的朋友参考下. 配置httpd.conf 监听多个端口 复制代码代码如下: # Listen: Allows you to bind A ...

  9. apache 2.2设置单IP多端口的虚拟主机

    系统配置为Centos 5.5 x85版,使用yum安装httpd 对于没有安装vim的,可以使用此命令安装:   yum -y install vim-enhanced 配置httpd.conf文件 ...

随机推荐

  1. python—datetime time 模板学习

    写在前面:本人在学习此内容是通过 https://www.cnblogs.com/pycode/p/date.html 文章学习! 时间模块——time python 中时间表示方法有:时间戳_:格式 ...

  2. python 层次索引交换级别以及排序问题

  3. AndroidAPI

    1词典 百度翻译 http://api.fanyi.baidu.com/api/trans/product/index 百度翻译支持多种语言互相翻译,包含PHP, JS, Python, C, Jav ...

  4. [转]JS 只能输入数字和两位小数的JS

    本文转自:http://blog.sina.com.cn/s/blog_724008890101dgep.html JS代码: <script language="JavaScript ...

  5. OpenStack Weekly Rank 2015.08.17

    Module Reviews Drafted Blueprints Completed Blueprints Filed Bugs Resolved Bugs Cinder 5 1 1 6 13 Sw ...

  6. (转)使用介质设备安装 AIX 以通过 HMC 安装分区

    使用介质设备安装 AIX 以通过 HMC 安装分区 原文:https://www.ibm.com/support/knowledgecenter/zh/ssw_aix_72/com.ibm.aix.h ...

  7. Python 多继承(新式类) 的mro算法

    转载自:http://www.cnblogs.com/panyinghua/p/3283831.html mro即method resolution order,主要用于在多继承时判断调的属性的路径( ...

  8. OPEN(SAP) UI5 学习入门系列之二: 最佳实践练习(下)

    上期我们完成了一个简单的主从页面,但是页面是静态的,不能交互,功能也很简单,只有一个销售订单的列表. 我们今天就一鼓作气把代码全都写完,由于本次的代码量较大,所以只对重点代码部分进行讲解. 具体每个文 ...

  9. 权限修饰符(public、protected、default、private)权限验证

    一.测试方法 在authorityTest包中建类AuthorityValidate package authorityTest; public class AuthorityValidate { p ...

  10. HihoCoder#1509 : 异或排序(二进制)

    题意 题目链接 Sol 挺简单的吧.考虑两个元素什么时候不满足条件 设\(a_i\)与\(a_i + 1\)最高的不同位分别为0 1,显然\(S\)的这一位必须为\(0\),否则这一位必须为\(1\) ...