前提:

Linux centOS虚拟机64位

1、首先确认是否已安装过MySQL

方法一:删除原有的MySQL目录:

  使用查找语句:

    whereis mysql

    find / -name mysql

  删除文件:

    rm -rf mysql文件名

方法二:卸载MySQL

  查找MySQL安装包:

    rpm -qa|grep -i mysql

结果:可以看到mysql的两个包mysql-4.1.12-3.RHEL4.1、mysqlclient10-3.23.58-4.RHEL4.1

然后删除:

    rpm -e --nodeps 包名

2、删除老版本mysql的开发头文件和库

  检查各个mysql文件夹是否删除干净

    find / -name mysql

  结果如下:

  /var/lib/mysql

  /usr/local/mysql

  /usr/lib/mysql

  /usr/include/mysql

  命令:

    rm -rf /usr/lib/mysql

    rm -rf /usr/include/mysql

3、删除干净MySQL后在线安装MySQL

  在线安装语句:

    yum install mysql mysql-server mysql-devel -y

  

  yum install -y mysql-server mysql mysql-deve

4、查看MySQL版本以确认是否安装成功

  查看mysql版本:

    rpm -qi mysql-server

5、启动MySQL

    service mysqld start

6、如何修改MySQL的ROOT账号的密码?

  修改ROOT账号密码语句: 

    mysqladmin -u root password 'root' 

    UPDATE user SET Password=PASSWORD('11111111') where USER='root';

  Mysql新版本使用该语句:

    UPDATE user SET authentication_string=PASSWORD('11111111') where USER='root';

  出现报错无法使用该密码正常登录:

  解决方法:

    1.停止mysql数据库

    /etc/init.d/mysqld stop

    2.执行如下命令

    mysqld_safe --user=mysql --skip-grant-tables --skip-networking &

    3.使用root登录mysql数据库

    mysql -u root mysql

    4.更新root密码

    mysql> UPDATE user SET Password=PASSWORD('newpassword') where USER='root';

    最新版MySQL请采用如下SQL:

    mysql> UPDATE user SET authentication_string=PASSWORD('newpassword') where USER='root';

    5.刷新权限

    mysql> FLUSH PRIVILEGES;

    6.退出mysql

    mysql> quit

    7.重启mysql

    /etc/init.d/mysqld restart

    8.使用root用户重新登录mysql

    mysql -uroot -p

    Enter password: <输入新设的密码newpassword>

7、如何设置开启启动?

    chkconfig mysqld on

    查看linux现在在监听的mysql端口

    netstat -anp| grep mysql

    默认3306

8、如何在/etc/my.cnf设置端口号?

  1、查看默认使用的端口号

  登录mysql

    mysql -u root -p

  使用命令show global variables like 'port';查看端口号

  2、修改端口,编辑/etc/my.cnf文件,早期版本有可能是my.conf文件名,增加端口参数,并且设定端口,注意该端口未被使用,保存退出。

增加port=3307这一行。

  3、 重新启动mysql

     /etc/init.d/mysqld restart

  重启失败

  查看一下log

  cat /var/log/mysqld.log

  log报错是防火墙问题导致启动失败。

  解决如下:

    1.  防火墙问题

    vi /etc/sysconfig/iptables

  添加如下行:

    -A INPUT -m state --state NEW -m tcp -p tcp --dport 8060 -j ACCEPT

  2. SELinux问题

  方法一: 不需要重启Linux:

  [root@dytl05 ~]# setenforce 0

9、ERROR 1130: Host 192.168.3.100 is not allowed to connect to this MySQL server错误如何解决?

  客户端链接mysql报错1130

1、查看是否能ping通服务端所在服务器IP

不能ping通的话,可以思考一下是不是服务器所在的主机防火墙是不是没关。

2、查看服务端是否已设置可以从任意主机连到mysql服务器。

登录mysql -u root -p

use mysql;

select Host, User from user;

update user set Host = '%' where User = 'root';

出现报错不要理会

select Host, User from user;

localhost变成了%就成功了

这时输入quit退出mysql.

然后重新启动MySQL。再用Navicat进行连接就可以连接上了

10、MySQL的基本命令

启动mysql: /etc/init.d/mysql start 
重启mysql: /etc/init.d/mysql restart 
停止mysql: /etc/init.d/mysql stop

mysql的配置文件是/etc/my.cnf。

本文为个人总结得出参考如下资料,图片均为本人个人所有,转载请告知。

参考资料:

http://www.cnblogs.com/zhangkaimin/p/4171269.html

http://www.cnblogs.com/james-roger/p/6943616.html

http://blog.csdn.net/wobin/article/details/10266165.html

http://www.linuxidc.com/Linux/2013-09/90110.html

http://www.cnblogs.com/bravehunter/p/5653317.html

https://jingyan.baidu.com/article/2c8c281dbf19a10008252a11.html

http://blog.csdn.net/brad_chen/article/details/50038793

http://blog.chinaunix.net/uid-20450406-id-1676510.html

http://blog.csdn.net/zsf8701/article/details/7718904

http://www.cnblogs.com/kerrycode/p/4364465.html

http://www.cnblogs.com/david-zhang-index/archive/2012/03/01/2375500.html

http://7424593.blog.51cto.com/7414593/1752592/

http://www.cnblogs.com/fnlingnzb-learner/p/5830622.html

http://www.cnblogs.com/coder-zhang/p/3828378.html

  

    

在Linux上进行mySql安装部署及遇到的问题的解决方法的更多相关文章

  1. Linux环境下MySQL报Table 'xxx' doesn't exist错误解决方法

    修改了lower_case_table_names=1 后,业务发有个库的表打不开了,看了表名以前是大写,查了一下如果设置不区分大小写, 以前的大小表名要改成小写.重启服务后可用! MYSQL在LIN ...

  2. 【Oracle 集群】11G RAC 知识图文详细教程之RAC在LINUX上使用NFS安装前准备(六)

    RAC在LINUX上使用NFS安装前准备(六) 概述:写下本文档的初衷和动力,来源于上篇的<oracle基本操作手册>.oracle基本操作手册是作者研一假期对oracle基础知识学习的汇 ...

  3. 大数据学习——Linux上常用软件安装

    4.1 Linux系统软件安装方式 Linux上的软件安装有以下几种常见方式: 1.二进制发布包 软件已经针对具体平台编译打包发布,只要解压,修改配置即可 2.RPM发布包 软件已经按照redhat的 ...

  4. 【转】【Oracle 集群】11G RAC 知识图文详细教程之RAC在LINUX上使用NFS安装前准备(六)

    原文地址:http://www.cnblogs.com/baiboy/p/orc6.html 阅读目录 目录 介绍 下载软件 操作系统安装 Oracle安装先决条件 创建共享磁盘 参考文献 相关文章 ...

  5. 【数据库开发】在Windows上和Linux上配置MySQL的过程

    [数据库开发]在Windows上和Linux上配置MySQL的过程 标签(空格分隔): [编程开发] 首先是在Windows上尝试用QT进行MySQL数据库开发,结果总出现driver不能load的错 ...

  6. 2-MySQL DBA笔记-MySQL安装部署和入门

    第2章 MySQL安装部署和入门 第1章介绍了MySQL的一些基础知识,本章将为读者介绍MySQL的部署.安装及一些常用命令和参数的设置.2.1 如何选择MySQL版本 在选择MySQL的版本时,要根 ...

  7. Windows 和 Linux 上Redis的安装守护进程配置

    # Windows 和 Linux 上Redis的安装守护进程配置 Redis 简介 ​ Redis是目前最常用的非关系型数据库(NOSql)之一,常以Key-Value的形式存储.Redis读写速度 ...

  8. Linux上的软件安装有哪些方式?

    Linux上的软件安装有以下几种常见方式介绍 1.二进制发布包 软件已经针对具体平台编译打包发布,只要解压,修改配置即可 2.RPM包 软件已经按照redhat的包管理工具规范RPM进行打包发布,需要 ...

  9. Ubuntu14.04 Django Mysql安装部署全过程

    Ubuntu14.04 Django Mysql安装部署全过程   一.简要步骤.(阿里云Ubuntu14.04) Python安装 Django Mysql的安装与配置 记录一下我的部署过程,也方便 ...

随机推荐

  1. PowerShell实现英汉互译_并保存

    代码如下:(介于着色 代码在文末下载) 功能简介: 自动识别英汉输入 返回结果 对于词数小于20的会保存在当前目录下temp_table.txt词文件 大于20的会被识别为句子进行互译 不会存于词文件 ...

  2. javascript之正则表达式基础知识小结

    javascript之正则表达式基础知识小结,对于学习正则表达式的朋友是个不错的基础入门资料.   元字符 ^ $ . * + ? = ! : | \ / ( ) [ ] { } 在使用这些符号时需要 ...

  3. PAT1089. Insert or Merge

    PAT1089. Insert or Merge 题目大意 给定一个初始序列src, 一个排序当中的序列tar, 问排序方式是 Insert Sort, 或者 Merge Sort. 并输出下一次迭代 ...

  4. 到底什么时候需要使用 final

    final: final修饰属性,则该属性不可再次改变,而且在初始化中必须在属性或者是构造方法中其中且中有一个中初始化他 final修饰方法,则该方法不可被重写 final修饰类,则不可被继承 1:当 ...

  5. Eslint代码规范

  6. Spring data JPA 理解(默认查询 自定义查询 分页查询)及no session 三种处理方法

    简介:Spring Data JPA 其实就是JDK方式(还有一种cglib的方式需要Class)的动态代理 (需要一个接口 有一大堆接口最上边的是Repository接口来自org.springfr ...

  7. Qt学习交流(广告)

    最近全面学习QT与c++,希望同行能够指教,于是打算建个群QQ群:85439482,欢迎大家,本群主要专注于QT皮肤库积累,软件架构以及标准c++学习.

  8. ABAP术语-Business Connector

    Business Connector 原文:http://www.cnblogs.com/qiangsheng/archive/2007/12/27/1016379.html XML-based st ...

  9. tidb损坏tikv节点怎么恢复集群

    tikv节点宕机(机器再起不来),或者数据节点被rm -rf 掉了怎么办 正常情况下tikv节点down掉了.此时不要去执行store delete  store_id .数据一般可以正常访问,但是如 ...

  10. html 截图粘粘图片JS

    web前端socket聊天室功能和在线编辑器上传编辑内容的时候经常会需要上传一些图文信息,但是很多编辑器不支持截图粘粘的功能,这里参考了网友分享的可用方法做一个记录. <html> < ...