一、软件列表:
windows和linux的jprofiler的版本必须一致
1、jprofiler_linux_9_1_1.tar.gz
2、jprofiler_windows_x64 9_1_1  
3、本地安装tomcat7(windows)
4、linux安装tomcat7(linux)

二、操作步骤
1、将jprofiler_linux_9_1_1.tar.gz拷贝到linux /usr/local目录下,并使用tar命令解压
2、生成startup_jprofiler.sh文件(该文件最后会拷贝到linux的tomcat bin目录下,并执行脚本,才能监控tomcat)
 打开:Session-->Integration Wizards-->New Remote Integration
 
 
 
 
这里注意在linux手上开启端口8849
 
 这里需要定位到本机的tomcat bin目录下
 
 
 
3、拷贝startup_jprofiler.sh到linux的tomcat bin目录下
a) 脚本授权:chmod 777 startup_jprofiler.sh
b) 执行脚本:./startup_jprofiler.sh
执行脚本可能报错:Error occurred during initialization of VM
Could not find agent library /usr/local/bin/linux-x64/libjprofilerti.so in absolute path, with error: /usr/local/bin/linux-x64/libjprofilerti.so: cannot open shared object file: No such file or directory
原因:对应目录下找不到文件libjprofilerti.so
解决:
cd /usr/local/jprofiler9/bin/linux-x64
cp libjprofilerti.so /usr/local/bin/linux-x64/libjprofilerti.so
 c)  执行输出
 
windows下重新执行步骤1,最后选择立即执行即可
 

三、注意事项
1、执行脚本报错
执行脚本:./startup_jprofiler.sh
执行脚本可能报错:Error occurred during initialization of VM
Could not find agent library /usr/local/bin/linux-x64/libjprofilerti.so in absolute path, with error: /usr/local/bin/linux-x64/libjprofilerti.so: cannot open shared object file: No such file or directory
原因:对应目录下找不到文件libjprofilerti.so
解决:
cd /usr/local/jprofiler9/bin/linux-x64
cp libjprofilerti.so /usr/local/bin/linux-x64/libjprofilerti.so

2、jprofiler连接不上
原因:未开启默认端口
vim /etc/sysconfig/iptables
service iptables restart

四、参考资料

jprofiler_监控远程linux服务器的tomcat进程(实践)的更多相关文章

  1. jprofiler_监控远程linux服务器的JVM进程(实践)

    几天前写了一篇文章,jprofiler_监控远程linux服务器的tomcat进程(实践),介绍了使用jprofiler怎样监控远程linux的tomcat进程,这两天想了想,除了可以监控tomcat ...

  2. jprofiler_监控远程linux服务器的JVM进程(转 非常棒)

    几天前写了一篇文章,jprofiler_监控远程linux服务器的tomcat进程(实践),介绍了使用jprofiler怎样监控远程linux的tomcat进程,这两天想了想,除了可以监控tomcat ...

  3. Nagios的安装配置与应用之五监控远程Linux服务器

    本文出自 “曹坏水” 博客,请务必保留此出处http://cao2012.blog.51cto.com/366908/1132113 NRPE是Nagios的一个功能扩展,它可在远程Linux和UNI ...

  4. 搭建基于Nagios的监控系统——之监控远程Linux服务器

    上一篇介绍了如何安装Nagios Core,这一篇跟大家分享一下如何将一台远程的Linux服务器加入纳入监控范围. 第一部分:在远程Linux上安装Nagios Plugins和NRPE   第一步: ...

  5. Jvisualvm监控远程linux下Tomcat

    Jvisualvm监控远程linux下Tomcat 1.编辑tomcat/bin/catalina.sh 加入下面这段代码,中间无换行: CATALINA_OPTS="$CATALINA_O ...

  6. Nagios学习笔记四:基于NRPE监控远程Linux主机

    1.NRPE简介 Nagios监控远程主机的方法有多种,其方式包括SNMP.NRPE.SSH和NCSA等.这里介绍其通过NRPE监控远程Linux主机的方式. NRPE(Nagios Remote P ...

  7. windows和linux下关闭Tomcat进程

    windows和linux下解决Tomcat进程 windows下启动Tomcat报错,8080端口号被占用,报错信息如下 两种解决方法,一种是关闭了这个端口号,另外一种是修改Tomcat下的serv ...

  8. Sublime Text编辑远程Linux服务器上的文件

    sublime有个叫sftp的插件,可以通过它直接打开远程机器上的文件进行编辑,并在保存后直接同步到远程linux服务器上. 用Package Control安装插件 按下Ctrl+Shift+P调出 ...

  9. Linux服务器上Tomcat的Web工程部署

    Linux服务器上Tomcat的Web工程部署 部署Web应用到Tomcat服务器就是将开放好的JavaWeb应用打包成war包,然后发布到tomcat服务器的webapps目录下: 步骤1,先进入t ...

随机推荐

  1. iOS __block 与 __weak

    关于__block 与__weak http://stackoverflow.com/questions/19227982/using-block-and-weak 一下是一些区别的介绍 MRC: _ ...

  2. 谈谈iOS中的锁

    1 前言 近日工作不是太忙,刚好有时间了解一些其他东西,本来打算今天上午去体检,但是看看天气还是明天再去吧,也有很大一个原因:就是周六没有预约上!闲话少说,这里简单对锁来个简单介绍分享. 2 目录 第 ...

  3. 错误解决:error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory

    执行以下代码,生成唯一的UID $fp = popen("/xxx/bin/tools/uuidgen system", "r");// $uid = frea ...

  4. DPA 9.1.85 升级到DPA 10.0.352流程

    SolarWinds DPA的升级其实是一件非常简单的事情,这里介绍一下从DPA 9.1.95升级到 DPA 10.0.352版本的流程.为什么要升级呢? DPA给用户发的邮件已经写的非常清楚了(如下 ...

  5. 浅析SQL SERVER执行计划中的各类怪相

    在查看执行计划或调优过程中,执行计划里面有些现象总会让人有些疑惑不解: 1:为什么同一条SQL语句有时候会走索引查找,有时候SQL脚本又不走索引查找,反而走全表扫描? 2:同一条SQL语句,查询条件的 ...

  6. SQL Server 2008 R2 Service Pack 3 已经发布

    微软SQL Server Product Team在9月26号官方博客宣布,Microsoft SQL Server 2008 R2 Service Pack 3 (SP3)正式发布了 .具体信息可以 ...

  7. LightMysql:为方便操作MySQL而封装的Python类

    原文链接:http://www.danfengcao.info/python/2015/12/26/lightweight-python-mysql-class.html mysqldb是Python ...

  8. 【转】70个经典的 Shell 脚本面试问题

    我们为你的面试准备选择了 70 个你可能遇到的 shell 脚面问题及解答.了解脚本或至少知道基础知识对系统管理员来说至关重要,它也有助于你在工作环境中自动完成很多任务.在过去的几年里,我们注意到所有 ...

  9. Linux I/O多路复用

    Linux中一切皆文件,不论是我们存储在磁盘上的字符文件,可执行文件还是我们的接入电脑的I/O设备等都被VFS抽象成了文件,比如标准输入设备默认是键盘,我们在操作标准输入设备的时候,其实操作的是默认打 ...

  10. ajax缓存问题

    默认情况下,请求总会被发出去,但浏览器有可能从它的缓存中调取数据.换句话说,在缓存过期之前,针对相同地址发起的多个Ajax请求,只有第一次会真正发送到服务端.要禁止使用缓存的结果,可以设置 cache ...