1.验证Centos是否安装MySQL

$>yum list installed | grep mysql

2.删除MySql

$>yum –y remove mysql-libs.X86_64

$>yum erase mysql-libs.x86_64

3.验证删除是否成功!

$>yum list installed | grep mysql

4.下载mysql二进制文件mysql-5.7.21-linux-glibc2.12-x86_64.tar.gz

$>su root

5.将mysql压缩包拷贝到/usr/local/目录下:

$>cd /usr/local

$>cp /mnt/hgfs/2.安装环境/download/mysql-5.7.21-linux-glibc2.12-x86_64.tar.gz .

6.解压:

$>tar -zxvf mysql-5.7.21-linux-glibc2.12-x86_64.tar.gz

并重命名mysql:

$>mv mysql-5.7.21-linux-glibc2.12-x86_64 mysql

删除原压缩包:

$>rm mysql-5.7.21-linux-glibc2.12-x86_64.tar.gz

7.创建mysql用户组:

$>groupadd mysql

在创建的mysql用户组中创建一个新用户mysql:

$>useradd -r -g mysql mysql

进入目录:

$>cd /usr/local/mysql

修改目录的拥有者:

$> chown -R mysql .

$> chgrp -R mysql .

(这里的点“.”代表的就是当前目录,选项-R表示递归当前目录及其子目录)

8.创建数据库存放文件夹和相关文件并修改权限

$>sudo mkdir -pv /data/mysqldb/3306/{logs,run,data}

$>sudo touch /data/mysqldb/3306/run/mysqld.pid

$>sudo touch /data/mysqldb/3306/logs/mysql-error.log

$>sudo chown -R mysql.mysql /data/mysqldb/

$>sudo chmod -R 777 /data/mysqldb

文件没有创建的话,启动Mysql时将会报错

9.修改配置文件

$>cd /usr/local/mysql

$>sudo vim my.cnf

------------------------------------------------------------------------

[client]

port=3306

socket=/data/mysqldb/3306/mysql.sock

default_character_set=utf8

[mysqld]

user=mysql

port=3306

socket=/data/mysqldb/3306/mysql.sock

basedir=/usr/local/mysql

datadir=/data/mysqldb/3306/data

pid-file=/data/mysqldb/3306/run/mysqld.pid

log-error=/data/mysqldb/3306/logs/mysql-error.log

character_set_server=utf8

[mysql]

socket=/data/mysqldb/3306/mysql.sock

[mysqldump]

socket=/data/mysqldb/3306/mysql.sock

[mysqladmin]

socket=/data/mysqldb/3306/mysql.sock

------------------------------------------------------------------------

yum -y install numactl

10.初始化mysql安装:

$>cd /usr/local/mysql

$>sudo ./bin/mysqld --defaults-file=/usr/local/mysql/my.cnf --initialize-insecure --user=mysql --datadir=/data/mysqldb/3306/data

Mysql 5.7以后对密码安全有更友好的提示了,

--initialize-insecure 以空密码初始化数据库

--initialize          随机生成一个密码并显示在屏幕中,第一次登录的时候必须提供此密码

11.把启动脚本放到开机初始化目录,添加开机启动mysql服务

复制启动服务脚本至/etc/init.d目录:

$>cd /usr/local/mysql

$>sudo cp ./support-files/mysql.server /etc/rc.d/init.d/mysqld

$>sudo chkconfig --add mysqld

$>sudo chkconfig mysqld on

$>chkconfig --list mysqld

$>chkconfig --del mysqld

12.启动mysql服务

安装好mysql后,就可以试着启动它,使用如下命令:

$> sudo service mysqld start

或

$> cd /usr/local/mysql

$> sudo ./support-files/mysql.server start

查看mysql服务是否启动:

$> ps -ef|grep mysql

看到mysql服务说明启动成功。

13.配置环境变量:

打开/etc/profile文件:

$> sudo gedit /etc/profile

在文件的最后,加上下面两行:

export MYSQL_HOME=/usr/local/mysql

export PATH=$PATH:$MYSQL_HOME/bin

保存并关闭文件,执行以下命令使得环境变量生效:

$> source /etc/profile

14.修改root的密码

进行安全配置(设置密码)

执行命令:

$>mysql -u root -p

回车执行后,因为一开始没有设置密码,所以这里不需要输入密码,直接回车即可登录。

执行成功后,控制台显示 mysql>,则表示进入mysql

输入命令(注意分号):

mysql> set password for 'root'@'localhost'=password('admin');

此时root用户的密码修改为admin。

退出mysql:

mysql> quit

重新登录:

mysql -u root -p

输入密码admin即可登录。

centos6.8安装mysql过程的更多相关文章

  1. Mysql系列三:Centos6下安装Mysql和Mysql主从复制的搭建

    一.Centos6下安装Mysql 检测下系统有没有自带的mysql:yum list installed | grep mysql, 如果已经有的话执行命令yum -y remove mysql-l ...

  2. Centos6.5 安装MYSQL 5.5 -5.6.-5.7 一键yum快速安装 ,初始配置

    Centos6.5 安装MYSQL 5.5 ---5.6---5.7 一键yum快速安装 ,初始配置 第一步:安装mysql-5.5---- 5.6 ---- 5.7的yum源 [root@sv03 ...

  3. 【转】CentOS6下安装mysql后,重置root密码方法

    本文转自:CentOS6下安装mysql后,重置root密码方法 centos下安装mysql,居然不知道root用户密码,本想重装,不过还是先度娘了一些,发现这篇文章,刚好解决我的燃眉之急,太赞了. ...

  4. CentOS6.9安装MySQL(编译安装、二进制安装)

    目录 CentOS6.9安装MySQL Linux安装MySQL的4种方式: 1. 二进制方式 特点:不需要安装,解压即可使用,不能定制功能 2. 编译安装 特点:可定制,安装慢 5.5之前: ./c ...

  5. win10安装mysql过程&&链接过程&&备份和导入数据&&grant命令

    win10安装mysql过程&&链接过程&&备份和导入数据&&grant命令   一 .安装 一开始在mysql官网(https://www.mysql ...

  6. centos6.5 安装mysql 的过程

    Linux中使用最广泛的数据库就是MySQL,使用在线yum的方式安装的版本落后MySQL网站好几个小版本, 所以折腾了几个星期,终于在CentOS 装好了mysql5.6,装完之后,对整个linux ...

  7. 在Centos6.5安装MySQL

    在阐述安装过程之前一定要再写一句,Centos7上安装MySQL是默认安装的MariaDB,因为在Centos7中用MariaDB代替了mysql数据库. linux安装软件很简单,有的时候只有一句话 ...

  8. centos6.8yum 安装mysql

    1:查看是否已有mysql版本 rpm -qa | grep mysql 删除mysql 账号和用户组 删除/etc/my.cnf 2:有的话就删除 rpm -e mysql-...... 或者 co ...

  9. Centos6.7安装mysql 5.6简单教程

    今天项目经理让我给服务器配一下mysql,以前配置mysql的时候,感觉好麻烦,前几天也帮朋友配置来着,今天装的时候一直报错,百度也没搞明白,所以打算换种方法装mysql,无意中发现了还有这种操作,容 ...

随机推荐

  1. Python标准库:内置函数hasattr() getattr() setattr() 函数使用方法详解

    hasattr(object, name) 本函数是用来判断对象object的属性(name表示)是否存在.如果属性(name表示)存在,则返回True,否则返回False.参数object是一个对象 ...

  2. 转 string和byte[]的转换 (C#)

    转 string和byte[]的转换 (C#)  string类型转成byte[]: byte[] byteArray = System.Text.Encoding.Default.GetBytes ...

  3. 安装PHPphp-5.4.4

    一.下载PHPphp-5.4.4 [root@aliyun software]# pwd /software[root@aliyun software]# wget http://mirrors.so ...

  4. 如何解决ORA-12547错误!

    最近在布置一个应用程序连接oracle后台数据库,数据库为oracle11g(11.2.0.2).应用程序属于root用户,所以需要以root用户通过系统认证的方式连接数据库.设置了root用户的环境 ...

  5. jQuery中的$.grep()使用

    grep()方法用于数组元素过滤筛选 grep(array,callback,invert) array:待过滤数组; callback:处理数组中的每个元素,并过滤元素,该函数中包含两个参数,第一个 ...

  6. Swap是个什么东东?

    要明白这个首先要知道什么是保护模式和实模式.以前的操作系统是实模式,例如dos.每个时候只有一个进程在跑,这个进程使用全部的物理内存.后来发展到保护模式,分时多进程.一个CPU上跑多个进程, 但进程不 ...

  7. Django的视图响应类型

    Django的视图响应类型 一. 视图函数编写原则 视图函数接受HTTP请求并返回响应,可以放在任何地方,可以是任何功能:视图函数可以返回Web文本,页面.重定向.错误.图片等任何内容:视图函数通过H ...

  8. 【vue】todolist小练习

    参考链接: http://www.imooc.com/learn/694 http://www.cnblogs.com/Chen-XiaoJun/p/6238137.html http://blog. ...

  9. CentOS 安装jira 6.3.6

    java 目录: /usr/java/jdk1.6.0_45 tomcat 目录:/usr/tomcat-7.0.29 jira 目录: /usr/local/jira jira 访问地址: cent ...

  10. 13.56Mhz SI522兼容MFRC522的资料以及对比性能

    (13.56Mhz芯片) SI522是一颗专门替代MFRC522/FM17522,PIN对PIN 完全软硬件兼容.相对于MFRC522,SI522完全替换,不需要做任何更改,同时接受模式下功耗低10m ...