我们都知道最简单的部署web项目的方式是打成war包直接仍在tomcat的webapps目录下,我上个项目也确实是这样做的,可是这给我们后期的维护带来了极大的不便,下面就简单研究一下以war包部署和解开部署的区别。

1.以war包部署:(适用于全量部署)

  利用eclipse或者maven等工具可以直接生成war包,如下:

现在我们直接将它丢到tomcat的webapps目录下:(如果tomcat是启动状态也可以直接扔在下面,tomcat会自动扫描war包并解压)

查看解压后的目录结构:(相当于eclipse的webapp,我们写的代码编译之后放在WEB-INF的classes目录下,引用的第三方jar包在WEB-INF的lib目录下)

到此部署成功,可以直接访问。

现在假如我们的项目因为需求变化需要重新补丁,但是就是因为修改了几个类我们需要重新部署,方法:

    删除war包之后重新打包部署-----此方法肯定成功,但是效率极低。每次都得传输大量的jar包,只第三方的jar包就200M。

    而且我们删掉Exam.war之后tomcat会自动去掉Exam目录,也就是清除掉此项目。也就是此项目依赖于war包,给维护带来极大不便。

2.以目录的形式部署(尽量使用这种)

  • 在上面打好的war之后,将war包解压:

  •  将我们写的代码编译之后的class文件进行打包,打成jar包放到lib目录下。

(1)打包:  也就是将编译之后的class文件打包

liqiang@root MINGW64 ~/Desktop/新建文件夹 (2)/WEB-INF/classes
$ pwd
/c/Users/liqiang/Desktop/新建文件夹 (2)/WEB-INF/classes liqiang@root MINGW64 ~/Desktop/新建文件夹 (2)/WEB-INF/classes
$ jar cvf exam-1.0.jar ./cn

(2)删掉原来class文件将上面的jar放到WEB-INF\lib目录下

  • 将上面的文件夹放到webapps目录下启动tomcat即可

注意:此时WEB-INF目录下只有我们的配置文件,我们的class文件在上面打成jar包放到WEB\lib目录下。

  我认为这种方式部署的好处是可以增量部署,我们如果在后期修改bug之后代码变了我们只需要将我们编译之后的代码重新打成jar包传到服务器(只用传一个jar包),如果我们是增加功能我们可以生成新的jar包放到WEB\lib目录,如果增加了新的配置文件我们可以放到WEB-INF\classes目录下,当然配置文件也可以打在jar包中。

  也就是我们在项目部署的时候尽量使用目录部署,便于后期修复bug与增加功能,可以实现增量部署。

  

  mysql安装的时候也尽量使用集成安装的方式,便于控制,mysql集成安装参考:  https://www.cnblogs.com/qlqwjy/p/9484582.html

【项目部署】部署项目以war包部署和解开以目录部署的区别的更多相关文章

  1. Linux下部署tomcat及tomcat war包应用程序

    1, 通过winscp将tomcat包(6和7版本都是一样的安装方法)和jdk-6u27-linux-x64.bin安装文件传送到linux 系统/opt里面.(这里没有固定要传送到/opt/hn,可 ...

  2. (转)Linux下部署tomcat及tomcat war包应用程序

    原文:http://www.cnblogs.com/smallfa/news/2017/07/17/7193620.html 1, 通过winscp将tomcat包(6和7版本都是一样的安装方法)和j ...

  3. 彻底解决java WEB项目的文件路径问题(war包)

    在j2EE项目中,我们通常会把项目打包公布,通常是war包,作为独立单元,能够远程上传,载入,公布,还能够实现版本号控制,但这与我们开发过程中使用MyEclipse自己主动部署有所不同,下面做具体说明 ...

  4. springBoot 项目war包部署及改为war包后资源路径错误问题

    参考资料: https://blog.csdn.net/rico_zhou/article/details/83415114 https://blog.csdn.net/pz641/article/d ...

  5. Docker实现运行tomcat并部署项目war包,并实现挂载目录

    之前写的有点乱,现在再来整理一下docker的简单部署运行 借鉴博客:https://blog.csdn.net/qq_32351227/article/details/78673591 一.dock ...

  6. 基于springboot多模块项目使用maven命令打成war包放到服务器上运行的问题

    首先,大家看到这个问题,可能并不陌生,而且脑子里第一映像就是使用mava中的clear package 或者 clear install进行打包,然后在项目中的target文件夹下面找到xxx.war ...

  7. Java的JAR包, EAR包 ,WAR包 都是干什么的,有什么区别

    JAR包:打成JAR包的代码,一般作为工具类,在项目中,会应用到N多JAR工具包: WAR包:JAVA WEB工程,都是打成WAR包,进行发布,如果我们的服务器选择TOMCAT等轻量级服务器,一般就打 ...

  8. tomcat如何配置启动时自动部署webapps下的war包

    1.找到 tomcat安装目录/conf/server.xml 2.修改host元素的配置如下: <Host name="localhost" appBase="w ...

  9. IntelliJ IDEA打包WAR并部署运行(mac osx)将Web项目War包部署到Tomcat服务器基本步骤(完整版)

    用IntelliJ IDEA做web开发体验很好,但导出war包比eclipse麻烦了不少,以下是解决方案: 打包:1.自动打包:File —> Project Structure —> ...

随机推荐

  1. 实训五(Cocos2dx-3.x 打包apk再理解)

    问题说明:Unable to resolve target 'android-10' SDK版本与Cocos项目默认的版本不相符 如果只是执行 cocos compile -p android 只是执 ...

  2. 做业5.2 TDD

    package runok;import java.util.*;import java.awt.*;import java.awt.event.ActionEvent;import java.awt ...

  3. Github作为图床的一个小坑

    Github作为图床的一个小坑 前言 听了少铭同学建议把github作为图床,结果遇到了一个小坑,总是显示不出来图片. 问题描述与解决 形如下的链接是显示不出来的: https://github.co ...

  4. Uploadify提示-Failed,上传不了文件,跟踪onUploadError事件,errorMsg:2156 SecurityError Error #2156 null

    在使用Uploadify上传文件时,提示-Failed,上传不了文件 折腾中.....,没有结果.....%>_<%... 于是跟踪onUploadError事件,发现 errorMsg: ...

  5. 联想一体机怎么设置u盘启动|联想一体机bios改U盘启动方法(转)

    本文转自:http://www.xitongcheng.com/jiaocheng/xtazjc_article_29090.html 所需工具: 1.联想Lenovo品牌一体机 2.启动U盘:大白菜 ...

  6. PHP从入门到精通

    php基本语法 1.变量类型 a.标量类型 bool integer float string b.复合类型 array object c.特殊类型 resource null d.伪类型 mixd ...

  7. Vue---从后台获取数据vue-resource的使用方法

    作为前端人员,在开发过程中,我们大多数情况都需要从后台请求数据,那么在vue中怎样从后台获取数据呢?接下来,我简单介绍一下vue-resource的使用方法,希望对大家有帮助. 一.下载vue-res ...

  8. Magical Girl Haze 南京网络赛2018

    题意: 就是使不大于k条路的权值变为零后求最短路 解析: d[i][j]表示使j条路变为权值后从起点到点i的最短路径 这题不能用spfa做  tle #include <iostream> ...

  9. BZOJ 2427 [HAOI2010]软件安装 | 这道树形背包裸题严谨地证明了我的菜

    传送门 BZOJ 2427 题解 Tarjan把环缩成点,然后跑树形背包即可. 我用的树形背包是DFS序上搞的那种. 要注意dp数组初始化成-INF! 要注意dp顺推的时候也不要忘记看数组是否越界! ...

  10. windows2008设置IIS服务器定时自动重启的方法

    我们在使用windows2008下IIS服务器时会经常出现资源耗尽的现象,运行一段时间下来就会出现访问服务器上的网站时提示数据库连接出错,重启IIS后网站又能正常访问了,这个问题可能困扰了很多站长朋友 ...