https://blog.csdn.net/guyan0319/article/details/78749639

https://www.cnblogs.com/frankdeng/p/9139035.html#top (还可以)

http://www.cnblogs.com/javashare/p/9380156.html         elk6.3 centos集群搭建 head插件安装

https://www.cnblogs.com/royfans/p/9711937.html              kibana创建饼图

https://blog.csdn.net/zwq912318834/article/details/78657787        kibana创建曲线图


(1) 启动elasticsearch,  切换成非root用户启动elasticsearch。浏览器访问http://192.1168.3.18:9100/

(2)启动grunt,(elasticsearch-head),cd切换到head-master文件夹再启动,[admin@node21 elasticsearch-head-master]$ grunt server &

(3)启动logstash ,    [admin@node21 bin]$ ./logstash -f /opt/datas/logstash-simple.conf

(4)启动bigdesk,浏览器打开 http://192.168.100.21/bigdesk-master/_site/#nodes ,点击右侧连接即可访问!

(5)启动kibana,[admin@node21 bin]$ ./kibana &   ,页面访问:192.168.100.21:5601

[root@smc logstash-6.2.4]# pwd
/root/logstash-6.2.4
[root@smc logstash-6.2.4]# ./bin/logstash -f /opt/datas/logstash-simple.conf                     然后随便输入些内容,再在网页的http://X.X.X.X:9100/ 的数据浏览->所有索引里面查看到刚才输入的内容。


错误处理:

1、centos 7 下 elasticsearch 运行失败的解决方法 https://blog.csdn.net/liucoding/article/details/80599997

报错信息:[elk@test elasticsearch-6.2.4]$ ./bin/elasticsearch -d
错误: 找不到或无法加载主类 org.elasticsearch.tools.launchers.JavaVersionChecker

解决方法:

不要在root 根目录就行,要在/home/xxxx/  项目下,下载elasticsearch

然后就用平时的普通用户就能运行了.

2、elasticsearch启动过程报错查看:先不要加参数-d

[elk@smc root]$ /home/elasticsearch-6.2.4/bin/elasticsearch
3、报错:

ERROR: [2] bootstrap checks failed
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]
[2]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
解决办法:https://blog.csdn.net/feinifi/article/details/73633235?utm_source=itdadao&utm_medium=referral

# cat /etc/sysctl.conf

vm.max_map_count=655360
net.ipv4.ip_forward = 1

4、elasticsearch及logstash启动过程稍长,需耐心等待。

5、安装nodejs

https://blog.csdn.net/zyjavaWeb/article/details/80023611

6、运行grunt server &报错解决办法

http://blog.sharechiwai.com/2014/10/fatal-error-unable-to-find-local-grunt/

报错信息:

[root@smc ~]# grunt server &
[1] 4367
[root@smc ~]# grunt-cli: The grunt command line interface (v1.2.0)

Fatal error: Unable to find local grunt.

If you're seeing this message, grunt hasn't been installed locally to
your project. For more information about installing and configuring grunt,
please see the Getting Started guide:

http://gruntjs.com/getting-started

[1]+ 退出 99 grunt server

解决办法:切换到elasticsearch-head-master文件夹,然后运行命令,

[root@smc ~]# cd elasticsearch-head-master/
[root@smc elasticsearch-head-master]# npm install grunt --save-dev

ELK测试安装的更多相关文章

  1. ELK 6安装配置 nginx日志收集 kabana汉化

    #ELK 6安装配置 nginx日志收集 kabana汉化 #环境 centos 7.4 ,ELK 6 ,单节点 #服务端 Logstash 收集,过滤 Elasticsearch 存储,索引日志 K ...

  2. ELK Stack (1) —— ELK + Redis安装

    ELK Stack (1) -- ELK + Redis安装 摘要 安装Elasticsearch.Logstash.Kibana与Redis以实现一个日志收集平台 版本 elasticsearch版 ...

  3. 求知的木头 Cannot load browser "PhantomJS": it is not registered! Perhaps you are missing some plugin? 测试安装遇到的BUG

    原文链接 求知的木头   Cannot load browser "PhantomJS": it is not registered! Perhaps you are missin ...

  4. elk的安装部署

    Elk日志安装文档 需要用到有三个软件包 和redis 分布式部署:已上图就是分布式部署的架构图 Logstash :    是部署在前台的应用上,收集数据的 和部署在redis和elasticsea ...

  5. ELK系列一:ELK的安装

    一.Elasticsearch.Kibana.Logstash.Elasticsearch-head的安装 ELK的安装 安装下载地址: https://www.elastic.co/cn/downl ...

  6. 【Docker】安装并测试安装成功

    1.环境描述 Centos 7 2.安装步骤 通过命令yum install docker安装 等待下载安装-,出现下图,按y继续 继续等待-出现下图按y继续 再继续等待- 知道出现上图表示安装完毕 ...

  7. 测试安装phpmyadmin4.0

    在测试环境准备测试安装phpmyadmin,测试环境上为一台zabbix 3.4的服务器,已经安装lamp环境. 根据安装文档,从phpmyadmin官网上下载了4.0版本,复制到/var/www/h ...

  8. ELK简单安装测试

    1 介绍组件 Filebeat是一个日志文件托运工具,在你的服务器上安装客户端后,filebeat会监控日志目录或者指定的日志文件,追踪读取这些文件(追踪文件的变化,不停的读). Kafka是一种高吞 ...

  9. elk集成安装配置

    三台虚拟机 193,194,195 本机 78 流程 pythonserver -> nginx -> logstash_shipper->kafka->logstash_in ...

随机推荐

  1. AES算法在Python中的使用

    Python有很多开源库,使用AES等加密算法时可以找对应的开源库.我记录一下安装方法: (1)下载开源库pycrypto 下载地址:https://pypi.python.org/pypi/pycr ...

  2. Selenium Python FirefoxWebDriver处理打开保存对话框

    代码如下(网上示例): #profile =  webdriver.FirefoxProfile(r"C:\Users\Skyyj\AppData\Roaming\Mozilla\Firef ...

  3. 关于Dubbo面试问题

    一.默认使用的是什么通信框架,还有别的选择吗? 默认也推荐使用netty框架,还有mina. 二.服务调用是阻塞的吗? 默认是阻塞的,可以异步调用,没有返回值的可以这么做. 三.一般使用什么注册中心? ...

  4. maven打包时跳过测试

    本文转载自:https://blog.csdn.net/thc1987/article/details/42458895 运行mvn install时跳过Test 方法一: <project&g ...

  5. bzoj 4866: [Ynoi2017]由乃的商场之旅

    设第i个字母的权值为1<<i,则一个可重集合可以重排为回文串,当且仅当这个集合的异或和x满足x==x&-x,用莫队维护区间内有多少对异或前缀和,异或后满足x==x&-x,这 ...

  6. 安卓模拟器错误 PANIC: Could not open

    最近在配置Android环境的时候着实让我迷惘了许久,最主要的一个问题就是在创建AVD的时候,出现如下问题: PANIC: Could not open ***

  7. 数据库SQL语言学习--上机练习2(连接查询 嵌套查询)

    上机练习2 1.              启动SQL Server 2008中的 SQL Server Management Studio. 2.              针对下面三张基本表进行操 ...

  8. Recyclerview 实现上拉加载更多

    LinearLayoutManager layoutManager; layoutManager = new LinearLayoutManager(getActivity()); layoutMan ...

  9. [UE4]使用DataTable

  10. echart line 初始化隐藏legend

    echart line,当line很多,且各line的取值区间相关非常大时,多条line同时显示,其实是没有太大的可读性的,因此需要在初始化时,把部分不太重要的legend隐藏起来. 具体做法如下: ...