cloudstack主机添加不成功

CloudStack正常启动,添加区域、提供点和群集都正常,但是添加主机时提示添加不成功。

先添加主机:

然后出现提示:

在网上找了一圈,基本上没什么回复,没办法,还得自己搞。

查看日志

进入/var/log/cloud/managerment,看管理服务器的日志:

tail -f management-server.log

查看日志发现出现异常信息:

2013-06-27 09:07:19,659 INFO  [cloud.resource.ResourceManagerImpl] (catalina-exec-17:null) Trying to add a new host at http://192.168.74.143 in data center 3
2013-06-27 09:07:19,664 WARN [kvm.discoverer.KvmServerDiscoverer] (catalina-exec-17:null) can't setup agent, due to java.io.IOException: There was a problem while connecting to 192.168.74.143:22 - There was a problem while connecting to 192.168.74.143:22
2013-06-27 09:07:19,664 WARN [cloud.resource.ResourceManagerImpl] (catalina-exec-17:null) Unable to find the server resources at http://192.168.74.143
2013-06-27 09:07:19,664 WARN [api.commands.AddHostCmd] (catalina-exec-17:null) Exception:
com.cloud.exception.DiscoveryException: Unable to add the host
at com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceManagerImpl.java:737)
at com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerImpl.java:544)
at com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:140)
at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
at com.cloud.api.ApiServer.queueCommand(ApiServer.java:544)
at com.cloud.api.ApiServer.handleRequest(ApiServer.java:423)
at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:312)
at com.cloud.api.ApiServlet.doGet(ApiServlet.java:64)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:615)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.java:889)
at org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.process(Http11NioProtocol.java:744)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:2282)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:679)
2013-06-27 09:07:19,666 WARN [cloud.api.ApiDispatcher] (catalina-exec-17:null) class com.cloud.api.ServerApiException : Unable to add the host

查看VT是否打开

因为没打开VT,所以导致不能添加Host的异常,打开VT后,再次添加,添加成功!

cloudstack当修改mysql的bind_address时导致连接不成功

修改参数后导致tomcat不能启动,查看日志,得到如下信息:

-- ::, WARN  [cluster.dao.ManagementServerHostDaoImpl] (Cluster-Heartbeat-:null) Unexpected exception,
com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure The last packet successfully received from the server was milliseconds ago. The last packet sent successfully to the server was milliseconds ago.
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:)
at java.lang.reflect.Constructor.newInstance(Constructor.java:)
at com.mysql.jdbc.Util.handleNewInstance(Util.java:)

在网上查了一些资料:

修改MySQL的参数了,wait_timeout最大为31536000即1年,在my.cnf中加入:

[mysqld]
wait_timeout=
interactive_timeout=

重启生效,需要同时修改这两个参数。

还是不行,于是

注释掉这行,如:#bind-address = 127.0.0.1

或者改为: bind-address = 0.0.0.0

允许任意IP访问;

如果指定ip,那么不知道为什么本机就不能访问,会导致一些异常,所以我修改为任意IP都可以访问,再重新授权。

grant all privileges on *.* to root@"%" identified by "password" with grant option;

   flush privileges;

重启mysql

sudo /etc/init.d/mysql restart

然后重新启动

sudo /etc/init.d/cloud-management restart

一切正常。

cloudstack注册ISO时提示connection refused

当注册模板的时候,配置好apache,并且在本地测试可以下载。

但是上传模板的时候还是提示拒绝连接:

进入Cloudstack的管理界面进行全局配置

搜索secstorage关键字,找到一个叫做“secstorage.allowed.internal.sites”的配置参数,设置为 可访问的IP如(192.168.1.1/24),敲回车确认即可。这个参数是说,Web服务器的网段在192.168.1.*;然后到管理节点的命令行重启服务: # service cloud-management restart  
重新登陆界面,在此添加ISO模版,就不会出现“connection refused”的错误。

虚拟化平台cloudstack(4)——几个异常的更多相关文章

  1. 虚拟化平台cloudstack新版本的调试

    虚拟化平台cloudstack(7)——新版本的调试 调试环境 ubuntu 12.04 JDK1.7 apache-maven-3.10 eclipse 4.2 Juno mysql 5 源码下载及 ...

  2. 虚拟化平台cloudstack(5)——参考资料

    虚拟化的几种方式 完全虚拟化: 半虚拟化: 硬件辅助虚拟化: 详细的内容可以看: http://pan.baidu.com/share/link?shareid=4134188256&uk=2 ...

  3. 虚拟化平台cloudstack(2)——安装(上)

    vmware workstation安装ubuntu server12.04 这个其实没什么说的了,下软件,安装,一顿下一步,OK. 安装完成后,为ubuntu server 12.04安装桌面. 使 ...

  4. 虚拟化平台cloudstack(8)——从UI开始

    UI ucloudstack采用的是前后端分离的架构,就是说前端可以选择使用web.swing甚至其它的界面,都可以. 我们来看cloudstack的UI信息吧,所有的cloudstack的UI都在{ ...

  5. 虚拟化平台cloudstack(7)——新版本的调试

    调试环境 ubuntu 12.04 JDK1.7 apache-maven-3.10 eclipse 4.2 Juno mysql 5 源码下载及调试 上面的几个软件在上一篇中已经介绍了. 在新的版本 ...

  6. 虚拟化平台cloudstack(6)——使用maven:jetty调试

    调试环境 ubuntu 12.04 JDK1.7 apache-maven-3.10 eclipse 4.2 Juno mysql 5 apache ant JDK的配置和安装 安装可以参考: htt ...

  7. 虚拟化平台cloudstack(3)——安装(下)

    登录时用户名和密码错误 默认账号密码 admin/password 管理节点安装好后,初始化数据库,完了使用admin和password登陆提示用户名密码错误,查看日志: Fail to genera ...

  8. 【VMware虚拟化解决方案】 基于VMware虚拟化平台VDI整体性能分析与优化

    一.说一说 本来打算将前期项目里面出现的问题的分析思路与解决方法写出来,第一.疏导一下自己的思路,第二.分析并找出自身在技术层面所存在欠缺.但由于每个人都有一根懒经所以迟迟未动.今天突然发现51CTO ...

  9. 恒天云技术分享系列5 – 虚拟化平台性能对比(KVM & VMware)

    恒天云技术分享系列:http://www.hengtianyun.com/download-show-id-14.html 概述 本性能测试报告将详细陈述各虚拟化平台基准性能测试的主要结论和详细结果. ...

随机推荐

  1. ubuntu如何傻瓜式安装eric6

    最近在搞PyQt5,听闻eric6是一个不错的IDE,但就是配置起来略蛋疼. 在网上搜到不少教程,都是要先编译安装Qt5, PyQt5, sip, qscintilla2, qscintilla2又分 ...

  2. 【Java学习笔记】foreach语句(高级for)

    package p2; import java.util.ArrayList; import java.util.HashMap; import java.util.List; import java ...

  3. 15.Xcode8 升级遇到的问题

    一:注释快捷键cmd+/不能用,解决方法: 1. Swift_3.0 没法快捷键(command+/)注释的原因:这个是因为苹果解决xcode ghost,把插件屏蔽了. 2. 解决办法: (1) 终 ...

  4. Cauchy 级数浓缩判别法

  5. wap,h5页面

    网址: 1:天猫(http://m.tmall.com) 2:淘宝(http://m.taobao.com) 3:京东(http://m.jd.com) 4:网易(http://3g.163.com) ...

  6. Microsoft.Office.Interop.Excel 程序集引用 ,Microsoft.Office.Interop.Excel.ApplicationClass 无法嵌入互操作类型

    using Microsoft.Office.Interop.Excel   添加程序集引用 方法:在引用--程序集--扩展中,添加引用Microsoft.Office.Interop.Excel,此 ...

  7. 天气预报API(一):全国城市代码列表(“旧编码”)

    说明 2016-12-09 补充 (后来)偶然发现中国天气网已经有城市ID列表的网页... 还发现城市编码有两种,暂且称中国天气网这些编码为旧标准 "旧编码"的特征是 9个字符长度 ...

  8. Windows 8.1 应用开发文章汇总

    Windows 8.1 应用再出发 - C# + XAML  1. Windows 8.1 应用再出发 - 创建我的第一个应用 2. Windows 8.1 应用再出发 - 几种常用控件 3. Win ...

  9. jquery 传递事件的自定义数据

    整理一下 1. <script type="text/javascript">$(document).ready(function(){  $("input& ...

  10. 【转】java调用webservice

    互联网上面有很多的免费webService服务,我们可以调用这些免费的WebService服务,将一些其他网站的内容信息集成到我们的Web应用中显示,下面就以获取天气预报数据和查询国内手机号码归属地为 ...