Xshell 链接 Could not connect to '192.168.80.129' (port 22): Connection failed
在使用Xshell链接虚拟机VM里面的Linux的时候、链接失败,报
Could not connect to '192.168.80.129' (port ): Connection failed
解决步骤:
1、重启VM、Linux、Xshell
2、重启未解决的话、本地命令行 ping Linux的IP
C:\Users\Administrator>ping 192.168.80.129
3、本地命令行 ping 通的话,转第5步。
C:\Users\Administrator>ping 192.168.80.129 正在 Ping 192.168.80.129 具有 字节的数据:
来自 192.168.80.129 的回复: 字节= 时间=1ms TTL=
来自 192.168.80.129 的回复: 字节= 时间<1ms TTL=
来自 192.168.80.129 的回复: 字节= 时间<1ms TTL=
来自 192.168.80.129 的回复: 字节= 时间<1ms TTL= 192.168.80.129 的 Ping 统计信息:
数据包: 已发送 = ,已接收 = ,丢失 = (% 丢失),
往返行程的估计时间(以毫秒为单位):
最短 = 0ms,最长 = 1ms,平均 = 0ms
4、本地命令行 ping 没有通,检查Linux的网络、具体:在Linux下输入ifconfig,此时查看不到IP。接下来执行vi /etc/sysconfig/network-scripts/ifcfg-eth0,打开文件后,发现文件是空的,这可能因为不小心把这个文件删除了。在这个文件中输入以下信息:
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.80.129
NETMASK=255.255.255.0
GATEWAY=192.168.80.2
其中IPADDR是根据自己需要设置的。我的这个设置虚拟机专用网络的ip为80网段的,在这里,我的IPADDR设置的就是192.168.80.129,GATEWAY设置的就是192.168.80.2
设置完成后,保存退出。
此时再次输入ifconfig,就可以查看到IP地址了。
5.关闭linux防火墙
service iptables stop chkconfig iptables off
6.启动ssh服务
service sshd start
检查SSHD是否在本运行级别下设置为开机启动
输入命令:chkconfig --list sshd
如图所示centos 6.5系统中SSH服在本运行级别下已经设置为开机启动,如果没设置启动就使用如下命令[chkconfig --level 2345 sshd on]设置下即可。

设置SSH服务为开机启动
输入命令:chkconfig sshd on 即可
注:若是chkconfig sshd off则禁止SSH开机启动。
如启动不成功,则需要安装ssh
安装ssh: yum install openssh-server
开启ssh服务:service sshd start 关闭ssh服务:service sshd stop 重启ssh服务:servcie sshd restart SSH服务开机自动启动:chkconfigsshd on 取消开机自启动:chkconfig sshd off 开启服务后,检查服务状态:service sshd status
7.在windows,打开命令行,出现如下信息
C:\Users\Administrator>ping 192.168.80.129 正在 Ping 192.168.80.129 具有 字节的数据:
来自 192.168.80.129 的回复: 字节= 时间=1ms TTL=
来自 192.168.80.129 的回复: 字节= 时间<1ms TTL=
来自 192.168.80.129 的回复: 字节= 时间<1ms TTL=
来自 192.168.80.129 的回复: 字节= 时间<1ms TTL= 192.168.80.129 的 Ping 统计信息:
数据包: 已发送 = ,已接收 = ,丢失 = (% 丢失),
往返行程的估计时间(以毫秒为单位):
最短 = 0ms,最长 = 1ms,平均 = 0ms
说明连接成功
8.此时通过xshell再次连接本地linux,就可以成功。
Xshell 链接 Could not connect to '192.168.80.129' (port 22): Connection failed的更多相关文章
- Could not connect to '192.168.80.145' (port 22): Connection failed的解决办法(远程连不上xshell)
问题状况表现1 这个问题一般是你 的什么配置影响了虚拟机的网卡网关设置!!!. 问题状况表现2 这个问题一般是你 的什么配置影响了虚拟机的网卡网关设置. 解决办法 网上的那些解决方案,我都试过,比如. ...
- xshell连接时报错:Could not connect to '192.168.2.125' (port 22): Connection failed.
解决思路: 1.首先用主机ping下虚拟机IP,看是否能ping通 2.如果ping不通就看虚拟机防火墙是否开启,service iptables status [root@mysql ~]# ser ...
- Xshell5连接虚拟机出现连Could not connect to '192.168.47.128' (port 22): Connection failed,解决办法
该日记写于2016年11月28日.在用Xshell5连接ubuntu虚拟OS时一直连接不上.出现这种情况的原因可能很多,有像百度上面说的没有关闭linux的防火墙,没有启动linux的ssh服务.但这 ...
- 用xshell5连接虚拟机,显示Could not connect to '192.168.3.128' (port 22): Connection failed.
原因:虚拟机上没有安装或者没有启动ssh 解决: 1.安装sshserver sudo apt-get install openssh-server 2.启动ssh服务 sudo service ss ...
- ftp连接服务器失败||或者Xshell链接错误:Could notconnect to '192.168.18.128' (port 22): Connection failed
有时候刚装完虚拟机发现xshell连接失败,或者使用ftp连接失败.(博主用的是unbuntu,其他linux系统可能在命令上稍有差别,但方法是一样的. xshell连接失败: ftp连接失败: 首先 ...
- Could not connect to '192.168.89.144' (port 22)
xshell连接linux主机时,会出现错误:Could not connect to '192.168.89.144' (port 22): Connection failed. 但是这时能ping ...
- 用xshell连接linux服务器失败 Could not connect to '112.74.73.194' (port 22): Connection failed.
用XSHELL连接linux服务器出现以下错误 Connecting to 42.51.xxx.xxx:22... Connection established. To escape to local ...
- ssh: connect to host 192.168.11.180 port 22: Connection refused
错误原因: 1.sshd 未安装:sudo apt-get install openssh-server 2.sshd 未启动:sudo net start sshd 3.防火墙:sudo ufw d ...
- Could not connect to 'xxx.xx.xx.xxx' (port 22): Connection failed.
刚刚使用xshell好好的,突然注销账号,准备重新连接突然连不上了. 这就很尴尬了,对我这种linux菜鸟只能去百度了,终于解决了,赶紧记录下这个坑 1.先登陆虚拟机,输入这段命令 查看ssh服务是否 ...
随机推荐
- ROS_Kinetic_25 在ubuntu16.04使用Leap_motion并作为手势输入控制Gazebo中的机器人
ROS_Kinetic_25 在ubuntu16.04使用Leap_motion并作为手势输入控制Gazebo中的机器人 先附上资料网址: 1. https://developer.leapmoti ...
- JSP自定义标签必知必会
自定义标签技术自sun公司发布以来,便一向很受欢迎!下面我就来谈一谈如何实现自定义标签,以及如何使用自定义标签. 如何实现自定义标签 首先我们应该知道原理,不管是标签还是JSP,本身实际上都会被JSP ...
- 程序员大牛 Jeff Atwood 的两本中文书
程序员大牛,StackOverflow.com创始人之一--Jeff Atwood 英文博客:http://blog.codinghorror.com <高效能程序员的修炼>,人民邮电出版 ...
- 高性能nosql ledisdb设计与实现 (2):replication
ledisdb现在已经支持replication机制,为ledisdb的高可用做出了保障. 使用 假设master的ip为10.20.187.100,端口6380,slave的ip为10.20.187 ...
- Web Service进阶(二)如何用Apache TCPMon来截获SOAP消息
注:以下是关于TCPMon的一些使用常识,如果不需要或是已经熟悉就不用往下看了. 在WebService服务器和客户机之间会传递SOAP消息,有时我们需要得到这些消息以便调试,而Apache的TCPM ...
- 【一天一道LeetCode】#82. Remove Duplicates from Sorted List II
一天一道LeetCode 本系列文章已全部上传至我的github,地址:ZeeCoder's Github 欢迎大家关注我的新浪微博,我的新浪微博 欢迎转载,转载请注明出处 (一)题目 Given a ...
- Leetcode_14_Longest Common Prefix
本文是在学习中的总结,欢迎转载但请注明出处:http://blog.csdn.net/pistolove/article/details/40555783 Longest Common Prefix ...
- c++中各个数据类型的大小
来哦金额各种数据类型有助于我们对这门语言的更好掌握,更好的利用之来编程,下面是一个简单的获得数据类型的大小的程序,虽然简单,但实用性却很高. #include <iostream> usi ...
- javascript语法之流程控制语句
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/ ...
- 【Android 系统开发】Android框架 与 源码结构
一. Android 框架 Android框架层级 : Android 自下 而 上 分为 4层; -- Linux内核层; -- 各种库 和 Android运行环境层; -- 应用框架层; -- 应 ...