nfs服务启动失败:Failed to start NFS status monitor for NFSv2/3 locking..
今天碰到个问题,服务器重启后,nfs服务就启动不了了,关闭都关不了。查看系统日志报下面的错:
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: Started Preprocess NFS configuration.
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: Starting NFS status monitor for NFSv2/3 locking....
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: Starting NFSv4 ID-name mapping service...
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.statd[20430]: Version 1.3.0 starting
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: Starting NFS Mount Daemon...
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.statd[20430]: Flags: TI-RPC
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.mountd[20431]: Could not bind socket: (98) Address already in use
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.mountd[20431]: Could not bind socket: (98) Address already in use
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.mountd[20431]: Could not bind socket: (98) Address already in use
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.mountd[20431]: Could not bind socket: (98) Address already in use
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.mountd[20431]: mountd: No V2 or V3 listeners created!
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: Started NFS Mount Daemon.
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.mountd[20432]: Version 1.3.0 starting
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: Started NFSv4 ID-name mapping service.
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.statd[20430]: Failed to register (statd, 1, udp): svc_reg() err: RPC: Remote system error - No route to host
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.statd[20430]: Failed to register (statd, 1, tcp): svc_reg() err: RPC: Remote system error - No route to host
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.statd[20430]: Failed to register (statd, 1, udp6): svc_reg() err: RPC: Remote system error - No route to host
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.statd[20430]: Failed to register (statd, 1, tcp6): svc_reg() err: RPC: Remote system error - No route to host
Aug 10 17:08:53 prod-r3-slt-s-01 rpc.statd[20430]: failed to create RPC listeners, exiting
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: rpc-statd.service: control process exited, code=exited status=1
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: Failed to start NFS status monitor for NFSv2/3 locking..
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: Unit rpc-statd.service entered failed state.
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: rpc-statd.service failed.
Aug 10 17:08:53 prod-r3-slt-s-01 systemd: Starting NFS server and services...
然后发现查看外国网站找到了一个解决办法:
systemctl enable rpcbind
systemctl start rpcbind
systemctl start nfs-server
这是网站出处:https://bbs.archlinux.org/viewtopic.php?id=193410
nfs服务启动失败:Failed to start NFS status monitor for NFSv2/3 locking..的更多相关文章
- ipv6禁用导致rpcbind服务启动失败实例
ipv6禁用导致rpcbind服务启动失败实例 昨天在做服务器磁盘分区扩容的时候出现过一个服务启动的问题,在此记录.情景再现:前天晚上申请做磁盘扩容,得到批准后,昨天早上5点开始做停机调整维护 ...
- CentOS 7下MySQL服务启动失败的解决思路
今天,启动MySQL服务器失败,如下所示: [root@spark01 ~]# /etc/init.d/mysqld start Starting mysqld (via systemctl): Jo ...
- Sonatype Nexus 服务启动失败问题解决
Sonatype Nexus 服务启动失败问题解决 问题前述: 近日在开发机本机安装了 Oracle 数据库快捷版 11g2 之后,重启电脑后发现本机的maven代理服务无法访问. 现象 通过 Win ...
- Docker安装、命令详情、层级架构、docker服务启动失败解决方法
容器背景: 层级架构: 容器对比传统化虚拟机: 可以把docker理解成是一款自带软件(比如:nignx.tomcat.....)的镜像操作系统(首先是要下载镜像) 以下是Windows环境安装Do ...
- 记录一次sshd服务启动失败
记录一次sshd服务启动失败 问题描述: 服务器开机之后发现无法通过远程连接服务器终端,但是服务器并未宕机,于是考虑到sshd服务出现异常 解决思路: 查看服务器sshd服务运行情况 [root@ha ...
- 玩转Windows服务系列——无COM接口Windows服务启动失败原因及解决方案
将VS创建的Windows服务项目编译生成的程序,通过命令行 “服务.exe -Service”注册为Windows服务后,就可以通过服务管理器进行管理了. 问题 通过服务管理器进行启动的时候,发现服 ...
- paip.花生壳 服务启动失败 以及不能安装服务,权限失败的解决
paip.花生壳 服务启动失败 以及不能安装服务,权限失败的解决 系统win7 NewPhDDNS_1.0.0.30166.exe 作者Attilax 艾龙, EMAIL:1466519819@ ...
- oracleDBconsole服务启动失败
问题出现的故障: 在一次正常使用企业管理器后,重新启动计算机,再次启动OracleDBConsoleORCL服务时,报:Windows 不能在 本地计算机 启动 OracleDBConsoleo ...
- “由于下列错误,Parallel port driver 服务启动失败”,注意了
最近在“事件查看器”中发现这么一个错误:“由于下列错误,Parallel port driver 服务启动失败”, 我到网上搜索了一下,发现很多网页上都说解决办法: 把HKEY_LOCAL_MACHI ...
随机推荐
- 洛谷p1106 删数问题 题解
传送门 # 4.24一个重要的日子.我人生中第一道7个测试点下载了5个的题目被我发现了,第一次用光下载数据点机会,真心坑点重重. 这题是一道很经典的贪心题目,可能是因为我太蒻了,导致我一直以为最少普及 ...
- java TripleDES加密
package com.zhx.base.util; import org.apache.commons.codec.binary.Base64; import javax.crypto.Cipher ...
- C# 串口操作系列(4) -- 协议篇,文本协议数据解析
C# 串口操作系列(4) -- 协议篇,文本协议数据解析 标签: c#uiobjectstringbyte 2010-06-09 01:50 19739人阅读 评论(26) 收藏 举报 分类: 通讯 ...
- 安装es6编译babel
1.它的安装命令如下. 全局安装 :$ npm install --global babel-cli项目下安装: $ npm install -g babel-cli --save-dev 2.配置. ...
- CSS、常用标签属性
div的样式:[width:宽度 :100像素.height:高度100px.background:背景颜色红色] 内嵌的形式:用<style type="text/css>&l ...
- http 缓存学习.
mark 一下 HTTP 缓存机制一二三 http://web.jobbole.com/92773/ 彻底弄懂HTTP缓存机制及原理 https://www.cnblogs.com/chenqf/p/ ...
- Centos服务器上NFS灾备环境及KVM的搭建及使用
1.概述 由于在单台服务器上搭建灾备环境需要KVM和NFS的支持,下面先列出KVM的搭建流程,再列出使用NFS实现单台服务器灾备的流程. A.搭建KVM环境 1>.主机环境准备 Linux Sy ...
- Bandwagon的配置记录(一) —— kexue上网
写在前面 这是kexue上网的一种方法. 看文章前,先拉最底下,看一遍“写在最后”. 租个服务器 我租了个洛杉矶的服务器,系统是ubuntu16.04 x86_64 进入KiwiVM Control ...
- django 标签的使用
首先重建一个common的app 然后创建__init__使common成为一个包 注意templatetags 名字使固定的 并在下面创建一个名字为fitter的过滤器 注册过滤器app htm ...
- ES6新增对象方法的访问描述符:get(只读)、set(只写)
Es6新增对象方法的访问描述符:get(只读).set(只写),可以直接使用,一般用于数据监听,用途类似于vue.$watch. var obj = { a:1, get bar() { return ...