MySQL常见报错汇总
1>.ERROR 1290 (HY000): The MySQL server is running with the --secure-file-priv option so it cannot execute this statement

报错原因:
在MySQL的配置文件中未指定“--secure-file-priv”参数的默认值,而改参数的功能就是确定使用SELECT ... INTO语句时将查询的结果保存到本地文件中,如果未指定则不可以使用该功能。
解决方案:
既然知道原因所在,我们需要做2个操作,第一步是修改配置文件,如下所示。第二步就是重启MySQL服务使得配置生效~
[root@node110 ~]# cat /etc/my.cnf | grep secure_file_priv
secure_file_priv=/yinzhengjie/backup
[root@node110 ~]#
[root@node110 ~]# /etc/init.d/mysql.server restart
Shutting down MySQL... SUCCESS!
Starting MySQL. SUCCESS!
[root@node110 ~]#
2>.ERROR 1 (HY000): Can't create/write to file '/yinzhengjie/backup/student.bak' (OS errno 13 - Permission denied) 
报错原因:
根据报错的提示信息大家不难判断,这是由于权限不足导致!
解决方案:
既然知道的报错的原因,解决起来就很轻松了,比如改目录分配相应的权限,一种比较暴力的方法就是给该目录分配最高权限。如下所示:(当然你也可以只给启动mysql服务的用户分配ACL权限~)
[root@node110 backup]# pwd
/yinzhengjie/backup
[root@node110 backup]#
[root@node110 yinzhengjie]# ll
total 12
drwxr-xr-x. 2 root root 4096 Jan 26 15:08 backup
drwxr-xr-x. 2 root root 4096 Jan 23 06:04 download
drwxr-xr-x. 3 root root 4096 Jan 23 06:04 softwares
[root@node110 yinzhengjie]# chmod 777 backup -R
[root@node110 yinzhengjie]#
[root@node110 yinzhengjie]#
[root@node110 yinzhengjie]# ll
total 12
drwxrwxrwx. 2 root root 4096 Jan 26 15:08 backup
drwxr-xr-x. 2 root root 4096 Jan 23 06:04 download
drwxr-xr-x. 3 root root 4096 Jan 23 06:04 softwares
[root@node110 yinzhengjie]#
3>.ERROR 1418 (HY000): This function has none of DETERMINISTIC, NO SQL, or READS SQL DATA in its declaration and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable)

报错原因:
根据上面的提示,想必大家猜的已经八九不离十来,这是我们开启了bin-log, 我们就必须指定我们的函数是否是上述提示信息中的 “DETERMINISTIC (不确定的)”,“ NO SQL (没有SQl语句,当然也不会修改数据)”,“ READS SQL DATA (只是读取数据,当然也不会修改数据)”,“ MODIFIES SQL DATA 要修改数据” ,“CONTAINS SQL (包含了SQL语句)”。
其中在function里面,只有 DETERMINISTIC, NO SQL 和 READS SQL DATA 被支持。如果我们开启了 bin-log, 我们就必须为我们的function指定一个参数。
解决方案:
在MySQL中创建函数时出现上述错误的解决方法,如下:
mysql> SHOW VARIABLES LIKE 'log_bin'; #在MySQL8.0中,log_bin被打开了,在MySQL5.7之前的版本是关闭状态的!
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| log_bin | ON |
+---------------+-------+
1 row in set (0.00 sec) mysql>
mysql> SHOW VARIABLES LIKE '%trust%';
+---------------------------------+-------+
| Variable_name | Value |
+---------------------------------+-------+
| log_bin_trust_function_creators | OFF |
+---------------------------------+-------+
1 row in set (0.00 sec) mysql>
mysql> set global log_bin_trust_function_creators=TRUE; #由于开启了log_bin功能,因此我们需要将创建函数的功能手动开启 Query OK, 0 rows affected (0.00 sec) mysql>
mysql> SHOW VARIABLES LIKE '%trust%';
+---------------------------------+-------+
| Variable_name | Value |
+---------------------------------+-------+
| log_bin_trust_function_creators | ON |
+---------------------------------+-------+
1 row in set (0.00 sec) mysql>
mysql>
mysql> set global log_bin_trust_function_creators=TRUE;
Query OK, 0 rows affected (0.00 sec) mysql>
mysql> CREATE FUNCTION hello(str CHAR(30))
-> RETURNS CHAR(50)
-> RETURN CONCAT('Hello,',str,'!');
Query OK, 0 rows affected (0.00 sec) mysql>
4>.mysqld: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory

报错原因:
缺少依赖库文件,名曰“libaio.so”。
解决方案:
既然知道缺少依赖库文件,我们直接使用yum工具安装一下即可!具体操作如下所示:
[root@node101 ~]# yum -y install libaio
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.jdcloud.com
* extras: mirrors.neusoft.edu.cn
* updates: mirrors..com
Resolving Dependencies
--> Running transaction check
---> Package libaio.x86_64 :0.3.-.el7 will be installed
--> Finished Dependency Resolution Dependencies Resolved =======================================================================================================================================================================================
Package Arch Version Repository Size
=======================================================================================================================================================================================
Installing:
libaio x86_64 0.3.-.el7 base k Transaction Summary
=======================================================================================================================================================================================
Install Package Total download size: k
Installed size: k
Downloading packages:
libaio-0.3.-.el7.x86_64.rpm | kB ::
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : libaio-0.3.-.el7.x86_64 /
Verifying : libaio-0.3.-.el7.x86_64 / Installed:
libaio.x86_64 :0.3.-.el7 Complete!
[root@node101 ~]#
[root@node101 ~]# yum -y install libaio
5>.mysqld_safe error: log-error set to '/var/log/mariadb/mariadb.log', however file don't exists. Create writable for user 'mysql'.

报错原因:
很明显是文件权限问题,大家可以自行去看"/etc/my.cnf"配置文件的内容配置的是否正确,如果你配置的目录或文件不存在的话,可能会抛出各种各样的异常!
解决方案:
[root@node101 ~]# mkdir /var/log/mariadb
[root@node101 ~]#
[root@node101 ~]# touch /var/log/mariadb/mariadb.log
[root@node101 ~]#
[root@node101 ~]# chown -R mysql:mysql /var/log/mariadb/
[root@node101 ~]#
如果你发现本篇博客没有你相关的错误处理记录,也可以去看看官网常见的错误分析,是否有和你报错一致的:https://dev.mysql.com/doc/refman/8.0/en/error-handling.html。
MySQL常见报错汇总的更多相关文章
- HDFS集群常见报错汇总
HDFS集群常见报错汇总 作者:尹正杰 版权声明:原创作品,谢绝转载!否则将追究法律责任. 一.DataXceiver error processing WRITE_BLOCK operation 报 ...
- Mysql常见报错解决方法
一:登录报错 ERROR 1045 (28000): Access denied for user 'mysql'@'localhost' (using password: NO) mysql日志文件 ...
- Mysql 常见报错和疑问汇总
1.初始化数据库的时候报错 error while loading shared libraries: libstdc++.so.5: cannot open shared object file: ...
- jdbc+mysql常见报错总结
1.The server time zone value '�й���ʱ��' is unrecognized or represents more than one time zone. You ...
- python 常见报错汇总
python官方文档:https://docs.python.org/zh-cn/3/tutorial/index.html 1.indentationerror:unindent does not ...
- SpringBoot工程常见报错汇总
1.Springboot测试类运行报错 java.lang.IllegalStateException: Unable to find a @SpringBootConfiguration, you ...
- Django 连接 MySQL 数据库及常见报错解决
目录 Django 连接 MySQL数据库及常见报错解决 终端或者数据库管理工具连接 MySQL ,并新建项目所需数据库 安装访问 MySQL 的 Python 模块 Django 相关配置 可能会遇 ...
- web报表工具FineReport使用中遇到的常见报错及解决办法(二)
web报表工具FineReport使用中遇到的常见报错及解决办法(二) 这里写点抛砖引玉,希望大家能把自己整理的问题及解决方法晾出来,Mark一下,利人利己. 出现问题先搜一下文档上有没有,再看看度娘 ...
- java常见报错及解决
Java常见报错信息: Java 常见异常种类 Java Exception: 1.Error 2.Runtime Exception 运行时异常 3.Exception 4.throw 用户自定 ...
随机推荐
- 【C/C++】c文件重点总结
c文件重点知识总结 程序文件数据文件--->分文本文件(ASCII文件)和映像文件(二进制文件) .区分是用记事本打开后能否看懂. 用二进制文件读写花费时间少,因为用文本文件需要有一个转换的过程 ...
- 一条命令停止所有lxc容器,删除所有lxc容器
for i in $(virsh -c lxc:/// list | grep -v 'Id' | awk '{print $2}');do virsh -c lxc:/// destroy ${i} ...
- Codeforces1101G (Zero XOR Subset)-less 【线性基】【贪心】
题目分析: 考虑到这是一个区间的异或问题,不妨求出前缀和,令$sum[i] = Xor_{j=1}^{i}a[j]$. 对于区间$[l,r]$的异或结果,等于$sum[r] \oplus sum[l- ...
- 【XSY2714】大佬的难题 数学 树状数组
题目描述 给你三个排列\(A,B,C\),求 \[ \sum_{1\leq x,y\leq n}[a_x<a_y][b_x<b_y][c_x<c_y] \] \(n\leq 2\ti ...
- 「2017 Multi-University Training Contest 1」2017多校训练1
1001 Add More Zero(签到题) 题目链接 HDU6033 Add More Zero 找出最大的k,使得\(2^m-1\ge 10^k\). 直接取log,-1可以忽略不计. #inc ...
- 执行sql脚本保留操作日志
需求场景,操作数据库场景较多,无专业dba,腾讯云mysql虽然提供了类似于phpmyadmin的管理后台,但是操作卡,效率低 #!/usr/bin CDATE=`date +%Y%m%d-%H%M% ...
- Get The Treasury HDU - 3642(体积扫描线)
给出n个立方体,要你求这些立方体至少被覆盖三次的部分. 先把这个立方体的信息存在来,发现Z的范围不大,z范围是是[-500,500],所以我们可以先离散化,然后枚举Z, 然后对于每一段Z的区域内,在当 ...
- 单片机的编程语言和开发环境 LET′S TRY“嵌入式编程”: 3 of 6
单片机的编程语言和开发环境 LET′S TRY“嵌入式编程”: 3 of 6 本连载讲解作为嵌入式系统开发技术人员所必需具备的基础知识.这些基础知识是硬件和软件技术人员都应该掌握的共通技术知识. 在“ ...
- hdu 2516(Fibonacci博弈博弈)
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2516 Problem Description 1堆石子有n个,两人轮流取.先取者第1次可以取任意多个, ...
- ArcGIS for qml -设置地图和视域中心
源码:https://github.com/sueRimn/ArcGIS-for-qml-demos 作者: 狐狸家的鱼 Github: 八至 版权声明:如需转载请获取授权和联系作者 ArcGIS R ...