网上的教程实在是太恶心了,不是太老,就是有问题,刚参考的一篇文章也有问题。自己记录下来,以后用就方便了,现在一边重新安装一遍,一边记录。笔者亲测,今天是5月29号深夜。

linux用的是centos6.2,yum install subversion,安装svn服务端。本篇操作均为root用户权限。

1.建立svn库目录。

mkdir -p /opt/svndata/repos1

2.建立版本库

svnadmin create /opt/svndata/repos1

3.修改配置文件

  (1)服务器主文件svnserve.conf(据说一定要顶格写)

vi /opt/svndata/repos1/conf/svnserve.conf

[general]
anon-access = none
auth-access = write
password-db = /opt/svndata/repos1/conf/passwd
authz-db = /opt/svndata/repos1/conf/authz
realm = repos1

  (2)用户密码

vi /opt/svndata/repos1/conf/passwd

[users]
wang = hello
king = hello

  (3)权限

vi /opt/svndata/repos1/conf/authz

[groups]
admin = wang
[/]
@admin = rw #可读写的意思
[repos1:/]
king = rw

4.建立启动svn的用户:

useradd svn
passwd svn

  根据提示为用户svn设置密码
  允许用户svn访问版本库:

  chown -R svn:svn /opt/svndata

5.启动svn

svnserve -d –-listen-port 3690 -r /opt/svndata

  如果出现cant bind server socket提示,就是端口被占用了。用下面的命令:

ps -e|grep svnserve

  把出现的id给kill掉,再用上面的命令启动。

6.验证启动状态

  使用命令:

ps -ef|grep  svnserve

  出现如下提示,则说明已经启动

root 6941 1 0 15:07 ? 00:00:00 svnserve -d –listen-port 3690 -r /opt/svndata

7.测试服务器

     命令:svn co svn://127.0.0.1/repos1
                Authentication realm: <svn://192.168.60.10:3690> 92731041-2dae-4c23-97fd-9e1ed7f0d18d
                Password for 'root':
                Authentication realm: <svn://192.168.60.10:3690> 92731041-2dae-4c23-97fd-9e1ed7f0d18d
                Username: server_group

  第一次要输入前面设置的账号和密码,以及linux用户密码,大致内容如上,上面这个是拷贝的别的地方的。最后出现  Checked out revision .. 说明已经ok了。

  还要注意linux的防火墙,端口不通过的话,客户端是访问不了的。

# vi /etc/sysconfig/iptables

添加如下一行,可以参照已有的已经开启的ssh的22端口

-A INPUT -m state --state NEW -m tcp -p tcp --dport 3690 -j ACCEPT

至此,全部ok,网上教程太坑爹,弄了几个小时了。也是第一次配置这个,希望这个能给一些和我一样的人,带来一些帮助。夜深了,晚安了。

linux下svn服务器的搭建的更多相关文章

  1. [svn] linux 下svn服务器的搭建

    1. 下载svn(subversion) yum install subversion 2.查看svn位置(其实看不看都无所谓) 3.创建svn版本库目录 svnadmin create /home/ ...

  2. linux(centos7)下SVN服务器如何搭建

    linux(centos)下SVN服务器如何搭建?说到SVN服务器,想必大家都知道,可以是在LINUX下如何搭建SVN服务器呢?那么今天给大家分享一下linux(centos)搭建SVN服务器的思路! ...

  3. Linux下SVN服务器搭建配置

    Linux下SVN服务器搭建配置 1.SVN服务安装 yum install subversion 2.创建SVN代码仓库 mkdir /data/svn svnadmin create /data/ ...

  4. centos7下SVN服务器如何搭建

    Centos7 搭建svn服务器 linux(centos)下SVN服务器如何搭建?说到SVN服务器,想必大家都知道,可以是在LINUX下如何搭建SVN服务器呢?那么今天给大家分享一下linux(ce ...

  5. Linux 下SVN服务器搭建

    系统环境        RHEL5.4最小化安装(关iptables,关selinux) + ssh + yum 一,安装必须的软件包.  yum install subversion (SVN服务器 ...

  6. Linux 下 SVN服务器搭建

    使用Linux(CentOS)搭建SVN服务器全攻略 虽然在windows上搭建SVN很简单,但是效能却不高,这当然是和linux相比了.然而在linux上搭建SVN却非常繁琐,所以今天这篇文章就来一 ...

  7. Linux下svn服务器搭建

    初次在linux上搭建svn服务器,本来以为很繁琐,其实很简单,主要分为以下几个步骤: 1.  首先安装subversion,命令:yum install subversion 2.  创建svn仓库 ...

  8. linux(centos)下SVN服务器如何搭建

    检测是否符合pptp的搭建环境的要求 使用下面的指令: 123 cat /dev/net/tun如果这条指令显示结果为下面的文本,则表明通过:cat: /dev/net/tun: File descr ...

  9. Linux下SVN服务器搭建(CentOS+Subversion)--转

    svn(subversion)是近年来崛起的版本管理工具,是CVS的接班人.目前,绝大多数开源软件都使用svn作为代码版本管理软件.svn 服务器有2种运行方式:独立服务器和借助apache等web服 ...

随机推荐

  1. Mysql8.0 Public Key Retrieval is not allow错误的解决办法

    在使用Mysql 8.0时重启后启动项目的事后会报错com.mysql.jdbc.exceptions.jdbc4.MysqlNonTransientConnectionException: Publ ...

  2. mysql错误:Can’t create TCP/IP socket (10106) 解决方法

    错误描述 “mysql错误:Can’t create TCP/IP socket (10106)”,目测是socket端口被占用的原因,然后在打开tomcat,报的错误中也包含了“socket”,再一 ...

  3. 浅谈Storm流式处理框架

    Hadoop的高吞吐,海量数据处理的能力使得人们可以方便地处理海量数据.但是,Hadoop的缺点也和它的优点同样鲜明——延迟大,响应缓慢,运维复杂. 有需求也就有创造,在Hadoop基本奠定了大数据霸 ...

  4. socket和udp简介

    socket简介 1.本地的进程间通信(IPC)有很多种方式,例如 队列 同步(互斥锁.条件变量等) 以上通信方式都是在一台机器上不同进程之间的通信方式,那么问题来了 网络中进程之间如何通信? 2. ...

  5. OpenMP 简单的规约

    ▶ 简单的计算和规约 ● 第一种方法,将全局和的指针传入工作函数中进行加和,使用 critical 来控制临界区的访问 #include <stdio.h> #include <st ...

  6. 集合工具类CollectionUtils、ListUtils、SetUtils、MapUtils的使用

    主要用它的isEmpty(final Collection<?> coll)静态方法来判断一个给定的集合是否为null或者是否长度为0.最近才发现此工具类还可以取集合的交集.并集.甚至差集 ...

  7. Python Geoip 获取IP地址经度、纬度

    简介: 除了一些免费的 API 接口,例如 http://ipinfo.io/223.155.166.172 可以得到一些信息外,还可以通过 python-geoip 库来解决这个问题. shell ...

  8. sql的预编译问题

  9. Vue SPA应用中使用Layer的iframe 弹出层,并且传值

    问题来源: BOOS 竟然说喜欢有可移动可最大化的弹出层,这!!! SPA 模式下就是这种引入Vue.js的写法 layer.open({ type: , area: ['840px', '550px ...

  10. MongoServerSettings Members

    The MongoServerSettings type exposes the following members. Constructors   Name Description MongoSer ...