CDH离线安装
1. 安装准备
- 系统:Centos 6
- Cloudera Manager分配如下:

- 安装版本:CDH-5.8.0
- 所需安装文件
- CDH相关
CDH-5.8.0-1.cdh5.8.0.p0.42-el6.parcel
CDH-5.8.0-1.cdh5.8.0.p0.42-el6.parcel.sha1
manifest.json
- Cloudera Manager相关
cloudera-manager-el6-cm5.13.0_x86_64.tar.gz
- 下载地址
http://archive.cloudera.com/cdh5/parcels/5.8/
http://archive.cloudera.com/cm5/cm/5/
- 下载地址
2. 开始安装-服务器环境配置
a) 三台机器配置免密登陆。
在每台服务器分别生成各自的公钥私钥命令如下
ssh-keygen –t rsa –P ‘’ –f ~/.ssh/id_rsa
此时查看 ~/.ssh目录下,会有两个文件,id_rsa(私钥)、id_rsa.pub(公钥)
将id_rsa.pub文件内容拼接到每台服务器的~/.ssh/authorized_keys文件
命令如下
cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys
b) 防火墙关闭
service iptables stop
chkconfig iptables off
如果系统为centos7
systemctl stop firewalld
c) 安装JDK并配置环境变量
在~/.bash_profile中或者/etc/profile中配置
d) 安装NTP,保证节点时间一致
yum install ntp -y
chkconfig ntpd on
ntpdate cn.pool.ntp.org
e) 安装配置mysql,在CM-SERVER(231)节点
yum install mysql-server
mysqld start
chkconfig mysqld on
chkconfig –list mysqld
修改权限
GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'yourpassword' WITH GRANT OPTION;
flush privileges;
f) 下载第三方包(每台机器上)
yum install chkconfig python bind-utils psmisc libxslt zlib sqlite cyrus-sasl-plain cyrus-sasl-gssapi fuse fuse-libs redhat-lsb –y
注意:http://192.168.1.231/cdh5/5.10/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
尝试其他镜像。
错误:Cannot retrieve repository metadata (repomd.xml) for repository: cloudera-cdh5. Please verify its path and try again
进入到/etc/yum.repos.d下,将cloudera相关的删掉
rm -rf cloudera-*
3. 安装Cloudera-Manager
a) 每台服务器上新建目录,并上传CM安装文件,解压
mkdir /opt/cloudera-manager
tar –zxvf cloudera-manager-el6-cm5.13.0_x86_64.tar.gz
b) 每台服务器创建用户cloudera-scm
useradd --system --no-create-home --shell=/bin/false --comment "Cloudera SCM User" cloudera-scm
c) 配置CM Agent
修改文件/opt/cloudera-manager/cm-5.13.0/etc/cloudera-scm-agent/config.ini
指定server是哪台
# Hostname of the CM server.
server_host=bdata31
d) 配置CM Server数据库(server节点做)
将mysql驱动jar包放在目录/usr/share/java下,名称为
mysql-connector-java.jar(必须为此名称)
给新建的用户添加mysql权限
grant all on *.* to 'root'@'%' identified by 'dpibigdata' with grant option;
flush privileges;
给CM配置mysql
cd /opt/cloudera-manager/cm-5.13.0/share/cmf/schema/
./scm_prepare_database.sh mysql cloudera -h bdata31 -uroot -pdpibigdata --scm-host bdata31 scm scm scm
依次对应数据库类型、数据库、数据库所在服务器、用户名、密码、cm service服务器
看到
All done, your SCM database is configured correctly!
说明配置成功
e) 创建parcel目录
Server节点
mkdir -p /opt/cloudera/parcel-repo
chown cloudera-scm:cloudera-scm /opt/cloudera/parcel-repo
Agent节点
mkdir -p /opt/cloudera/parcels
chown cloudera-scm:cloudera-scm /opt/cloudera/parcels
f) 将这三个文件放入server的/opt/cloudera/parcel-repo下
CDH-5.8.0-1.cdh5.8.0.p0.42-el6.parcel
CDH-5.8.0-1.cdh5.8.0.p0.42-el6.parcel.sha1
manifest.json
注意:需要将CDH-5.8.0-1.cdh5.8.0.p0.42-el6.parcel.sha1改为
CDH-5.8.0-1.cdh5.8.0.p0.42-el6.parcel.sha
否则在安装页面会检测不到parcel包
4. 启动CM
a) 启动cm-server(server节点)
cd /opt/cloudera-manager/cm-5.13.0/etc/init.d/
./cloudera-scm-server start
server首次启动会自动创建表以及数据,不要立即关闭或重启,否则需要删除所有表及数据重新安装
可监控server的日志
tail -f cloudera-scm-server.log
看到此行说明启动成功,可以进行下一步操作
2017-11-17 12:17:39,288 INFO WebServerImpl:com.cloudera.server.cmf.WebServerImpl: Started Jetty server.
b) 启动cm-agent(agent节点)
cd /opt/cloudera-manager/cm-5.13.0/etc/init.d
./cloudera-scm-agent start
5. 此时可以访问server服务器7180节点来安装CDH
用户名密码都是admin

选择免费版本->继续

选择免费版本


为CDH集群安装指定主机
192.168.1.231,192.168.1.232,192.168.1.233
点击搜索可看到结果列表,当前受管应该都为是,否则说明agent有问题


直接使用本地JDK,不需要勾选

此处不选择单用户模式,继续

填写服务器密码,继续


注意:
BEGIN host -t PTR 192.168.1.231
231.1.168.192.in-addr.arpa domain name pointer bogon.
END (0)
using bogon as scm server hostname
BEGIN which python
/usr/bin/python
END (0)
BEGIN python -c 'import socket; import sys; s = socket.socket(socket.AF_INET); s.settimeout(5.0); s.connect((sys.argv[1], int(sys.argv[2]))); s.close();' bogon 7182
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "<string>", line 1, in connect
socket.gaierror: [Errno -2] Name or service not known
END (1)
could not contact scm server at bogon:7182, giving up
waiting for rollback request
有可能是因为重启agent的时候supervisord进程没关掉
ps -ef|grep supervisord
kill -9 进程ID

检查完成

选择自定义服务

选择HDFS Hive YARN

配置节点信息

配置hive数据库


默认,继续

等待安装完成,继续

完成。
CDH离线安装的更多相关文章
- CDH 离线安装 CM
CDH支持Yum包,Tar包,RPM包,Cloudera Manager(CM)四种安装方式 Cloudera Manager(CM) 用于CDH集群管理,可进行节点安装,配置,服务管理等,提供Web ...
- CDH离线安装之安装包下载地址
cloudermanager安装包地址:http://archive.cloudera.com/cm5/cm/5/cloudera-manager-el6-cm5.3.0_x86_64.tar.gz, ...
- CentOS 6.4 离线安装 Cloudera 5.7.1 CDH 5.7.1
因为项目开发需要要在本地组建一个Hadoop/Spark集群,除了Hadoop/Spark还要同时安装多个相关的组件,如果一个个组件安装配置,对于一个由多台服务器组成的集群来说,工作量是巨大的. 所以 ...
- CDH平台搭建解决离线安装依赖包的方法
背景介绍: 1CDH开发平台在搭建的过程中,会遇到各种各样的问题,其中的各种依赖就是一个很让人头痛的问题.如果安装脚本文件出现了这种问题,那么就可以把以下的这种方法加入shell中,但是不要用yum来 ...
- CentOS 7离线安装CDH 5.16.1完全指南(含各种错误处理)
安装包下载 1.CM软件包下载 从http://archive.cloudera.com/cm5/redhat/7/x86_64/cm/5.16.1/RPMS/x86_64/下载rpm包,如下: 其实 ...
- Ubuntu14.04用apt在线/离线安装CDH5.1.2[Apache Hadoop 2.3.0]
目录 [TOC] 1.CDH介绍 1.1.什么是CDH和CM? CDH一个对Apache Hadoop的集成环境的封装,可以使用Cloudera Manager进行自动化安装. Cloudera-Ma ...
- 离线安装Cloudera Manager 5和CDH5(最新版5.1.3) 完全教程
关于CDH和Cloudera Manager CDH (Cloudera's Distribution, including Apache Hadoop),是Hadoop众多分支中的一种,由Cloud ...
- Coudera-Manager/CDH的安装和部署
由于之前部署的集群采用的是用apache hadoop的方式来实现,但是考虑到运维的成本问题,下面将apache hadoop转换成cloudera cdh.下面主要讲解一下cloudera cdh的 ...
- CDH-5.4.3离线安装
使用CM离线安装CDH-5.4.3,如下: cdh5.4.3安装 配置/etc/hosts vim /etc/hosts 192.168.10.1 s1 192.168.10.2 s2 192.168 ...
随机推荐
- Python的 numpy中 meshgrid 和 mgrid 的区别和使用
一.meshgrid函数 meshgrid函数通常使用在数据的矢量化上. 它适用于生成网格型数据,可以接受两个一维数组生成两个二维矩阵,对应两个数组中所有的(x,y)对. 示例展示: 由上面的示例展示 ...
- invalid configuration x86_64-unknown-linux-gnu' machine x86_64-unknown' not recognized
转载自:http://blog.csdn.net/php_boy/article/details/7382998 前两天在装机器软件的时候, 出现了下面的错误, invalid configurati ...
- JavaScript和JQuery中的事件\委托链\事件冒泡\事件捕获,兼容所有浏览器
有做过北大青鸟培训讲师经验的我,如今在一家公司做技术部经理的职位,发现有很多程序员的基本功相当糟糕,在组织企业内部培训时讲解了一些案例,总结了一些经典代码,希望对自己和有需要的人提供一些帮助吧: Ja ...
- android使用JsonWriter拼json字符串
JsonWriter使用 Example: 拼一个如下的json格式String { [ { "id": 912345678901, ...
- iOS_21团购_Popover适应iPad横竖屏切换
终于效果图: 代码片段: // // DockItemLocation.m // 帅哥_团购 // // Created by beyond on 14-8-13. // Copyright (c) ...
- failed to load selinux policy freezing
一.原因: 在修改selinux配置文件时输入并保存了一个错误的配置参数. 二.挽救: 1. 重启系统. 2. 在启动选项上按 e. 3. 进入grub编辑页面. 4. 向下移动光标至fi下一行. 5 ...
- jquery中常见问题及解决办法小结
1 在开发开放聊天室的过程中,遇到使用ajax提交表单插入数据库时会插入两条数据的情况 解决办法,在ajax函数返回后,return false. $("#btn").click( ...
- linux安装php环境,yum安装php环境
用yum来管理安装Apache PHP Mysql的基本安装.1. 安装Apahce, PHP, Mysql, 以及php连接mysql库组件.yum -y install httpd php mys ...
- C++中虚基类在派生类中的内存布局
今天重温C++的知识,当看到虚基类这点的时候,那时候也没有太过追究,就是知道虚基类是消除了类继承之间的二义性问题而已,可是很是好奇,它是怎么消除的,内存布局是怎么分配的呢?于是就深入研究了一下,具体的 ...
- Jquery—Jquery异步功能实例
Jquery确实是一个非常好的JavaScript框架,今天利用闲暇时间给大家一个借助Jquery异步实现校验username的唯一性的样例: 代码1--index.jsp文件: <%@ pag ...