Linux中如何安装loadgenerator
/* 1. 到官方网站到HP官网下载Load Generator 安装文件 _Load_Generator_11.00_T7330-15010.iso或者其它网站下载loadrunner-11-load-generator.iso
2.确认linux下安装c++,或者安装了c++但是与Load Generator 解析的c++文件不匹配时需要下载c++包,我这里下载的是:compat-libstdc++-33-3.2.3-69.el6.i686.rpm
确认安装c++命令:rpm - q(ps:-与q之间有空格,出现usage)
安装c++包命令:rpm -ivh compat-libstdc++-33-3.2.3-69.el6.i686.rpm(ps:-与ivh之间没有空格)
安装包地址已共享:安装linux下loadrunner所需软件
3.解压loadrunner-11-load-generator.iso,解压改文件需先创建一个空目录用于挂载解压后的文件
eg:
第一步:先创建一个目录用于存放loadrunner-11-load-generator.iso和libstdc++-33-3.2.3-69.el6.i686.rpm;
mkdir /sysvol/must_soft
第二步:创建一个空目录用于挂载解压后的文件
mkdir /sysvol/loadrunner
第三步:解压loadrunner-11-load-generator.iso
mount -o loop loadrunner-11-load-generator.iso /sysvol/loadrunner
(ps:这里使用loop挂载:使用loop的原因)*/
以上部分可以忽略,因为很麻烦,引起多种问题
解压成功后能看到挂载目录,并且解压之后解压目录有三个文件:Hp Linux Solaris(为了方便,直接在windows中解压好,然后把linux文件夹通过FTP上传到Linux服务器中)
第四步:进入Linux 目录执行./installer.sh。在运行installer.sh时会提示没有某某文件没有执行权限,此时在Linux目录中运行命令:chmod +x -R * ,就会给该目录下的所有shell文件赋予执行权限,再次执行./installer.sh成功,然后依次选择:n----a----i----f 即安装完毕,安装完成之后的loadrunner的执行目录在/opt/HP/HP_LoadGenerator(默认位置)
4.配置环境:
(1)查看自己的环境下是哪一种shell ( echo $0),我的环境下查看的为:/bin/bash
【1】添加用户:useradd -g 0 -s /bin/bash hpload
【2】在root用户下,/root/.bashrc中添加环境变量:
(这些环境变量来自于/opt/HP/HP_LoadGenerator/ env.csh)
export PRODUCT_DIR=/opt/HP/HP_LoadGenerator
export M_LROOT=$PRODUCT_DIR
export LD_LIBRARY_PATH=${M_LROOT}/bin
export PATH=${M_LROOT}/bin:$PATH
执行:source /root/.bashrc
(2)验证loadrunner是否安装成功
[1]切换到hpload用户:su hpload
[2]cd /opt/HP/HP_LoadGenerator/bin/
./verify_generator
若出现以下图1,表示刚刚在/root/.bashrc下的环境变量设置成功
若出现以下图2,表示刚刚的环境变量设置失败,需重设图2:
图2
出现图一:表示还需要设置一下DISPLAY环境变量
设置方法:在终端:export DISPLAY=192.168.8.188:0.0(ps:192.168.8.188为controller 服务器即当前linux服务器的ip)
如果在用户hp_load中无法export换成root用户重新export再切换到hp_load用户,执行确认是否安装成功的命令
(cd /opt/HP/HP_LoadGenerator/bin/;./verify_generator),出现下图表示刚刚的export成功
此时验证是否成功已经不报:verify_generator must have a DISPLAY set, please set and rerun;而是报/tmp的权限问题。现在把/tmp目录改成777的权限即可:命令为:chmod 777 /tmp(ps :此操作需要在root用户下执行);再进行上一步的操作,出现下图所示:
[hp_load@localhost bin]$ ./verify_generator
===================================================
HP
Vuser Environment Verification Utility
===================================================
Product: LoadRunner 11.0
Version: 11.0.0.8866
Build: 8866
localhost.Infoworks:
verify_generator...OK
verify_generator...OK
verify_generator...OK
Don't forget to make sure that the name of the controller machine
is also in .rhosts
Verify $M_LROOT ...Failed
_____It was not possible to set the $M_LROOT from
_____the shell dot files. One of several things might be happening:
_____1) $M_LROOT is not set at all in the shell dot files.
_____2) There is some error in the shell dot files which stops their execution
_____ before it sets $M_LROOT.
_____3) There is conditional code in the shell dot files (most likely related to
_____ interactive and non interactive shells) and $M_LROOT is set
_____ only in one of the sections.
_____Aborting virtual user tests on host localhost.Infoworks
verify_generator...OK
_______________________________________________
Summary:
________
Vuser Host localhost.Infoworks: Failed
验证ok,(ps:Vuser Host localhost.Infoworks: Failed此错误目前没有影响loadrunner代理的正常启动,暂不用考虑)
5.启动linux下的loadrunner负载
cd /opt/HP/HP_LoadGenerator/bin
[hp_load@localhost bin]$ ./m_daemon_setup start
m_agent_daemon ( 7001), 
出现上述则表示已经启动成功
在启动m_daemon_setup 时根据linux系统的不同可能会报错,我的是centOS6.5,安装时报以下错误
错误1:/lib/ld-linux.so.2: bad ELF interpreter: No such file or directory问题
解决:直接执行命令yum install glibc.i686,安装glibc
错误2:error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
解决:执行命令yum install libstdc++.so.5 ,安装libstdc
解决了以上错误后再次执行./m_daemon_setup start 成功,注意不能使用root用户启动,如果想要连接该负载机,必须关闭该服务器防火墙或是设置防火墙策略
讲到这里安装步骤就完,现在讲如何在Windows 系统下启用 刚才安装的Load Generator
1. 打开Controller 的Load Generator 。 点击 场景--> Load Generator

2. 添加一个Load Generator 。点击 添加--> 输入名称(名称即ip)--> 选择平台 --> 点击更多 --> 点击 Unix 环境 --> 勾选“不使用RSH” --> 确定

3. 添加后测试连接,如果显示连接成功就功造成了,连接时如果有其它问题建议大家多思考,注意那些连接不成功的提前。我个人觉得LoadRunner 在提示之方面做的比较好,出了问题基本上看提示就知道问题在哪里。祝大家一切顺利。

linux下loadrunner 的ip地址欺骗:
步骤一:添加虚拟网卡,用于配置可以欺骗的ip地址(注:用于ip地址欺骗的地址必须保证无人正在使用,一般公司里需要向it部门申请空闲ip地址段,以免照成网络使用混乱)
一般写脚本用于添加虚拟网卡:
直接配置虚拟网卡: eg: ifconfig em1:2 192.168.82.111 netmask 255.255.252.0
add_network.sh
#!/bin/bash
ifconfig em1:1 192.168.82.110 netmask 255.255.252.0
ifconfig em1:2 192.168.82.111 netmask 255.255.252.0
ifconfig em1:3 192.168.82.112 netmask 255.255.252.0
-----ip地址192.168.82.110~192.168.82.112均为空闲ip并且能够连接需要测试的服务器ip
网卡配置完之后如下图所示:
使用ip欺骗时需注意:
1.要使用it部门给的可用ip列表,防止云平台的ip使用混乱
2.使用完成之后最好释放ip资源(如果用xp就直接释放;如果用linux就service network restart就会还原)
Linux中如何安装loadgenerator的更多相关文章
- linux中编译安装Apache、PHP、MySQL(上)
1.简介 在阿里云买了个云服务器,一直没时间折腾.过了近十天了吧,才有时间好好玩玩这个云服务器.自己是做Web开发的,所以我需要的开发环境是LAMP.之前打算是采用yum安装,不过yum安装apach ...
- Linux中redis安装配置及使用详解
Linux中redis安装配置及使用详解 一. Redis基本知识 1.Redis 的数据类型 字符串 , 列表 (lists) , 集合 (sets) , 有序集合 (sorts sets) , 哈 ...
- Linux中Nginx安装与配置详解
转载自:http://www.linuxidc.com/Linux/2016-08/134110.htm Linux中Nginx安装与配置详解(CentOS-6.5:nginx-1.5.0). 1 N ...
- Linux中如何安装Apache服务器
Linux中如何安装Apache服务器 由于学习的需要,所有手动安装了一下Apache源码包,安装过程中的问题千奇百怪,但是如果弄清楚了问题出在哪里,那么也不是太难.如果有学习者出现安装中的问题,可仔 ...
- Linux课程---11、Linux中软件安装和调试
Linux课程---11.Linux中软件安装和调试 一.总结 一句话总结: 启动过程:1.安装软件,2.修改配置文件,3.启动服务 查看过程:4.查看进程,5.查看端口 关闭过程:6.关闭软件,7. ...
- linux中Nginx安装
linux中Nginx安装 编译安装 Nginx的优点太多,这里不再赘述,详情请看这篇博客深入理解nginx. Nginx的安装有rpm包安装.编译安装和docker安装.本文将介绍编译安装方 ...
- linux中RabbitMQ安装教程
linux中RabbitMQ安装教程 在做一个微服务项目时候用到消息队列,于是深入了解了消息队列知识,并在linux上安装了Rabbitmq,本博客介绍Rabbitmq的安装教程,想要深入了解消息队列 ...
- linux中rpm安装
目录 一:linux中rpm安装 1.rpm简介 2.区别 3.RPM命令五种基本模式 二:RPM安装全面解析 1,下载软件包 2, 安装软件包 3, 尝试卸载 4, 更新(升级) 5,软件包名称: ...
- 【转】Linux中如何安装.rpm、.tar、.tar.gz和tar.bz2
我以下面三个包为例:(三个包都在/etc/opt下)A.example-1.2.3-1.rpmB.example-1.2.3-1.tarC.example-1.2.3-1.tar.gz 1.对于rpm ...
随机推荐
- python-组播
#!/usr/bin/python #coding=utf-8 #发送端 import sys,struct,socket from time import sleep message="h ...
- leetcode1:线性表
//定义二维数组int **array = new int*[row_num]; ;i<row_num;i++) { array[i] = new int[col_num]; } vector& ...
- linux ssh 免密码登录的配置过程
# ssh-keygen -t rsa -C "自定义描述" -f ~/.ssh/自定义生成的rsa文件 # cd ./.ssh # touch config # 粘贴 Host ...
- Delphi下OpenGL2d绘图(05)-画图片Bmp
一.前言 找了不少资料,要画图片要先处理一下,需要引用别的单元,Delphi中没带,需要另外下载Gl.pas.看网上说是自带的OpenGl单元封装的是1.0版的,有此函数未声明.网上可以找到Gl.pa ...
- ubuntu上安装R的时候遇到的问题总结
首先感谢这两篇博客的指导,第一篇是关于报错的总结,第二篇是第一篇中没有提到的错误,也就是我在安装的时候出现的错误. 1.下载R包 (去官网选择一个离你最近的镜像网址,我的是清华提供的镜像下载速度比较快 ...
- [转]How to get return values and output values from a stored procedure with EF Core?
本文转自:https://stackoverflow.com/questions/43935345/how-to-get-return-values-and-output-values-from-a- ...
- Docker学习之Centos7下安装
Docker学习之Centos7下安装 centos7 64下直接使用yum安装docker环境,步骤如下: 卸载旧版本docker sudo yum remove docker docker-com ...
- 后台UI模板开发规范
AdminLTE模板 在接触新模板之前,需要对bootstrap有初步了解,文档戳这里 主要是了解有哪些控件.样式.元素 可以直接follow使用(形成需要什么的时候直接去查文档的意识,而不是都自己 ...
- PHP高级工程师面试 - 笔试题
Part1:HTTP协议 1.状态码的含义 1xx(临时响应) 表示临时响应并需要请求者继续执行操作的状态代码. 代码 说明 100 (继续) 请求者应当继续提出请求. 服务器返回此代码表示已收到请求 ...
- 设计模式之——外观or门面模式
1.概念 定义一个高层的统一的外观接口类,该接口用于客户端调用,和一个实现类用来包装子系统中多个类,客户端可以通过客户端完成对子系统的方法调用. 2.适用场景 2.1 代码移植,降低了现有系统的复杂度 ...