binlog_format='mixed'
(root@g1-db-test-v01:3306)[(none)]>use test;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A Database changed
(root@g1-db-test-v01:3306)[test]>update db1.t2 set name='haha' where id=105;
Query OK, 1 row affected (0.00 sec)
Rows matched: 1 Changed: 1 Warnings: 0 (root@g1-db-test-v01:3306)[test]>use db1;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A Database changed
(root@g1-db-test-v01:3306)[db1]>delete from test.t1 where id=11;
Query OK, 1 row affected (0.02 sec)
 
假如使用mysqlbinlog恢复db1的数据,命令加上参加 -d :
mysqlbinlog -d db1 test-mysql-bin.000115 > 115d.sql
 
/*!50530 SET @@SESSION.PSEUDO_SLAVE_MODE=1*/;
/*!40019 SET @@session.max_insert_delayed_threads=0*/;
/*!50003 SET @OLD_COMPLETION_TYPE=@@COMPLETION_TYPE,COMPLETION_TYPE=0*/;
DELIMITER /*!*/;
# at 4
#170809 15:38:35 server id 1882073306 end_log_pos 120 CRC32 0x9c11ffa3 Start: binlog v 4, server v 5.6.23-72.1-log created 170809 15:38:35
# Warning: this binlog is either in use or was not closed properly.
BINLOG '
+7uKWQ/aKC5wdAAAAHgAAAABAAQANS42LjIzLTcyLjEtbG9nAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAEzgNAAgAEgAEBAQEEgAAXAAEGggAAAAICAgCAAAACgoKGRkAAaP/
EZw=
'/*!*/;
# at 120
#170809 15:39:20 server id 1882073306 end_log_pos 198 CRC32 0x58ea2e3a Query thread_id=75 exec_time=0 error_code=0
SET TIMESTAMP=1502264360/*!*/;
SET @@session.pseudo_thread_id=75/*!*/;
SET @@session.foreign_key_checks=1, @@session.sql_auto_is_null=0, @@session.unique_checks=1, @@session.autocommit=1/*!*/;
SET @@session.sql_mode=1073741824/*!*/;
SET @@session.auto_increment_increment=1, @@session.auto_increment_offset=1/*!*/;
/*!\C utf8 *//*!*/;
SET @@session.character_set_client=33,@@session.collation_connection=33,@@session.collation_server=33/*!*/;
SET @@session.lc_time_names=0/*!*/;
SET @@session.collation_database=DEFAULT/*!*/;
BEGIN
/*!*/;
# at 198
# at 313
#170809 15:39:20 server id 1882073306 end_log_pos 344 CRC32 0xb2671190 Xid = 32389
COMMIT/*!*/;
# at 344
#170809 15:41:05 server id 1882073306 end_log_pos 422 CRC32 0x4befc6fe Query thread_id=75 exec_time=0 error_code=0
SET TIMESTAMP=1502264465/*!*/;
BEGIN
/*!*/;
# at 422
#170809 15:41:05 server id 1882073306 end_log_pos 526 CRC32 0x2b0ef4d4 Query thread_id=75 exec_time=0 error_code=0
use `db1`/*!*/;
SET TIMESTAMP=1502264465/*!*/;
delete from test.t1 where id=11
/*!*/;
# at 526
#170809 15:41:05 server id 1882073306 end_log_pos 557 CRC32 0xb34d26a0 Xid = 32473
COMMIT/*!*/;
DELIMITER ;
# End of log file
ROLLBACK /* added by mysqlbinlog */;
/*!50003 SET COMPLETION_TYPE=@OLD_COMPLETION_TYPE*/;
/*!50530 SET @@SESSION.PSEUDO_SLAVE_MODE=0*/;
(END)

上面的binlog只记录了 delete from test.t1 where id=11

 
描述这样一种场景,上述案例本想恢复update那一条数据,结果只能恢复delete那一条。
而delete的却是test库的表,如果在测试环境进行恢复,因只需恢复db1,没有创建test库,则恢复时会报错,恢复终止。
 
也就是说,在binlog_format='statement/mix'时,如果mysqlbinlog 不加 --database(-d)参数,解析的binlog里记录所有变更sql。但如果增加了 --database db1,则只记录use db1后面的变更sql
 
这样有一个问题,如果db1里的一张表 t1被删除了,我们想恢复。按照一般方法,是先使用最近备份恢复db1所有数据(因为按库备份),然后使用mysqlbinlog恢复db1的数据到drop t1前一刻,此时使用mysqlbinlog 如果加了 --databae=db1,那在有跨库操作的情况下,会遗漏部分sql;而如果不加 --database=db1,那就更没法恢复了,因为之前只使用了db1的备份先恢复的,也就是只恢复了db1。综上,不加--database的话,就要将所库都先恢复一遍,然后使用mysqlbinlog不加参数继续恢复。
 
当设置row模式时,则不存在这种问题。
binlog_format='row'

(root@g1-db-test-v01:3306)[(none)]>use test;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A Database changed
(root@g1-db-test-v01:3306)[test]>update db1.t2 set name='hehe' where id=105;
Query OK, 1 row affected (0.00 sec)
Rows matched: 1 Changed: 1 Warnings: 0 (root@g1-db-test-v01:3306)[test]>use db1;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A Database changed
(root@g1-db-test-v01:3306)[db1]>delete from test.t1 where id=10;
Query OK, 1 row affected (0.02 sec)
 
mysqlbinlog --base64-output=decode-rows -vv -d db1 test-mysql-bin.000116 > 116d.sql
 
/*!50530 SET @@SESSION.PSEUDO_SLAVE_MODE=1*/;
/*!40019 SET @@session.max_insert_delayed_threads=0*/;
/*!50003 SET @OLD_COMPLETION_TYPE=@@COMPLETION_TYPE,COMPLETION_TYPE=0*/;
DELIMITER /*!*/;
# at 4
#170809 16:28:12 server id 1882073306 end_log_pos 120 CRC32 0x6c11777a Start: binlog v 4, server v 5.6.23-72.1-log created 170809 16:28:12
# Warning: this binlog is either in use or was not closed properly.
# at 120
#170809 16:28:51 server id 1882073306 end_log_pos 192 CRC32 0x256a9f3c Query thread_id=78 exec_time=0 error_code=0
SET TIMESTAMP=1502267331/*!*/;
SET @@session.pseudo_thread_id=78/*!*/;
SET @@session.foreign_key_checks=1, @@session.sql_auto_is_null=0, @@session.unique_checks=1, @@session.autocommit=1/*!*/;
SET @@session.sql_mode=1073741824/*!*/;
SET @@session.auto_increment_increment=1, @@session.auto_increment_offset=1/*!*/;
/*!\C utf8 *//*!*/;
SET @@session.character_set_client=33,@@session.collation_connection=33,@@session.collation_server=33/*!*/;
SET @@session.lc_time_names=0/*!*/;
SET @@session.collation_database=DEFAULT/*!*/;
BEGIN
/*!*/;
# at 192
#170809 16:28:51 server id 1882073306 end_log_pos 246 CRC32 0x285d8d5d Table_map: `db1`.`t2` mapped to number 395
# at 246
#170809 16:28:51 server id 1882073306 end_log_pos 366 CRC32 0xb84daa2e Update_rows: table id 395 flags: STMT_END_F
### UPDATE `db1`.`t2`
### WHERE
### @1=105 /* INT meta=0 nullable=0 is_null=0 */
### @2='haha' /* VARSTRING(90) meta=90 nullable=0 is_null=0 */
### @3='57747ab889255af96b48d65e505382' /* VARSTRING(90) meta=90 nullable=0 is_null=0 */
### @4='' /* VARSTRING(72) meta=72 nullable=0 is_null=0 */
### @5=NULL /* VARSTRING(72) meta=0 nullable=1 is_null=1 */
### SET
### @1=105 /* INT meta=0 nullable=0 is_null=0 */
### @2='hehe' /* VARSTRING(90) meta=90 nullable=0 is_null=0 */
### @3='57747ab889255af96b48d65e505382' /* VARSTRING(90) meta=90 nullable=0 is_null=0 */
### @4='' /* VARSTRING(72) meta=72 nullable=0 is_null=0 */
### @5=NULL /* VARSTRING(72) meta=0 nullable=1 is_null=1 */
# at 366
#170809 16:28:51 server id 1882073306 end_log_pos 397 CRC32 0x74a5b1df Xid = 32558
COMMIT/*!*/;
# at 397
#170809 16:29:07 server id 1882073306 end_log_pos 468 CRC32 0x66079b66 Query thread_id=78 exec_time=0 error_code=0
SET TIMESTAMP=1502267347/*!*/;
BEGIN
/*!*/;
# at 468
# at 519
# at 567
#170809 16:29:07 server id 1882073306 end_log_pos 598 CRC32 0xb3ffd246 Xid = 32583
COMMIT/*!*/;
DELIMITER ;
# End of log file
ROLLBACK /* added by mysqlbinlog */;
/*!50003 SET COMPLETION_TYPE=@OLD_COMPLETION_TYPE*/;
/*!50530 SET @@SESSION.PSEUDO_SLAVE_MODE=0*/;
(END)

binlog_format不同模式下,对mysqlbinlog恢复的影响的更多相关文章

  1. CentOS下利用mysqlbinlog恢复MySQL数据库

    如果不小心对数据库进行误操作,而又没有及时备份怎么办?这恐怕是广大的coder经常遇到的一类问题.我今天就因为不小心删除了某个数据库,但最后的备份是1个礼拜前的,唯一能解决的办法就是通过mysqlbi ...

  2. 使用 “恢复模式” 或 “DFU 模式” 来更新和恢复 iOS 固件

    请访问原文链接:https://sysin.org/article/apple-ios-dfu/,查看最新版.原创作品,转载请保留出处. 作者:gc(at)sysin.org,主页:www.sysin ...

  3. Oracle在归档模式下恢复

    =============== 数据库的完全恢复 =============== 在归档模式下数据库完全恢复时,数据库所经过的状态如下: 1.利用备份修复(Restores)损坏或丢失的数据文件,即将 ...

  4. 非归档模式下使用Rman进行备份和恢复

    实验环境: 一.首先进行全库数据备份: 在非归档模式下,rman备份需要在mount模式下进行 SQL> select status from v$instance; STATUS ------ ...

  5. sql server 备份与恢复系列三 简单恢复模式下的备份与还原

    一.概述 前面讲了备份的一些理论知识,这篇开始讲在简单恢复模式下的备份与还原.在简单模式下是不能做日志备份的,发生灾难后,数据库最后一次备份之后做的数据修改将是全部丢失的,所以在生产环境下,数据又很重 ...

  6. 使用alter database datafile 'XXX' offline drop 是否能够恢复(非归档模式下)

    今天在群里面听到一位网友在说使用了alter database datafile 'XXX' offline drop命令是否能够恢复数据,在非归档模式下,下面是用一个实验来验证一下 ######## ...

  7. oracle非归档模式下的冷备份和恢复

    查看归档的相关信息 SQL> archive log list数据库日志模式             非存档模式自动存档             禁用存档终点            USE_DB ...

  8. 浅谈SQL Server中的事务日志(四)----在完整恢复模式下日志的角色

    简介 生产环境下的数据是如果可以写在资产负债表上的话,我想这个资产所占的数额一定不会小.而墨菲定律(事情如果有变坏的可能,无论这种可能性有多小,它总会发生)仿佛是给DBA量身定做的.在上篇文章介绍的简 ...

  9. 浅谈SQL Server中的事务日志(三)----在简单恢复模式下日志的角色

    简介 在简单恢复模式下,日志文件的作用仅仅是保证了SQL Server事务的ACID属性.并不承担具体的恢复数据的角色.正如”简单”这个词的字面意思一样,数据的备份和恢复仅仅是依赖于手动备份和恢复.在 ...

随机推荐

  1. LeetCode 之 Longest Valid Parentheses(栈)

    [问题描写叙述] Given a string containing just the characters '(' and ')', find the length of the longest v ...

  2. android的ListView点击item使item展开的做法

    直接上代码把.主要是又一次给item measure高度,直接上代码把 import java.util.ArrayList; import android.app.Activity; import ...

  3. Linux---有关dig命令的有用脚本

    这里直接给出脚本以及运行的效果图,主要推断了一下cdn然后能够直接过滤url.默认就是dig +域名 +short. 脚本qdig(随便能够取一个名字)例如以下: #!/usr/bin/env bas ...

  4. Trie树(Prefix Tree)介绍

    本文用尽量简洁的语言介绍一种树形数据结构 -- Trie树. 一.什么是Trie树 Trie树,又叫字典树.前缀树(Prefix Tree).单词查找树 或 键树,是一种多叉树结构.如下图: 上图是一 ...

  5. 【C语言】推断一个数是否为2的n次方

    //推断一个数是否为2的n次方 #include <stdio.h> int is_two_n(int num) { if ((num&(num - 1))) //去掉一个1,推断 ...

  6. HTTP请求库——axios源码阅读与分析

    概述 在前端开发过程中,我们经常会遇到需要发送异步请求的情况.而使用一个功能齐全,接口完善的HTTP请求库,能够在很大程度上减少我们的开发成本,提高我们的开发效率. axios是一个在近些年来非常火的 ...

  7. C++之new和malloc差别

         在C++程序猿面试中.非常easy被问到new 和 malloc的差别.偶尔在quora上逛.看到Robert Love的总结.才发现自己仅仅知道里面的一两项就沾沾自喜,从来没有像这位大牛一 ...

  8. Replica Sets+Sharding方案之真枪实弹篇

    话说在虚拟机中会报各种错误.在真实的环境中就不会那么痛苦了. 想了一下虚拟机中报错的原因有. 机器卡,处理的时间长就会抛出错误 还有虚拟机假设给的空间太小.也会报异常. 此处讲讲我的大致思路. 第一, ...

  9. TypeError: db.addUser is not a function : @(shell):1:1 ——mongoDB创建新用户名密码的方法

    不多说,旧版本使用 db.addUser("root","root") 新版本使用这句会出现这个错误提示 TypeError: db.addUser is no ...

  10. 剑指offer面试题24-二叉搜索树的后序遍历序列

    题目: /*  * 输入一个整数数组,推断该数组是不是某二叉搜索树的兴许遍历的结果.<br/>  * 假设是则返回true,否则返回false.<br/>  * 如果输入的数组 ...