The error message “Please check for sufficient write file permissions” is generated by the Web-based downloader, known as Magento Connect Manager, which forms part of the Magento eCommerce platform. The Magento eCommerce platform is an open-source platform -- its source code can be downloaded, modified or distributed free of charge -- that is designed for online merchants.

Cause

  • In order to use the Magento Connect Manager for installing, or upgrading, Magento software, you must have write permissions on all Magento files, including the main installation folder, or root folder. If you don’t, the Magento Connect Manager may generate the error message. To prevent the error message, you must add write permissions to the Magento root folder and all files and folders below the root folder. You can do this by entering the root folder and recursively changing the permissions on all the files and folders to “777.” Recursively means entering each folder you find below the root folder and changing the permissions on all the files and folders it contains and so on down the file system hierarchy to the bottom of the directory tree.

File Permissions

  • Under the Unix operating system, file permissions are divided into three groups: “user,” “group” and “other.” Within each group, individual file permissions are represented by the letters r, w and x -- for “read,” “write” and “execute” -- or by the numbers 4, 2 and 1, in binary. The command “chmod 777 {filename}” changes the permissions on {filename} to read, write and execute for everyone.

Adding Write Permissions

  • You can change the file permissions via a File Transfer Protocol (FTP) or Secure Shell (SSH) client. FTP is a software protocol for exchanging information between computers over a network, while SSH is a shell program for executing commands on a remote computer. To change file permissions via an SSH client, log in to your SSH account and type the following Unix commands:
    cd
    find . -type d -exec chmod 777 {} \;
    chmod 666 downloader/config.ini

Removing Write Permissions

  • Once you’ve changed the file permissions, you should be able to access the Magneto Connect Manager to complete the installation or upgrade you’re attempting. However, once you’ve completed the installation or upgrade, you need to remove the write permissions from the files and folders once again. To do this via SSH, type the following commands:
    find . -type d -exec chmod 755 {} \;
    find . -type f -exec chmod 644 {} \;
    chmod o+w var media app/etc/use_cache.ser

Read more : http://www.ehow.com/info_12226902_error-please-check-sufficient-write-file-permissions.html

Error of "Please Check for Sufficient Write File Permissions"的更多相关文章

  1. Magento Connector: Error: Please check for sufficient write file permissions

    请确保下面的文件是可写的: /path/to/your/magento-install/path/to/your/magento-install/downloader/path/to/your/mag ...

  2. centos6.6下编译安装mysql5.6之后启动失败:Starting MySQL... ERROR! The server quit without updating PID file (/var/lib/mysql/localhost.localdomain.pid).

    今天在编译安装mysql5.6时候出现Starting MySQL... ERROR! The server quit without updating PID file (/var/lib/mysq ...

  3. O/S-Error: (OS 23) Data error (cyclic redundancy check)问题处理

    RMAN-03002: backup plus archivelog 命令 (在 08/24/2015 03:31:00 上) 失败ORA-19501: 文件 "XXXXXX.DBF&quo ...

  4. mysql 有报错  ERROR! MySQL is not running, but lock file (/var/lock/subsys/mysql) exists

    sh-4.1# /etc/init.d/mysqld status ERROR! MySQL is not running, but lock file (/var/lock/subsys/mysql ...

  5. 错误提示:LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt 的解决方法

    最近在win7 系统下,打算利用 cmake 生成项目文件,然后用vs2010进行编译.但是在cmake的时候出现错误弹窗:

  6. [转]MySQL: Starting MySQL….. ERROR! The server quit without updating PID file

    转自: http://icesquare.com/wordpress/mysql-starting-mysql-error-the-server-quit-without-updating-pid-f ...

  7. LinkIssue: Error 'LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or cor

    参考:http://blog.csdn.net/junjiehe/article/details/16888197 使用VisualStudio 编译链接中可能出现如下错误: LINK : fatal ...

  8. MySQL: Starting MySQL….. ERROR! The server quit without updating PID file解决办法

    MySQL: Starting MySQL….. ERROR! The server quit without updating PID file解决办法 1 问题 [root@localhost m ...

  9. 错误:error libGL.so: cannot open shared object file: No such file or directory

    Failed to load libGL.soerror libGL.so: cannot open shared object file: No such file or directory 启动e ...

随机推荐

  1. jquery 键盘回车事件

    <input id="search" placeholder="输入要领用的资产条码" id="scanCode" type=&quo ...

  2. mysql 外键 级联

    主表 -- 创建用户信息表 create table userinfo ( userid int primary key not null auto_increment COMMENT '主键', u ...

  3. NPOIExcel

    public class NPOIExcel { private string _title; private string _sheetName; private string _filePath; ...

  4. 比管理员(administrator)更高权限的TrustedInstaller

    http://www.gezila.com/tutorials/9664.html 什么是TrustedInstaller管理权限 ?好多朋友都在使用Windows7系统.在使用过程中,有些朋友在删除 ...

  5. Python for Infomatics 第13章 网页服务一(译)

    注:文章原文为Dr. Charles Severance 的 <Python for Informatics>.文中代码用3.4版改写,并在本机测试通过. 一旦利用程序通过HTTP协议获得 ...

  6. [Leetcode] Roman to Integer

    Given a roman numeral, convert it to an integer. Input is guaranteed to be within the range from 1 t ...

  7. Markdown工具的使用

    Markdown 工具的使用 基本操作 CMD-N 建立一个新的工作表 CMD-SHIFT-N 建立一个新的组 CMD-CTRL-N 建立一个新的过滤器 项目总是会被创建在当前所选的附近 工作表会被创 ...

  8. Java的序列化ID的作用

    Java的序列化ID的作用 简单来说,Java的序列化机制是通过在运行时判断类的serialVersionUID来验证版本一致性的.在进行反序列化时,JVM会把传来的字节流中的serialVersio ...

  9. Windows程序内部运行机制 转自http://www.cnblogs.com/zhili/p/WinMain.html

    一.引言 要想熟练掌握Windows应用程序的开发,首先需要理解Windows平台下程序运行的内部机制,然而在.NET平台下,创建一个Windows桌面程序,只需要简单地选择Windows窗体应用程序 ...

  10. mysql刷日志的两个参数

    innodb_flush_log_at_trx_commit 0:每秒 ----log---disk1:事物提交 ---log ---disk2:事物提交---log 每秒 ---disk sync_ ...