SQL2008报错“请验证实例名称是否正确并且SQL Server已配置为允许远程连接”

第一步:

连接远程服务器时SQL2008报错“请验证实例名称是否正确并且SQL Server已配置为允许远程连接”

报错内容见下图:

解决方法:

1、先连接到本机,

2、然后在对象资源管理器中右键“方面”进入服务器配置页面,

3、选择进入“外围应用配置器”

4、将RemoteDacEnbled的属性设为Ture

5、点击“确定”,搞定!

如果这一步还没解决问题

第二步:

首先查看端口,看有没1433(SQL Server的缺省端口)

1、运行->cmd->netstat –ano

看是否有

TCP    0.0.0.0:1433           0.0.0.0:0              LISTENING       ****

如果没有这一条,远程连接是连不上的

2.数据库引擎没有启动。有两种启动方式: 
(1)开始->程序->Microsoft SQL Server 2005->SQL Server 2005外围应用配置器,在打开的界面单击"服务的连接的外围应用配置器",在打开的界面中找到Database Engine,单击"服务",在右侧查看是否已启动,如果没有启动可单击"启动",并确保"启动类型"为自动,不要为手动,否则下次开机时又要手动启动; 
(2)可打开:开始->程序->Microsoft SQL Server 2005->配置工具->SQL Server Configuration Manager,选中SQL Server 2005服务中SQL Server(MSSQLSERVER) ,并单击工具栏中的"启动服务"按钮把服务状态改为启动; 
使用上面两种方式时,有时候在启动的时候可能会出现错误,不能启动,这时就要查看"SQL Server 2005配置管理器"中的SQL Server 2005网络配置->MSSQLSERVER协议中的VIA是否已启用,如果已启用,则把它禁止.然后再执行上述一种方式操作就可以了.

3.是否已经允许远程连接。这个部分可以简单的分为4个方面,分别是在 SQL Server上启用远程连接、启用SQL Server 浏览服务、在Windows 防火墙中为SQL Server 2005 创建例外和在Windows 防火墙中为“SQLBrowser”创建例外。下面是几个具体的操作方式:
在SQLServer 实例上启用远程连接

(1)指向“开始->程序->Microsoft SQL Server 2005->配置工具->SQL Server 外围应用配置器”

(2)在“SQL Server 2005 外围应用配置器”页, 单击“服务和连接的外围应用配置器”

(3).然后单击展开“数据库引擎”, 选中“远程连接”,在右边选中“本地连接和远程连接”,再选择要使用的协议,( 这个地方应当启用TCP/IP 和命名管道服务!)单击“应用”,您会看到下消息: 
“直到重新启动数据库引擎服务后,对连接设置所做的更改才会生效。”,

单击“确定”按钮返回
(4).展开“数据库引擎”, 选中“服务”,在右边单击“停止”,等到 MSSQLSERVER 服务停止, 
然后单击“启动”,重新启动MSSQLSERVER 服务。

4、启用SQLServer 浏览器服务 (该服务停止时只本机访问)
(1).指向“开始->程序->Microsoft SQL Server 2005->配置工具->SQL Server 外围应用配置器” 
(2).在“SQL Server 2005 外围应用配置器”页, 单击“服务和连接的外围应用配置器” 
(3).然后单击展开“SQL Server Browser”, 选中“服务”,在右边“启动类型”选择“自动”,再单击“启动”,单击“确定”按钮返回

5、打开sql server 2005 的1433端口

开始->程序->Microsoft SQL Server 2005->配置工具->Sql Server Configuration Manager->MSSQLSERVER的协议
 看看TCP/IP协议是否启动,如果启动,右键菜单点"属性" ,在分页菜单中选"IP地址",把     "IP1"和"IP2"中"TCP端口"为1433,"已启用"改为"是"

一定要IPALL的TCP动态端口删除,TCP端口改为1433,只改IP1、IP2不好用,在这个问题很多网上的解决办法都没有明确,走了很多的弯路! 
开始->程序->Microsoft SQL Server 2005配置工具->Sql Server Configuration Manager->SQL Native Client 配置->客户端协议->TCP/IP
选择TCP/IP右键菜单中"属性",确认"默认端口"是1433,"已启用"为"是"(这是最最重要的)

6、在 Windows 防火墙设置,有人索性将防火墙关闭,当然你可以在Windows 防火墙中为“SQL Server 2005”、“SQLBrowser”创建例外

在Windows 防火墙中为“SQL Server 2005”创建例外:

.在 Windows 防火墙设置界面中,选择“ 例外” 选项卡,然后单击“添加程序” 
.在“添加程序窗口”中单击“浏览” 
然后找到“C:/ProgramFiles/Microsoft Files/Microsoft SQL Server/ MSSQL.1 /MSSQL/Binn/sqlservr.exe”,单击“确定”返回 
注意 : 路径可能会根据 SQL Server 2005 安装不同而不同。 MSSQL.1 是占位符,对应数据库实例ID。 
对每个需要打开远程访问的SQL Server 2005 实例,重复步骤 1 至 3。
在Windows 防火墙中为“SQLBrowser”创建例外 
.在 Windows 防火墙设置界面中,选择“ 例外” 选项卡,然后单击“添加程序” 
在“添加程序窗口”中单击“浏览” 
然后找到“C:/ProgramFiles/Microsoft Files/Microsoft SQL Server/90/Shared/sqlbrowser.exe”,
单击“确定”返回

7、再次查看端口,看有没1433(SQL Server的缺省端口)

1、运行->cmd->netstat –ano

TCP    0.0.0.0:1433           0.0.0.0:0              LISTENING       ****

有了

现在进行远程连接就好了!

SQLServer 客户端远程访问配置的更多相关文章

  1. Oracle 远程访问配置 在 Windows Forms 和 WPF 应用中使用 FontAwesome 图标 C#反序列化XML异常:在 XML文档(0, 0)中有一个错误“缺少根元素” C#[Win32&WinCE&WM]应用程序只能运行一个实例:MutexHelper Decimal类型截取保留N位小数向上取, Decimal类型截取保留N位小数并且不进行四舍五入操作

    Oracle 远程访问配置   服务端配置 如果不想自己写,可以通过 Net Manager 来配置. 以下配置文件中的 localhost 改为 ip 地址,否则,远程不能访问. 1.网络监听配置 ...

  2. CAS客户端服务器端配置步骤

    来自我的个人网站:http://lkf.22web.org/ cas介绍: CAS 是 Yale 大学发起的一个开源项目,旨在为 Web 应用系统提供一种可靠的单点登录方法,CAS 在 2004 年 ...

  3. Oracle 客户端安装配置

    电脑上安装了Oracle11G,我远程导出一个10g的数据库数据时,报了错误,猜测可能是我的11G客户端版本的问题.所以下载了10G的客户端 安装. 其实客户端的配置读取的是两个文件监听配置文件lis ...

  4. 8021x 获取IP信息失败,请检查锐捷认证客户端当前配置是否符合所在网络的要求,检查完毕后尝试重新认证

    早上一起床,登陆锐捷客户端上网,谁知道错问题了.不能联网了,锐捷登陆成功,但是一会儿就提示失败,获取IP信息失败了.下面我描述一下问题原因: 锐捷登陆后有认证提示,和往常正常情况一样的,不过有个小感叹 ...

  5. SharePoint 2013+ Sqlserver 2014 Kerberos 配置传奇, 最终的解决方案 验证。

    SharePoint 2013+ Sqlserver 2014 Kerberos 配置传奇. 1,安装数据库,我就不多说安装,客户一定要注意. 我将参照以下实施例和账户. 2,建立DNS,假设没有DN ...

  6. 关于一个WCF调用的服务端和客户端的配置信息集合

    客户端的配置我知道. 但是: httpTransport maxReceivedMessageSize="2147483647" <dataContractSerialize ...

  7. 第十九章——使用资源调控器管理资源(1)——使用SQLServer Management Studio 配置资源调控器

    原文:第十九章--使用资源调控器管理资源(1)--使用SQLServer Management Studio 配置资源调控器 本系列包含: 1. 使用SQLServer Management Stud ...

  8. 第十七章——配置SQLServer(4)——优化SQLServer实例的配置

    原文:第十七章--配置SQLServer(4)--优化SQLServer实例的配置 前言: Sp_configure 可以用于管理和优化SQLServer资源,而且绝大部分配置都可以使用SQLServ ...

  9. chrony时间同步 服务端 客户端 安装配置

    chrony时间同步 服务端 客户端 安装配置 原创内容http://www.cnblogs.com/elvi/p/7658021.html #!/bin/sh #运行环境 centos7 #chro ...

随机推荐

  1. [译] EXTENDING JQUERY – 2.2 A simple plugin

    2.2 一个简单的插件示例 jQuery 插件能做任何事情,这个已经由浩如烟海的各类第三方插件如证明.小到只影响一个元素,大到改变多个元素的外观和行为,jQuery 的各种功能等你来扩展. 2.2.1 ...

  2. html5 svg 圆形进度条

    html5 svg 圆形进度条 <!DOCTYPE html> <html lang="en"> <head> <meta charset ...

  3. Session 类

     Session 类 Session 类可以使用户在浏览您的网站时,维持他们的状态并跟踪他们的行为. Session 类将每个用户的 session 信息序列化(serialize)后存储到到 coo ...

  4. jquery获取radio和select选中值

    //jquery 获取radio选中值 <input type="radio" name="c_type" value="a" > ...

  5. RTP/RTCP的时间同步机制

    转自:http://blog.csdn.net/leesphone/article/details/5571972 RTP支持传送不同codec的steaming,不同codec的clock rate ...

  6. 官方Tomcat 8.0.24 Web漏洞整改记录

    测试环境 web服务器:apache-tomcat-8.0.24-windows-x64 测试工具:Acunetix Web Vulnerability Scanner 9.5 官方Tomcat测试结 ...

  7. github 使用网址

    [Github教程]史上最全github使用方法:github入门到精通 http://blog.csdn.net/hcbbt/article/details/11651229 githup的使用 h ...

  8. Angular JS学习之指令

    1.Angular JS通过称为指令的新属性来扩展HTML:通过内置的指令来为应用添加功能: 2.AngularJS指令:AngularJS指令是扩展的HTML属性,带有前缀ng-: **ng-app ...

  9. javascript优化--11模式(设计模式)02

    策略模式 在选择最佳策略以处理特定任务(上下文)的时候仍然保持相同的接口: //表单验证的例子 var data = { firs_name: "Super", last_name ...

  10. [xsd学习]xsd实例

    以下为一个表示学校的xml文件,学校内有若干学生,每个学生都有基本信息,电脑信息,选课信息 <?xml version="1.0" encoding="UTF-8& ...