eclipse启动tomcat错误:A Java Exception has occurred(转)
在tomcat bin目录下执行startup.bat可以正常启动,但在eclipse下安装了tomcat插件并且配置tomcat路径后启动且报错:A Java Exception has occurred

解决方法,在eclipse中[window][Preferences]找到[tomcat][JVM Settings],在右边的配置页中找到[Classpath (Before generated classpath)],点击[jar/Zip]在弹出的文件选择框中选择tomcat目录下的bin/tomcat-juli.jar文件,如图:

启动tomcat,错误解决!
|
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
|
2013-11-20 21:53:56 [I]-[INFO] [FileOperationFactory] Read the ci base configuration file success!2013-11-20 21:53:56 [I]-[INFO] [FileOperationFactory] Read the ci fields configuration file success!2013-11-20 21:53:56 [I]-[INFO] [FileOperationFactory] Read the database configuration file success!2013-11-20 21:53:56 [I]-[INFO] [FileOperationFactory] Read the ci relation configuration file success!2013-11-20 21:53:57 [I]-[INFO] [FileServer] Neo4j Server started.十一月 20, 2013 9:53:58 下午 org.apache.catalina.startup.HostConfig deployDirectoryINFO: Deploying web application directory D:\tomcat\webapps\mxgraph十一月 20, 2013 9:53:58 下午 org.apache.catalina.startup.HostConfig deployDirectoryINFO: Deploying web application directory D:\tomcat\webapps\mxGraphExamples十一月 20, 2013 9:53:58 下午 org.apache.catalina.startup.HostConfig deployDirectoryINFO: Deploying web application directory D:\tomcat\webapps\ROOT十一月 20, 2013 9:53:58 下午 org.apache.coyote.AbstractProtocol startINFO: Starting ProtocolHandler ["http-nio-8080"]十一月 20, 2013 9:53:58 下午 org.apache.coyote.AbstractProtocol startINFO: Starting ProtocolHandler ["ajp-nio-8009"]十一月 20, 2013 9:53:58 下午 org.apache.catalina.startup.Catalina startINFO: Server startup in 12930 ms |
eclipse启动tomcat错误:A Java Exception has occurred(转)的更多相关文章
- Eclipse启动Tomcat错误:Several ports (8080, 8009) required by Tomcat v6.0 Server at localhost are already(转载)
转载自:http://blog.csdn.net/aigochina/article/details/7891107 Eclipse启动Tomcat错误: Several ports (8080, 8 ...
- Eclipse启动Tomcat错误:Several ports (8080, 8009) required by Tomcat v6.0 Server at localhost are already
Eclipse启动Tomcat错误: Several ports (8080, 8009) required by Tomcat v6.0 Server at localhost are alread ...
- Eclipse启动Tomcat错误(其他类似)
Eclipse启动Tomcat错误信息: Several ports (8080, 8009) required by Tomcat v6.0 Server at localhost are alre ...
- eclipse启动tomcat错误:A Java Exception has occurred
在tomcat bin目录下执行startup.bat可以正常启动,但在eclipse下安装了tomcat插件并且配置tomcat路径后启动且报错:A Java Exception has occur ...
- Eclipse启动Tomcat时发生java.lang.IllegalArgumentException: <session-config> element is limited to 1 occurrence
在学习struts 2时,为了方便,直接从下载的struts的apps目录下的struts2-blank.war压缩包下的WEB-INF\复制的web.xml,当我启动Tomcat时,发生 java. ...
- eclipse启动tomcat错误解决
clipse启动tomcat报出下面的错误提示: 控制台: 九月 06, 2018 9:01:31 下午 org.apache.tomcat.util.digester.SetPropertiesRu ...
- Eclipse 启动出现错误 no java virtual machine was found
出现此问题的原因是eclipse找不到javaw.exe的path,打开eclipse.ini文件: -startup plugins/org.eclipse.equinox.launcher_1.3 ...
- Eclipse启动Tomcat错误:Several ports (8005,8009) required by Tomcat v6.0 Server at localhost are already
解决办法: 1.netstat -aon|findstr 8005 可查看指定端口号使用情况 2.tasklist |findstr 10452 找出占用指定进程Id的程序 3.taskkill /p ...
- Eclipse 运行弹出A Java Exception has occurred.并报错Exception in thread 的解决方案
这个问题是由较高版本的JDK编译的java class文件试图在较低版本的JVM上运行而产生的错误. 1.解决措施就是保证jvm(java命令)和jdk(javac命令)版本一致.如果是linux版本 ...
随机推荐
- CUTE FTP 控制连接已关闭
使用Cute FTP连接FTP站点时,出现上述错误,在另外一台电脑上却可以正常连接. 原因:FTP服务器IP访问规则的限制 解决方法:在ServerU 服务器中进入服务器详细信息配置界面,在IP访问规 ...
- ArcEngine开发 尝试读取或写入受保护的内存。这通常指示其他内存已损坏。
if(pFeature!=null) { IPoint pnt = pFeature.Shape as IPoint; pntArray.Add(pnt); } 调试是pntArray.Add(pnt ...
- Unknown collation: 'utf8mb4_unicode_ci'
日前给一个政府机关做个小的门户网站,用的是wordpress+主题开发,部署时发现导入数据库sql文本时出现Unknown collation: 'utf8mb4_unicode_ci'的错误,查了下 ...
- Bootstrap页面布局18 - BS导航路径以及分页器
导航路径:又叫“面包屑”,功能是让用户知道所处的位置. <!--面包屑--> <ul class='breadcrumb'> <li><a href='#'& ...
- Thread safety
https://en.wikipedia.org/wiki/Thread_safety Thread safety is a computer programming concept applicab ...
- mysql 权限篇
mysql库 user(用户以及所有库权限配置) db(具体库权限配置) 配置完毕要用命令 FLUSH PRIVILEGES; 刷新权限 备份数据库可以直接copy文件的形式,不过这样copy的文件会 ...
- HelloWorld之jetty运行
jetty是一个轻便的嵌入式servlet容器.其启动运行非常简单.eclipse下运行jetty容器有如下几步, 一.建一个普通的java工程 二.把jetty需要的包导入工程分别是jetty-6. ...
- Delphi XE5 与其他版本共存
来源于http://www.board4allcz.eu 作者是gateway 如果你想使用Delphi诸如XE4.XE3.XE2.XE之类的版本跟Delphi XE5共存的话,在cglm.ini中简 ...
- 局部变量、结构体和main函数
在函数中定义的变量称为自动局部变量.因为每次调用该函数时,它们都自动“创建”,并且它们的只对于函数来说是局部的,局部对象的变量都会默认为空.局部变量的值只能在定义该变量的函数中访问,不能从函数之外访问 ...
- cwe