[原]openstack-kilo--issue(十七) heat创建网络Quota exceeded for resources OverQuotaClient: resources.dmz_protected_network_sub
----- 1 -------
在使用heat创建网络的时候,报错如下
INFO heat.engine.stack [-] Stack CREATE FAILED (mmsc_network_stack): Resource CREATE failed: OverQuotaClient: resources.dmz_protected_network: Quota exceeded for resources: ['network']
INFO heat.engine.service [-] Stack create failed, status FAILED
问题点分析:是因为neutron的network数量进行了限制:
vim /etc/neutron/neutron.conf # quota_network =
quota_network = //将默认的10改大,超过需要创建的网络数
重启neutron
]# systemctl restart neutron-dhcp-agent.service neutron-l3-agent.service neutron-metadata-agent.service neutron-openvswitch-agent.service neutron-server.service neutron-ovs-cleanup.service
-------- 2 -------
在使用heat创建网络的时候,解决了网络数量问题依然报错如下:
INFO heat.engine.stack [-] Stack CREATE FAILED (mmsc_network_stack): Resource CREATE failed: OverQuotaClient: resources.dmz_protected_network_sub: Quota exceeded for resources: ['subnet']
INFO heat.engine.service [-] Stack create failed, status FAILED
问题分析,在报错中发现有dmz_protected_network_sub字样,查看子网络的个数是否没有达到需要创建的子网数量并进行修改:
vim /etc/neutron/neutron.conf # quota_subnet =
quota_subnet = //修改subnet数量 # quota_port =
quota_port = # quota_vip =
quota_vip =
重启neutron
]# systemctl restart neutron-dhcp-agent.service neutron-l3-agent.service neutron-metadata-agent.service neutron-openvswitch-agent.service neutron-server.service neutron-ovs-cleanup.service
--- 3-----
解决了子网问题:依然报错如下:
TRACE heat.engine.resource BadRequest: Bad router request: Cidr 10.68.125.0/ of subnet d498b539-9eba-4bfc-91cd-6370b781ba8a overlaps with cidr 10.68.125.0/ of subnet 7e8b4e32-423c-4d5a-b9ae-22cf2e9d3417
TRACE heat.engine.resource
INFO heat.engine.stack [-] Stack CREATE FAILED (mmsc_network_stack): Resource CREATE failed: BadRequest: resources.vmmsc_oam_router_interface: Bad router request: Cidr 10.68.125.0/ of subnet d498b539-9eba-4bfc-91cd-6370b781ba8a overlaps with cidr 10.68.125.0/ of subnet 7e8b4e32-423c-4d5a-b9ae-22cf2e9d3417
INFO heat.engine.service [-] Stack create failed, status FAILED
查看报错说有两个子网重复了,检查yaml文件,果然有两个子网重复
修改为唯一的子网并删除创建失败的stack后,再重新heat创建,
重启neutron
]# systemctl restart neutron-dhcp-agent.service neutron-l3-agent.service neutron-metadata-agent.service neutron-openvswitch-agent.service neutron-server.service neutron-ovs-cleanup.service
问题解决
[原]openstack-kilo--issue(十七) heat创建网络Quota exceeded for resources OverQuotaClient: resources.dmz_protected_network_sub的更多相关文章
- openstack 上床镜像, 创建网络, 创建虚拟机 命令
==================================================================================================== ...
- OpenStack命令 创建网络和路由管理
1.登陆用户 :tdy(前提条件创建了tdy用户) 编写登陆用户tdy用户 脚本文件 user-operc.sh user-operc.sh : 登陆用户tdy: $ source user-ope ...
- OpenStack创建网络和虚拟机、dhcp设备、虚拟路由器、虚拟机访问外网原理分析
创建网络和虚拟机流程: 1.创建网络和子网 背后发生了什么: Neutron让控制节点上针对此子网的dhcp(虚拟设备)启动,用于给该子网下的实例分配ip 2.生成虚拟机 背后发生了什么: 用户通过G ...
- [译] OpenStack Kilo 版本中 Neutron 的新变化
OpenStack Kilo 版本,OpenStack 这个开源项目的第11个版本,已经于2015年4月正式发布了.现在是个合适的时间来看看这个版本中Neutron到底发生了哪些变化了,以及引入了哪些 ...
- openstack第四章:neutron— 网络服务
第四篇neutron— 网络服务 一.neutron 介绍: Neutron 概述 传统的网络管理方式很大程度上依赖于管理员手工配置和维护各种网络硬件设备:而云环境下的网络已经变得非常复杂,特别是 ...
- OpenStack Kilo版加CEPH部署手册
OpenStack Kilo版加CEPH部署手册 作者: yz联系方式: QQ: 949587200日期: 2015-7-13版本: Kilo 转载地址: http://mp.weixin.qq.co ...
- CentOS7安装OpenStack(Rocky版)-06.安装Neutron网络服务(控制节点)
上一章介绍了独立的nova计算节点的安装方法,本章分享openstack的网络服务neutron的安装配制方法 ------------------- 完美的分割线 ----------------- ...
- openstack kilo部署-基础环境
公司也想搞个私有云玩玩,于是展开了一系列的调研,部署测试,openstack 有几个版本真是坑爹!!,如果喜欢被虐有兄弟,你就试试 openstack 的 juno , icehouse等版本,用不了 ...
- Openstack实现共有云多flat网络
首先给两台虚拟机添加网卡,模式为仅主机模式 配置控制节点IP /etc/sysconfig/network-scripts/ifcfg-eth1 TYPE=Ethernet BOOTPROTO=sta ...
随机推荐
- 关于Hook CreateMutex
我是个驱动新手,最近学习破解多开.经过一个通宵的百度和摸索,简单的多开kugou用以下代码可以了. MyNtCreateMutant( OUT PHANDLE MutantHandle, IN ACC ...
- Knockout.Js官网学习(Mapping插件)
前言 Knockout设计成允许你使用任何JavaScript对象作为view model.必须view model的一些属性是observable的,你可以使用KO绑定他们到你的UI元素上,当这些o ...
- mysql 5.7 离线安装
删除原有的mariadbrpm -qa|grep mariadbrpm -e --nodeps mariadb-libs 安装rpm -ivh mysql-community-common-5.7.2 ...
- 谈一下Docker与Kubernetes集群的日志和日志管理
本文的测试环境为CentOS 7.3,Kubernetes集群为1.11.2,安装步骤参见kubeadm安装kubernetes V1.11.1 集群 日志对于我们管理Kubernetes集群及其上的 ...
- 你真的会用Gson吗?Gson使用指南(4)
原文出处: 怪盗kidou 注:此系列基于Gson 2.4. 本次文章的主要内容: TypeAdapter JsonSerializer与JsonDeserializer TypeAdapterFac ...
- Intellij IDEA 通过数据库表逆向生成带注释的实体类文件超级详细步骤,附详细解决方案
参考:https://blog.csdn.net/qq_34371461/article/details/80571281 https://blog.csdn.net/mqchenrong/arti ...
- WPF如何为程序添加splashScreen(初始屏幕)
一.考虑到大部分的splashscreen其实都只是一个图片,所以最简单的做法是,先导入一张图片,然后设置它的生成操作为“splash screen” 二.通过程序设置SplashScreen pub ...
- XMR恶意挖矿脚本处理笔记
一.登录 攻击者如何登录系统未能查出,所有日志已被清除.为防万一,把系统中没用的用户都删掉并修改其他用户密码. 二.被攻击后的表象 1.服务器资源被大量占用,资源占用率飙升: 2.服务器所有JS文件被 ...
- 12C -- ORA-65005: missing or invalid file name pattern for file
克隆pdb创建新的pdb的时候遇到了以下的错误,具体过程如下文.数据库版本:12.2.0.1 查看已有pdb的tempfile文件 SQL> select name from v$tempfil ...
- Effective Java 第三版——47. 优先使用Collection而不是Stream来作为方法的返回类型
Tips <Effective Java, Third Edition>一书英文版已经出版,这本书的第二版想必很多人都读过,号称Java四大名著之一,不过第二版2009年出版,到现在已经将 ...