参考文章:http://blog.csdn.net/hel12he/article/details/49781813

     http://www.laozuo.org/8178.html

     http://blog.csdn.net/dingd_158/article/details/51857386

     https://bbs.aliyun.com/simple/t309229.html

     

操作系统: CentOS 7.3 64位

1.从xampp官网下载xampp安装包

2.给xampp安装包可执行的权限

# chmod 777 xampp-linux-x64-5.6.30-1-installer.run

3. 运行 ./xampp-linux-x64-5.6.14-0-installer.run 进行安装操作。

4.启动xampp:

# /opt/lampp/lampp start

停止xampp:

# /opt/lampp/lampp stop

卸载xampp:

# /opt/lampp/lampp stop

# rm -rf /opt/lampp

5. 通过Xshell在本地访问阿里云服务器

问题:

我的阿里云服务器公网IP为: 47.95.0.112,启动xampp后从浏览器访问 http://47.95.0.112 失败。

外网无法访问ECS网站

解决路径:

1.  先在服务器本地访问 localhost

 阿里云服务器下没有浏览器,安装浏览器:

w3m

w3m文本浏览器是基于GPL协议发布的且支持表格、颜色、SSL连接以及内链图像,因速度快而著称。一般在默认的Linux常规发行版本中都有自带,如果没有安装的话我们也可以自己apt-get或者yum安装。

a、安装

apt­-get install w3m   (debian系统版本)
yum install w3m       (centos系统版本)

b、使用

w3m localhost      访问成功

w3m 47.95.0.112     访问失败

2.初步怀疑是xampp配置问题

Linux|XAMPP Linux 5.6.8 64bit 外网无法访问 可以通过修改下面的文件

vi opt/lampp/etc/extra/httpd-xampp.conf

在如下代码段中 将Require Local 修改替换为 Require all granted

# since XAMPP 1.4.3
<Directory "/opt/lampp/phpmyadmin">
AllowOverride AuthConfig Limit
Require all granted
</Directory> <Directory "/opt/lampp/phpsqliteadmin">
AllowOverride AuthConfig Limit
Require all granted
</Directory>

意思就是将接受本地请求授权为接受所有请求

再次在本地通过浏览器访问 http://47.95.0.112  失败

3. 进一步怀疑是阿里云的配置问题

有网友反应服务器上的网站,服务器上可以访问,但是外网却无法访问,研究了一下,原因竟然是因为安全组未开放80端口 

在购买云服务器时,如果选择自定义配置,网络设置里有一项是安全组,安全组作用是:类似防火墙功能,用于设置网络访问控制,可以到管理控制台修改。 
如下图,如果这里选择了默认的安全组,只开放了22和3389端口,那网站需要的80端口和ftp需要的21端口都会被关闭,其中的80端口未开放,导致了网站外网无法访问。

点击右上角的 添加安全组规则 或 直接克隆,按下图设置

再次在本地通过浏览器访问 http://47.95.0.112  成功

在阿里云服务器上搭建xampp遇到的问题的更多相关文章

  1. 阿里云服务器上搭建seafile专业版

    因为官方一键安装教程在阿里云服务器上无法安装,由于水平有限,无法解决,所以选择手动安装 参考资料: 1,.腾讯云搭建seafile服务器 2.How to Install Seafile with N ...

  2. 在阿里云服务器上搭建 Apache Tomat 应用

    在阿里云上购买一台服务器,系统采用 window 2008 Server 企业版,64位 1.下载Java7 JRE,安装 http://www.java.com/zh_CN/download/man ...

  3. 如何在阿里云服务器上搭建wordpress个人网站

    1.购买云服务器.域名.域名解析.配置linux系统上的web环境.FTP等参照下面的链接. https://www.cnblogs.com/smyhvae/p/4965163.html?tdsour ...

  4. 阿里云服务器上通过Docker部署redmine

    背景:在日常工作的过程中会遇到各种各样的问题,每个问题来了之后需要花时间解决.这里就面临两个问题. 1:问题责任不明确,有时候会遇到数据库或者物理服务器的问题,这时候就需要把相应问题指派给相应的人,传 ...

  5. Linux学习2-在阿里云服务器上部署禅道环境

    前言 以前出去面试总会被问到:测试环境怎么搭建?刚工作1-2年不会搭建测试环境还可以原谅自己,工作3-5年后如果还是对测试环境搭建一无所知,面试官会一脸的鄙视. 本篇以最简单的禅道环境搭建为例,学习下 ...

  6. 阿里云服务器上安装mysql的心路历程(博友们进来看看哦)

    在阿里云花了100买了一台云服务器,配置如下: CPU: 1核 内存: 512MB 数据盘: 0G 带宽: 1Mbps 阿里云服务器安装mysql搞得我想吐血,搞了一个多星期,现在才搞好,而且,还有许 ...

  7. 在阿里云服务器上安装完成并启动Tomcat后,通过http不能访问--解决办法

    在阿里云服务器上安装完成并启动Tomcat后,通过http不能访问的原因是阿里云平台为了安全设置了安全组策略,必须我们授权的端口,其他计算机才能通过http访问 解决办法:(这里以阿里轻量应用服务器为 ...

  8. jdbc连接阿里云服务器上的MySQL数据库 及 数据库IP限制

    问题1:Jdbc 如何连接阿里云服务器上的MySQL数据库? 解决: 上截图: 其中IP是阿里云服务器的公网IP地址. 问题2:   刚开始接手开发的时候,使用Navicat连接阿里云服务器上的数据后 ...

  9. 使用Navicat连接阿里云服务器上的MySQL数据库--转

    手把手教你如何正确连接阿里云服务器上的数据库: 1.首先打开Navicat,文件>新建连接>MySQL连接,其他的如一图所示. 2.因为是连接服务器上的MySQL,所以我们使用SSH连接, ...

随机推荐

  1. Step3 SQL Server 通过备份文件初始化复制

    一.本文所涉及的内容(Contents) 本文所涉及的内容(Contents) 背景(Contexts) 搭建过程(Process) 注意事项(Attention) 疑问(Questions) 参考文 ...

  2. checkbox 全选效果

    html部分 <p id="all">全选</p> <input type="checkbox" /><br/> ...

  3. 数据分析之Matplotlib

    一.Matplotlib的基础知识     Matplotlib中的基本图表包括的元素     •x轴和y轴 axis     水平和垂直的轴线     •x轴和y轴刻度 tick     刻度标示坐 ...

  4. 用WPE+CCproxy+自动代理截取安卓游戏封包

    wpe三件套:https://pan.baidu.com/s/19gI2GPZ0iuu4wpKljCOn4A 用WPE+CCproxy+自动代理截取安卓游戏封包>>

  5. NOSQL中的redis缓存数据库

    NOSQL概述 什么是NOSQL? NoSql(NoSQL=Not Only SQL),意思为"不仅仅是SQL",是一个全新的数据库理念,泛指非关系型的数据库. 为什么需要NOSQ ...

  6. redis 入门笔记

    http://www.cnblogs.com/xinysu/p/7366142.html

  7. Golang并发编程优势与核心goroutine及注意细节

    Go语言为并发编程而内置的上层API基于CSP(communication sequential processes,顺序通信进程)模型.这就意味着显式锁都是可以避免的,比如资源竞争,比如多个进程同时 ...

  8. matlab的三维绘图和四维绘图

    一.三维绘图1.曲线图plot3(X1,Y1,Z1,...):以默认线性属性绘制三维点集(X1,Y1,Z1)确定的曲线plot3(X1,Y1,Z1,LineSpec):以参数LineSpec确定的线性 ...

  9. linux 压缩工具

    gzip gunzip zcat bzip2 bunzip2 bzcat xz unxz xzcat a:  gzip 用法 # gzip file  压缩文件 不会保留源文件 直接生成 file.g ...

  10. rsync: read error: Connection reset by peer (104)

    Centos7    rsync守护进程上传文件失败 [root@nfs ~]# rsync -avz /etc rsync_backup@172.16.1.41::backupsending inc ...