执行redis命令redis-trib.rb查看集群信息报错cannot load such file -- redis (LoadError)
问题描述:
在执行redis-trib.rb命令查看集群状态的时候,报错:
[aiprd@hadoop1 ~]$ redis-trib.rb check 192.168.30.10:
Traceback (most recent call last):
: from /home/aiprd/softwares/redis-3.2./src/redis-trib.rb::in `<main>'
: from /home/aiprd/app/ruby-2.6./lib/ruby/2.6./rubygems/core_ext/kernel_require.rb::in `require'
/home/aiprd/app/ruby-2.6./lib/ruby/2.6./rubygems/core_ext/kernel_require.rb::in `require': cannot load such file -- redis (LoadError)
问题解决:
1.从错误来看是少了redis的组件
2.下载redis组件
下载地址:https://rubygems.org/downloads/redis-4.1.2.gem
3.上传至服务器,并安装【gem组件的离线安装】
[aiprd@hadoop1 softwares]$ gem install -l redis-4.1..gem
Successfully installed redis-4.1.
Parsing documentation for redis-4.1.
Installing ri documentation for redis-4.1.
Done installing documentation for redis after seconds
gem installed
4.再次执行查看集群信息的命令
[aiprd@hadoop1 softwares]$ redis-trib.rb check 192.168.30.10:
[ERR] Sorry, can't connect to node 192.168.30.10:7000
报错,无法连接上集群节点,由于redis集群开启了认证,因此需要在redis组件的客户端程序中配置redis集群的认证密码
5.进入ruby安装路径,找到redis的client.rb文件
[aiprd@hadoop1 ~]$ cd /home/aiprd/app/ruby/lib/ruby/gems/2.6.0/gems/redis-4.1.2/lib/redis #/home/aiprd/app/ruby是ruby的安装路径,即--prefix指定的路径
[aiprd@hadoop1 redis]$ ls -l client.rb
-rw-r--r-- 1 aiprd aiprd 16407 Aug 2 11:06 client.rb
6.修改该文件,增加密码如下:
:password => "3GESWjNba9@pMDG",
7.再次执行查看集群状态信息的命令
[aiprd@hadoop1 ~]$ redis-trib.rb check 192.168.30.10:
>>> Performing Cluster Check (using node 192.168.30.10:)
M: 2c8bb60808a0b2bcb155eb45759b8c989cb409f3 192.168.30.10:
slots:- ( slots) master
additional replica(s)
M: 4161a6852df45ee50a065e5e275a24cb1b77f1c1 192.168.30.10:
slots:- ( slots) master
additional replica(s)
M: b7fdb4a783aa829818eb804c0cc04161ece5e845 192.168.30.10:
slots:- ( slots) master
additional replica(s)
S: e6b0a64e05e5f3e8dc4b369967090f78fe3c87dc 192.168.30.11:
slots: ( slots) slave
replicates b7fdb4a783aa829818eb804c0cc04161ece5e845
S: 37168bd4232c2d1f1f9a22bd88f221e4f15bf4d9 192.168.30.11:
slots: ( slots) slave
replicates 4161a6852df45ee50a065e5e275a24cb1b77f1c1
S: cab31dd3554524187ffb4a2758af91f72c8238ac 192.168.30.11:
slots: ( slots) slave
replicates 2c8bb60808a0b2bcb155eb45759b8c989cb409f3
[OK] All nodes agree about slots configuration.
>>> Check for open slots...
>>> Check slots coverage...
[OK] All slots covered.
命令执行成功,问题解决。
文档创建时间:2019年8月2日11:25:25
执行redis命令redis-trib.rb查看集群信息报错cannot load such file -- redis (LoadError)的更多相关文章
- ceph-deploy离线部署ceph集群及报错解决FAQ
ceph-deploy部署ceph集群 环境介绍 主机名 ip地址 操作系统 角色 备注 ceph-node1 10.153.204.13 Centos7.6 mon.osd.mds.mgr.rgw. ...
- Redis集群创建报错
Redis集群环境:och163/och164/och165 在执行如下脚本时报错: ./src/redis-trib.rb create 10.1.253.163: 10.1.253.164: 10 ...
- 【问题集】redis集群set报错(error) MOVED 11469 192.168.181.201:7002
没有启动集群模式(即缺少了那个"-c"): redis-cli -c -h yourhost -p yourpost
- rabbimq集群搭建报错:Error: unable TO perform an operation ON node 'rabbit@test3'. Please see diagnostics information AND suggestions below.
在搭建rabbitmq集群的时候,添加内存节点时,抛出异常:Error: unable TO perform an operation ON node 'rabbit@test3'. Please s ...
- IMPI Python集群运行报错:
Intel MPI环境利用hostfile多主机运行下报错 HYDU_process_mfile_token (../../utils/args/args.c:523): token slots no ...
- elasticsearch配置集群+elk报错总结
配置ELK的时候,我平常遇到了以下几种报错情况,整理如下(持续更新中): elasticsearch启动失败 # systemctl start elasticsearch Job for elast ...
- HBase 2.1.3 集群 web 报错InvalidProtocolBufferException 解决方法
搭建好HBase 集群后,各种后台进程都正常,搭建手册参考: Hbase 2.1.3 集群搭建手册https://www.cndba.cn/dave/article/3322 但是通过web访问,却报 ...
- elasticsearch集群搭建报错: not enough master nodes discovered during pinging
自己用一台 阿里云 服务器 搭建ES集群的时候,总是报上面的问题. 而且两个ES服务都是报同样的问题.自己的配置文件如下: es服务1配置文件 cluster.name: elasticsearch ...
- 外网无法连接Kafka集群(报错:NoBrokersAvailable)
本地Consumer和Producer无法使用远程Kafka服务器的解决方法: 分别修改各台服务器Kafka配置文件server.properties, 在#listeners=PLAINTEXT:/ ...
随机推荐
- H3C 什么是漫游
- linux命令实现在当前文件夹下面模糊搜索文件
在当前文件中查找包含的字符串 find . -name "*.txt" | xargs grep 'abc' ,例如:查找txt文件中包含字符串a的字符串
- Tomcat内存溢出解决方法
Java内存溢出详解 一.常见的Java内存溢出有以下三种: 1. java.lang.OutOfMemoryError: Java heap space ----JVM Heap(堆)溢出 JVM在 ...
- scrum-master个人实践回顾总结
个人回顾总结 一.开课提出问题 第一次博客地址:https://www.cnblogs.com/Slow-Walker/p/11513179.html 二.问题回答 2.1问题1:针对单元测试 怎么保 ...
- Linux core dump总结
文章链接:https://www.cnblogs.com/Anker/p/6079580.html 1.前言 一直在从事linux下后台开发,经常与core文件打交道.还记得刚开始从事linux下开发 ...
- 数字转datetime格式
原数据:int型 转成年月日 时分秒的形式 source_test['happenTime'] = source_test['happenTime'].map(lambda x:str(x)) sou ...
- 项目Beta冲刺(团队)——05.29(7/7)
项目Beta冲刺(团队)--05.29(7/7) 格式描述 课程名称:软件工程1916|W(福州大学) 作业要求:项目Beta冲刺(团队) 团队名称:为了交项目干杯 作业目标:记录Beta敏捷冲刺第7 ...
- JMeter基础【第六篇】JMeter5.1事务、检查点、集合点、思考时间、其余设置等
JMeter5.1事务.检查点.集合点.思考时间.其余设置等
- Spark常规性能调优
1.1.1 常规性能调优一:最优资源配置 Spark性能调优的第一步,就是为任务分配更多的资源,在一定范围内,增加资源的分配与性能的提升是成正比的,实现了最优的资源配置后,在此基础上再考虑进行 ...
- sleep、yield、wait、join的区别(阿里)
只有runnable到running时才会占用cpu时间片,其他都会出让cpu时间片.线程的资源有不少,但应该包含CPU资源和锁资源这两类.sleep(long mills):让出CPU资源,但是不会 ...