LoadRunner如何监控Linux系统资源

一 简述:LoadRunner监控Linux资源时弹出如下错误:

  Monitor name :UNIX Resources. Cannot initialize the monitoring on 192.168.52.189. Error while creating the RPC client. Ensure that the machine can be connected and that it runs the rstat daemon (use rpcinfo utility for this verification). Detailed error: RPC: Failed to create RPC client.

  RPC-TCP: Failed to establish RPC server address.

  上述问题的实质是Linux系统中未安装rpc.rstatd,服务未开启的原因造成。

  于是接下来就验证我们的推测:

  首先查看rpc.rstatd是否安装

  以下是代码片段:

  [root@localhost bin]# whereis rpc.rstatd

如果列表中没有rpc.rstatd

  发现系统未安装rpc.rstatd

备注:rstatd Rstat协议允许网络上的用户获得同一网络上各机器的性能参数。

  二 准备下载包:下载rpc.rstatd-4.0.1.tar.gz安装包

  下载地址:http://sourceforge.net/projects/rstatd

  利用ssh客户端上传rpc.rstatd-4.0.1.tar.gz包至Linux下/home/Michael/tool/目录下

  三 执行安装程序包:

  以下是代码片段:

  tar -xzvf rpc.rstatd-4.0.1.tar.gz //解压rcp.rstatd

  cd rpc.rstatd-4.0.1 //进入到rpc.rstatd目录中

  ./configure //配置rc.rstatd的安装,以下我的是按照默认方式的

  make //编译rc.rstatd

  make install // 安装

  四 重启xinetd

  以下是代码片段:

  /etc/init.d/xinetd restart

  五 修改etc/xinetd.d目录下面的3个conf (rlogin, rsh, rexec)中的disable置均设置为no

  以下是代码片段:

  cd /etc/xinetd.d //进入到etc/xinetd.conf目录中

  Vi rlogin //编辑disable=no,保存

  Vi rsh // 编辑disable=no,保存

  Vi rexec //编辑disable=no,保存

  六 启动rpc.rstatd和检测

  以下是代码片段:

  rpc.rstatd //启动rpc.rstatd进程

  rpcinfo –p // 执行此命令检查rpc服务的状态

  [root@localhost xinetd.d]# rpcinfo -p

  程序版本协议 端口

program vers proto   port  service

100000    4   tcp    111  portmapper

100000    3   tcp    111  portmapper

100000    2   tcp    111  portmapper

100000    4   udp    111  portmapper

100000    3   udp    111  portmapper

100000    2   udp    111  portmapper

100024    1   udp  40879  status

100024    1   tcp  53726  status

100001    5   udp    899  rstatd

100001    3   udp    899  rstatd

100001    2   udp    899  rstatd

100001    1   udp    899  rstatd

看到rstatd,就说明rstatd服务已经启动。可以用LR去监视了。

七 利用Loadunner中的Controller监控Linux资源

  1 在controller中,将Systeme Resourece Graphs中的UNIX resources拖到右键的资源监控区域

  2 鼠标右键选择Add Measurements,添加被监控linux的IP地址192.168.52.189,选择需监控的性能指标,确认后,如下图所示即表示成功^_^

可能有的会提示计算机上访问度量cpu utilization的数据,这个是因为你没有这个资源度量,你在添加计算机的时候在下面重新添加资源度量cpu和你需要的相关信息就OK了

LoadRunner如何监控Linux系统资源的更多相关文章

  1. Loadrunner监控Linux系统资源

    一.安装rsh和rpcbind 1.查看是否安装:rpm -qa |grep rsh 2.安装rsh:yum -y install rsh* 3.yum  -y install nfs-utils r ...

  2. LoadRunner如何监控Linux下的系统资源

    1. 安装rsh,rsh-server [root@localhost /]# yum install rsh [root@localhost /]# yum install rsh-server 或 ...

  3. LR监控linux系统资源

    一.检查系统是否安装rpc服务 使用LR监控Linux,首先查看系统是否开启了rpc服务,其次查看Linux系统守护进程rpc.restat是否启动,该进程是必须的.可以通过命令rpcinfo -p来 ...

  4. loadrunner如何监控linux,以及重点指标分析

    监控UNIX一. lr监控UNIX ,UNIX先启动一rstatd服务 以下是在IBM AIX系统中启动rstatd服务的方法: 1. 使用telnet以root用户的身份登录入AIX系统 2. 在命 ...

  5. LoadRunner设置监控Windows系统资源步骤

    一般在客户端通过LoadRunner对服务器进行压力测试,都需要实时监控服务器端的系统资源,本篇主要简单介绍一下如何设置在LoadRunner的Controller中配置监控Windows Resou ...

  6. LR杂记-nmon+analyser监控linux系统资源

    1.查看linux具体版本号信息 file /sbin/init 2.下载相应nmon版本号 http://pkgs.repoforge.org/nmon/ 3.安装 rpm -ivh nmon-14 ...

  7. nmon监控Linux服务器系统资源

    本文转自:http://www.cnblogs.com/hyzhou/archive/2011/12/29/2305860.html 在实际的测试过程中,Loadrunner监控Linux系统资源不太 ...

  8. loadrunner监控linux之linux下安装rpc

    安装和配置rpc服务 说明:rpc服务需rsh的支持,一般情况下rsh已安装.通过rpm -qa rsh命令查看. 下载rpc.rstatd-4.0.1.tar.gz,可先下载到window下,通过f ...

  9. (转)LR监控Linux系统性能计数器详解

    从LR里面add measurement,填写linux机器的IP,出现所有unix/linux的计数器,包括cpu的,mem的,disk,network的.这里介绍几个常用的: (对于如何监控Lin ...

随机推荐

  1. DI容器Ninject在管理接口和实现、基类和派生类并实现依赖注入方面的实例

    当一个类依赖于另一个具体类的时候,这样很容易形成两者间的"强耦合"关系.我们通常根据具体类抽象出一个接口,然后让类来依赖这个接口,这样就形成了"松耦合"关系,有 ...

  2. UITableView 让 cell 被选中的颜色底色快速消失,而不是一直停留在cell上

    //单元格被选中 -(void)tableView:(UITableView *)tableView didSelectRowAtIndexPath:(NSIndexPath *)indexPath ...

  3. 算法:冒泡排序(Bubble Sort)、插入排序(Insertion Sort)和选择排序(Selection Sort)总结

    背景 这两天温习了 5 中排序算法,之前也都看过它们的实现,因为没有深入分析的缘故,一直记不住谁是谁,本文就记录一下我学习的一些心得. 三种排序算法可以总结为如下: 都将数组分为已排序部分和未排序部分 ...

  4. Spring4.0+quartz2.2.1+memcahce多台nginx实现均衡

    1.每台nginx都有公网地址,在域名处设置同个域名多个指向,最简单实现轮洵.但故障切负会慢一点.2.一台公网nginx通过upstream功能,轮洵.ip.url多方式分发到内网多台nginx.但公 ...

  5. linux下通过iptables只允许指定ip地址访问指定端口的设置方法

    这篇文章主要介绍了linux下通过iptables只允许指定ip地址访问指定端口的设置方法,需要的朋友可以参考下. 首先,清除所有预设置 iptables -F#清除预设表filter中的所有规则链的 ...

  6. easyui 排序实现

    1.对easyui  datagrid 返回的数据,进行排序处理,便于搜索到我们的有用的信息. 例如: 2.datagrid 需要设置 sortable : true { field : 'crtTi ...

  7. 0, \0, NULL

    字符串.字符数组输入.输出与'\0'的问题 原创首发,欢迎转载! 作者按 字符串.字符数组以"%s"格式输入时,以遇到'空格'为这个字符串输入结束. 字符串.字符数组以" ...

  8. 中国计算机学会CCF推荐国际学术会议和期刊目录(PDF版,2015年)

    total: CCF推荐国际学术会议和期刊目录(下载) parts: 点击下载:  计算机体系结构并行与分布计算存储系统.pdf 点击下载:  计算机网络.pdf 点击下载:  网络与信息安全.pdf ...

  9. bind原理图释

    (原文:http://blog.think-async.com/2010/04/bind-illustrated.html) 本文解释了bind 是如何工作的.为了清晰,我对图中的语法作了一些简化(例 ...

  10. C++ RegCreateKeyEx成功了,但是注册表并没有这一项

    C++ - RegCreateKeyEx success but without result Could anybody tell me what's wrong is with this code ...