ORA-27301: OS failure message: Not enough space
OS:HP-UNIX
ORA-27300: OS system dependent operation:fork failed with status: 12
ORA-27301: OS failure message: Not enough space
ORA-27302: failure occurred at: skgpspawn3
swapinfo -mt
发现swap已经100percent了。sqlplus无法连接到数据库中。应用这边的人找过来了,说他们应用无法连上数据库了。
查看系统日志:
more /var/adm/syslog/syslog.log
发现系统频繁出现无法分配内存的错误
应用那边说今天早上他们把WebLogic中jdbc调大到了200,按说应该是没有问题,预计是jdbc没有释放,叫他们把连接数调整到原样,swap恢复到88percent。数据库恢复正常
看mos原文:
| Troubleshooting Guide ORA-3136: WARNING Inbound Connection Timed Out (Doc ID 465043.1) |
ToBottom |
![]() |
|
In this Document
APPLIES TO:Oracle Net Services – Version 10.2.0.5 to 11.2.0.4 [Release 10.2 to 11.2] PURPOSETroubleshooting guide for "ORA-3136 WARNING inbound connection timed out" seen in the alert log. TROUBLESHOOTING STEPSThe "WARNING: inbound connection timed out (ORA-3136)" in the alert log indicates that the client was not able to complete the authentication process You might also see the errors ORA-12170 or TNS-12535 in the sqlnet.log that is generated on the server. From 10.2.0.1 onwards the default setting for the parameter SQLNET.INBOUND_CONNECT_TIMEOUT is 60 seconds. If the client is not able to authenticate within 60 seconds, the warning would appear in the alert log and the client connection will be terminated.
Note: This timeout restriction was introduced to combat Denial of Service (DoS) attack whereby malicious clients attempt to flood database servers with connect requests that consumes
resources. The following are the most likely reasons for this error -
To understand what is causing this issue, following checks can be done The default value of 60 seconds is good enough in most conditions for the database server to authenticate a client connection. If it is taking longer, then it's worth checking 1. Check whether local connection on the database server is successful & quick. It is often necessary to increase the values for INBOUND CONNECT TIMEOUT at both the listener and the database in order to resolve this issue. It is usually advisable to set the database (sqlnet.ora) value slightly higher than the listener (listener.ora). To set these parameters to use values higher than the default of 60 seconds, follow these instructions and restart the listener. There is no need to restart Oracle: Edit the server side sqlnet.ora file and add this parameter: SQLNET.INBOUND_CONNECT_TIMEOUT=<n> Where <n> is the value in seconds. E.g.:
SQLNET.INBOUND_CONNECT_TIMEOUT = 120
Edit the listener.ora file and add this parameter: INBOUND_CONNECT_TIMEOUT_<listenername> = <n> Again, where <n> is the timeout value in seconds. For example if the listener name is LISTENER then use:
INBOUND_CONNECT_TIMEOUT_LISTENER = 110
From Oracle version 10.2.0.1 onwards the default value of INBOUND_CONNECT_TIMEOUT_<listenername> is 60 seconds. For previous releases it is zero or OFF by default.
How to check whether inbound timeout is active for the listener and database server: For example, INBOUND_CONNECT_TIMEOUT_<listener_name> =110 You can check whether the parameter is active or not by simply doing telnet to the listener port.
$ telnet 123.23.23.23 1521
The telnet session should disconnect after 110 seconds which indicates that the inbound connection timeout for the listener is active. Alternatively, check at the LSNRCTL prompt using: LSNRCTL>set current_listener <listener_name> To check whether database server SQLNET.INBOUND_CONNECT_TIMEOUT is active:
SQLNET.INBOUND_CONNECT_TIMEOUT=120
a. For Dedicated server setup, enable the support level sqlnet server tracing will show the timeout value as below:
niotns: Enabling CTO, value=120000 (milliseconds) <== 120 seconds
niotns: Not enabling dead connection detection. niotns: listener bequeathed shadow coming to life… b. For shared Server setup,
$ telnet 123.23.23.23 51658
The telnet session should disconnect after 120 seconds which indicates that the sqlnet.inbound_connect_timeout is active. If you have further questions regarding this issue then please create a Service Request in My Oracle Support and provide the following information: a. Client and matching server traces generated at support level. Note 395525.1 How to Enable Oracle Net Client,Server,Listener,Kerberos and External procedure Tracing from Net Manager b. Upload sqlnet.ora, listener.ora Sqlnet.log, & Alert_<sid>.log from database server REFERENCESNOTE:395525.1 - How to Enable Oracle id=730066.1&parent=DOCUMENT&sourceId=465043.1" style="">NOTE:730066.1 id=374116.1&parent=DOCUMENT&sourceId=465043.1" style="">NOTE:374116.1 |
ORA-27301: OS failure message: Not enough space的更多相关文章
- ORA-27300: OS system dependent operation:sendmsg failed with status: 105 ORA-27301: OS failure message: No buffer space available
早上查看数据库alert日志,发现如下ORA-报错: kgxpvfynet: mtype: 61 process 6460 failed because of a resource problem i ...
- mysql Communication link failure, message from server: "Can't get hostname for your address"
在连接mysql jdbc时候,抛出了 com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Communicat ...
- 性能测试过程中oracle数据库报ORA-27301 ORA-27302错
最近在性能测试过程中发现,发现虚拟用户数上不去,加载到一定的数量应用端就报错,提示连接数据库出错.在测试的过程中查看web容器的线程池 数据源的连接池 都还有空闲,同时查看oracle的v$sessi ...
- 一次goldengate故障引发的操作系统hang起,HA自动切换
现场: 跑着数据库的主机A报警应用连接不上数据库,我们无法ssh到主机.第一反应是通过telnet到远程控制口,发现数据库资源和硬件资源在被切换到HA架构的主机B(备机,通常性能比主机A的差,抗不住应 ...
- 苏大文正节点一 ORA-00603 ORA-27504 ORA-27300 ORA-27301 ORA-27302 BUG
Problem Description --------------------------------------------------- Tue Sep 01 04:05:33 2020 s ...
- ORA-27154: post/wait create failed ORA-27300 ORA-27301 ORA-27302
今天刚装了Oracle 11g,配制好了之后启动数据库时遇到下面的错误:SQL> startupORA-27154: post/wait create failedORA-27300: OS s ...
- 转载:oracle 启动过程--oracle深入研究
Oracle数据库的启动-nomount状态深入解析 通常所说的Oracle Server主要由两个部分组成:Instance和Database.Instance是指一组后台进程(在Windows上是 ...
- oracle之 Got minus one from a read call 与 ORA-27154: post/wait create failed
在部署应用的时候,有时候应用可以直接启动,但偶尔应用却无法启动,报错信息是: java.sql.SQLRecoverableException: IO Error: Got minus one fro ...
- 从ORA-27300,ORA-27301到ORA-00064
近期因为session数量添加,须要调整session,也就是要调整process參数. 看是比較简单的一个问题,却遭遇了ORA-27300,ORA-27301.因为这个涉及到了有关内核參数k ...
随机推荐
- POJ 1172 DFS
(感谢wzc学长的幻灯片) 单组数据 注意从必经点能到标记过的点则此点不是分裂点. //By: Sirius_Ren #include <cstdio> #include <queu ...
- HBase编程 API入门系列之delete(客户端而言)(3)
心得,写在前面的话,也许,中间会要多次执行,连接超时,多试试就好了. 前面的基础,如下 HBase编程 API入门系列之put(客户端而言)(1) HBase编程 API入门系列之get(客户端而言) ...
- 用js制作一个计算器
使用js制作计算器 <!doctype html> <html lang="en"> <head> <meta charset=" ...
- springboot 的 @Async
/** * Created by zhiqi.shao on 2018/4/3. */ @EnableAsync @Configuration public class TaskPoolConfig ...
- Node.js 常用Mongoose方法
Node.js 手册查询-Mongoose 方法 一.Schema 一种以文件形式存储的数据库模型骨架,无法直接通往数据库端,也就是说它不具备对数据库的操作能力.可以说是数据属性模型(传统意义的表结构 ...
- crypto-js RC4和hash_hmac运用
遇到一个问题,前端需要加密,可能用到一些算法,推荐这个库:crypto-js, RC4是一个可逆的加密,看下用法: import CryptoJS from 'crypto-js'; const RC ...
- Django_文件上传
使用Django框架实现文件上传功能 upload.html <!DOCTYPE html> <html lang="en"> <head> ...
- javascript中的计算题
一.js中的数据类型共六种: 值类型五种:Boolea Number String Null undefined 引用类型:Object ----三大引用类型:Object Array ...
- python tips:作为dict的key的类
Python的dict由hash实现,解决hash冲突的方法是二次探查法.hash值相同的元素会形成链表.所以dict在查找key时,首先获取hash值,直接得到链表的表头:而后在链表中查找等于key ...
- day37-2元类,单例模式
目录 元类 造类的第一种形式 class做了什么事 控制元类产生的类 控制元类产生的对象 实例化类 加上元类后类的属性查找顺序 元类控制模版 单例模式 1. 使用类方法的特性 2. 使用装饰器 3. ...
To.gif)