Web服务器的配置与管理
Web服务器的配置与管理(2) 虚拟主机技术
在上篇博文中,我们已经利用IIS搭建好了一台Web服务器,并可以成功访问IIS中自带的默认站点,那么我们是否可以在这台服务器中再创建另外一个Web站点?也就是说,在一台Web服务器中是否可以同时存在多个网站呢? 答案当然是肯定的,其实很多中小企业的网站都是从网上租用的空间,提供空间租用的Web服务器里就同时存在了很多个网站。 但是当多个网站同时存在于一台服务器里时,就必须得有一种方法能够将它们区分开,这种方法也就是虚拟主机技术。 有三种方法可以实现虚拟主机技术:
- 利用不同的IP地址
- 利用不同的端口号
- 利用不同的主机名(域名)
也就是说,只要让不同的网站在IP地址、端口号、主机名这三项中有一项是不相同的,那么这些网站就可以共存了。 下面分别来介绍这三种虚拟主机技术。 1. 使用不同IP地址架设多个网站 这种方法是为每个网站设置一个不同的IP,要采用这种方式首先需要Web服务器安装有多块网卡,每块网卡使用不同的IP。如果web服务器中只有一块网卡,那么也可以给这一块网卡绑定多个IP地址。打开本地连接,在TCP/IP属性的“高级”设置中,为服务器再添加一个IP地址192.168.0.15,如下图所示。

下面我们在【IIS管理器】中再新建一个Web站点。 在IIS管理器中选择“网站”,然后在右侧的“操作”面板中选择“添加网站”。 “网站名称”可以随意设置,这里用ytvc。 “物理路径”也就是网站的主目录,这里设置为c:\ytvc。 网站的协议类型仍为http,IP地址使用192.168.1.15,端口号80。

网站创建好之后,在其主目录中也存放一个名为Default.htm的网页文件,这样在客户端输入不同的IP地址便可以访问相应的网站。
2. 使用不同TCP端口架设多个网站

这样客户端在访问默认网站的时候,仍然可以通过URL“http://192.168.1.5”的形式访问,而如果要访问ytvc网站,则端口号就不能省略,必须要使用“http://192.168.1.5:8000”形式的URL。 但这时客户端无法访问ytvc网站,这是因为web服务器上的防火墙将发往TCP8000端口的数据自动过滤掉了,可以暂时关闭防火墙进行测试,或是在防火墙中增加一条入站规则。 打开防火墙的高级设置,新建一条入站规则,要创建的规则类型选择“端口”。

指定规则应用于TCP 8000端口。

对满足条件的操作允许连接。

在所有的网络上全部应用该规则。

为规则随意起一个名称。

入站规则创建好之后,在客户端就可以用8000端口正常访问ytvc网站了。 采用这种方式,客户端在访问网站时必须要在网址后面加上相应的端口号,而用户是不可能去记住每个网站的端口号的,所以这种方式在实践中也很少采用。

然后再将默认网站的主机名设置为www.coolpen.net。

这样客户端就可以通过输入不同的网址以访问不同的网站,这也是实际中最经常采用也是最为推荐的一种方式,但采用这种方式就无法通过IP地址来访问相应的网站了(实际中的很多网站都是可以用网址访问,但无法用IP地址访问。)
【转载】http://www.it165.net/admin/html/201304/1012.html
Web服务器的配置与管理(3) 配置虚拟目录
一个网站中的所有网页和相关文件都要存放在主目录下,为了对文件进行归类整理,也可以在主目录下面建立子文件夹,分别存放不同内容的文件,例如一个网站中,新闻类的网页放在主目录的news文件夹,技术类的网页文件放在主目录的tech文件夹,产品类的网页文件放在products文件夹等,这些直接存放在主目录下的子文件夹都称为物理目录。 下面我们在默认站点的主目录下创建一个名为news的子目录,并在其中放置2个网页文件。

在客户端访问时,如果输入URL “http://www.coolpen.net/news”,那么就是打开news子目录中的默认首页,如果输入URL “http://www.coolpen.net/news/news.htm”,那么就是打开news子目录中指定的网页。 并非所有的子目录都要在物理上直接位于主目录中,如我们也可以“C:\tech”设置为默认站点的子目录,这种在逻辑上归属于某个网站之下的子目录就称为虚拟目录。虚拟目录是主网站的下一级目录,并且要依附于主网站,但它的物理位置不在主目录下。 下面我们先创建“C:\tech”文件夹,然后将其设置为默认站点的虚拟目录。 打开【IIS管理器】,在默认站点上右键单击,选择“添加虚拟目录”。

虚拟目录的别名这里就用tech,然后输入其物理路径。

在C:\tech文件夹中放置一些测试网页,然后在客户端可以像访问物理目录一样的去访问它们。 我们还可以将位于另外一台服务器上的共享文件夹设置为Web站点的虚拟目录,这也是虚拟目录技术的最大优势所在。 下面我们将位于文件服务器FS上共享文件夹fs设置为默认站点的虚拟目录。 注意,在指定虚拟目录的路径时必须要使用UNC路径。

由于这个虚拟目录是位于网络上的共享文件夹,所以必须要传递身份验证,也就是要指定以哪个用户的身份去访问。点击“连接为”,然后输入域管理员账户和密码。

这样在客户端就可以正常访问了。 最后总结一下:

【转载】http://www.it165.net/admin/html/201304/1011.html
Web服务器的配置与管理(4) 配置访问权限和安全
1. 用户身份验证

在“安全性”中勾选要安装的3种身份验证方法。

这4种身份验证方法的优先级为:

基本身份验证

然后在客户端测试,用admin用户可以成功访问网站。

下面再用一个域用户zhangsan进行测试,如果只输入zhangsan的用户名,是无法通过验证的,必须要指定zhangsan所在的域,即使用域用户账户的全名coolpen\zhangsan

我们也可以在web服务器上指定所处的域。选中基本身份验证,然后点击右侧的“编辑”按钮对其进行设置。

默认域:指定Web服务器所处的域。当用户连接网站时,如果用户输入了一个用户名zhangsan,那么服务器优先将其视为本地用户进行身份验证,如果发现zhangsan不是本地用户,则自动将其视为coolpen.net域的域用户,将用户名和密码送到此域的域控制器检查。这样设置的好处是,即使是域用户,也可以只输入用户名,而不需要输入全名了。
摘要式身份验证
2. IP地址限制

组件安装完成后,重新打开IIS管理器,会发现其中多了一个“IP地址和域限制”的功能组件。

打开该组件,点击右侧的“添加允许条目”,可以设置只允许哪些客户端访问该网站。可以只允许某个特定的IP地址,也可以是一个地址段。

需要注意的是,如果设置了允许条目,那除了指定的这些IP地址之外,其它的客户端访问网站时是将被允许还是拒绝呢?这个可以通过右侧的“编辑功能设置”来设置。

可以根据需要将未指定的客户端设为允许或拒绝访问。

拒绝访问的设置与此类似。 3. 网站性能调整

4. 配置日志

【转载】http://www.it165.net/admin/html/201304/1013.html
Web服务器的配置与管理的更多相关文章
- 403.14-Forbidden Web 服务器被配置为不列出此目录的内容及Login on failed for "IIS APPPOOL\ASP.NET v4.0"问题
问题1: 发布mvc3报错:403.14-Forbidden Web 服务器被配置为不列出此目录的内容 折腾了半天,提示里面的解决方法是: 如果不希望启用目录浏览,请确保配置了默认文档并且该文件存在. ...
- iis7 发布mvc3 遇到的HTTP错误 403.14-Forbidden Web 服务器被配置为不列出此目录的内容及Login on failed for "IIS APPPOOL\ASP.NET v4.0"问题
问题1: 发布mvc3报错:403.14-Forbidden Web 服务器被配置为不列出此目录的内容 折腾了半天,提示里面的解决方法是: 如果不希望启用目录浏览,请确保配置了默认文档并且该文件存在. ...
- iis7 发布mvc 遇到的HTTP错误 403.14-Forbidden Web 服务器被配置为不列出此目录的内容
iis 7上发布mvc报错:403.14-Forbidden Web 服务器被配置为不列出此目录的内容 提示里面的解决方法是: 如果不希望启用目录浏览,请确保配置了默认文档并且该文件存在. 使用 II ...
- iis8.0配置 使用备忘 403.14 - Forbidden Web 服务器被配置为不列出此目录的内容
由于对iis的了解度不够,使用中总会碰到这样那样的问题,在这我先开个头,遇到问题再一一更新: 我用的是iis8; 1.发布到iis服务器下的网站你自己可以访问,局域网的其他机器不能? 答:是否开放了对 ...
- iis 7上发布mvc报错:403.14-Forbidden Web 服务器被配置为不列出此目录的内容
iis 7上发布mvc报错:403.14-Forbidden Web 服务器被配置为不列出此目录的内容 提示里面的解决方法是: 如果不希望启用目录浏览,请确保配置了默认文档并且该文件存在. 使用 II ...
- 发布mvc报错:403.14-Forbidden Web 服务器被配置为不列出此目录的内容
有两个地方需要配置: 1.web.config中的节点: <system.webServer> <validation validateIntegratedModeConfigura ...
- vs2015启动网站调试提示 HTTP 错误 403.14 - Forbidden Web 服务器被配置为不列出此目录的内容。 解决方法
今天安装了vs2015 下载一个项目进行试用,启动调试的时候提示 HTTP 错误 403.14 - Forbidden Web 服务器被配置为不列出此目录的内容. 最可能的原因: 没有为请求的 URL ...
- vs2012启动网站调试提示 HTTP 错误 403.14 - Forbidden Web 服务器被配置为不列出此目录的内容
启动vs2012调试网站的时候提示: HTTP 错误 403.14 - Forbidden Web 服务器被配置为不列出此目录的内容. 最可能的原因: 没有为请求的 URL 配置默认文档,并且没有在服 ...
- 分享:linux下apache服务器的配置和管理
linux下apache服务器的配置和管理. 一.两个重要目录: Apache有两个重要的目录:1.配置目录/etc/httpd/conf:2.文档目录/var/www: 二.两种配置模式: Apac ...
随机推荐
- Django的模板变量
变量的值来自context中的数据字典, 类似于字典对象的keys到values的映射关系. 变量是被}}和{{括起来的部分 变量看起来就像是这样: {{ variable }}. 当模版引擎遇到一个 ...
- Python—后台运行(nohup 、&、 2>&1详解)
一.脚本文件(test.py) # -*- coding: UTF-8 -*- import time print("hello"," python") os. ...
- java.sql.BatchUpdateException: ORA-01691: Lob 段 CSASSSMBI.SYS_LOB0000076987C00003$$ 无法通过 128 (在表空间 HRDL_CSASS 中) 扩展
问题: 在tomcat日志信息中出现:java.sql.BatchUpdateException: ORA-01691: Lob 段 CSASSSMBI.SYS_LOB0000076987C00003 ...
- 01 语言基础+高级:1-3 常用API第一部分_day08【String类、static、Arrays类、Math类】
day08[String类.static.Arrays类.Math类] String类static关键字Arrays类Math类 教学目标能够使用String类的构造方法创建字符串对象能够明确Stri ...
- SOA架构设计分析
SOA(Service-Oriented Architecture,面向服务的架构)是一个组件模型,它将应用程序的不同功能单元(称为服务)进行拆分,并通过这些服务之间定义良好的接口和契约联系起来. S ...
- Spring注解配置和xml配置优缺点比较
Spring注解配置和xml配置优缺点比较 编辑 在昨天发布的文章<spring boot基于注解方式配置datasource>一文中凯哥简单的对xml配置和注解配置进行了比较.然后朋 ...
- Data总结
getTime() 方法可返回距 1970 年 1 月 1 日之间的毫秒数 var d = new Date(); var n = d.getTime(); //一长串数字
- <强化学习>开门帖
(本系列只用作本人笔记,如果看官是以新手开始学习RL,不建议看我写的笔记昂) 今天是2020年2月7日,开始二刷david silver ulc课程.https://www.youtube.com/w ...
- CodeForces 993B Open Communication(STL 模拟)
https://codeforces.com/problemset/problem/993/b 这题不难,暴力就能过,主要是题意太难懂了 题意: 现在有两个人,每个人手中有一对数,第一个人手中的数是n ...
- 17.3.13--python编码问题
1----字符编码: 字符编码(英语:Character encoding).字集码是把字符集中的字符编码为指定集合中某一对象(例如:比特模式.自然数串行.8位组或者电脉冲),以便文本在计算机中存储和 ...