Zabbix icmp pinger processes more than 75% busy

 

Zabbix server报"Zabbix icmp pinger processes more than 75% busy",之所以出现这个错误,因为昨天将模板Template Module ICMP Ping链接到Template OS Windows by Zabbix agent模板下和Template OS Linux by Zabbix agent模板下去了,而又忘记修改参数StartPingers,此时由于只有默认的一个线程在在ping,所以出现了这个告警。具体过程如下:

检查发现参数StartPingers没有配置,使用默认的值为1,此参数用于设置启用icmp协议PING主机方式启动线程数量。如果线程数量太小,监控的服务器数量过多的话,那么它有可能处于非常繁忙的状态。我们可以适当的调整其大小值

#grep StartPingers /etc/zabbix/zabbix_server.conf 

 

### Option: StartPingers

 

# StartPingers=1

调整参数大小后,重启Zabbix-Server服务,发现出错。具体情况如下所示:

# systemctl restart zabbix-server

 

Job for zabbix-server.service failed because the control process exited with error code.

 

See "systemctl status zabbix-server.service" and "journalctl -xe" for details.

检查错误信息,发现是参数设置错误,正确的参数是StartPingers,但是我漏掉了一个s,设置成StartPinger,出现了下面错误。修改后,重启Zabbix-Server服务,解决问题。

# journalctl -xe

..............................................

-- Subject: Automatic restarting of a unit has been scheduled

-- Defined-By: systemd

-- Support: https://access.redhat.com/support

-- 

-- Automatic restarting of the unit zabbix-server.service has been scheduled, as the result for

-- the configured Restart= setting for the unit.

Aug 20 10:13:26 xxxxxx systemd[1]: Stopped Zabbix Server.

-- Subject: Unit zabbix-server.service has finished shutting down

-- Defined-By: systemd

-- Support: https://access.redhat.com/support

-- 

-- Unit zabbix-server.service has finished shutting down.

Aug 20 10:13:26 xxxxxx systemd[1]: Starting Zabbix Server...

-- Subject: Unit zabbix-server.service has begun start-up

-- Defined-By: systemd

-- Support: https://access.redhat.com/support

-- 

-- Unit zabbix-server.service has begun starting up.

Aug 20 10:13:26 xxxxxx zabbix_server[2873831]: zabbix_server [2873831]: unknown parameter "StartPinger" in config file "/etc/zabbix/zabbix_server.conf", line 242

Aug 20 10:13:26 xxxxxx systemd[1]: zabbix-server.service: Control process exited, code=exited status=1

Aug 20 10:13:26 xxxxxx systemd[1]: zabbix-server.service: Failed with result 'exit-code'.

Aug 20 10:13:26 xxxxxx systemd[1]: Failed to start Zabbix Server.

-- Subject: Unit zabbix-server.service has failed

-- Defined-By: systemd

-- Support: https://access.redhat.com/support

-- 

-- Unit zabbix-server.service has failed.

-- 

-- The result is failed.

Zabbix icmp pinger processes more than 75% busy的更多相关文章

  1. Zabbix报错:"Zabbix http poller processes more than 75% busy"的解决

    一.钉钉收到告警 主机名称:Zabbix服务端-172.28.18.75 IP地址 :127.0.0.1 告警时间:2019.10.22 13:34:39 告警信息:Zabbix http polle ...

  2. Zabbix unreachable poller processes more than 75% busy

    “Zabbix poller processes more than 75% busy”警报问题解决 虽然Zabbix的监控警报各种有,碰到最多的几个莫过于内存耗尽,网络不通,IO太慢还有这个“Zab ...

  3. Zabbix poller processes more than 75% busy

    Centos7.5  在设置网络监控的时候zabbix提示Zabbix poller processes more than 75% busy 问题 原因 默认只开启一个Discoverers进程,就 ...

  4. zabbix 邮件报警事件:Zabbix discoverer processes more than 75% busy

    Problem has been resolved at :: on Problem name: Zabbix discoverer processes more than % busy Host: ...

  5. Zabbix housekeeper processes more than 75% busy

    原因分析 为了防止数据库持续增大,Zabbix有自动删除历史数据的机制,即housekeeper,而在频繁清理历史数据的时候,MySQL数据库可能出现性能降低的情况,此时就会告警. 一般来说,Zabb ...

  6. zabbix告警“Zabbix poller processes more than 75% busy”

    告警原因: 1.某个进程卡住了, 2.僵尸进程出错,太多,导致慢了 3.网络延迟(可忽略) 4.zabbix消耗的内存多了 告警危害: 普通告警,暂无危害(但是最好处理) 处理方法: 一:简单,粗暴( ...

  7. Zabbix discoverer processes more than 75% busy

    [root@86 ~]# grep -n "StartDiscoverers" /usr/local/zabbix/etc/zabbix_server.conf 176:### O ...

  8. 解决CentOS“Zabbix discoverer processes 75% busy”的问题

    解决CentOS“Zabbix discoverer processes 75% busy”的问题 运维  立杰  4年前 (2014-08-11)  1104℃  0评论 在使用Zabbix过程中, ...

  9. Zabbix 各种报错信息和遇到的问题处理(持续总结更新~~~~~)

    问题1:Zabbix poller processes more than 75% busy 解决: 1.修改配置文件: # vim /etc/zabbix/zabbix_server.conf St ...

随机推荐

  1. 牛!Python 也能实现图像姿态识别溺水行为了!

    作者 | 李秋键 责编 | Carol 封图 | CSDN 下载自视觉中国 众所周知随着人工智能智能的发展,人工智能的落地项目也在变得越来越多,尤其是计算机视觉方面. 很多人学习python,不知道从 ...

  2. SPM:Single-stage Multi-person Pose Machines

    figure1图b figure1 -a   figure3-a 图一-a

  3. 学习Hibernate5 JPA这一篇就够了

    配套资料,免费下载 链接:https://pan.baidu.com/s/158JkczSacADez-fEMDXSYQ 提取码:2ce1 复制这段内容后打开百度网盘手机App,操作更方便哦 第一章 ...

  4. tableau用户分类

    1.观察消费金额的分布 直接[消费金额]直方图趋势不明显的时候,可以考虑将金额对数化处理 这样看起来就近似个正态分布了 2.怎么看超市卖的最好的产品 更深层次的分析怎么做呢? 这个聚合字段在数据源不会 ...

  5. Flutter 容器Container类和布局Layout类

    1.布局和容器 [布局]是把[容器]按照不同的方式排列起来. Scaffold包含的主要部门:appBar,body,bottomNavigator 其中body可以是一个布局组件,也可以是一个容器组 ...

  6. Windows下的Minio启动命令

    1.首先安装Minio到你的 Windows系统的盘符中,例如D盘 2. 打开dos命令行,进入存放minio.exe的文件夹下,输入 minio.exe server /data  命令,意味着启动 ...

  7. JVM对象分配

    1.JVM中执行字节码new指令时: 1.1.分配内存 分配策略有两种方式:(1)指针碰撞 当JVM内存区域是连续的规整的,所有用过的内存都放在一边,空闲的内存都放在另外一边,中间放着 指针作为分界点 ...

  8. 网络基础之IP地址

    一.IP地址 1.IP地址就是给互联网上每一台主机 (或路由器)每一个接口分配一个在全世界范围内是唯一的32位二进制的地址标识符.现在由互联网名字和数字分配机构ICANN进行分配. 2.转换成十进制 ...

  9. 精讲响应式webclient第1篇-响应式非阻塞IO与基础用法

    笔者在之前已经写了一系列的关于RestTemplate的文章,如下: 精讲RestTemplate第1篇-在Spring或非Spring环境下如何使用 精讲RestTemplate第2篇-多种底层HT ...

  10. ceph 快照,克隆

    转载 https://my.oschina.net/wangzilong/blog/1595081 ceph 快照,克隆 ceph是一个非常好的后端存储系统.其中包括最常用的块存储,对象存储,文件系统 ...