503 Service Unavailable
转自:https://jingyan.baidu.com/article/6b1823099a258eba58e15902.html

第一 服务是不是被关闭了。
第二 原因IIS设置最大并发连接数
网站在浏览的过程中,突然页面显示Service Unavailable HTTP Error 503. The service is unavailable.一般系统会在30秒左右恢复正常,多刷新几次就能正常访问了。本次说明网站当前访问人数过多,超过了系统的iis连接数(或CPU峰值)限制,出现Service Unavailable的提示的原因,主要讲解【最大并发连接数】【队列长度】【最大工作进程数】关系及作用。
- 打开网站服务器IIS---【控制面板】-【管理工具】--【Internet信息服务IIS管理器】

- 打开应用程序池--找到网站对应使用的应用程序池--选择右侧【高级设置】

- 在【高级设置】窗口可看见该应用程序池【队列长度】,队列长度与网站设置的最大连接数相关

- 在【高级设置】窗口可看见该应用程序池【最大工作线程数】,最大工作线程数与服务器相关(一般1-20内)

- 在IIS窗口找到对应网站右击【管理网站】---【高级设置】,窗口中连接限制下的【最大并发连接数】设置,这个参数并不是越大越好


- 【最大并发连接数】【队列长度】【最大工作进程数】参数关系及作用说明当用户客户操作网站时就会向服务器网站发送请求,多个客户端访问网站时会有多个请求,请求过来时会根据网站设置的【最大并发连接数】进行处理超过最大并发连接数的会直接返回Service Unavailable HTTP Error 503. The service is unavailable.【最大并发数】会根据网站使用应用池【最大工作线程数】+【队列长度】进行分配处理返回信息,首先根据最大工作线程数返回信息,其它990个进行排队等待,前面10个完成会进行队列中处理信息,如果最大并发数减去最大工作进程数大于队列长度也会多的直接Service Unavailable HTTP Error 503. The service is unavailable.。如下图:

- 总结:设置的过程中 最好是【最大并发连接数】1000=【队列长度】990+【最大工作进程数】10
503 Service Unavailable的更多相关文章
- 静态属性,直接把iis搞垮掉 Http error 503 Service Unavailable
属性有个好处,可以在get的时候做一些特殊处理,比如返回一个默认值,正是这个特性,吸引我讲静态字段修改了成静态属性,代码如下: public static string 微信订阅号 { get { i ...
- 转)VCSA 6.5重启无法访问,报错“503 Service Unavailable”的解决方法
1. 问题 重启vcenter,登陆vsphere client,提示 “503 Service Unavailable (Failed to connect to endpoint: [N7Vmac ...
- 503是一种HTTP状态码。英文名503 Service Unavailable与404(404 Not Found)是同属一种网页状态出错码。前者是服务器出错的一种返回状态,后者是网页程序没有相关的结果后返回的一种状态,需要优化网站的时候通常需要制作404出错页以便网站整体优化。
goldCat1 商城 消息 | 百度首页 新闻网页贴吧知道音乐图片视频地图百科文库 进入词条搜索词条帮助 近期有不法分子冒充官方收费编辑词条,百度百科严正声明:百科词条人人可编辑,词条创建和修改均免 ...
- (整理)IIS 7 503 "service unavailable" errors
原文地址:http://mvolo.com/where-did-my-iis7-server-go-troubleshooting-503-quotservice-unavailablequot-er ...
- haproxy 503 service unavailable no server is avaible to handle this request
原因: haproxy 对server检测时是对默认页面进行检测,如果没有默认错误,则直接报503错误,不会转发到相应的server上去. 解决方法: 添加 option httpchk 检测页面位置 ...
- ESXi 6.7 的https服务挂掉处理方法 503 Service Unavailable
首先进入EXSi开启SSH(ESXi的主机控制台,非web控制台,是安装esxi的控制台) 然后 /etc/init.d/hostd status 显示已停止, 使用 /etc/init.d/host ...
- ActiveMQ部署步骤和后台管理网站Service Unavailable问题解决笔记
最近部署ActiveMQ的时候,发现有的服务器可以打开后台管理网址,有的服务器无法打开,Jetty报503 Service Unavailable. 搞了很久终于发现了问题,现将部署和解决过程做笔记如 ...
- WIN7 + IIS7 Service Unavailable HTTP Error 503. The service is unavailable.
在win7上开启IIS功能,进行网站发布. 但是开启IIS之后,打开默认网站都打不开,显示 Service Unavailable HTTP Error 503. The service is una ...
- 503 Service Temporarily Unavailable
503 Service Temporarily Unavailable 最近网站刷新后经常出现503 Service Temporarily Unavailable错误,有时有可以,联想到最近在ngi ...
随机推荐
- Linux的思维导图
- Java_IO流输入输出
第三章 输入输出 一.I/O Input/Output 二.File 用途:对文件和目录进行常规操作(除文件读写操作外). 方法:exists():判断文件或目录是否存在 isFile():判断是否是 ...
- Lexicographical Substring Search (spoj7259) (sam(后缀自动机)+第k小子串)
Little Daniel loves to play with strings! He always finds different ways to have fun with strings! K ...
- 代码审计就该这么来3 beescms getshell
本文作者:i春秋作家——索马里的海贼 前言上一回(http://bbs.ichunqiu.com/thread-13714-1-1.html)说到快速漏洞挖掘中的几个重点关注对象,命令执行,文件操作, ...
- Service由浅到深——AIDL的使用方式
前言 最近有很多朋友问我这个AIDL怎么用,也许由于是工作性质的原因,很多人都没有使用过aidl,所以和他们讲解完以后,感觉对方也是半懂不懂的,所以今天我就从浅到深的分析一下这个aidl具体是怎么用的 ...
- nginx的几种负载均衡策略
转自https://www.cnblogs.com/1214804270hacker/p/9325150.html 一.关于Nginx的负载均衡 在服务器集群中,Nginx起到一个代理服务器的角色(即 ...
- MQ 消息队列的比较
目前业界有很多MQ产品,我们作如下对比: RabbitMQ 是使用Erlang编写的一个开源的消息队列,本身支持很多的协议:AMQP,XMPP, SMTP, STOMP,也正是如此,使的它变的非常重量 ...
- AI 的下一个重大挑战:理解语言的细微差别
简评:人类语言非常博大精妙,同一句话在不同的语境下,就有不同的含义.连人类有时候都不能辨别其中细微的差别,机器能吗?这就是人工智能的下一个巨大挑战:理解语言的细微差别.本文原作者是 Salesforc ...
- power designer和uml应用
1.power designer和uml应用,它们可以帮助我们画图power designer还能在画图时帮助你完成代码.对于新手是很合适的一个画图工具, 2.这就是power designer 的示 ...
- HBase 使用外部的 zookeeper
HBase 启动时,默认会根据hbase-site.xml文件中的如下设置端口上启动一个zookeeper服务: <property> <name>hbase.zookeepe ...