很多步骤不说明了,请参照本人的centos6.7下编译安装lamp,这次的架构是nginx+php-fpm一台服务器,mysql一台服务器

(1)首先编译安装nginx:

操作命令: yum -y groupinstall "Development Tools" "Server Platform Development"

      yum -y install pcre-devel

      useradd -r nginx  

      mkdir /var/tmp/nginx   事先得创建此目录,不然启动nginx时会报错

      tar xf nginx-1.8.1.tar.gz

      cd nginx-1.8.1

./configure --prefix=/usr/local/nginx --sbin-path=/usr/local/nginx/sbin/nginx

--error-log-path=/var/log/nginx/error.log  --conf-path=/etc/nginx/nginx.conf

--http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx/nginx.pid --lock-path=/var/lock/nginx.lock --

user=nginx --group=nginx --with-http_ssl_module --with-http_flv_module --with-http_stub_status_module --http-

client-body-temp-path=/var/tmp/nginx/client/ --http-proxy-temp-path=/var/tmp/nginx/proxy/ --http-fastcgi-temp-

path=/var/tmp/nginx/fcgi/ --with-pcre     

make && make install

echo "export PATH=/usr/local/nginx/sbin:$PATH" > /etc/profile.d/nginx.sh

exec bash

(2) 编译安装php:

操作命令: yum -y install libxml2-devel   bzip2-devel   libjpeg-devel    libpng-devel    freetype-devel     libcurl-devel

libmcrypt-devel(此包在epel源中)

tar xf php-5.4.40.tar.bz2  cd php-5.4.40

./configure --prefix=/usr/local/php --with-mysql=mysqlnd --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --

with-openssl --enable-fpm --enable-sockets --enable-sysvshm --enable-mbstring --with-freetype-dir --with-jpeg-dir -

-with-png-dir --with-zlib-dir --with-libxml-dir=/usr --enable-xml --with-mhash --with-mcrypt --with-config-file-

path=/etc --with-config-file-scan-dir=/etc/php.d --with-bz2 --with-curl

make && make install       make test

cp php.ini-production /etc/php.ini

cp sapi/fpm/init.d.php-fpm /etc/rc.d/init.d/php-fpm

chmod +x /etc/rc.d/init.d/php-fpm

chkconfig --add php-fpm

chkconfig php-fpm on

cp /usr/local/php/etc/php-fpm.conf.default /usr/local/php/etc/php-fpm.conf   为php-fpm提供配置文件

vim /usr/local/php/etc/php-fpm.conf

pm.max_children = 150      最大进程数(根据压测进行调试)

pm.start_servers = 8

pm.min_spare_servers = 5

pm.max_spare_servers = 10

user=nginx

group=nginx

(3)整合nginx和php5

vim /etc/nginx/nginx.conf

$fastcgi_script_name   代表请求的uri      映射关系为  www.$$$.com/index.php --> /use/local/nginx/html/index.php

fastcgi_params  映射到此文件/etc/nginx/fastcgi_params

MySQL的编译安装在编译lamp博文中已经介绍了,此处不叙述

使用fastcgi_cache 模块添加缓存功能

  在http上下文中添加下面选项:

为php添加加速器:

  tar xf xcache-3.2.0.tar.bz2    cd xcache-3.2.0

    /usr/local/php/bin/phpize  ./configure --enable-xcache --with-php-config=/usr/local/php/bin/php-config

  make && make install   mkdir /etc/php.d    cp xcache.ini /etc/php.d/

   service php-fpm restart

查看各软件编译时的参数:

php:php -r "phpinfo();" | grep configure

nginx: nginx -V

apache: cat /usr/local/httpd/build/config.nice

mysql: cat /usr/local/mysql/bin/mysqlbug | grep CONFIGURE_LINE

centos6.7下编译安装lnmp的更多相关文章

  1. centos下编译安装lnmp

    centos下编译安装lnmp 本文以centos为背景在其中编译安装nginx搭建lnmp环境. 编译安装nginx时,需要事先安装 开发包组"Development Tools" ...

  2. centos6.7下 编译安装MySQL5.7

    centos6.7下编译安装MySQL5.7 准备工作 #-----依赖包及MySQL和boost安装包----- #yum包安装: shell> yum -y install gcc-c++ ...

  3. Linux(CentOS6.5)下编译安装PHP5.6.22时报错”configure: error: ZLIB extension requires gzgets in zlib”的解决方式(确定已经编译安装Zlib,并已经指定Zlib路径)

    本文地址http://comexchan.cnblogs.com/,作者Comex Chan,尊重知识产权,转载请注明出处,谢谢!   今天在CentOS6.5下编译安装PHP时,一直报错 confi ...

  4. CentOS6.5_64bit下编译安装MySQL-5.6.23

    转载请注明出处:http://blog.csdn.net/guoyjoe/article/details/44785511 ************************************** ...

  5. CentOS6.5下编译安装LAMP环境

    LAMP(Linux-Apache-MySQL-PHP)网站架构是目前国际流行的Web框架.该框架能够满足大流量.大并发量的网站需求:当然.也可以直接使用高性能的服务器.高性能的负载均衡硬件以及CDN ...

  6. 阿里云centos6.5实践编译安装LNMP架构web环境

    LNMP 代表的就是:Linux系统下Nginx+MySQL+PHP这种网站服务器架构. 本次测试需求: **实践centos6.5编译安装 LNMP生产环境 架构 web生产环境 使用 ngx_pa ...

  7. centos6源码编译安装lnmp环境

    操作系统 版本 64位 CentOS-6.6    10.0.0.20 安装环境所需依赖包 yum -y install gcc automake autoconf libtool make gcc- ...

  8. centos6.7下编译安装lamp环境

    编译C源代码: 前提:提供开发工具及开发环境 通过“包组”提供开发组件,CentOS 6: "Development Tools", "Server Platform D ...

  9. Centos6.5下编译安装ACE6.0

    ACE在Linux下的编译安装步骤(CentOS6.5 64Bit) Linux平台安装(CentOS6.5 64bit) 1, 下载ACE软件包,上传至Linux服务器(假设目录为/opt/ace, ...

随机推荐

  1. crm plugin 未能加载文件或程序集“xxxx,”或它的某一个依赖项。系统找不到指定的文件。

    plugin运行出错. 1  plugin文件如果是 注册到disk,应该是注册到 C:\Program Files\Microsoft Dynamics CRM\Server\bin\assembl ...

  2. 批处理操作mysql数据库

    批处理操作mysql数据库 1.使用批处理自动登录mysql数据库 @echo offcd C:\program files\mysql\mysql server 5.5\binmysql -u ro ...

  3. mysql数据库同步

    mysql数据库同步  1.1. Master 设置步骤 配置 my.cnf 文件 确保主服务器主机上my.cnf文件的[mysqld]部分包括一个log-bin选项.该部分还应有一个server-i ...

  4. 使用spring的邮件发送功能

    使用spring提供的MailSender和JavaMailSender类. 1.邮件对象类 package cn.luxh.app.mail; import java.util.List; impo ...

  5. 网站注册(css)

    <! DOCTYPE HTML><html><head><meta charset="utf-8"><title>作业2 ...

  6. 删除sqlserver2008日记文件

    use master go alter database dbname set recovery simple with no_wait go alter database dbname set re ...

  7. C#程序用Inno Setup打包,以管理员身份运行的处理方法

    一.C#项目端的处理 目标:快捷方式有带盾的标识 在源码的Properties目录中找到 app.manifest,将其中level="asInvoker" 改成 level=&q ...

  8. Unity球形插值Slerp解析

    Unity球形插值,官方有个太阳升降的例子: http://docs.unity3d.com/ScriptReference/Vector3.Slerp.html 一开始主观认为这个球形插值Slerp ...

  9. 互联网行业都缺前端工程师-最高offer薪水38k*16

    摘要:现在,几乎整个互联网行业都缺前端工程师,不仅在刚起步的创业公司,对上市公司乃至巨头这个问题也一样存在.没错,优秀的前端工程师简直比大熊猫还稀少. 现在,几乎整个互联网行业都缺前端工程师,不仅在刚 ...

  10. Laxcus大数据管理系统2.0(9)- 第七章 分布任务组件

    第七章 分布任务组件 Laxcus 2.0版本的分布任务组件,是在1.x版本的基础上,重新整合中间件和分布计算技术,按照新增加的功能,设计的一套新的.分布状态下运行的数据计算组件和数据构建组件,以及依 ...